[GUIDE] ADB Driver Install for Dummies

Quinny899

Recognized Developer / Recognized Contributor
Jan 26, 2011
8,407
7,669
253
23
Salford, Greater Manchester, UK
quinny898.co.uk
The most simple way is this thread. I've done all the editing work for you.

This guide is based on Windows 7 Home Premium. It may be different on your computer. If you are on a Linux build or Mac, you don't need this

Steps: Difficulty: Easy/Medium
1. Download this zip and extract it to your desktop
2. Open the start menu, type Device Manager in the search box, then wait and the Shortcut "Device Manager" will appear above in the box. Click it. Wait a moment and Device Manager will appear
3. Enable USB Debugging on your Archos device, in Settings > Applications > Development > Tick USB Debugging and accept the warning
4. Plug in your device into your PC
5. Go back to device manager and find ADB under Unknown Devices (will have a yellow ! next to it)
6. Right click and select Update Device Driver Software...
7. Select Browse my computer for driver software
8. Select Let me pick from a list of drivers installed on my computer
9. Select Show all and click next
10. Click Have Disk, then Browse
11. Go to your extracted folder and go into it, until a file called android_winusb.inf is there. Double click that (NOT android_winusb_old.inf)
12. Click OK and then Next
-Note: If it says not signed, just click next anyway
13. Wait and if it says not signed, click install drivers anyway
14. Wait until it's done, then close all of your programs
15. Press the windows key and R at the same time on your keyboard
16. Type cmd and hit enter (Command prompt will appear)
17. Copy and paste the following code into it:
Code:
echo 0x0e79 >> "%USERPROFILE%\.android\adb_usb.ini
18. Type adb kill-server
19. Type adb devices, and your device should now show up
20. Hit the thanks button below

Thanks to cajl-jbmm from MoDaCo for posting the modification required for the drivers to work
 

baari21

Senior Member
Jan 28, 2012
87
3
0
www.GaffarGpsSolutions.com
adb devices isn't saying anything.

Good day. I followed your previous steps but when I do "adb devices" I get no response. That is, no message back. When I try it once more this is the message I get:


Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. All rights reserved.

C:\Users\Dell>"C:\Program Files\Android\android-sdk\platform-tools\adb.exe">adb
devices

C:\Users\Dell>"C:\Program Files\Android\android-sdk\platform-tools\adb.exe">adb
devices
The process cannot access the file because it is being used by another process.

C:\Users\Dell>


Any help you have is welcomed.
 

pma7779

Member
Dec 17, 2010
39
4
0
I am having a similar problem.
When I type "adb devices" in command prompt, it returns with:
'adb' is not recognized as an internal or external command, operable program or batch file.

Not sure how to access adb in command prompt.
 

baari21

Senior Member
Jan 28, 2012
87
3
0
www.GaffarGpsSolutions.com
I got it to work. Even though there was no response stating the device was connected I tried "adb reboot" to check if the device was infact working with the adb and it was. So i got it working but perfectly. Only thing is there is no response stating the device is connected but i can live without that. Thanks for the help guys.
 

alan12

New member
Mar 31, 2010
1
0
0
adb tool has moved

The adb tool has moved to platform-tools/

If you don't see this directory in your SDK, launch the SDK and AVD Manager (execute the android tool) and install "Android SDK Platform-tools"

Please also update your PATH environment variable to include the platform-tools/ directory, so you can execute adb from any location.
 

MrLarner

Senior Member
Jan 6, 2012
277
15
0
I hope someone is on to help me here, i've done these steps...
1. Download this zip and extract it to your desktop
2. Open the start menu, type Device Manager in the search box, then wait and the Shortcut "Device Manager" will appear above in the box. Click it. Wait a moment and Device Manager will appear
3. Enable USB Debugging on your Archos device, in Settings > Applications > Development > Tick USB Debugging and accept the warning
4. Plug in your device into your PC
5. Go back to device manager and find ADB under Unknown Devices (will have a yellow ! next to it)
6. Right click and select Update Device Driver Software...
7. Select Browse my computer for driver software
8. Select Let me pick from a list of drivers installed on my computer
9. Select Show all and click next
10. Click Have Disk, then Browse
11. Go to your extracted folder and go into it, until a file called android_winusb.inf is there. Double click that (NOT android_winusb_old.inf)
12. Click OK and then Next

BUT... when i click next, it comes up saying....
'the folder you specified doesn't contain a compatible software driver for your device. If the folder contains a driver, make sure it is designed to work with windows for x64-based systems.

SO WHAT NOW????
 

Quinny899

Recognized Developer / Recognized Contributor
Jan 26, 2011
8,407
7,669
253
23
Salford, Greater Manchester, UK
quinny898.co.uk
I hope someone is on to help me here, i've done these steps...
1. Download this zip and extract it to your desktop
2. Open the start menu, type Device Manager in the search box, then wait and the Shortcut "Device Manager" will appear above in the box. Click it. Wait a moment and Device Manager will appear
3. Enable USB Debugging on your Archos device, in Settings > Applications > Development > Tick USB Debugging and accept the warning
4. Plug in your device into your PC
5. Go back to device manager and find ADB under Unknown Devices (will have a yellow ! next to it)
6. Right click and select Update Device Driver Software...
7. Select Browse my computer for driver software
8. Select Let me pick from a list of drivers installed on my computer
9. Select Show all and click next
10. Click Have Disk, then Browse
11. Go to your extracted folder and go into it, until a file called android_winusb.inf is there. Double click that (NOT android_winusb_old.inf)
12. Click OK and then Next

BUT... when i click next, it comes up saying....
'the folder you specified doesn't contain a compatible software driver for your device. If the folder contains a driver, make sure it is designed to work with windows for x64-based systems.

SO WHAT NOW????
You have a 64 bit version of Windows so it's not compatible, sorry

Sent from my HTC Desire HD using XDA
 

MrLarner

Senior Member
Jan 6, 2012
277
15
0
Is there anything i can do about it?
is there something else i can download instead?
or is the only option to use another computer?
 
Last edited:

divx118

Senior Member
Dec 20, 2009
345
198
0
Last edited:

MrLarner

Senior Member
Jan 6, 2012
277
15
0
adb should perfectly work on 64 bit windows 7. I used it in the past, now I mainly use linux.
Just download the driver from ftp://support.archos.com/ARCHOS it/ADB/adb_winusb_driver.zip

Edit: also look here http://www.archos.com/support/support_tech/updates_adb.html?country=nl&lang=en

divx118
Is that link for the driver different to the 1 i got from the opening post?
will this 1 work on windows x64?

---------- Post added at 04:20 PM ---------- Previous post was at 04:16 PM ----------

Ignore that last post, i checked it and its exactly the same as the file in the opening post.
I need a file which will work on windows x64
 

divx118

Senior Member
Dec 20, 2009
345
198
0
Is that link for the driver different to the 1 i got from the opening post?
will this 1 work on windows x64?
The link I posted is the original driver provided by archos and works with windows x64. Where the one in the opening post comes from I don't know.

divx118
 

MrLarner

Senior Member
Jan 6, 2012
277
15
0
Something else i noticed,
when i done these steps...

1. Download this zip and extract it to your desktop
2. Open the start menu, type Device Manager in the search box, then wait and the Shortcut "Device Manager" will appear above in the box. Click it. Wait a moment and Device Manager will appear
3. Enable USB Debugging on your Archos device, in Settings > Applications > Development > Tick USB Debugging and accept the warning
4. Plug in your device into your PC
5. Go back to device manager and find ADB under Unknown Devices (will have a yellow ! next to it)

all went well until i got to 5, it didnt show up unknown devices, it showed up at portable devices and it did not have a yellow ! next to it????
does it mean anything?
 

fzelle

Senior Member
Mar 19, 2006
1,011
143
0
Yes, that means you haven't checked USB - Debugging on the device or selected MassStorage in the dropdown.

Sometimes it's not enough that it is selected, so deselect it, leave the menu, get in again and select it.
 
Last edited:

MrLarner

Senior Member
Jan 6, 2012
277
15
0
Yes, that means you haven't checked USB - Debugging on the device or selected MassStorage in the dropdown.
I have, 100% checked usb debugging on.
and where would this mass storage be? i cant find it.
also, for me to enable usb debugging, i have to go to...
{ } Developer options.

---------- Post added at 06:29 PM ---------- Previous post was at 06:20 PM ----------

ok think i solved it, i managed to go to storage settings and then had the option once the usb was connected to chose between MTP - Media Device, or, PTP - Camera,
so i changed it from MTP to PTP and now when i go to device manager, its showing up as other devices and then archos has the yellow ! next to it.
does this mean i can continue now?

---------- Post added at 06:37 PM ---------- Previous post was at 06:29 PM ----------

Blimey im hitting problems at every step :mad:

i've now got to here...

17. Copy and paste the following code into it:
Code:
echo 0x0e79 >> "%USERPROFILE%\.android\adb_usb.ini
18. Type adb kill-server
19. Type adb devices, and your device should now show up
20. Hit the thanks button below

But when i type adb kill-server it comes up saying....
'adb' is not recognized as an internal or external command, operable program or batch file.

what now???
 

MrLarner

Senior Member
Jan 6, 2012
277
15
0
I've looked into it and everyone says i need to change the path???
i cant find out how to do this, or what to change the path to, someone please help!