• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[GUIDE] Android 8 API27 SUPERMOD for YT9216BF YT9216CFJ YT9216BJ YT9216BFJ YT9216CJ - root, Viper4Android, TWRP, Custom UI, brick recovery and more

Search This thread

algupta81

Member
Apr 18, 2021
34
2
40
India
Samsung Galaxy M30s

Attachments

  • 20211018_001116.jpg
    20211018_001116.jpg
    4.6 MB · Views: 15

RandCat

Senior Member
Oct 1, 2021
55
0
Yes, you need to follow the instructions to the letter. Every detail.
Yes that's what I'm doing? Anything else in settings that might be interrupting? I had USB debug mode on, I turned that off, and in factory settings it looks like I'm able to have control over the 2 usb ports in the back but not in the front, but I'm not sure what this means as I was able to transfer data through the front usb port at some point. It's also in host mode (vs device), but tried both and rebooted, didn't help.
 

ExtremeMOD

Senior Member
Aug 14, 2020
706
169
41
London
extrememod.co.uk
I m getting error message to select Format all+ download when selecting only Vendor an Android while flashing new ROM. Please suggest
Thank God for that! You should not be doing this. You will kill your head unit.
If you wish to restore your head unit, you only need to flash your USER_ROM file from your backup. Do not erase anything.
After you have restored your backup, simply run Factory Reset and you're done.

Also, make sure to extract your scatter file from your backup. Follow the instruction video I shared before and then go here for the backup restoration process.

Ok I seem to find the issue.The partition size value in Scatter file did not get changed to that figure from other portal we copied over.Modified and now its flashing. Lets see how it goes

I really hope you're not running Format+All option. Why would you even think of that? Your device isn't bricked.
 

algupta81

Member
Apr 18, 2021
34
2
40
India
Samsung Galaxy M30s
Thank God for that! You should not be doing this. You will kill your head unit.
If you wish to restore your head unit, you only need to flash your USER_ROM file from your backup. Do not erase anything.
After you have restored your backup, simply run Factory Reset and you're done.

Also, make sure to extract your scatter file from your backup. Follow the instruction video I shared before and then go here for the backup restoration process.
Ok I seem to find the issue. The partition size value in Scatter file did not get changed to that figure from other portal we copied over. Modified and now its flashing. Lets see how it goes
 

ExtremeMOD

Senior Member
Aug 14, 2020
706
169
41
London
extrememod.co.uk
Are we supposed to see this? What is this for because I don't have that file path.View attachment 5435559

Don't see the attachment.

Yes that's what I'm doing? Anything else in settings that might be interrupting? I had USB debug mode on, I turned that off, and in factory settings it looks like I'm able to have control over the 2 usb ports in the back but not in the front, but I'm not sure what this means as I was able to transfer data through the front usb port at some point. It's also in host mode (vs device), but tried both and rebooted, didn't help.

You don't need to do any changes in the Settings inside your head unit. It should be completely shut down and disconnected from power during the installation process.
 

RandCat

Senior Member
Oct 1, 2021
55
0
You don't need to do any changes in the Settings inside your head unit. It should be completely shut down and disconnected from power during the installation process.
Oh! I didn't realize it had to be disconnected. I tried that just now and tried running the memory test, same results though :/ Do you think it's the fact I'm using the front USB port? I'm confused if that is so because I actually found this thread through a review of the same head unit I bought.
 

RandCat

Senior Member
Oct 1, 2021
55
0
Could this device that was already there before I installed the mediatek driver be the culprit?
1634499800650.png
 

algupta81

Member
Apr 18, 2021
34
2
40
India
Samsung Galaxy M30s
On running reboot recovery after TWRP install and reboot, the screen is going white but if u disconnect power and switch it on again , the unit comes on fine. I tried both ways mentioned in file with only Recovery selected and other way by selecting 4 files bt same result everytime.
 

Attachments

  • 20211018_011307.jpg
    20211018_011307.jpg
    3.2 MB · Views: 4
Last edited:

ExtremeMOD

Senior Member
Aug 14, 2020
706
169
41
London
extrememod.co.uk
Could this device that was already there before I installed the mediatek driver be the culprit? View attachment 5435591

Oh! I didn't realize it had to be disconnected. I tried that just now and tried running the memory test, same results though :/ Do you think it's the fact I'm using the front USB port? I'm confused if that is so because I actually found this thread through a review of the same head unit I bought.

Stop everything you are doing before you ruin your head unit. You do not seem to follow any instructions by looking at the screenshots you shared.

Let's start with the basics. Share your System Info screen and Android info. See examples below.

System Info.png Android Info kernel.jpg
 

RandCat

Senior Member
Oct 1, 2021
55
0
Stop everything you are doing before you ruin your head unit. You do not seem to follow any instructions by looking at the screenshots you shared.

Let's start with the basics. Share your System Info screen and Android info. See examples below.

View attachment 5435605 View attachment 5435603
I am trying to follow directions as best as I can. I am simply retracing my steps and seeing if there's anything in particular I should be doing for my specific setup. Your tutorial does not already show a COM device in device manager, while mine does. Your head unit does not have a front usb port, mine does. I'm making it clear what the distinct differences are in hopes you can understand it problem better.

My system info is shared here: https://forum.xda-developers.com/t/...ecovery-and-more.4305169/page-3#post-85787457
 

ExtremeMOD

Senior Member
Aug 14, 2020
706
169
41
London
extrememod.co.uk
I am trying to follow directions as best as I can. I am simply retracing my steps and seeing if there's anything in particular I should be doing for my specific setup. Your tutorial does not already show a COM device in device manager, while mine does. Your head unit does not have a front usb port, mine does. I'm making it clear what the distinct differences are in hopes you can understand it problem better.

My system info is shared here: https://forum.xda-developers.com/t/...ecovery-and-more.4305169/page-3#post-85787457

Then please explain why are you trying to upload firmware from a different Android version and a completely different head unit?

The screenshot you shared shows Android 6 outdated user_rom file for YT9213AJ head unit...

Is your head unit still working fine?
 

RandCat

Senior Member
Oct 1, 2021
55
0
Then please explain why are you trying to upload firmware from a different Android version and a completely different head unit?

The screenshot you shared shows Android 6 outdated user_rom file for YT9213AJ head unit...

Is your head unit still working fine?
That's my question, why does it show YT9213AJ? It was like that on first boot of SP Flash Tool.

My head unit is working fine. It has not been connected via USB to my computer yet.
 

ExtremeMOD

Senior Member
Aug 14, 2020
706
169
41
London
extrememod.co.uk
OK but 1 question. The 1 GB TWRP folder only has recovery.Img but the 2 GB folder has Scatter , preloader and recovery. Which scatter file would we need to use in 1 GB ?

Thank you for letting me know. I'm removing scatter and preloader as you should only copy your own into the TWRP folder but of course no need to tick preloader in Flash Tool, as per instructions.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hello i have a yt9216bj , i would like to change the firmware is it possible ?

    Thanks in advance

    Yes it is. Make sure to follow all the steps as advised.
    1
    Thanks. And those are original files you extracted from your backup, correct?
    Yes, extracted from original boot1 and rom_user files, correct.
    1
    Sorry, i missed i use this "YT9216BF_6.2v3.5_02.05.2021"

    Okay, in this case:

    1. Restore your backup

    2. Flash the firmware again but without the boot.img file (so only Android/System and Vendor)

    3. If 2GB TWRP file doesn't work, try the 1GB one.
    1
    Okay, in this case:

    1. Restore your backup

    2. Flash the firmware again but without the boot.img file (so only Android/System and Vendor)

    3. If 2GB TWRP file doesn't work, try the 1GB one.
    Finished!!! Thank you Very Much.

    i Flashed Android/System and Vendor only. But TWRP 2 GB Not work, Worked with 1GB
  • 12
    Hi all,

    If you want to greatly improve the way your head unit works, sounds and looks like - you've come to the right place!

    Why install this?
    With this package you will greatly improve:
    • Stability
    • Speed
    • User Interface
    • Sound tweaking options
    • Customization options
    20210805112900.jpg

    • ON PHYSICAL BUTTONS: this software has only been tested on head units with no physical buttons (like volume) | Before making any changes, access the CAR SETTINGS -> FACTORY SETTINGS -> ENCODER SETTINGS on your head unit and take a screenshot of the current settings (see example below). After installing the package, go back to these settings and adjust them if needed. If that doesn't help and if you can't successfully re-calibrate the buttons after installing the firmware, restore your backup

      encoder settings.png

    Disclaimer
    I do not create the software itself but rather use research and put together different mods and hacks into one package that includes very user-friendly step-by-step instructions on how to install it all. You will find the links to original posts in the instructions pdf's if credit is due. The software might include smaller changes made by me and has been fully tested in real units.

    This guide works on the following 1Gb RAM and 2 Gb RAM units with fake Android 10 and Android 11 installed:

    - YT9216BF | YT9216CFJ | YT9216BJ | YT9216BFJ | YT9216CJ

    !! TAKE A PICTURE OF YOUR SYSTEM INFO AND KERNEL VERSION BEFORE DOING ANYTHING TO YOUR HEAD UNIT !!


    Screenshot_20181015-082542.png 20210805092140.jpg

    The zip file package contains:
    • Modified firmware - courtesy of Stranger21UFA @ 4PDA (link to the original post)
    • TWRP (separate folders for 1GB and 2GB RAM units)
    • Root via Magisk
    • Viper4Android
    • Car Launcher
    • Boot Animation
    • SEPARATE INSTRUCTIONS ARE INCLUDED IN EVERY FOLDER

    >>>> ALWAYS BACKUP YOUR UNIT BEFORE MAKING ANY CHANGES TO IT <<<<

    !! IMPORTANT !!

    This is a fairly advanced installation process and will require you to follow the individual guides included in the software package - to the letter. Failing to do so, will (in "best" case) result in a slow and buggy head unit and in the worse case - brick it altogether.​


    DOWNLOAD #5
    YT9216BF * YT9216CFJ * YT9216BJ * YT9216BFJ * YT9216CJ - supermod software package & drivers

    STEP-BY-STEP GUIDE (upgrading from working stock firmware):
    1. DO NOT SKIP ANY STEPS, AND INSTALL EVERYTHING IN THE CORRECT ORDER. STEPS 5 AND 6 ARE MOST CRITICAL.

    2. Proceed to download the software package for your unit and the drivers package in the same folder

    3. It's highly recommended to do these upgrades with your unit connected on your desktop, rather than in the car. Video Guide

    4. Install the Mediatek & ADB drivers on your Windows computer. Video Guide - use the same principle for ADB drivers.

    5. Backup your current system by exporting a full memory dump. Video Guide

    6. Import back your memory dump from step-5 to ensure it fully works. This is how.

    7. Install the package. Separate instructions are included in every folder of the downloaded zip file. Follow them by the order.

    IF THIS SOFTWARE PACKAGE HAS BRICKED YOUR HEAD UNIT AND YOU HAVE YOUR BACKUP AVAILABLE, follow the steps below:
    1. DO NOT SKIP ANY STEPS, AND INSTALL EVERYTHING IN THE CORRECT ORDER.

    2. It's highly recommended to do these upgrades with your unit connected on your desktop, rather than in the car. Video Guide

    3. Install the Mediatek & ADB drivers on your Windows computer. Video Guide - use the same principle for ADB drivers - (download link is in the video description)

    4. Watch this video on Test Point recovery

    5. Import back your memory dump. This is how.

    6. If successful - try to install the software package again or stay with your original one

    IF THIS SOFTWARE PACKAGE HAS BRICKED YOUR HEAD UNIT AND YOU HAVE NO BACKUP AVAILABLE, follow the steps below:
    1. Share the pictures of your System Info and Kernel in this thread and I'll try to help you

    20210805091905.jpg 20210805091639.jpg 20210805112820.jpg 20210805091836.jpg

    ------------------------------------------

    This post is being frequently updated and you'll find more guides and mods in my signature​

    ------------------------------------------

    Thanks! And if this post is helpful to you please don't forget to "like" it.

    Enjoy!​


    [V4A][VIPER4ANDROID][ViperFX][ROOT][TWRP][8227L][YT9216BF] [YT9216CFJ] [YT9216BJ] [YT9216BFJ] [YT9216CJ]
    4
    Below post is to show my respect & appreciation to iceblue1980 and in addition to share my experience that had for a few days while trying to make my unit better with above firmware.

    As I downloaded firmware package, I chose not to follow his guide by letter & skip a few steps, for example & most important, not to take full back up of memory.
    Then disaster followed, as I almost bricked the unit.
    So I turned back to post/s to find solutions. Iceblue1980 was there, day & night responding to me & sending me several alternatives to try.
    He even volunteered to fix my unit by sending it to him without any money even if he had to spend valuable time for it.
    Finally, after several attempts & lots of files / firmwares / guides he sent me the gold package & we made it work !!!

    I carefully followed his last guide by letter & that was it.

    Now my unit is back to life & even better than ever.

    This guy is awesome & I personally thank him so much.

    To all members, PLS FOLLOW author's
    guides BY LETTER EVERYTIME to avoid surprises !!!!
    AND
    Don't forget to thank the people who are there for you day or night.
    They use lot of their personal time to be there for you & that is priceless !!

    :) :) :) :)
    2
    The links go to a '404' page.
    I did the first step as per the guide then did a factory reset. I then installed TWRP and rebooted then unit. Then I ran the 'reboot recovery' command in the terminal emulator and the unit rebooted, but it only shows the logo, some vertical lines on the bottom half of the screen, then a black screen and hangs there.

    I can still reboot normally and the unit will run.

    Separately, when resuming audio tracks after key-off, the audio is very choppy and unusable. Both bluetooth audio and the music app behave the same.

    To recover, I have to reset the unit and then the audio is ok.

    Also there's a very loud audio boom on start up and shutdown of the unit. This is not there in the stock firmware.View attachment 5409085

    Thank you for sharing these details. I'm afraid your head unit is not compatible with any of my software packages. If you haven't done so already, please revert back to factory firmware to avoid issues.
    2
    The method I had to use slightly differs from everything I have read.

    1.) I wired a toggle switch to my positive lead. Left it in the off position (no power to head unit)

    You could share a picture of your soldered button. Some folks here might find it helpful :)

    I'm thinking of making a guide going for a permanent mod, where the soldered tactile SMD button will be accessible through a small hole in the back of the head unit (similar to how you access the RESET button). That way you can use a 'needle' to short the test points, rather than picking the unit apart every time.
    2
    View attachment 5405715my board is this where is the recovery pin ? And where I conect an antenna for wifi

    These are the recovery test points:

    IMG-20210909-WA0006.jpeg

    The Wifi/BT antenna mod is shown here, however I plan to post a proper guide on this particular mod in the future.