[GUIDE] Android 8 API27 SUPERMOD for YT9216BF YT9216CFJ YT9216BJ YT9216BFJ YT9216CJ - root, Viper4Android, TWRP, Custom UI, brick recovery and more

Search This thread
Feb 1, 2015
27
4
I bought an 8227l headunit, Jcac10003-0C2, it has an tm2313 dsp, 2gb fake(1gb real + swap), 32gb rom. Equalizer is very bad, few options, only balance, no subwoofer output. How I can download you equalizer app to try(I download your rom but I can't find equalizer or dsp app)? I want to enable subwoofer out, it has rca sub out but no sound. I like to try your rom too but I wait my warranty expire to backup my rom and try.
 

ExtremeMOD

Senior Member
Aug 14, 2020
970
221
London
extrememod.co.uk
I bought an 8227l headunit, Jcac10003-0C2, it has an tm2313 dsp, 2gb fake(1gb real + swap), 32gb rom. Equalizer is very bad, few options, only balance, no subwoofer output. How I can download you equalizer app to try(I download your rom but I can't find equalizer or dsp app)? I want to enable subwoofer out, it has rca sub out but no sound. I like to try your rom too but I wait my warranty expire to backup my rom and try.

Our ROM will not work on your head unit. The issues you have cannot be fixed with software. Hardware modifications are required and only after - software.
 

ExtremeMOD

Senior Member
Aug 14, 2020
970
221
London
extrememod.co.uk
I will investigate later, maybe I can hardwire an subwoofer out from tm2313 dsp like I saw in datasheet. Your rom not work, but Apps maybe work? With root?

Apps will work with root. The stability will depend on your firmware.

As for the hardware - first check if your TM2313 is authentic. Or better yet, change it to TDA7313 (don't forget to change the caps on pin 18 and 20 to 2,2 uf).

Change the internal amp YD7388 (or TDA7388) to TDA7850 and with a 10,000 uf cap. Fortify the powerlines to the internal amp by soldering extra cables between the power source and the power pins on the amp.
 
  • Like
Reactions: leonardcoutinho

RandCat

Senior Member
Oct 1, 2021
58
0
I somehow set an unlock method, the pattern unlock, and then it changed into swipe unlock. Now when I swipe the launcher i got doesnt load and if i press the nav buttons it goes black. Any ideas?
2022-07-0120.49.028294477631561857329.jpg
 

ExtremeMOD

Senior Member
Aug 14, 2020
970
221
London
extrememod.co.uk
I somehow set an unlock method, the pattern unlock, and then it changed into swipe unlock. Now when I swipe the launcher i got doesnt load and if i press the nav buttons it goes black. Any ideas?View attachment 5650479

If you installed our software, simply re-flash Androd.img or Syste.img file. If you haven't installed our software, please start your own thread.
 
Feb 1, 2015
27
4
Apps will work with root. The stability will depend on your firmware.

As for the hardware - first check if your TM2313 is authentic. Or better yet, change it to TDA7313 (don't forget to change the caps on pin 18 and 20 to 2,2 uf).

Change the internal amp YD7388 (or TDA7388) to TDA7850 and with a 10,000 uf cap. Fortify the powerlines to the internal amp by soldering extra cables between the power source and the power pins on the amp.
Thanks for tips, I will change amp to tda 7850 and 10k cap first, then tm2313. And I saw an method to root my hu. At least stock rom is stable.
 
  • Like
Reactions: ExtremeMOD

artur0st26

New member
Jul 22, 2022
1
0
What's up mate, I'm trying to find out if Android 8 API27 SUPERMOD is compatible with my unit, I bought it recently but it's too limited in some aspects, it's the 2GB RAM 32GB ROM version


IMG-20211230-WA0016.jpg
Screenshot_20211230-151032.png
 
Feb 1, 2015
27
4
Apps will work with root. The stability will depend on your firmware.

As for the hardware - first check if your TM2313 is authentic. Or better yet, change it to TDA7313 (don't forget to change the caps on pin 18 and 20 to 2,2 uf).

Change the internal amp YD7388 (or TDA7388) to TDA7850 and with a 10,000 uf cap. Fortify the powerlines to the internal amp by soldering extra cables between the power source and the power pins on the amp.
Its possible to adjust subwoofer output with tm2313/tda7313 or I need an headunit with 37033 chip? or sub out have not to do this? My subwoofer out(green rca one) not work.
 

ExtremeMOD

Senior Member
Aug 14, 2020
970
221
London
extrememod.co.uk
Its possible to adjust subwoofer output with tm2313/tda7313 or I need an headunit with 37033 chip? or sub out have not to do this? My subwoofer out(green rca one) not work.

Your subwoofer should come with the appropriate connection instructions. Normally an active subwoofer is connected to the FrontLeft + FrontRight speakers and power through the blue AMP+ cable.

A passive subwoofer will not work as your head unit needs a proper TDA7850 MOD with active cooling to run a passive sub.
 
Feb 1, 2015
27
4
Your subwoofer should come with the appropriate connection instructions. Normally an active subwoofer is connected to the FrontLeft + FrontRight speakers and power through the blue AMP+ cable.

A passive subwoofer will not work as your head unit needs a proper TDA7850 MOD with active cooling to run a passive sub.
I did this, but my headunit came with green sub rca out, but not working. They I use white and red rca out. My sub has active amp.
 
Last edited:

ExtremeMOD

Senior Member
Aug 14, 2020
970
221
London
extrememod.co.uk
I did this, but my headunit came with green sub rca out, but not working. They I use white and red rca out. My sub has active amp.

If you are using an external amplifier to drive your speakers, see if you can connect your sub there instead.

If you are using the internal amp of the Head Unit, don't use RCA connections for your speakers at all. Connect the speaker cables directly to the main harness of the head unit.
 
Sep 8, 2019
16
3
21
Serbia
Hi, i have installed your firmware MOD for about 3 months, and recently i have a problem with red button lights, i reflashed whole stock firmware and then mod firmware but that didn't fixed problem. Other color lights works but red doesn't, for example if i leave a car overnight and then start next morning, red light work for about 10-15 seconds and then shuts off. Rest of the colors works fine. Here are some photos, i checked all cables from inside, and all cables looks well soldered and connected.
 

Attachments

  • 20220810_130703.jpg
    20220810_130703.jpg
    1.2 MB · Views: 34
  • 20220810_131058.jpg
    20220810_131058.jpg
    1.3 MB · Views: 29
  • 20220810_131104.jpg
    20220810_131104.jpg
    1.4 MB · Views: 29
  • 20220810_130618.jpg
    20220810_130618.jpg
    1.1 MB · Views: 26
  • 20220810_131018.jpg
    20220810_131018.jpg
    1.3 MB · Views: 27
  • 20220810_130659.jpg
    20220810_130659.jpg
    1.3 MB · Views: 24
  • 20220810_130629.jpg
    20220810_130629.jpg
    1 MB · Views: 26
  • 20220807_173825.jpg
    20220807_173825.jpg
    2.7 MB · Views: 20
  • 20220807_173755.jpg
    20220807_173755.jpg
    2.4 MB · Views: 20
  • 20220807_210611.jpg
    20220807_210611.jpg
    1.3 MB · Views: 30

ExtremeMOD

Senior Member
Aug 14, 2020
970
221
London
extrememod.co.uk
Hi, i have installed your firmware MOD for about 3 months, and recently i have a problem with red button lights, i reflashed whole stock firmware and then mod firmware but that didn't fixed problem. Other color lights works but red doesn't, for example if i leave a car overnight and then start next morning, red light work for about 10-15 seconds and then shuts off. Rest of the colors works fine. Here are some photos, i checked all cables from inside, and all cables looks well soldered and connected.

Reflash stock again and see if that fixes the problem. If it does, then there's bug in our mod.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 23
    Hi all,

    If you want to greatly improve the way your head unit works, sounds and looks like - you've come to the right place!

    Why install this?
    With this package you will greatly improve:
    • Stability
    • Speed
    • User Interface
    • Sound tweaking options
    • Customisation options
    20210805112900.jpg 20210805091905.jpg 20210805091639.jpg 20210805091836.jpg

    • ON PHYSICAL BUTTONS: this software has only been tested on head units with no physical buttons (like volume) | Before making any changes, access the CAR SETTINGS -> FACTORY SETTINGS -> ENCODER SETTINGS on your head unit and take a screenshot of the current settings (see example below). After installing the package, go back to these settings and adjust them if needed. If that doesn't help and if you can't successfully re-calibrate the buttons after installing the firmware, restore your backup

      encoder settings.png

    Disclaimer
    I do not create the software itself but rather use research and put together different mods and hacks into one package that includes very user-friendly step-by-step instructions on how to install it all. You will find the links to original posts in the instructions pdf's if credit is due. The software might include smaller changes made by me and has been fully tested in real units.

    This guide works on the following 1Gb RAM and 2 Gb RAM units with fake Android 10 and Android 11 installed:

    - YT9216BF | YT9216CFJ | YT9216BJ | YT9216BFJ | YT9216CJ

    !! TAKE A PICTURE OF YOUR SYSTEM INFO AND KERNEL VERSION BEFORE DOING ANYTHING TO YOUR HEAD UNIT !!


    Screenshot_20181015-082542.png 20210805092140.jpg

    The zip file package contains:
    • Modified firmware - courtesy of Stranger21UFA @ 4PDA (link to the original post)
    • TWRP (separate folders for 1GB and 2GB RAM units)
    • Root via Magisk
    • Viper4Android
    • Car Launcher
    • Boot Animation
    • SEPARATE INSTRUCTIONS ARE INCLUDED IN EVERY FOLDER

    >>>> ALWAYS BACKUP YOUR UNIT BEFORE MAKING ANY CHANGES TO IT <<<<

    !! IMPORTANT !!

    This is a fairly advanced installation process and will require you to follow the individual guides included in the software package - to the letter. Failing to do so, will (in "best" case) result in a slow and buggy head unit and in the worse case - brick it altogether.​


    DOWNLOAD
    YT9216BF * YT9216CFJ * YT9216BJ * YT9216BFJ * YT9216CJ - supermod software package & drivers

    STEP-BY-STEP GUIDE (upgrading from working stock firmware):
    1. DO NOT SKIP ANY STEPS, AND INSTALL EVERYTHING IN THE CORRECT ORDER. STEPS 5 AND 6 ARE MOST CRITICAL.

    2. Proceed to download the software package for your unit and the drivers package in the same folder

    3. It's highly recommended to do these upgrades with your unit connected on your desktop, rather than in the car. Video Guide

    4. Install the Mediatek & ADB drivers on your Windows computer. Video Guide - use the same principle for ADB drivers.

    5. Backup your current system by exporting a full memory dump. Video Guide

    6. Import back your memory dump from step-5 to ensure it fully works. This is how.

    7. Install the package. Separate instructions are included in every folder of the downloaded zip file. Follow them by the order.

    IF THIS SOFTWARE PACKAGE HAS BRICKED YOUR HEAD UNIT AND YOU HAVE YOUR BACKUP AVAILABLE, follow the steps below:
    1. DO NOT SKIP ANY STEPS, AND INSTALL EVERYTHING IN THE CORRECT ORDER.

    2. It's highly recommended to do these upgrades with your unit connected on your desktop, rather than in the car. Video Guide

    3. Install the Mediatek & ADB drivers on your Windows computer. Video Guide - use the same principle for ADB drivers - (download link is in the video description)

    4. Watch this video on Test Point recovery

    5. Import back your memory dump. This is how.

    6. If successful - try to install the software package again or stay with your original one

    IF THIS SOFTWARE PACKAGE HAS BRICKED YOUR HEAD UNIT AND YOU HAVE NO BACKUP AVAILABLE, follow the steps below:
    1. Share the pictures of your System Info and Kernel in this thread and we'll try to help you



    ------------------------------------------

    This post is being frequently updated and you'll find more guides and mods in our signature​

    ------------------------------------------

    ** IF YOU ARE UNABLE TO RESTORE YOUR UNIT, PLEASE CONSIDER DONATING IT TO US @ ExtremeMOD, SO WE CAN BUILD MORE MODS AND TUTORIALS


    Thanks! And if this post is helpful to you please don't forget to "like" it.

    Enjoy!​


    [V4A][VIPER4ANDROID][ViperFX][ROOT][TWRP][8227L][YT9216BF] [YT9216CFJ] [YT9216BJ] [YT9216BFJ] [YT9216CJ]
    4
    Below post is to show my respect & appreciation to iceblue1980 and in addition to share my experience that had for a few days while trying to make my unit better with above firmware.

    As I downloaded firmware package, I chose not to follow his guide by letter & skip a few steps, for example & most important, not to take full back up of memory.
    Then disaster followed, as I almost bricked the unit.
    So I turned back to post/s to find solutions. Iceblue1980 was there, day & night responding to me & sending me several alternatives to try.
    He even volunteered to fix my unit by sending it to him without any money even if he had to spend valuable time for it.
    Finally, after several attempts & lots of files / firmwares / guides he sent me the gold package & we made it work !!!

    I carefully followed his last guide by letter & that was it.

    Now my unit is back to life & even better than ever.

    This guy is awesome & I personally thank him so much.

    To all members, PLS FOLLOW author's
    guides BY LETTER EVERYTIME to avoid surprises !!!!
    AND
    Don't forget to thank the people who are there for you day or night.
    They use lot of their personal time to be there for you & that is priceless !!

    :) :) :) :)
    2
    The links go to a '404' page.
    I did the first step as per the guide then did a factory reset. I then installed TWRP and rebooted then unit. Then I ran the 'reboot recovery' command in the terminal emulator and the unit rebooted, but it only shows the logo, some vertical lines on the bottom half of the screen, then a black screen and hangs there.

    I can still reboot normally and the unit will run.

    Separately, when resuming audio tracks after key-off, the audio is very choppy and unusable. Both bluetooth audio and the music app behave the same.

    To recover, I have to reset the unit and then the audio is ok.

    Also there's a very loud audio boom on start up and shutdown of the unit. This is not there in the stock firmware.View attachment 5409085

    Thank you for sharing these details. I'm afraid your head unit is not compatible with any of my software packages. If you haven't done so already, please revert back to factory firmware to avoid issues.
    2
    The method I had to use slightly differs from everything I have read.

    1.) I wired a toggle switch to my positive lead. Left it in the off position (no power to head unit)

    You could share a picture of your soldered button. Some folks here might find it helpful :)

    I'm thinking of making a guide going for a permanent mod, where the soldered tactile SMD button will be accessible through a small hole in the back of the head unit (similar to how you access the RESET button). That way you can use a 'needle' to short the test points, rather than picking the unit apart every time.
    2
    View attachment 5405715my board is this where is the recovery pin ? And where I conect an antenna for wifi

    These are the recovery test points:

    IMG-20210909-WA0006.jpeg

    The Wifi/BT antenna mod is shown here, however I plan to post a proper guide on this particular mod in the future.