[GUIDE][BEGONIA]Unlock Bootloader, Flash TWRP and Root[PROPER]

Search This thread


New member
Jun 13, 2021
Please help, i followed the guide but when I hold vol up + power i don't get into TWRP and phone keeps rebooting

EDIT: Ok, I got it working. I had to unbrick it using this method and then used TWRP from pixel experience.
Last edited:


Senior Member
Feb 18, 2011
Redmi Note 8 Pro
Howto fix format data problem?
updated to miui12.5, formatdata always error 1

i had done flash miui12.5 ROM via MIflash, but still failed


May 29, 2011
I trier this metod and i waited 168 hour but any things happened Always says wait 168 hour any one give me solution to unlock my bootloader


May 29, 2011
now , i want to unlock my bootloader this is my probleme now when i try with mi unlock this msg open wait 50 hour


Dec 22, 2017
I just upgraded to miui 12.5 and it's very buggy so I was thinking of clean flashing it. Can someone tell me how should I do that? There are so many recoveries I don't know which one to use. Should I first downgrade to miui 12.0.x?


Senior Member
Dec 19, 2011
Redmi Note 8 Pro
I just upgraded to miui 12.5 and it's very buggy so I was thinking of clean flashing it. Can someone tell me how should I do that? There are so many recoveries I don't know which one to use. Should I first downgrade to miui 12.0.x?
Why don't you just try a factory reset. Its basically the same thing. No need to downgrade first.
Settings } about phone } factory reset

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    subscribe to alltricks channel?

    you should advice me: google search
    It's playlist for Begonia devices which includes TWRP and root for 12.5.x for noobs. Even noobs that can't read, still can follow videos and work
    And no one ask you to subscribe that one. You asked for a good method but can't spend 1 min to take a look what others show you. Why not just use Google search before you asked?
    That's the reason why i asked after spending hours reading threads like megatthread, install twrp proper etc... and failing resulting bootloop, had to reflash stock through fastboot etc...
    I use to flash many xiaomi (redmi note 3g , 4x, 7, poco f3 etc) mostly snapdragon ones and never faced such issues and difficulties like begonia, that's the reason why I finally just asked helps...

    However thank you for the YT link, I hope I manage to flash properly, I'll tell you
    Yep. Begonia need disable AVB (or patch vbmeta) after root to make it boot. And you can see it in that video tutorial. And don't try to use official TWRP, it's only for A9 which is outdated
    I did what you said and it worked! No worries cause no more update, 12.5.15 was the last one, thank you for your advicements
  • 48
    * Your warranty is now void.
    * I am not responsible for bricked devices, dead SD cards,
    * thermonuclear war, or you getting fired because the alarm app failed. Please
    * do some research if you have any concerns about features included in this ROM
    * before flashing it! YOU are choosing to make these modifications, and if
    * you point the finger at me for messing up your device, I will laugh at you.


    Here we are guys... After searching here and there i found some working ways to Root this device without getting bricked. So let's discuss about these :


    - Download the Mi Unlock app to PC, and sign in with your Mi Account;
    - Enable Developer Option in your phone by tapping the "Build Number" 7 times
    - Go to Developer Options "Settings > Additional Settings > Developer Options
    - Enable USB Debugging and OEM Unlocking
    - Aslo add account in Mi Unlock Status (Can be found in Developer Options
    - Install all the required drivers (adb drivers, vcom drivers etc.) In your PC [I'll link these below]
    - Shut down your phone manually, and hold Volume down key and Power button to enter Fastboot mode
    - Connect your phone to PC using USB cable and click "Unlock". In Mi Unlock Tool
    - You will be given a specific time (168 hours mostly)
    - Wait until that and redo Unlock process
    - Woah you have Unlocked your device :)


    - Install Minimal ADB and fastboot on your PC [Link will be provided below]
    - Download LR Team TWRP [This work for now, I'll provide link below and will update it after we have another proper TWRP]
    - Put that TWRP in the file location of ADB and Fastboot (Right click on Minimal ADB and Fastboot icon on desktop and click on Open file location)
    - rename that recovery to "twrp" for convenience (optional)
    - Now Connect your phone to PC With USB Debugging on (keep phone on).
    - Type
    adb devices
    and accept the pop up on phone's screen.
    - Now reboot your phone to Fastboot mode
    - Type
    fastboot devices
    - Your device ID will be visible on Screen.
    - Then type
    fastboot flash recovery twrp.img
    - When it's done, Remove cable and Hold Power + Vol. Up when phone starts turning on leave the power button but keep pressing Vol. UP until TWRP splash Screen shows up.
    - Done U did it :)

    3. ROOTING :

    - In TWRP mount System
    - Go to Advanced > file manager
    - then go to system_root > system and delete "recovery-from-boot.p"
    - Go home and again go to advanced and Select "Close AVB2.0" swipe to confirm.
    - Go back and select "Install Root"
    - Here you go magisk 19.4 will be installed (U can chose any other versions afterwards.)
    - Reboot the device to system.
    - Ah Yes you did it

    In case anything goes wrong ask me here or in official telegram group


    1. Mi Unlock tool
    2. Minimal ADB and Fastboot
    3. ADB Drivers for MTK
    4. MTK USB Drivers
    5. LR Team TWRP

    If this helped you then hit the Thanks Button. Good Luck :)
    Fastboot not working --> solution

    Hi everyone,

    I follow this tutorial and I face a twrp boot loop, I then try to install another TWRP and BAMM ... no more able to access recovery and fastboot. So here's what saved my day and my phone: flashing back Team LR TWRP using adb. YESSSS you've read well :D

    Please share this solution everywhere because that really did a miracle.

    (1) Flash recovery using adb YESSSSS

    Source: blog[dot]matt[dot]wf

    Enable your USB debugging bridge in switch via adb to the terminal:

    ./adb shell
    Then you should be able to find your recovery partion with:

    DEV=$(ls /dev/block/platform/*/by-name/recovery); echo $DEV
    that should output something like this:

    If this is the case you only have to put the recovery.img on your sd-card or the internal storage and you are one command from flashing:

    dd of=$DEV if=/external_sd/recovery.img
    Thats it! No binaries you have to install. No ****ty fastboot udev rules :S

    You can enter into your new recovery system with:

    ./adb reboot recovery

    2) Good now I was able to be back in the LR Team TWRP. From there I removed root and thus magisk, make sure to disabled DM Verify again and a miracle happenned, I was able to boot my phone and Fastboot is back !
    Hey Pritish1998,

    I must admit, I was a little leery, after reading all the other threads about installing twrp and rooting and the horror stories they contained. Well, your instructions seemed fairly simple. I followed them EXACTLY... and I lost my ass, everything got wiped, my imei, everything!!!

    Totally kidding, everything worked perfectly, I followed your steps exactly as stated. I did not loose any data, nothing, every app, all my downloads, everything is still on my phone. THANK YOU SO MUCH!

    Also, TWRP, is still installed, didn't get wiped out by the stock recovery. I have root, and oh, I am on MIUI Global, on the United States phone I ordered off of Amazon. More Specifically, MIUI Global Android Version 9 PPR1.180610.011. I received the MIUI 11 update about 3 days ago, and was still waiting the 160 some hours out for the bootloader unlock. I just got the bootloader unlocked about 3 hours ago. Went through numerous instructions and posts and this one seemed to make the most sense. I wasn't sure about MIUI 11 working, but fudge it, I thought I would just return the phone if I had a problem, but nope, you're instructions were clear and precise and I followed them to a tee and its working great and I have Magisk and did the safetynet update, and I'm all good.

    I haven't updated Magisk to 20.1 though. Didn't want to press my luck.

    Thanks so much bro, really, thank you.
    These are the the same instructions as found here https://forum.xda-developers.com/showpost.php?p=80604223&postcount=2
    Why create a new thread without giving any credits. It's cluttering the forum.

    In case anything goes wrong ask me here or in official telegram group
    Reported, read the FAQ about telegram.
    Thanks, it did brilliantly, any advice on the TWRP can't make the backup folder?
    I'm keen to start pruning the system of the useless Xiaomi bloatware but not without a backup, flashed Magisk 20.1 also, working perfectly.

    Wait for a proper TWRP. Cuz devs are already working on it