• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[GUIDE][BOOTLOADER,TWRP, ROOT]Lenovo TAB3 8/TB3-850F

Search This thread

jojaba2u

New member
Apr 23, 2020
2
0
Louisiana
Another Boot Loop Fix

I followed these instructions, but I threw myself into a boot loop because I rushed and did fastboot flash recovery twrp.img after I unlocked the bootloader. I obviously panicked, but I was able to fix it by flashing the stock recovery on the tablet. When it was in the boot loop, I clicked the volume down and power button and ran adb reboot bootloader in terminal until it was able to boot back into fastboot. Then I just ran fastboot flash recovery recovery.img

I'm unable to post any links in this post since I'm new, but you can probably find the stock recovery img in one of these posts or google it. If you're still having trouble, message me, and I'll make sure you get it.
---
After I got the tablet up and running, I followed the instructions more closely, and I got it up and running. Thanks so much for this post!
 
Jul 11, 2020
14
1
Who can share the firmware tb3-850f of 850f_ USR_ S100023_ 1604141138_ MPM0._ Row is another download address, not flashable zip. I can't download it with GDrive in China. Who has the download connection and sharing of mega cloud disk. thank you. Sorry, my English.

---------- Post added at 11:25 AM ---------- Previous post was at 10:55 AM ----------

To the best of my knowledge, this is the most current Android 6.0 stock ROM for the Lenovo Tab3 TB3-850F, built from the most current firmware version. To specify, this firmware is for the "81 Hardware Code" variant. (The Lenovo/Moto Smart Assistant recognizes two variants of the TB3-850F -- the "80" and the "81" "Hardware Code" models. To verify your variant, check the last two digits of your S/N, which will be either 80 or 81. The 81 variant uses the MT6735m SoC, while the 80 variant is believed to run on the very similar MT8161. While the specs of the two variants are almost exactly identical, the Moto/Lenovo Smart Assistant does distinguish two variants -- and while I cannot confirm whether there is a firmware difference between the two models, I do want to make note of the confirmed OEM distinction.)

TB3-850F_USR_S100031_1710101_MPNO_ROW:
https://mega.nz/#!xcsUHYpS!wU6mg6OFJCWVC8hcMxdZa80ljGY9PgUrOF98JcMiI70

By the way, are you all needing any particular ROMs or firmware packages for the 850F? I have various files in my Mega cloud that I've gathered from here, Android Central, etc. Just let me know and I don't mind sharing if I can help.
Also, please note that I did not create this stock ROM installer. Credit should go to the author listed in the TWRP installation script. (The name I cannot recall off top).

do you have firmware tb3-850f of 850f_ USR_ S100023_ 1604141138_ MPM0._ Row on mega drive? i can't download form google drive. thank you.
 
Who can share the firmware tb3-850f of 850f_ USR_ S100023_ 1604141138_ MPM0._ Row is another download address, not flashable zip. I can't download it with GDrive in China. Who has the download connection and sharing of mega cloud disk. thank you. Sorry, my English.

---------- Post added at 11:25 AM ---------- Previous post was at 10:55 AM ----------



do you have firmware tb3-850f of 850f_ USR_ S100023_ 1604141138_ MPM0._ Row on mega drive? i can't download form google drive. thank you.
Give me a day or two, as I'm not presently at home. I'll upload to Mega and post a link. I have the firmware package you need. Ok, no wait. I was able to find you a Mega link over at Android Central. This is TB3-850F_USR_S100023_1604141138_MPNO_ROW.zip, official signed Android 6.0 Marshmallow firmware for the Lenovo Tab 3 8/TB3-850F tablet, archive size 1.4 GB.
https://mega.nz/file/FYRGVAIR#k9WaA6MhZ4Nd20VOa_NFNVdyp9KdeNN0FXnejVTt4As
 
Last edited:
  • Like
Reactions: pndwal

MightyFalcon

Member
Jul 11, 2010
5
1
Does anyone have an active mirror of the files for this? Preferably not a Google Drive that requires permission to be granted to it first? I have no way of knowing if the OP still monitors the account for those files for requests for access. I've been able to cobble together some of the files to go back to stock and get unlocked, but I don't know if the TWRP I have found in another thread is the newest for this tablet either.
 

MinecraftW06

Member
Mar 8, 2021
5
0
HELP! I mounted /system as read/write, and now I'm in a bootloop!
What can I do?
UPDATE: I managed to get inside TWRP, but I still can't fix the problem
 
Last edited:

Cyphos84

New member
Apr 3, 2021
2
0
Hi:

Thanks for the guide, but i need access to download the files. These files are compatible with YT3-850F_S000122_191223_ROW ?

Thanks in advance!
 

Hemphiz

Senior Member
Sep 12, 2015
923
312
Bristol
m.9gag.com

Crisdax

Member
Jun 15, 2021
5
0
¡Novedades Flash para usuarios de TB3-850F!

¡Ahora tenemos LOS14.1 estable para TB3-850F! :)

Simplemente actualice TB3-850M LOS 14.1 ROM de [MENTION = 5968730] al_rus [/ MENTION] de la 4PDA rusa, luego actualice TB3850F_MOD_boot.img desde el archivo zip de [MENTION = 8548258] wezroot2k [/ MENTION] (de XDA) para curar los bootloops y inestabilidad en TB3-850F.

Lectura: Detalles de los esfuerzos con esto en las dos últimas páginas aquí.

Archivos:

TB3-850M LOS 14.1 ROM: https://yadi.sk/d/FKiFjn9x3Rp4MU

TB3850F_MOD_boot.zip: https://forum.xda-developers.com/attachment.php?attachmentid=4698911&d=1549212166

Un gran agradecimiento a [MENTION = 5968730] al_rus [/ MENTION] (4PDA, hilo de firmware TB3-850M, http://4pda.ru/forum/index.php?showtopic=764969 ) por su tremendo trabajo en TB3-850M LOS 14.1 ROM.

Además, felicitaciones a [MENTION = 8548258] wezroot2k [/ MENTION] (próximo desarrollador de XDA) para TB3850F_MOD_boot.img (kernel y puerto de disco ram) y por continuar haciendo ajustes a LOS14.1 para optimizarlo para TB3-850F. :) PW

- Mensaje similar (sin enlaces a archivos) publicado en los siguientes hilos de XDA TB3-850F:
- https://forum.xda-developers.com/android/help/lenovo-tab-3-8-tb3-850f-unbrick-root-t3598727
- https://forum.xda-developers.com/android/general/rom-lenovo-tab-3-8-tb3-850f-t3617594
- https://forum.xda-developers.com/android/help/qa-lenovo-tab-3-8-tb3-850f-t3700868
- https://forum.xda-developers.com/th...m-stock-android-6-0-rom-lenovo-tab-3-t3825165
- https://forum.xda-developers.com/android/general/rom-lenovo-tab-3-8-tb3-850f-android-6-0-t3593043
- https://forum.xda-developers.com/android/help/lenovo-tab3-8-2016-custom-recovery-t3483454
hola , déjame a ver si entendí abro el zip del tb3 850m y lo descomprimo y remplazo el boot del 850m por el de 850f lo comprimo de nuevo y lo instalo ?
 
  • Like
Reactions: pndwal

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hello,
    Have this tablet some alternative rom, than original, with newer android?
    Yes there is a LineageOS 14.1 (Android 7.1.2) custom ROM available for this tablet. It's posted here on XDA. Here is a link to the custom ROM thread https://forum.xda-developers.com/t/...eos-14-1-for-lenovo-tab-3-8-tb3-850f.3900320/
  • 12
    This guide, for the Lenovo Tab 3 8" (TB3-850F), has 3 purposes:

    1. Unlocking your bootloader;
    2. Installing TWRP custom recovery;
    3. Attaining superuser privileges (root) of the stock OS.

    NOTE:
    I can attest & confirm that this method has worked 100% on at least 7 devices of my own. Please read and re-read the instructions carefully before proceeding. If you follow this tutorial exactly as delineated, you should have no adverse issues in unlocking your bootloader, flashing custom recovery, or achieving systemless root of the stock Android OS.




    MENTIONS & THANKS:
    Based on XDA Senior Member @Hemphiz's groundbreaking root and custom recovery for this device, I am now revising this thread wth improved step-by-step instructions based on members' feedback and experiences. Thanks @Hemphiz for your research, assimilation of necessary files, and for breaking ground on this tablet. Thanks also for your granting me ownership of the thread. Your contributions are greatly appreciated by many. Thanks to the great @Chainfire for his flashable systemless rooting script. Thanks to @jemmini for compiling TWRP for this tablet. Finally, thanks to the many members who have tested this guide and provided much needed input & user experience.

    DISCLAIMER: As always, please be reminded of the risk involved with flashing a custom recovery and/or attempting to attain superuser privileges of your Android OS. I will not be held responsible for devices bricked or otherwise rendered inoperable as a result of this thread. You assume full responsibility for any good or bad which may result from proceeding any further. However, with that having been said, I will provide any and all support possible. Read and follow the foregoing steps thoroughly and carefully prior to proceeding. NOTE: THIS GUIDE IS INTENDED ONLY FOR THE LENOVO TAB 3 8"/TB3-850F.

    REQUIREMENTS:

    1. Minimal ADB & Fastboot v1.4 (or newer) Windows Installer;
    2. Windows PC or laptop (Mac may be used; however this guide is intended for Windows 7 and newer operating systems);
    3. Official Lenovo USB Device Driver v1.1.21;
    4. TWRP v3.0.1 for the TB3-850F;
    5. ADB Driver Installer for Windows;
    6. SuperSU v2.82-SR5 flashable zip.

    (All files, drivers & utilities for this process are available in the below download link)

    DOWNLOAD LINK: https://drive.google.com/folderview?id=1l-YN5aXmjDF3O1bHxFHVIxLKuvd847Q9




    INSTRUCTIONS:


    1. First and foremost, unlocking the bootloader is necessary. Also, this step is a good place to make some requisite preparations. Power on your Tab 3 and select SETTINGS once booted up. Go to ABOUT DEVICE, find BUILD NUMBER, and tap it 7 or 8 times until DEVELOPER OPTIONS is enabled. In DEVELOPER OPTIONS, tick OEM UNLOCKING and USB DEBUGGING. On your PC, install the Minimal ADB & Fastboot utilities, the ADB Driver Installer, and the Lenovo USB Driver Installer. Connect your Tab 3 to your PC with the supplied (or quality equivalent) OEM charging/syncing cable. Open a command window in your ADB/Fastboot directory, by holding SHIFT and right clicking in the desired path. In the command window, type: adb devices & press RETURN. If your device is connected properly, the command window will display a string of numbers/letters, which represent your device's serial number. If your serial number does not appear in the window, try changing USB ports, change syncing cables, or try reinstalling the ADB Drivers. Once properly connected, type adb reboot bootloader & press RETURN. Your tablet should boot into Fastboot Mode, which will be displayed in white bold letters on your device's display once complete. Once in Fastboot Mode, type fastboot oem unlock & press RETURN. Your device will prompt you to press Volume Up to proceed with unlocking the bootloader, or Volume Down to cancel the process. WARNING: UNLOCKING THE BOOTLOADER AUTOMATICALLY INITIATES A FACTORY DATA RESET. YOU WILL LOSE ANY UNSAVED VIDEOS, MUSIC, PERSONAL FILES, ETC.

    2. Now that your bootloader is unlocked, you are ready to flash TWRP. Download the twrp.img file from my link and save it to your PC in the ADB/Fastboot path/directory. Also, save a copy of the file on your device's internal storage or external micro SD card. Since your device underwent a factory data reset, you will again need to enable DEVELOPER OPTIONS & tick OEM UNLOCKING & USB DEBUGGING as you did in Step 1. When you have done this, again open a command window, ensure a proper connecion, & type adb reboot bootloader & press RETURN. Once in Fastboot Mode, type fastboot boot twrp.img & RETURN. EXTREMELY IMPORTANT NOTE: this device's boot image is secured with dm-verity. Leave the /system partition as read-only when prompted by TWRP. Mounting /system as read/write at this point will result in a boot loop. Flashing SuperSU, as outlined in Step 3, will patch dm-verity and fix this.
    From the TWRP main menu, select INSTALL, select the image file option in the bottom right of the screen, navigate to the location where you saved twrp.img in device storage or external storage, and commence the installation. Be certain and correctly choose "recovery" when prompted by TWRP. Now select REBOOT, then RECOVERY. Your TWRP custom recovery should now be successfully installed on your device's /recovery partition.

    3. Now, it is time to root this tablet. Download & save a copy of the SuperSU v2.82-SR5 zip file to the tablet's internal or external storage. In TWRP main menu, select INSTALL & navigate to the saved SuperSU zip. Commence with installation. Systemless root mode will unpack, modify, repack and flash the patched boot image. Once done, reboot system. Your Android OS should now have full systemless root, and the /system partition may now safely mount as read/write.

    TROUBLESHOOTING:

    In the event your device becomes stuck in a bootloop, or is otherwise failing to boot into the OS, the following is a link to my stock firmware images thread for this device. NOTE: the following link will be beneficial only if your device successfully boots into Recovery/Fastboot mode. This link provides stock partition images of /boot, /recovery, /logo & /system. Typically, flashing the stock boot & system images will get you up & running again, and will restore the Android OS to stock condition.
    https://forum.xda-developers.com/an...o-tab-3-8-tb3-850f-android-6-0-t3593043/page5

    In the unfortunate event that you encounter a brick (your device fails to boot into the OS or Recovery Mode), please visit @r&xp's thread on unbricking your device & restoring it to factory stock condition. Members using his thread be sure to thank @r&xp. His collection of necessary files & comprehensive instructions has saved many, many bricked tablets. https://forum.xda-developers.com/android/help/lenovo-tab-3-8-tb3-850f-unbrick-root-t3598727
    5
    News Flash for users of TB3-850F!

    We now have stable LOS14.1 for TB3-850F! :)

    See post above. Regards, PW.

    Alerting:
    @Hemphiz
    @Lister Of Smeg
    @mtpc
    @stonedpsycho
    @fran89
    @r&xp
    @john3voltas
    @Garcy23
    @voland34
    @DeblaGaming
    @sorun343
    @limited_imagination
    4
    Yeah, I'm not sure how I screwed it up but I'm glad it's working. In order to get into adb I tried the method you mentioned of holding the volume+ for 5 seconds and then plugging in the usb cable. From there I used adb to reboot into the bootloader. I tried flashing the boot and recovery images from there, but it didn't seem like they took. So then I used the fastboot boot command with the TWRP image, but it wouldn't let me access the data partition for some reason. I went to reboot and then all hell broke loose and it was just rebooting through TWRP failing with openscript and then rebooting again nonstop. I couldn't manage to shut it off completely even holding the power button for 30 seconds or so. I figured I was screwed, but held the volume up, volume down (and I think power?) at the same time and suddenly it actually launched TWRP. However, it couldn't access the data partition for some reason. I threw the stock boot, recovery, and system images on an SD card and then flashed them all and that finally got it working.

    I've rooted other phones, but I've had hardly any experience with adb. Fortunately I feel like I did learn quite a bit from screwing up, which is always a plus.
    Great work. Sounds like a good learning experience for you also. These devices on a MediaTek platform are a horse of a different color indeed. I've bricked a good handful of these devices through trial & error myself. By the way, please be sure and hit the thanks button on the OP. @Hemphiz done an excellent job initiating TWRP & root for this great budget tablet.
    I am currently working on a stock based 6.0.1 ROM for this device: rooted, deodexed, debloated & zip aligned. I'll add a few baked-in features like Substratum & Viper4Android. Also I'll add a couple of tunable governors & tweaks to the stock kernel. I'm terribly tied up at work, resulting in having to take a couple weeks break from Android, but I should be up & running again in 3 weeks or so.
    Anyway, I'm very glad it worked out for you. Try this to iron out any bugs with booting TWRP. First, save a copy of the twrp.img to your internal storage or external micro SD card. Next, get your device into TWRP. Select INSTALL, then select the flash img option in the bottom right-hand corner. Navigate to the location of your TWRP.img, commence to install and select "RECOVERY" when prompted to do do. Once done, wipe Cache & Dalvik/ART. Reboot system. This should allow smooth booting of TWRP, with no loops or lags.
    4
    my tablet is tab 3-850f_S100030_161209_row

    so i guess it could be possible to root...i am little be afriad to do that...

    this step 6

    #6 Now you need to boot to your custom recovery via the button combo for the device. (imo this tablet is a pain to boot into recovery compared to most devices) power off the phone. Wait a few seconds. Now hold the power button - then while still holding the power button press Volume up and then Volume down. Hold it for about a second then let them all go. If it worked then you will get the usual boot logo followed by the main twrp screen. Swipe to allow it to make modifications. If it boots into the Chinese recovery thing then just turn it off and try again. I would suggest getting an app that allows you to "reboot to recovery" once your all done and rooted. For root. Simply put the "Supersu sr3" zip in the storage of your tablet. Then flash it via twrp. "install - find where you put the zip - flash - reboot system" Done.

    would someone be more specific to explain...i get my tab in boot mode with holding power buton and volume down an up......and in display is simbol of android with mesage no command..its confused me...

    ---------- Post added at 01:45 PM ---------- Previous post was at 01:28 PM ----------

    i found a solution...press power button 2 seconds and quick press once volume up....

    now i am in recovery boot menu...

    so if someone to explain more specific this step 6

    thanx for advices

    regard

    See this post from Lister of Smeg's TB3-850F Thread, re root & recovery for TB3-850F. Note 'To Enter TWRP':

    filedropper.com/tb3850froot (for files)
    Quote:
    Originally Posted by mtpc
    Hey guys, It's me again. I managed to crack down the russian CAPTCHA and downloaded those files, and it just WORKS! I now have full root on my TB3-850f. I wrote down simple HOW-TO:
    [Slightly ammended by Peter Wallace (Original Post #49)]
    1) Copy SuperSU-v2.79-SR1-20161221223537.zip to the tablet
    2) Enable developer and USB debugging
    3) Open cmd (command Window) in folder with ADB and FASTBOOT
    4) Type these commands:adb reboot bootloader
    Then:fastboot oem unlock
    5) Hold down power button and reboot. Repeat 2) and enable OEM UNLOCK
    6) Repeat 3) and type:adb reboot bootloader
    7) then type:fastboot boot recovery.img (must be copied in the same folder as adb.exe and fastboot.exe)
    (Don't flash recovery yet - system will replace stock recovery before you have root)
    8) Use TWRP to install SuperSU. - Now you have ROOT (Systemless) (can update to SR3, etc)
    9) Repeat 3) and type: adb reboot bootloader
    10) Type:fastboot flash recovery recovery.img - Now your new TWRP recovery will be permanent.
    11) Use TWRP to reinstall SuperSU as lost in step 10 - Now you have ROOT (Systemless).

    To Enter TWRP:
    After powering down, press power, wait 1 sec then hold both vol up & down also (all 3 buttons) until vibrates.

    I also uploaded the files here: filedropper.com/tb3850froot

    Peter W:
    Here is link to latest 850f rom:
    http://lenovo-forums.ru/files/file/1549-lenovo-tab3-a8-tb3-850f_s100030_161209_row/
    Which takes you to https://cloud.mail.ru/public/8T5R/RWCkuBz19
    4
    Thanks for the guide!
    Everything works but when I reboot into recovery I just get the dead android with no command under him..
    I tried two times with same result Fastboot reports twrp flashes ok

    Any ideas?

    Thanks
    Not to hijack the OP's thread but here are my thoughts. The dead Android indicates that TWRP did not successfully flash to your /recovery partition. Sounds like stock recovery is still installed. First, place a copy of twrp.img on your device's internal storage or on an external micro SD. Try this: instead of typing the command "fastboot flash recovery twrp.img", type " fastboot boot twrp.img" (assuming your twrp file is named twrp.img. If it isn't, rename it twrp.img for simplicity purposes). This command will temporarily boot your device into TWRP recovery. From the main menu on TWRP, select INSTALL. In the bottom right of the screen, select the option for "img" files. Navigate to where you stored "twrp.img" and select it. Install it to "RECOVERY" when prompted. Once it flashes, select REBOOT then select RECOVERY. Your device should now successfully boot into TWRP recovery.