[GUIDE] Bootloader Unlock On RUI 2.0 based on Android 11(R)

Search This thread


Jan 17, 2022
Thats a driver issues. connect phone to PC and install pdanet on PC it'll auto install the drivers.
after that fb should work.
Still no luck, I installed pdanet on my phone and pc, and it did install drivers, but whenever i start the in depth testing and it booted in the bootloader, my pc still can't detect my phone. So i can't do any fastboot commands like the fastboot flashing unlock


  • Untitled.png
    185.4 KB · Views: 90


Jan 17, 2022
still no luck finding solution, i'm still stuck on this message "oplus verify fail" and my pc can't detect my phone when in bootloader. so still can't do the
fastboot flashing unlock

tried factory resetting my phone, tried reapplying on deep test. nothing seems to work


  • 271642841_930952300731637_2744796602881486565_n (1).jpg
    271642841_930952300731637_2744796602881486565_n (1).jpg
    33.5 KB · Views: 60


New member
Apr 22, 2021
What should i do? The app isn't installed in my phone and i did factory reset and nothing changed


  • Screenshot_2022-02-13-16-23-36-20.jpg
    131.1 KB · Views: 52
  • Like
Reactions: Almasd


Senior Member
Jan 19, 2018
Realme 6 Pro
It's a bit more complicated than just exiting deep_test. There are guides available. Please follow them. Also make sure everything is stock. That includes recovery, boot, system, vbmeta etc.


New member
Mar 10, 2022
*After unlocking Widevine L1 will be replaced by Widevine L3, which as of now can't be fixed/patched. If you already had L3 on locked bootloader... My condolences.*

What does this mean i already have L3 on my device does that mean if i attempt this, it will have serious problem? Sorry i'm new to this.

Top Liked Posts

  • There are no posts matching your filters.
  • 12
    (26/09/21) Note.- This tool is primarily for realme 6Pro on RUI2.0, and is expected to work on it without issues. However deep-test apks sometimes work for other devices too... If it's working on yours then good, if not then there's nothing that can be done except find the correct one for your device [c.realme.com]. These tools have in-built checks and I have no idea which parameters it considers, if I had to guess I'd say a certain fw version requirement and the model of chipset. So if you have any device other than RMX2061/3 and this tool didn't work, I'm sorry.

    If you've updated to realme UI 2.0 and want to unlock, this will allow you to do it.
    Your warranty may now be void.
    *After unlocking your phone ALL OF YOUR DATA WILL BE ERASED! Backup before you Proceed.*

    *After unlocking Widevine L1 will be replaced by Widevine L3, which as of now can't be fixed/patched. If you already had L3 on locked bootloader... My condolences.*
    *Safety-Net fails so some banking apps may not work and Play Store certification will be gone*

    ADB and Fastboot.
    Deeptesting APK for A11.

    Steps for Unlock:-
    1. Backup your data.
    2. Install deeptesting.apk.
    3. Open the app and click start applying.
    4. Wait for application to be summited and processed.
    5. Minimize the app and head over to developer settings and turn on OEM Unlock and USB Debugging.
    6. Open deeptesting again and click on start in-depth test, the phone will reboot to bootloader. OR manually do that by pressing volume - and power in switched off state.
    7. Connect phone to PC. Open ADB folder and use right click+shift and from the there click on open powershell/cmd here or type cmd in address bar.
    8. Type fastboot flashing unlock(cmd) or ./fastboot flashing unlock(powershell).
    9. Use volume and power button to select unlock the bootloader.
    10. Phone will format and reboot.

    *If you had unlocked bootloader and updated from RUI 1.0 --> 2.0, you don't need to repeat this.*
    *If you know how to unlock or have unlocked before, Congratulations! Also this guide isn't for you, but you may find the APK useful.*
    *For people who are unlocking their device for the first time, make sure when re-locking, all partitions are stock, or you'll have a very bad day... or a week/month if there aren't any service center nearby.*
    My device is realme x2 (Chinese rom). when I tried to install the deep testing app it says an app with same signature has already been installed . But I did not install that app never before. How can I do this?
    Use adb reboot-bootloader.
    when stuck at boot /recovery destroyed screen. there is no adb.
    Good morning,

    i tried this deep testing version on my realme 8 5g (android 11 UI 2.0),
    but it doesn't work and the message comes out

    "Failed to submit application. - This phone model does not support deep testing."

    what can I do?
    Wait for realme to allow bl unlocks on 8 5G.