• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[GUIDE][CHANNEL] Stock Android 10 for Boost Mobile Moto G7 Play

Search This thread
That should have posted 2 hours ago.

This is what I f'ing loathe about this process because it happens virtually EVERY time regardless of the device or OS or mod that I'm doing.

The first thing I did was make sure sdk tools were updated. There were updates for Android 6 and 10, as well as two new modules to install. It took about a half hour to go through them all, but everything is updated.

Downloaded LoS, latest version, and the recovery image.

Go to the first step on the LoS install, which is to sideload a specific zip file. kay...
-reboot into bootloader, then from there to recovery
-adb sideload <the file>
-on computer: error:closed
-on phone: Error 21, footer is wrong

This nearly ALWAYS happens, and I have yet to find a fix. I google for an answer, keeping results to just within the last year, and someone on Reddit had suggested a fix that worked for the poster. His problem was that he was in stock recovery. He needed to be in LoS recovery.

I think "well, they give you a recovery image separate with the OS download, maybe it's to boot with, like TWRP." So I boot into the bootloader and try to fastboot boot <lineage recovery.img>..........and it just starts up normal. I go to settings and check the build, and it's still the Android 10 version I started with. Tried it again, same results.

So then I get the bright idea to stay where I'm at in stock OS and adb reboot <lineage recovery.img>

Now, on my phone it's in a weird Android Recovery screen. "Can't load Android system. Your data may be corrupted. If you continue to get this message...." Then it gives me two options: Try again or factory reset.

Well, my mama didn't raise no quitter, so I hit Try Again. It goes to the black screen with "N/A" on it (which is what it would do back when I had this thing rooted and everything was peachy until I forgot the lock screen pattern), but then I get that error message again.

I'm going to factory reset and see what happens. Anyone with a solution, feel free to chime in anytime.
I do admire your persistence. And yes it's a pain in the ass to say the least. The G7 Play's A/B partition scheme complicates things even further. The error message you ate receiving on the footer sounds familiar. I'll see what I can find on it.
 
I'll see what I can find on it.
You'll find a lot, since it's a common issue sideloading things. Over the past 4 years, when I started looking into Android stuff, I have around a 2% success rate sideloading.

I'm interested your take on the rest though. The power went out for a few hours about 20 minutes after my last update, so I haven't tried anything else.

I would LOVE to go back to the build I had when I first rooted this thing successfully back in (I think) Oct 2019, but I don't remember what build I had, and it wouldn't matter since I can't go back to it because the bootloader updated during one of these trials and I can't roll that back.
 
It is a very common misconception that Motorola devices cannot be downgraded. As you noted correctly, the bootloader-type partitions cannot be downgraded (bootloader.img) nor can the partition index table (gpt.bin). Otherwise, all other files in the firmware package should flash normally. Here are two official firmware packages for the CHANNEL.


I have an archive of most of the Android 9 Pie builds. If you want any of them me know. Again, I reiterate that it is not necessary to downgrade your bootloader or partition index in order to downgrade your Android version or firmware build.
 

Top Liked Posts