[Guide] Convert to Global [WIP]

esjames

Senior Member
Nov 8, 2013
397
104
73
Cheriton
I can say from my personal experience that the A11 modem does work, I just cant get it to roam onto the sprint bands B25/B26. If someone has figured this out please share :)
 

erik29gamer

Member
Mar 7, 2010
33
7
28
Weird. I did:
Unlock bootloader --> twrp & root --> backup persist and modem --> MSM Tmobile 10.5.7 --> unlock bootloader again --> recovery to 10.12 --> upgrade to Android 11. Not seeing any dual sim support at all with two sims inserted. Did I happen to miss something along the way?
Title says it all. Look I have 2 phones one with dual sim one without. There are no sim connections for a 2nd sim card on the T-mobile OnePlus 8. Shine a light in there you'll see the top doesn't look like the bottom...
Sorry for taking a while to get back. I stuck my T-Mobile SIM in the bottom side slot, SIM 2. It detects the SIM fine, but shows no service. So there is absolutely contacts for the 2nd slot.


https://imgur.com/a/eJTYYTu
 
Last edited:

mslezak

Senior Member
Dec 12, 2016
270
249
43
Houston
Sorry for taking a while to get back. I stuck my T-Mobile SIM in the bottom side slot, SIM 2. It detects the SIM fine, but shows no service. So there is absolutely contacts for the 2nd slot.


https://imgur.com/a/eJTYYTu
I tried again with a live sim. The internet settings show the right carrier but I can't get a connection to the internet or make a phone call. Checked the APN. The slot is there but as far as I can tell, you can't use it. It says no active connection. So still, I say 1 SIM on a TMO phone.
 
Last edited:

xxBrun0xx

Senior Member
Jan 1, 2012
2,254
701
193
CT
Just wanted to chime in. I kept having " no sim detected" messages appear after converting my t-mobile OnePlus 8. I run a TMobile sim. Turns out the sim itself went bad. Replaced it with a new sim and have had zero network issues on A11 global modem since. Weird issue, but easy to fix.
 

rzracer2

Senior Member
Feb 9, 2012
248
37
48
I converted to Android 10 global then took the update to 11 and another update to 11.0.1.1. I went to boot into the latest TWRP image so I could backup boot to root it but always boots to Qualcomm crash dump screen. Tried older versions but the same outcome. Other then that, fingerprint and modem seems to be working fine with no extra work. Thanks
 

brain_72

Member
Oct 7, 2013
9
1
3

What about this video, just flashing the rom with fastboot without backup persist and modem, with out MSM or custom recovery and root?

Im very confused with all of this, i dont know if i need to use MSM or just flash with fastboot, or backup persist and modem :(
 

brain_72

Member
Oct 7, 2013
9
1
3
Finally got the global working

1. MSM Back to T-Mobile 10.5.7
2. Upgrade to T-Mobile 10.5.10
3. Unlock bootloader
4. Flash fastboot 10.5.11
5. Restore persist.img for fingerprint

Need to do steps # 2, 5 otherwise no signal and no finger print
hi, i have the T-Mobile 10.5.10,im waitting the unlock code for the bootloader, do i need to downgrade to 10.5.7??? i dont understand what is the point. thanks
 

Hammerhand.17

Senior Member
May 29, 2010
601
107
73
Winterfell
And how can you chek if it worked? I have gone through the guide with an 8 pro and it still is marked as "in2020" (chinese version), although in firmware information I can see the "11BA" mark; is it right, or should I see "in2023"?

Thanks!
 

TheKnux

Senior Member
Sep 28, 2011
2,514
775
193
Akron
So I converted my OP8 to global a few months ago, and after having to MSM a few times, I finally got it. However, my girlfriend also has a OP8 and for some reason I can't get hers to convert. When I use a fastboot ROM, when it reboots to fastboot after using the flashall, it enters Crash Dump mode. Then I have to MSM back to stock. I tried entering fastbootd, but for some reason when I enter the command "adb reboot fastboot" it enters normal fastboot. When I do it on my already converted OP8, it enters fastbootd. I tried all of the possible commands and it still ends up in Crash Dump mode. Any pointers? I can provide more info if needed, this was just the gist.
 

BIGWORM

Retired Forum Moderator
Sep 18, 2009
2,132
1,023
183
So I used to the flash_all on my TMO 8T, but from what I can tell, I think I'm still on the TMO variant. Should I try again?
 

dj41490

New member
Dec 19, 2020
2
0
1
Man.... I give up... tried a couple times and it either gives me crash dump error or not allowed because of critical partition. I have an IN2017 Tmobile phone btw.
 

castle200

Member
Apr 23, 2011
13
0
31
Los Angeles
I did everything correct as far I know. Backed up persist, backed up the modem, flash_all to android 10 and OTA to android 11... Only issues I have so far is that Google Pay and Netflix don't work on the phone anymore. Is there a work around for that? I'm not rooted but the bootloader is still unlocked. I would hate to lock it again as I know that's not a good thing to do in most cases. I was hoping the OTA would do that but it didn't
 

xxBrun0xx

Senior Member
Jan 1, 2012
2,254
701
193
CT
I did everything correct as far I know. Backed up persist, backed up the modem, flash_all to android 10 and OTA to android 11... Only issues I have so far is that Google Pay and Netflix don't work on the phone anymore. Is there a work around for that? I'm not rooted but the bootloader is still unlocked. I would hate to lock it again as I know that's not a good thing to do in most cases. I was hoping the OTA would do that but it didn't
The issue is that your bootloader is still unlocked so you're failing safetynet (which apps like netflix and banking apps check). Flash a rooted boot.img (to install magisk), open magisk manager app, and enable Magisk Hide and you'll be all set.