• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[GUIDE] Deploying Astoria Packages Manually To W10M

Status
Not open for further replies.
Search This thread
Status
Not open for further replies.

Top Liked Posts

  • There are no posts matching your filters.
  • 31
    MOD EDIT: I'm closing this thread for now until the possibility opens back up for us to get Astoria running again. Too many posts cluttering away :)

    Hi everyone,

    After several days of sniffing Windows Update traffic and lots of downgrading
    , I've found a way to get Astoria installed and working on the HTC One M8 for Windows. that's right..
    In THEORY, this should work for all devices that aren't supported by Astoria project.

    The reason for this: In the process to go straight to 10536 directly from wp8.1,
    the needed aow.wim file got pulled by MS (for security reasons i suppose
    and i have no idea when or if they will bring it back).

    Requirements:

    -installed WDK,WPAK,WPDK (containing iutool.exe) get it there: http://forum.xda-developers.com/win...ools-wdk-wpak-wpdk-cabs-building-wp8-t3183972
    -w10m build 10536 installed on phone
    -usb connection to pc
    -astoria cabs

    Here are the direct download links of the needed astoria cabs:

    10166 (canonical)
    Code:
    http://wp.ds.download.windowsupdate.com/d/msdownload/update/software/dflt/2015/07/microsoft.ms_projecta.mainos.spkg_9dec9dcfe0f22750e3737e9a484e7a60e193303c.cab

    10512 (diff)
    Code:
    http://wp.ds.download.windowsupdate.com/d/msdownload/update/software/dflt/2015/08/microsoft.ms_projecta.mainos.cbsu_c36c1e67bd04b694a01b65efeb70213ff439be76.cab

    10514 (diff)
    Code:
    http://wp.ds.download.windowsupdate.com/d/msdownload/update/software/dflt/2015/08/microsoft.ms_projecta.mainos.cbsu_7ec3fb51b79d57de88e6adaa0e27800106ecedd8.cab

    10536 (diff)
    Code:
    http://wp.ds.download.windowsupdate.com/d/msdownload/update/software/dflt/2015/09/microsoft.ms_projecta.mainos.cbsu_f0ea237eea0f74372a7eb6745585a06a4ee3feb9.cab


    Instructions:

    -Go to iutool path in cmd with admin rights (usually c:\program files (x86)\windows phone kits\8.1\tools\bin\i386)

    -Type "iutool -l" to see if the device is connected and recognized.

    1 put only the first cab (10166) to a new folder like c:\cabs

    2 then type: iutool -v -p c:\cabs

    3 it should push the cab to the device and start the update.

    4 there might be a error 0x8024a110 but it should work.

    5 the device will automatically reboot very soon and go to flash mode (gears) to apply the cab.

    6 then there will be the usual "data migration".

    Repeat steps 1-6 with all the cabs in correct order one by one.

    Astoria should now be installed and working.

    There are already guides on xda about getting apk's installed via wconnect.

    Thanks to @snickler for helping me with the method to obtain the cabs even if ms tries to prevent it.
    Thanks to XDA Dev Team for daily chats and support.

    Screenshot:
    attachment.php
    3
    I would love to try this out but no able to get a Connection with my pc (only with the iutool, all other connections are working). I always get this error: "ERROR: 0x80070490 Command failed. (HRESULT = 0x80070490)" when I enter the command "iutool -l". And sorry for asking this, I know this isn't a noob forum but need your help.

    I had this problems, I just enable the "Developer Mode", restart the phone and computer, and after is ok in Lumia 830.

    From MS site:
    MSDN said:
    0x80070490
    ERROR_NOT_FOUND
    This can happen if there is leftover registration information on the PC. To resolve this issue, remove all registered mobile devices from the Devices and Printers control panel.

    This helped for me. Unplug the device, open Devices and Printers and remove all "Windows phone" devices. Plug it back in, wait until Windows recognizes it (it appears in Explorer) and it should work.
    2
    Nice work, mate. Worked nice on build 10536 on a Lumia 930.

    But I still have one doubt: is it possible to run this on build 10581?

    No.
    1
    BTW why not all cabs at a time ? :p

    No need to DLOAD 6GB Stuff.
    i836 is enough for everything, if any one would share. Just below than 10 MB :p

    Because the cabs won't install all at once as some are diffs. Each cab is a corresponding package version. It checks for version dependencies and if there's a clash or if you're trying to install a cab that is lower or higher than the dependency, it won't let you do it.
    1
    project Astoria is DEAD and not working....

    please close this thread...

    This is a good idea. I'm going to close this thread for now.. If Microsoft decides to ever bring this back, then I'll re-open. It's pointless to keep pages upon pages of "omg doesn't work" building up