[Guide] Enable camera API 2 (No root)

Search This thread

abctablet

Member
Jul 4, 2019
9
0
0
Toronto
Will this work on Zenfone 5Q ZC600KL? We have 7.1.1 because ASUS refuses to upgrade it to Pie and keeps lying and delaying the upgrade... thanks, really tired of this customer service and garbage camera on a phone that;s ADVERTISED for pictures.
 

valkes2

Member
Jul 10, 2019
11
4
0
I REALLY need some help

Phone: Asus Zenfone Selfie Pro 4
What i want: to install GCAM

I got the ADB device recognized by windows
Cant get it recognized as a Fastboot device

Ive tried several drivers and nothing seems to make my phone a "fastboot device" recognized by windows
Can somebody help me?
 

udinz23

Member
Apr 19, 2019
11
12
0
Bandung
I REALLY need some help

Phone: Asus Zenfone Selfie Pro 4
What i want: to install GCAM

I got the ADB device recognized by windows
Cant get it recognized as a Fastboot device

Ive tried several drivers and nothing seems to make my phone a "fastboot device" recognized by windows
Can somebody help me?

you missed the 's' on 'device' it should be "fastboot devices"
 

valkes2

Member
Jul 10, 2019
11
4
0
then give us ur screenshot

Thank you for asking. Thank you all for the help

Here are the screens

First the Minimal Adb screen

Here´s my device manager. Ive got the drivers from asus official page

And last my phone screen just to show that debugging is enabled


Sorry for not being able to post the screenshots as images on the post, the forum simply showed my pictures as broken and i couldnt find how to solve it.
But if you check the links you will see that they are simple png images

Once again, thank you all for the help

PS: My phone is a ZD552KL. I got the "USB Drivers" from asus page. Maybe i should go for other drivers?
 
Last edited:

egha5037

Senior Member
Mar 14, 2016
139
12
28
Jakarta
Thank you for asking. Thank you all for the help

Here are the screens

First the Minimal Adb screen

Here´s my device manager. Ive got the drivers from asus official page

And last my phone screen just to show that debugging is enabled

Sorry for not being able to post the screenshots as images on the post, the forum simply showed my pictures as broken and i couldnt find how to solve it.
But if you check the links you will see that they are simple png images

Once again, thank you all for the help

PS: My phone is a ZD552KL. I got the "USB Drivers" from asus page. Maybe i should go for other drivers?
if you going to use fastboot u should turn off your phone and boot into bootloader if your phone turned on then go ahed with adb
that's why fastboot doesn't recognize ur devices
 
Last edited:

Pudgio

New member
Jul 15, 2019
1
1
0
I followed the method exactly like several people mentioned here, up to the point where I type .\fastboot oem enable_camera_hal3 true and it will say Failed (write to device failed (invalid argument) and the phone goes black screen with very small "press any key to shut down" on top left of the screen.

Please any help will be appreciated, and as a completely noob here, I have gone through all 35 pages in this thread and still cant solve this issue.

I have the Stable pie upgrade (May update) and latest firmware, and everything still pure (no root or anything)

Thanks in advance
 
  • Like
Reactions: aswinkr77

NamitNayan

Senior Member
Feb 11, 2017
644
187
43
And here's my error
no root,latest pie(053) update
command prompt was opened as administrator


the command
fastboot devices
show the device name fine
so I don't think any issues with fastboot


fixed: somehow installed Linux(manjaro had no errors,others were like not even booting)
command worked fine in it.(had to enter twice,first time some error)
 

Attachments

  • IMG_20190716_153131_1.jpg
    IMG_20190716_153131_1.jpg
    55.8 KB · Views: 730
Last edited:

theroyalak

Member
Mar 15, 2018
6
0
0
Root is not needed.
Also mention what error are you getting so we can help in a better way.
Warranty and Ota won't be affected by this method.

I have zb601kl and my firmware is WW_Phone-16.2017.1906.056-20190772. when I try to enter command
Code:
fastboot oem enable_camera_hal3 true
my phone screen goes black and just "press any key to reboot" is written on the screen. And my cmd gives this error:-

Code:
C:\Users\aritr\Desktop\platform-tools>fastboot devices
J7AAGXXXXXXXXXP fastboot

C:\Users\aritr\Desktop\platform-tools>fastboot oem enable_camera_hal3 true
                                                   FAILED (Write to device failed (No such file or directory))
fastboot: error: Command failed

C:\Users\aritr\Desktop\platform-tools>


My CMD screenshot:-
Sketch.png

Any solution???
Please help me!!!
 
Last edited:

GliderZ

Senior Member
Jul 12, 2018
70
11
0
I have zb601kl and my firmware is WW_Phone-16.2017.1906.056-20190772. when I try to enter command my phone screen goes black and just "press any key to reboot" is written on the screen. And my cmd gives this error:-




My CMD screenshot:-
Any solution???
Please help me!!!

Trying using any other usb cable other than the one that comes from Asus. Also try changing your usb ports. One more thing, repeat the same steps you mentioned in your previous posts 2 or 3 times
 

theroyalak

Member
Mar 15, 2018
6
0
0
Trying using any other usb cable other than the one that comes from Asus. Also try changing your usb ports. One more thing, repeat the same steps you mentioned in your previous posts 2 or 3 times

I tried using all the USB ports(2.0 and 3.0). I tried all the USB cables I had. I had tried multiple drivers. Still showing the same error.:crying:
Please help me!!!
 

moklev

Member
Sep 26, 2018
5
2
0
My CMD screenshot:-
Sketch.png

Any solution???
Please help me!!![/QUOTE]

1. Put you phone in fastboot mode and connect it with a USB cable.
2. Use Debian / Ubuntu.
Terminal:
sudo fastboot devices
sudo fastboot oem enable_camera_hal3 true
sudo fastboot reboot
(sudo IS REQUIRED!)
3. Install OpenCamera from Play Store or F-Droid.
4. Enable API Camera2
5. Enable RAW mode (JPEG+DNG)
6. Enjoy :)

Works perfect with Stock Pie update .58 (september 2019).
 

GiovannaLite

New member
Oct 19, 2019
1
0
0
I followed the method exactly like several people mentioned here, up to the point where I type .\fastboot oem enable_camera_hal3 true and it will say Failed (write to device failed (invalid argument) and the phone goes black screen with very small "press any key to shut down" on top left of the screen.

Please any help will be appreciated, and as a completely noob here, I have gone through all 35 pages in this thread and still cant solve this issue.

I have the Stable pie upgrade (May update) and latest firmware, and everything still pure (no root or anything)

Thanks in advance

Have you found any solution for this? I'm having the same exact situation here.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 72
    -----Working------
    (Tested by users)

    I'm not liable for any damage, dead devices, corrupt sd cards bla bla bla

    Steps:

    1) setup fastboot and adb drivers on pc
    2) power off the phone and enter fastboot mode.
    3) fire up fastboot terminal and connect your phone to the pc, enable USB debugging mode from dev. options too.
    4) Run the command:

    fastboot oem enable_camera_hal3 true

    5) reboot
    6) check g cam or any camera API testing apps to make sure if it's working.
    7) report back here if all is good.

    Thanks to @shakalaca
    7
    I read the first post thank you

    first mention enabling developer options and USB debugging many people don't know

    1. i need the link to download adb drivers for this phone (please give a link to download it)
    2. which camera apk file and where should we get
    3. how to install ADB driver in pc for this phone
    4. and how to bring terminal window and what are the commands not the only last command (fastboot oem enable....) I am asking this not only for me. for the users who are all new to XDA.

    please give 2 links one for adb drivers and apk file please give other commands, nobody is hurting no one, no one ask helps unless they don't know it. so kindly talk good, not rude. Ty again for reply

    1. Enable USB Debugging ( Google is the best friend )
    2. About adb and fastboot ( Google still the best friend ) just type ' Minimal Fastboot '
    Link :


    https://androidfilehost.com/?fid=962187416754459552

    3. Extract Minimal Fastboot then press Shift + Right Click the folder then select ' Open Command Window Here '.
    4. Then check make sure your devices is connected . ( type 'adb devices') your devices should be listed if connected to adb.
    5. Allow USB Debugging on devices.
    6. Now type 'adb reboot bootloader' ( easy way boot your devices to bootloader )
    7 Then run the command on first post.
    8.If success, then reboot your devices type 'fastboot reboot' or reboot manual.
    9. Then download the apk file, link

    https://forum.xda-developers.com/as...nable-camera-api-2-root-t3823498/post77222331


    10. Check you gcam.
    11. Done
    6
    Thanks to all those who tested this. The method works.

    I'll make a script to make things much more easier.

    If you get error at fastboot window saying device not found or waiting for device. That's a driver issue.
    Check some comments down below, a user has mentioned methods to solve it.

    OTA will not be effected in any way by this mod.
    Warranty should not be void too.
    4
    Can someone share some gcam apk?
    I'm confuse which one i must use,i just flash that command.
    Greetings

    GoogleCamera-Pixel2Mod-Arnova8G2-V8.1.apk
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone