• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[GUIDE] Enable VoLTE & VoWiFi on all devices NO ROOT.

Search This thread

LennARTpas

Member
May 19, 2016
20
16
This is a quick guide on how to enable VoLTE and VoWIFI on every OnePlus 8 or 8 Pro device.

This method involves downgrading the OnePlus LogKit APK to the OnePlus 7 version.
I recommend you to backup the existing LogKit APK using ADB on a
Or download an APK extractor from the Play Store, i personally recommend: https://play.google.com/store/apps/d...m.ext.ui&hl=nl

After you extracted the original LogKit you need to download the old LogKit which you can find as an attachment in the thread.
Install the downloaded LogKit APK and follow the steps:

1. Open the Dialer app on the device.
2. dial *#800# and LogKit will open up.
3. Scroll all the way down and click on Function Switch (this is missing from the stock OnePlus 8 LogKit APK).
4. Select VoLTE and when prompted to reboot, press cancel.
5. Select VoWifi and when prompted to reboot press OK.
6. Your device will now reboot and you should have VoLTE & VoWifi enabled.
7. Reinstall the backup from the LogKit apk (VoLTE & VoWifi should still be enabled when you reinstall the backed up LogKit apk).

The above has been tested to work in The Netherlands.
If you have followed the steps, please let me know what your results are!

WiFi Calling Screenshot:
bBIuNrkl.jpg
 

Attachments

  • com.oem.oemlogkit_1.0-1_minAPI28(nodpi)_apkmirror.com.apk
    947.4 KB · Views: 6,473

mmuntean2

Senior Member
Aug 20, 2010
134
13
Timisoara
Works but..

Tested on oneplus 8, in Europe. VoLTE works without any problems, but VoWifi has issues, meaning I see the VoWifi symbol constantly disappear and the phone goes to cellular calling mode, then it appears again and so on, despite having the Call on Wifi set as priority in settings. I have no idea why it does this, it's like it is losing the handshake between itself and the mobile operator's network for Wifi Calling.
Very often I see VoLTE symbol instead of the VoWifi despite the fact that my wifi network is fine.
When it loses the Wifi Calling, it happens randomly, for 5 minutes or for more. I have to either switch to airplane mode or restart the phone sometimes to get VoWifi working again.
Any idea what else could be done? I have even done the QPST changes, activating the India vodafone VoLTE for Sub0 and Sub1 and still, same issue.
I have the International/Global firmware on it, not the European one.
Network: Orange Romania
 

tomj44

Member
May 6, 2012
18
6
I have same issues with me my one plus 8 (N2013 model)
I haven't tried QPST changes
Volte button and force vowifi button have disapear since change carrier from one who doesn't support Volte/vowifi (Orange Fr) to Bouygues Telecom (France)
Volte working fine, vowifi just time to time like you have explain very randomly
Tom


Tested on oneplus 8, in Europe. VoLTE works without any problems, but VoWifi has issues, meaning I see the VoWifi symbol constantly disappear and the phone goes to cellular calling mode, then it appears again and so on, despite having the Call on Wifi set as priority in settings. I have no idea why it does this, it's like it is losing the handshake between itself and the mobile operator's network for Wifi Calling.
Very often I see VoLTE symbol instead of the VoWifi despite the fact that my wifi network is fine.
When it loses the Wifi Calling, it happens randomly, for 5 minutes or for more. I have to either switch to airplane mode or restart the phone sometimes to get VoWifi working again.
Any idea what else could be done? I have even done the QPST changes, activating the India vodafone VoLTE for Sub0 and Sub1 and still, same issue.
I have the International/Global firmware on it, not the European one.
Network: Orange Romania
 

BeardKing

Senior Member
Nov 1, 2012
390
172
Philadelphia
OnePlus 8
Just an FYI to anyone wondering: I bought the IN2015 model directly from OnePlus. VoLTE and VoWiFi both work right out of the box with T-Mobile (I'm in the Philadelphia area). I didn't even have to turn them on, they were already enabled.
 

mmuntean2

Senior Member
Aug 20, 2010
134
13
Timisoara
I have same issues with me my one plus 8 (N2013 model)
I haven't tried QPST changes
Volte button and force vowifi button have disapear since change carrier from one who doesn't support Volte/vowifi (Orange Fr) to Bouygues Telecom (France)
Volte working fine, vowifi just time to time like you have explain very randomly
Tom
It seems that after I switched back to EU firmware, from Global, I no longer have problems with VoWifi. I also switched in QPST from India Vodafone to Telia Finland, but even with Telia, when I was using the global firmware, I would still have issues with VoWifi constantly disconnecting. Now, with the EU firmware, seems to work with 0 problems. I have it like this for 3 days now, and VoWifi stays on all the time when I am conencted to a wifi network.
You may want try to switch to Telia Finland in qpst PDC app and check afterwards. Also install the older logkit apk to be able to enable the volte and vowifi buttons.
 

7ORO

Senior Member
Jan 19, 2013
75
99
Volte for additional carriers

Thanks for the guide. @LennARTpas

Maybe you can add this to first post:

If volte is enabled but not active follow the following additional steps:

1. Perform all steps of the first post
2. Enable Volte in Settings > SIM & Network > SIM 1/2 > Volte/Vowifi
2. Download the following files:
QPST (Install on PC / preferable inside Virtual Machine) - https://androidfilehost.com/?fid=11410963190603912872
Qualcomm Driver (Install on PC / preferable inside Virtual Machine, select WWAN option) - https://androidfilehost.com/?fid=11410963190603864074
Oneplus Engineering Mode (Install on phone) - https://www.apkmirror.com/apk/oneplu...-apk-download/
3. Install Oneplus Engineering Mode
4. Phone Dialer > Enter *#801# > Open with Engineering Mode > enable "Full-port Switch"
5. Connect phone to PC
6. Run PDC Program
7. Select Qualcomm device
8. Note down the current configuration (where "Active" is shown)
9. Activate India-VoLTE Vodafone (Right Click > Set SelectedConfig > Sub0 and Sub1)
10. Press Activate
11. Volte should now work. If not change back the configuration to the original state
 
  • Like
Reactions: sirioo and vins069

yot2703

Senior Member
Apr 24, 2013
494
50
Lod
Thanks for the guide. @LennARTpas

Maybe you can add this to first post:

If volte is enabled but not active follow the following additional steps:

1. Perform all steps of the first post
2. Enable Volte in Settings > SIM & Network > SIM 1/2 > Volte/Vowifi
2. Download the following files:
QPST (Install on PC / preferable inside Virtual Machine) - https://androidfilehost.com/?fid=11410963190603912872
Qualcomm Driver (Install on PC / preferable inside Virtual Machine, select WWAN option) - https://androidfilehost.com/?fid=11410963190603864074
Oneplus Engineering Mode (Install on phone) - https://www.apkmirror.com/apk/oneplu...-apk-download/
3. Install Oneplus Engineering Mode
4. Phone Dialer > Enter *#801# > Open with Engineering Mode > enable "Full-port Switch"
5. Connect phone to PC
6. Run PDC Program
7. Select Qualcomm device
8. Note down the current configuration (where "Active" is shown)
9. Activate India-VoLTE Vodafone (Right Click > Set SelectedConfig > Sub0 and Sub1)
10. Press Activate
11. Volte should now work. If not change back the configuration to the original state
It's funny , just switched to OP8 and it doesn't work...
I did that always on my OP6T and worked perfectly.

Edit : VoLTE works , VoWIFI doesn't work :\
 
Last edited:

sirioo

Senior Member
Sep 28, 2011
683
284
Naples
I have an op8 IN2010 with oos 10.5.7 eu (BA) .

I use SIM Vodafone Italy but the VoLTE icon does not appear in the status bar



I changed from Italy VoLTE Vodafone to India VoLTE Vodafone









Is VoLTE active? Why doesn't the icon appear in the status bar? Thx
 
Last edited:

jhhoogen

New member
Jan 26, 2014
3
0
plus.google.com
I get volte and vowifi on, but nothings seems to work to get KPN netherlands vowifi active. But lost the smart 5g button

After i install the old logkit, i still lost the smart 5g button.

How to get the button back.

Verstuurd vanaf mijn IN2013 met Tapatalk
 
Last edited:

Xavster2

Member
Jun 17, 2019
26
7
Does not work when using an AT&T mvno. They're notorious for preventing users from using VoLTE and VoWIFI if its not a carrier branded device so this doesn't surprise me.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    This is a quick guide on how to enable VoLTE and VoWIFI on every OnePlus 8 or 8 Pro device.

    This method involves downgrading the OnePlus LogKit APK to the OnePlus 7 version.
    I recommend you to backup the existing LogKit APK using ADB on a
    Or download an APK extractor from the Play Store, i personally recommend: https://play.google.com/store/apps/d...m.ext.ui&hl=nl

    After you extracted the original LogKit you need to download the old LogKit which you can find as an attachment in the thread.
    Install the downloaded LogKit APK and follow the steps:

    1. Open the Dialer app on the device.
    2. dial *#800# and LogKit will open up.
    3. Scroll all the way down and click on Function Switch (this is missing from the stock OnePlus 8 LogKit APK).
    4. Select VoLTE and when prompted to reboot, press cancel.
    5. Select VoWifi and when prompted to reboot press OK.
    6. Your device will now reboot and you should have VoLTE & VoWifi enabled.
    7. Reinstall the backup from the LogKit apk (VoLTE & VoWifi should still be enabled when you reinstall the backed up LogKit apk).

    The above has been tested to work in The Netherlands.
    If you have followed the steps, please let me know what your results are!

    WiFi Calling Screenshot:
    bBIuNrkl.jpg
    2
    Good work:good:

    Thanks...

    My device OnePlus 8 / IN2010
    2
    original logkit of the OnePlus 8

    Do you have the original logkit? I miss make backup

    here the original logkit of the OnePlus 8
    2
    Volte for additional carriers

    Thanks for the guide. @LennARTpas

    Maybe you can add this to first post:

    If volte is enabled but not active follow the following additional steps:

    1. Perform all steps of the first post
    2. Enable Volte in Settings > SIM & Network > SIM 1/2 > Volte/Vowifi
    2. Download the following files:
    QPST (Install on PC / preferable inside Virtual Machine) - https://androidfilehost.com/?fid=11410963190603912872
    Qualcomm Driver (Install on PC / preferable inside Virtual Machine, select WWAN option) - https://androidfilehost.com/?fid=11410963190603864074
    Oneplus Engineering Mode (Install on phone) - https://www.apkmirror.com/apk/oneplu...-apk-download/
    3. Install Oneplus Engineering Mode
    4. Phone Dialer > Enter *#801# > Open with Engineering Mode > enable "Full-port Switch"
    5. Connect phone to PC
    6. Run PDC Program
    7. Select Qualcomm device
    8. Note down the current configuration (where "Active" is shown)
    9. Activate India-VoLTE Vodafone (Right Click > Set SelectedConfig > Sub0 and Sub1)
    10. Press Activate
    11. Volte should now work. If not change back the configuration to the original state