[Guide]Enabling VoLTE on stock ROM (Calls and SMS)

Search This thread

WingXBlade

Senior Member
Dec 16, 2014
76
21
Kuala Lumpur
Hi all.
I just want to post a guide for people wondering how to enable VoLTE in unsupported countries. Apparently, Xiaomi only enable VoLTE for SEA countries etc. and Japan (Where I'm staying) is not supported.
So, I have been having problems receiving SMS and calling other numbers. After reading this blog post, I have solved that problem and maybe I can help others solving this problem. This is the procedure written in the blog post in English.

1. Setting APN (Might not be applicable for other countries)
-----------------
for Au user with VoLTE enabled sim, create a new APN and set it as below
・NAME:ims
・APN:ims
・MCC:440
・MNC:51
・TYPE:ims

for DoCoMo user with VoLTE enabled sim, create a new APN and set it as below
・NAME:ims
・APN:ims
・TYPE:ims
・APN protocol:IPv4v6

2. Go to dial and dial *#*#86583#*#* . It should show carrier check disabled or something along the lines.
3. If the phone does not have a signal after step 2. reboot the device and it should connect after that.

Hope this will help anyone who is having trouble enabling VoLTE.
 

fards

Inactive Recognized Developer
Last edited:
  • Like
Reactions: WingXBlade

Mr.J_I

Member
Feb 22, 2019
5
3
Volte Restore

Run the below code in your dialer app manually. You should see a message stating "Volte Carrier check disable" else run the code again.
After 30 seconds your volte network should be retored. Pull down the notification bar to check for the volte symbol.

*#*#86583#*#*

Cheers!! :D
 
  • Like
Reactions: spkprs and vismaiy

hervefr83

Member
Jul 21, 2017
26
4
Hi

Thanks for this topic.
I have a problem : my poco F1 (MIUI Global 10.3.5.0) says it is enabled only for SIM1.
But as I use a µSD card (which has to be plugged instead of SIM1) I only have SIM2 place to put my SIM.
So I only have SIM2, no SIM1, and my poco says "only for SIM1"...... WTF ?!!
Someone has an idea for having VoLTE (and VoWiFi) on SIM2 ???

Thanks !
 

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    Hi all.
    I just want to post a guide for people wondering how to enable VoLTE in unsupported countries. Apparently, Xiaomi only enable VoLTE for SEA countries etc. and Japan (Where I'm staying) is not supported.
    So, I have been having problems receiving SMS and calling other numbers. After reading this blog post, I have solved that problem and maybe I can help others solving this problem. This is the procedure written in the blog post in English.

    1. Setting APN (Might not be applicable for other countries)
    -----------------
    for Au user with VoLTE enabled sim, create a new APN and set it as below
    ・NAME:ims
    ・APN:ims
    ・MCC:440
    ・MNC:51
    ・TYPE:ims

    for DoCoMo user with VoLTE enabled sim, create a new APN and set it as below
    ・NAME:ims
    ・APN:ims
    ・TYPE:ims
    ・APN protocol:IPv4v6

    2. Go to dial and dial *#*#86583#*#* . It should show carrier check disabled or something along the lines.
    3. If the phone does not have a signal after step 2. reboot the device and it should connect after that.

    Hope this will help anyone who is having trouble enabling VoLTE.
    2
    Volte Restore

    Run the below code in your dialer app manually. You should see a message stating "Volte Carrier check disable" else run the code again.
    After 30 seconds your volte network should be retored. Pull down the notification bar to check for the volte symbol.

    *#*#86583#*#*

    Cheers!! :D
    1
    thanks man . *#*#86583#*#* did worked for me in Sri lanka
    1
    thanks man . *#*#86583#*#* did worked for me in Sri lanka

    I'm glad I was able to help :)
    1
    its a pity there's not such a short code to enable the VoWifi in the same way

    EDIT:

    Turns out setprop persist.dbg.wfc_avail_ovr 1 enables the switch, but the service still shows as unavailable.

    using the build.prop changes I came up with for this https://forum.xda-developers.com/oneplus-5/themes/magisk-volte-enabler-t3649647
    enables UT interface.