[Guide] Fix Device Not Showing Up In Fastboot Mode (Windows 10/11)

Search This thread

phoneturf

Senior Member
Feb 28, 2008
386
120
OnePlus 9
Perhaps it's been a recent Windows 11 update that's caused it, but the driver was not recognized "for a 64 bit system." I tried it with both the Oneplus drivers as well as the generic driver method I found somewhere else. Had to go to an old Win 10 PC to root my OP.
 

phoneturf

Senior Member
Feb 28, 2008
386
120
OnePlus 9
Figured it out. BTW, for one thing, when I tried to boot into advanced startup mode, I first had to go to my Microsoft windows account and get a very long security code to enter before it would allow me to make changes. Once I got past this, I was able to reboot with Disable driver signing enforcement.

Once I did, it would not allow me to install the individual driver as stated above. However, a day later after thinking about it, and having my PC still in disable driver signing mode, I just reran OnePlus_USB_Drivers_Setup.exe and once I did, it started recognizing the phone in fastboot mode.
 

Rootk1t

Senior Member
Jun 2, 2013
1,858
781
Figured it out. BTW, for one thing, when I tried to boot into advanced startup mode, I first had to go to my Microsoft windows account and get a very long security code to enter before it would allow me to make changes. Once I got past this, I was able to reboot with Disable driver signing enforcement.

Once I did, it would not allow me to install the individual driver as stated above. However, a day later after thinking about it, and having my PC still in disable driver signing mode, I just reran OnePlus_USB_Drivers_Setup.exe and once I did, it started recognizing the phone in fastboot mode.
It seems that with every new Windows release they make it harder and harder to disable driver signing, to install unsigned drivers. I see that it's done for hardening security, though its making more difficult to use tools like MSM and others.
 

loupeppe

Member
Jul 20, 2018
12
0
Thank you so much for this. So glad I found this thread after hours of getting nowhere. I so appreciate the time you took to write this up.
 

JustinChase

Senior Member
Jan 31, 2007
362
47
no luck for me. I've tried several drivers, including installing the Android SDK and downloading from there. Disabled driver signing (using the stupid-long bitlocker code), tried installing directly, tried windows update. nothing allows the computer to find the phone in fastboot.

finds it find in adb, but nothing I've tried over the last couple hours has fixed this annoying issue.

Any more thoughts on what to try?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 90

    I have done this on Windows 10/11 with the 8 Pro, 8T, and 9 Pro personally.

    Other members have had success with the OP5T, OP6T, OP7P, OP7T, OP8 and even a OP1 for @mawil1013 and somehow a Xiaomi Mi 9T lol

    After fighting this for about an hour, and trying everything I could think of, this was the only way I could get my T-Mobile 8T to show up while in fastboot mode.
    I tried the below, and probably more...
    • Ensuring I had the latest fastboot version
    • Manually installing the bootloader driver from googles SDK
    • Several restarts
    • Just installing OnePlus' driver that come on the phone per-installed

    To fix the issue, we are going to disable driver signing enforcement in Windows and then install the Unsigned OnePlus drivers.​

    1. Install the OnePlus drivers that are included with your phone.
      • They should show up as CD Drive: OnePlus Drivers when you just connect your phone to your computer.
      • I'm sure you can find the installation package somewhere online, but I don't have a good download source so I am not going to give out random links.
    2. This will create a directory containing the USB driver. This will most likely be
      • C:\Program Files (x86)\OnePlus USB Drivers
      • In that folder there is a driver, but both when installed using the installer incuded with my phone, and a downloaded version, I ran into...
        • The hash for the file is not present in the specified catalog file. The file is likely corrupt or the victim of tampering.
    3. To get around this we are going to disabled signed drivers on windows.
      1. Select the “Start” button.
      2. Type “startup”.
      3. Select “Change advanced startup settings“.
      4. Select “Restart now” under the “Advanced startup” area.
      5. Once presented with the Advanced options select...
        • “Troubleshoot“ --> “Advanced Options“ --> “Startup Options“ --> “Restart“
      6. After that, a menu will appear where you can press “7” on your keyboard to choose “Disable driver signing enforcement“.
    4. Now Device Driver Signing should be disabled, allowing you to install any driver until you reboot, meaning we can install our unsigned OnePlus driver.
      1. Pop open Device Manager
        • You can press windows + x to bring up a menu, then you can press m or select device manager for quick access
      2. Boot your device into fastboot mode.
        • This should cause it to show up in device manager as "Andriod", with a yellow triangle
      3. In device manager right click the "android" device
      4. Then press the following options
        • Update driver --> Browse my computer --> Let me pick --> Have Disk
      5. Navigate to the folder from earlier: C:\Program Files (x86)\OnePlus USB Drivers
      6. Select OnePlus_android_winusb.inf and click okay
      7. After that, OnePlus Android Bootloader interface should be selected. Go ahead and install it.

    Congrats! Your device should start showing up in fast boot mode.
    7
    The easiest method for any newbie is to install , iobit driver booster , free.


    Then update the android driver. The fastboot would be working fine after that.
    4
    I also struggled with this issue but found another solution. Once my phone was plugged in (can't remember if it was system or fastboot) I went to Windows Update and browsed the optional updates. One of the optional updates was a driver for android recovery. Installed it and it worked.
    3
    Wow I didn't even realize that I had helped people until now! I am so glad I could help you guys @bigd4ve @jefffeely and @Pain-N-Panic
    2
    I also struggled with this issue but found another solution. Once my phone was plugged in (can't remember if it was system or fastboot) I went to Windows Update and browsed the optional updates. One of the optional updates was a driver for android recovery. Installed it and it worked.
    THANK YOU! This worked 100% for me, super easy too. Went to Windows Update, View Optional Updates, saw the Android External Device update, device showed in fastboot after installing.