• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[Guide] Fix Device not showing up in Fastboot Mode (windows 10)

Search This thread

Mbektic

New member
Jul 2, 2020
4
39
Louisville
Hey Guys,

After fighting this for about an hour, and trying everything I could think of, this was the only way I could get my T-Mobile 8T to show up while in fastboot mode.
I tried the below, and probably more...
  • Ensuring I had the latest fastboot version
  • Manually installing the bootloader driver from googles SDK
  • Several restarts
  • Just installing OnePlus' driver that come on the phone per-installed

So for me, the issue was resolved by doing the following below.
1) install the OnePlus drivers that are included with your phone.
--- they should show up as CD Drive: OnePlus Drivers when you just connect your phone to your computer
2) This will create a directory like this... C:\Program Files (x86)\OnePlus USB Drivers, containing the USB driver
3) In that folder there is a driver "" but both when installed from my phone, and a downloaded version, i ran into The hash for the file is not present in the specified catalog file. The file is likely corrupt or the victim of tampering.. So next we are going to disabled signed drivers on windows.
-----Select the “Start” button.
-----Type “startup”.
-----Select “Change advanced startup settings“.
-----Select “Restart now” under the “Advanced startup” area.
-----Select “Troubleshoot“.
-----Select “Advanced Options“.
-----Select “Startup Options“.
-----Select “Restart“.
-----A menu will appear where you can press “7” on your keyboard to choose “Disable driver signing enforcement“.
Now Device Driver Signing should be disabled, allowing you to install any driver you like in Windows 10 until you reboot.
4) Boot your device into fastboot mode. This should cause it to show up in device manager as Andriod, with a yellow triangle
5) In device manager(press windows + x to bring up a menu, then you can press m or select device manager for quick access) right click the android device
-----Update driver
-----Browse my computer
-----Let me pick
-----Have Disk
-----Navigate to C:\Program Files (x86)\OnePlus USB Drivers
-----Select OnePlus_android_winusb.inf and click okay
-----OnePlus Android Bootloader interface should be selected, and go ahead and install it.

After that your device should start showing up in fast boot mode.
I'm not sure if for some reason my driver version just was lacking a hash, or if it is a common issue, but hopefully i'll save someone a couple of minutes.
 

wangsu10

Member
Dec 25, 2017
22
8
There is no CD Drive show up....
find on internet a oneplus usb driver and installed....
then got this message trying to get the [oem get_unlock_code]
Code:
FAILED (remote: 'Command not supported in default implementation')
fastboot: error: Command failed


Thanks OP.
finally works...

Okay, I just figured out my mistake, but I'll leave it in case someone else stumbles across the same thing. The fix: choose your language, then choose "reboot to fastboot" and confirm that you're sure. You'll get to a screen with "Fastboot mode" in red near the top. Once there, run the get code command.

REFERENCE: reference link
 
Last edited:

bynarie

Senior Member
Aug 2, 2013
298
140
Hilliard OH
OnePlus 7T
Hey Guys,

After fighting this for about an hour, and trying everything I could think of, this was the only way I could get my T-Mobile 8T to show up while in fastboot mode.
I tried the below, and probably more...
  • Ensuring I had the latest fastboot version
  • Manually installing the bootloader driver from googles SDK
  • Several restarts
  • Just installing OnePlus' driver that come on the phone per-installed

So for me, the issue was resolved by doing the following below.
1) install the OnePlus drivers that are included with your phone.
--- they should show up as CD Drive: OnePlus Drivers when you just connect your phone to your computer
2) This will create a directory like this... C:\Program Files (x86)\OnePlus USB Drivers, containing the USB driver
3) In that folder there is a driver "" but both when installed from my phone, and a downloaded version, i ran into The hash for the file is not present in the specified catalog file. The file is likely corrupt or the victim of tampering.. So next we are going to disabled signed drivers on windows.
-----Select the “Start” button.
-----Type “startup”.
-----Select “Change advanced startup settings“.
-----Select “Restart now” under the “Advanced startup” area.
-----Select “Troubleshoot“.
-----Select “Advanced Options“.
-----Select “Startup Options“.
-----Select “Restart“.
-----A menu will appear where you can press “7” on your keyboard to choose “Disable driver signing enforcement“.
Now Device Driver Signing should be disabled, allowing you to install any driver you like in Windows 10 until you reboot.
4) Boot your device into fastboot mode. This should cause it to show up in device manager as Andriod, with a yellow triangle
5) In device manager(press windows + x to bring up a menu, then you can press m or select device manager for quick access) right click the android device
-----Update driver
-----Browse my computer
-----Let me pick
-----Have Disk
-----Navigate to C:\Program Files (x86)\OnePlus USB Drivers
-----Select OnePlus_android_winusb.inf and click okay
-----OnePlus Android Bootloader interface should be selected, and go ahead and install it.

After that your device should start showing up in fast boot mode.
I'm not sure if for some reason my driver version just was lacking a hash, or if it is a common issue, but hopefully i'll save someone a couple of minutes.
Yes, I also had to disable device driver signing, then the phone showed up in the bootloader.. You can just open an admin command prompt, type "bcdedit /set testsigning on", REBOOT, then install the proper driver. This seems to be a problem with OOS11.
 

dogmatism

Senior Member
Dec 20, 2006
290
145
The easiest method for any newbie is to install , iobit driver booster , free.


Then update the android driver. The fastboot would be working fine after that.
 

dankovac1999

Senior Member
Sep 18, 2016
90
21
22
HTC Leo
HTC Wildfire S
The easiest method for any newbie is to install , iobit driver booster , free.


Then update the android driver. The fastboot would be working fine after that.

I just cant thank as much as I have to! I couldnt find solution for months, I was using magisk module on old phone to use fastboot and it sucked. Now updated driver and works like charm. Thank you so much!
 

Samuel Holland

Senior Member
Jun 26, 2013
444
211
lake charles
Thanks for making this thread. I couldn't believe I were having so many issues on my desktop, when I had managed to get everything right when I first got the phone(8PRO) on my laptop. I had adb & fastboot installed, then plugging in Kona w/ usb debug off allowed me to install the adb driver and then for fastboot(while in fastboot, using window's "device manager" I selected the Google usb driver I had downloaded, and finally for edl mode driver just in case (msm), I installed the qualcomm driver while in edl mode(😅 whew). Anyway thanks,
 
Last edited:

Zheranon

Senior Member
Jan 23, 2010
125
21
New York, NY
I cannot believe I did not see this thread earlier...

Just finished solving the same problem after going nuts for a couple of hours.

It is most definitely just getting the PC to install the OnePlus drivers AND disabling the driver signing.

What a pain.
 
  • Like
Reactions: Samuel Holland

exgtigsr

Senior Member
Aug 13, 2010
78
6
Hey Guys,

After fighting this for about an hour, and trying everything I could think of, this was the only way I could get my T-Mobile 8T to show up while in fastboot mode.
I tried the below, and probably more...
  • Ensuring I had the latest fastboot version
  • Manually installing the bootloader driver from googles SDK
  • Several restarts
  • Just installing OnePlus' driver that come on the phone per-installed

So for me, the issue was resolved by doing the following below.
1) install the OnePlus drivers that are included with your phone.
--- they should show up as CD Drive: OnePlus Drivers when you just connect your phone to your computer
2) This will create a directory like this... C:\Program Files (x86)\OnePlus USB Drivers, containing the USB driver
3) In that folder there is a driver "" but both when installed from my phone, and a downloaded version, i ran into The hash for the file is not present in the specified catalog file. The file is likely corrupt or the victim of tampering.. So next we are going to disabled signed drivers on windows.
-----Select the “Start” button.
-----Type “startup”.
-----Select “Change advanced startup settings“.
-----Select “Restart now” under the “Advanced startup” area.
-----Select “Troubleshoot“.
-----Select “Advanced Options“.
-----Select “Startup Options“.
-----Select “Restart“.
-----A menu will appear where you can press “7” on your keyboard to choose “Disable driver signing enforcement“.
Now Device Driver Signing should be disabled, allowing you to install any driver you like in Windows 10 until you reboot.
4) Boot your device into fastboot mode. This should cause it to show up in device manager as Andriod, with a yellow triangle
5) In device manager(press windows + x to bring up a menu, then you can press m or select device manager for quick access) right click the android device
-----Update driver
-----Browse my computer
-----Let me pick
-----Have Disk
-----Navigate to C:\Program Files (x86)\OnePlus USB Drivers
-----Select OnePlus_android_winusb.inf and click okay
-----OnePlus Android Bootloader interface should be selected, and go ahead and install it.

After that your device should start showing up in fast boot mode.
I'm not sure if for some reason my driver version just was lacking a hash, or if it is a common issue, but hopefully i'll save someone a couple of minutes.
you've saved my sanity on oneplus5T after upgrading to Android Q 10. Thank you 🙌🙌🙌
 
  • Like
Reactions: Samuel Holland

behel1t

New member
Oct 24, 2013
2
2
I also struggled with this issue but found another solution. Once my phone was plugged in (can't remember if it was system or fastboot) I went to Windows Update and browsed the optional updates. One of the optional updates was a driver for android recovery. Installed it and it worked.
 
  • Like
  • Love
Reactions: Laapander and smjkh

zzjea

Senior Member
Jan 16, 2017
75
10
Houston
OnePlus 8T
Yes, I also had to disable device driver signing, then the phone showed up in the bootloader.. You can just open an admin command prompt, type "bcdedit /set testsigning on", REBOOT, then install the proper driver. This seems to be a problem with OOS11.
Between the OP and this post, I was finally able to get the drivers to work on my 8T (Sim Free- Carrier Unlocked) new phone from Oneplus. I spent several hours trying to determine what the issues were and then found this thread. I am successfully unlocked from the bootloader. Thank you both.
 

smjkh

Member
Aug 25, 2018
5
1
I also struggled with this issue but found another solution. Once my phone was plugged in (can't remember if it was system or fastboot) I went to Windows Update and browsed the optional updates. One of the optional updates was a driver for android recovery. Installed it and it worked.
THANK YOU! This worked 100% for me, super easy too. Went to Windows Update, View Optional Updates, saw the Android External Device update, device showed in fastboot after installing.
 
  • Like
Reactions: behel1t

sabinjamal

Member
Feb 15, 2014
28
0
27
Trivandrum
Hey Guys,

After fighting this for about an hour, and trying everything I could think of, this was the only way I could get my T-Mobile 8T to show up while in fastboot mode.
I tried the below, and probably more...
  • Ensuring I had the latest fastboot version
  • Manually installing the bootloader driver from googles SDK
  • Several restarts
  • Just installing OnePlus' driver that come on the phone per-installed

So for me, the issue was resolved by doing the following below.
1) install the OnePlus drivers that are included with your phone.
--- they should show up as CD Drive: OnePlus Drivers when you just connect your phone to your computer
2) This will create a directory like this... C:\Program Files (x86)\OnePlus USB Drivers, containing the USB driver
3) In that folder there is a driver "" but both when installed from my phone, and a downloaded version, i ran into The hash for the file is not present in the specified catalog file. The file is likely corrupt or the victim of tampering.. So next we are going to disabled signed drivers on windows.
-----Select the “Start” button.
-----Type “startup”.
-----Select “Change advanced startup settings“.
-----Select “Restart now” under the “Advanced startup” area.
-----Select “Troubleshoot“.
-----Select “Advanced Options“.
-----Select “Startup Options“.
-----Select “Restart“.
-----A menu will appear where you can press “7” on your keyboard to choose “Disable driver signing enforcement“.
Now Device Driver Signing should be disabled, allowing you to install any driver you like in Windows 10 until you reboot.
4) Boot your device into fastboot mode. This should cause it to show up in device manager as Andriod, with a yellow triangle
5) In device manager(press windows + x to bring up a menu, then you can press m or select device manager for quick access) right click the android device
-----Update driver
-----Browse my computer
-----Let me pick
-----Have Disk
-----Navigate to C:\Program Files (x86)\OnePlus USB Drivers
-----Select OnePlus_android_winusb.inf and click okay
-----OnePlus Android Bootloader interface should be selected, and go ahead and install it.

After that your device should start showing up in fast boot mode.
I'm not sure if for some reason my driver version just was lacking a hash, or if it is a common issue, but hopefully i'll save someone a couple of minutes.
ohhh my man, you really saved my time. thanks a lot. appreciates ur help.
 

chinbags

Senior Member
Jul 13, 2010
116
27
New York
Hey Guys,

After fighting this for about an hour, and trying everything I could think of, this was the only way I could get my T-Mobile 8T to show up while in fastboot mode.
I tried the below, and probably more...
  • Ensuring I had the latest fastboot version
  • Manually installing the bootloader driver from googles SDK
  • Several restarts
  • Just installing OnePlus' driver that come on the phone per-installed

So for me, the issue was resolved by doing the following below.
1) install the OnePlus drivers that are included with your phone.
--- they should show up as CD Drive: OnePlus Drivers when you just connect your phone to your computer
2) This will create a directory like this... C:\Program Files (x86)\OnePlus USB Drivers, containing the USB driver
3) In that folder there is a driver "" but both when installed from my phone, and a downloaded version, i ran into The hash for the file is not present in the specified catalog file. The file is likely corrupt or the victim of tampering.. So next we are going to disabled signed drivers on windows.
-----Select the “Start” button.
-----Type “startup”.
-----Select “Change advanced startup settings“.
-----Select “Restart now” under the “Advanced startup” area.
-----Select “Troubleshoot“.
-----Select “Advanced Options“.
-----Select “Startup Options“.
-----Select “Restart“.
-----A menu will appear where you can press “7” on your keyboard to choose “Disable driver signing enforcement“.
Now Device Driver Signing should be disabled, allowing you to install any driver you like in Windows 10 until you reboot.
4) Boot your device into fastboot mode. This should cause it to show up in device manager as Andriod, with a yellow triangle
5) In device manager(press windows + x to bring up a menu, then you can press m or select device manager for quick access) right click the android device
-----Update driver
-----Browse my computer
-----Let me pick
-----Have Disk
-----Navigate to C:\Program Files (x86)\OnePlus USB Drivers
-----Select OnePlus_android_winusb.inf and click okay
-----OnePlus Android Bootloader interface should be selected, and go ahead and install it.

After that your device should start showing up in fast boot mode.
I'm not sure if for some reason my driver version just was lacking a hash, or if it is a common issue, but hopefully i'll save someone a couple of minutes.
Thanks for this - I know its a little after the fact but 6+ months later this post has gotten me out of a fastboot hole with a oneplus 9. Now fully rooted only for this. Thanks again.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 35
    Hey Guys,

    After fighting this for about an hour, and trying everything I could think of, this was the only way I could get my T-Mobile 8T to show up while in fastboot mode.
    I tried the below, and probably more...
    • Ensuring I had the latest fastboot version
    • Manually installing the bootloader driver from googles SDK
    • Several restarts
    • Just installing OnePlus' driver that come on the phone per-installed

    So for me, the issue was resolved by doing the following below.
    1) install the OnePlus drivers that are included with your phone.
    --- they should show up as CD Drive: OnePlus Drivers when you just connect your phone to your computer
    2) This will create a directory like this... C:\Program Files (x86)\OnePlus USB Drivers, containing the USB driver
    3) In that folder there is a driver "" but both when installed from my phone, and a downloaded version, i ran into The hash for the file is not present in the specified catalog file. The file is likely corrupt or the victim of tampering.. So next we are going to disabled signed drivers on windows.
    -----Select the “Start” button.
    -----Type “startup”.
    -----Select “Change advanced startup settings“.
    -----Select “Restart now” under the “Advanced startup” area.
    -----Select “Troubleshoot“.
    -----Select “Advanced Options“.
    -----Select “Startup Options“.
    -----Select “Restart“.
    -----A menu will appear where you can press “7” on your keyboard to choose “Disable driver signing enforcement“.
    Now Device Driver Signing should be disabled, allowing you to install any driver you like in Windows 10 until you reboot.
    4) Boot your device into fastboot mode. This should cause it to show up in device manager as Andriod, with a yellow triangle
    5) In device manager(press windows + x to bring up a menu, then you can press m or select device manager for quick access) right click the android device
    -----Update driver
    -----Browse my computer
    -----Let me pick
    -----Have Disk
    -----Navigate to C:\Program Files (x86)\OnePlus USB Drivers
    -----Select OnePlus_android_winusb.inf and click okay
    -----OnePlus Android Bootloader interface should be selected, and go ahead and install it.

    After that your device should start showing up in fast boot mode.
    I'm not sure if for some reason my driver version just was lacking a hash, or if it is a common issue, but hopefully i'll save someone a couple of minutes.
    3
    Wow I didn't even realize that I had helped people until now! I am so glad I could help you guys @bigd4ve @jefffeely and @Pain-N-Panic
    2
    The easiest method for any newbie is to install , iobit driver booster , free.


    Then update the android driver. The fastboot would be working fine after that.
    2
    I also struggled with this issue but found another solution. Once my phone was plugged in (can't remember if it was system or fastboot) I went to Windows Update and browsed the optional updates. One of the optional updates was a driver for android recovery. Installed it and it worked.
    1
    I cannot believe I did not see this thread earlier...

    Just finished solving the same problem after going nuts for a couple of hours.

    It is most definitely just getting the PC to install the OnePlus drivers AND disabling the driver signing.

    What a pain.