• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[GUIDE] Fix/Enable 5G and DSS

Search This thread

Rootk1t

Senior Member
Jun 2, 2013
1,479
660
I have the engineering mode apk installed on my phone, by every time I dial *#801# nothing happens.
I have tried uninstalling Magisk, and any root apps I have on the phone to see if that is the issue, but the same thing happens.
Any ideas how I am meant to get this to work.
Maybe try reinstalling it or use some other version of engineering mode apk file.
 

onken

Senior Member
May 1, 2012
64
1
Hello

I have this same problem, i have Nord 2 ( with mediatek )
Not working 5G in Play, T-Mobile in Poland

I can modyfication my telephone to run 5G in Poland ??
 

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    Enable 5G and DSS on OnePlus 8T

    As you may or may not know OnePlus didn't add proper changes into EFS configs to allow us use 5G on every network in the world. This guide will help you unlock 5G access and DSS (Dynamic Spectrum Sharing) and doesn't require root access until you don't want to access 5G in SA (standalone) mode.

    I'm NOT responsible to any damage you make to your phone. There's barely any chance to damage anything, but you've been warned.

    Requirements:
    • EngineerMode apk installed on your phone.
    • USB Debugging enabled on your phone.
    • OnePlus drivers installed on your desktop.
    • QPST app installed on your desktop.
    • Qualcomm diagnostic drivers.
    Downloads:

    Instruction #1 - enable 5G:
    1. On your phone, dial *#801# > use EngineerMode > enable Engineer Mode Toggle (ON) and connect your device to your Desktop via USB.
    2. On your Desktop, open Device Manager. You should see two new 'other devices'. Update their drivers by: right click > Update Driver > Browse my computer [...] > Let me pick [...] > All devices > then browse for Qualcom diagnostic drivers you've downloaded & use qcmdm.inf > choose something called 'Android Modem 9018'.
    3. Open QPST. You should see devices in Active Phones and Ports list. If not: Add new port > add two devices shown in the list. Then: Start Clients > QPST EFS Explorer and select SDX55 device. This may take a few seconds.
    4. Once you see EFS Explorer go to /policyman, then copy to a separate folder following files as a backup: carrier_policy.xml, carrier_policy.xml_Subscription01.
    5. Delete those 2 files from the EFS Explorer. Find my corresponding configs and copy them over to the /policyman.
    6. On your phone, disable Engineer Mode Toggle, disconnect from your PC and reboot.
    7. Once booted, dial *#*#4636#*#* > Phone Information > Set preferred network type to NR/LTE/TDSCDMA/GSM/WCDMA. Now you should have 5G NSA enabled.
    * To enable (force) 5G SA, you have to use Network Signal Guru app to change NR5G Mode from NSA to NSA/SA or SA. But this will require root access.

    You can make sure everything is working correctly by using CellMapper app and checking 5G Status. RESTRICTED means your plan doesn't allow you to use 5G, NOT_RESTRICTED means you are too far from the cell, try to move closer, CONNECTED means everything is working perfectly. However, this method isn't ideal - every software update or SIM card change you will loose all modifications.


    Instruction #2 - enable DSS:

    Dynamic spectrum sharing (DSS) provides a very useful migration path from LTE to NR by allowing LTE and NR to share the same carrier.
    1. Follow 1st and 3rd step from Instruction #1.
    2. Once you see EFS Explorer go to /policyman and copy lte_feature_restrictions.xml file to your computer - we're going to edit it, so make a backup somewhere.
    3. Open the file with a text editor of your choice.
    You should see a section like this:
    XML:
    <plmn_list name="dss_plmns" ns="global">
          228-01 505-01 505-11 505-39 505-71 505-72 204-04 262-01 262-06 204-16 204-20 232-03 232-07 204-04 311-480 240-02 238-06 240-01 206-01 204-08 204-12 204-18 204-69 238-01 238-10
    </plmn_list>
    These are the networks allowed to use DSS. Now you should go to MCC-MNC and find a proper mcc-mnc
    codes for your network. Add them to the file as shown above.

    Now you should find section looking like this:

    XML:
    <lte_feature name="NR_DSS">
        <all_of>
          <boolean_test name="carrier:dss_is_enabled" />
          <serving_plmn_in list="dss_plmns" />
        </all_of>
    </lte_feature>
    And change it to this:
    XML:
    <lte_feature name="NR_DSS">
        <any_of>
          <boolean_test name="carrier:dss_is_enabled" />
          <serving_plmn_in list="dss_plmns" />
        </any_of>
    </lte_feature>

    All you have to do now is to save the file, copy it over to the /policyman in the EFS Explorer and copy step 6. and 7. from Instruction #1. And that's it!

    Remember: OP8T from different regions with support of the same 5G bands would sometimes not work in the NSA mode in your carrier network because of different ENDC combos and different LTE anchors. Check if your device would support your carrier network at cacombos.com.

    More on how to properly edit carrier plicy files at MT-TECH Blog. Guide tested on KB2003: Play/P4, KB2007: T-Mobile and KB2005: Verizon.

    Special thanks to:

    • Mr. Minh Truong
    • Mr. Abdullah Alshehri
    • Evenshop Themobilestore
    2
    I can confirm that this guide worked on Verizon in the U.S, at least on the n5 band. However, 5G speeds are still slower for me than 4G. While it may prove more useful in the future, I don't think 5G is mature enough to replace 4G just yet.
    1
    You should use qcmdm.inf and then browse for 'Qualcomm Android Modem 9018' (it should be right on top of the list). I will add this to the main post. Sorry, my bad
    That fixed it, thanks!
    1
    Ah I see. Good to see it's working.
    Maybe the carrier operator decided to move the cell away or upgrade it in the near future at you home place if it was such bad at performance. Who knows
    I just flashed back to T-mobile's 011.0.1.3.KB09CB and 5g is back at my house, just only 5mbps lol. I am now suspecting that they changed the modem for 11.0.4.6 so that it would only switch to 5g if it had a stronger signal.
    1
    Can you extract and post here carrier policy files while you're on 11.0.1.3? I'm curious to see how do they look like.
    Here's the whole folder. I had already pulled it to compare lol.