[GUIDE] [FIX] YUREKA (AO5510) Touchscreen Calibration Issue

Search This thread

fid8592

New member
Mar 15, 2018
1
0
Many Thanks to all of you guys.... who have put their efforts a lot.
finally I succeed to repair touch for Yureka. but in little bit different way.

GTP tool was not working in both the custom ROM mentioned above. hence I started in recovery mode and mounted everything, immediately it detected the TP IC and its version and then I flashed the config. and... its done.



but can u suggest step by step how to mount everything and what all are included in it bcz i m not a developer i dont know what things are there which could make thungs correct............sugggest stepwise guide orr else you tube video guide so that i could have a check on how to do...
 

Akhilsurya1993

New member
Sep 11, 2017
2
1
not able to flash yureka cfg file

hi i have the same issue as u have mentioned in ur post but i have used gtpadb tool and it detected my mobile but cant flash the cfg file bcoz
this happens

[3.516][IC type]: GT970
[3.516][Profile Name]: GT970_1039_46-A05510-TP-Firmware.cfg
[3.516][Configuration Length]: 186
[3.516] Check configuration length: Checksum succeeded
[3.516] GT9 Series "Checksum" Check: Checksum succeeded
[3.517]<Error> Failed to send configuration!


my ic GT970
IC 970_1041

PLEASE HELP ME
 

LICHG4E

New member
Jun 10, 2020
2
1
i have the same problem but on my infinix phone , i flashed the phone and the y axis calibration is wrong its higher than whats shown in display, please i tried every stock rom but no luck , i can't find a solution
 

Top Liked Posts

  • There are no posts matching your filters.
  • 6

    Hurray! Finally, I fix the touch calibration issue; many many thanks to God who showed me the right path.

    After suffering hard in last 15 days, even not getting any help from YU Officials, finally God bestowed upon me his blessings and provided me the hint to fix the issue.

    What caused the Issue?

    YU Televentures recently released a new batch of Yureka Plus (YU5510A-LP) devices with VoLTE feature. This created a storm in Yureka /Plus section of the forum. Some users even bricked after flashing the new firmware since it was totally different from the previous Yureka firmware. I got the backup of /system and /boot from a YU5510A-LP user. I deodexed the files and made a ROM out of it and flashed on my device to test whether it boots or not (a common process of ROM porting). It didn’t boot but it went beyond the boot logo and since the Kernel of YU5510-A didn’t have the correct display drivers for AO5510, I was getting strange characters on the screen. After that I rebooted to TWRP recovery. I was shocked the touch was malfunctioning. If I touch up it was working down, it was totally a mess. :mad:

    This issue is much dangerous than bricking the device. Even if we brick, we may recover it by following @ricks guide, but with malfunctioning touchscreen phone is utterly useless. It can’t be fixed even after flashing the EMMC backup.

    After that I reported to the YU Officials about the touch calibration issue, they didn’t provide any fix, but created a Warning thread regarding it. So sad. :(

    They were even not ready to provide me the touch firmware of Yureka AO5510. They told me that they are also trying to find the cause of touch calibration issue and don’t have the required files. Here is the quote of the reply from YU Officials:

    I am afraid that we don't have any files for fixing the issue. To make sure that such thing does not happen we internally test every case before releasing the software. In your case, you got the software from unknown sources and flashed it on your device with your own consent and understanding. Yes, we have devs but they work on cases which have higher reproducibility rate like the proximity sensor issue.

    After that I analysed the YU5510A-LP VoLTE firmware and found that it was created by Coolpad, a Chinese Smartphone Company. So YU Televentures has imported not only the smartphone (YU5510A-LP) but also the firmware from Coolpad. That’s why it has some unknown bugs which the YU Offical Devs don’t know because they haven’t made the firmware. That’s why the devs didn’t have fix for touch calibration issue. YU is spending very less on service and devs, which very much disappointing. YU, an Indian brand made Yureka for tech freaks and that’s why so many devs engaged in it and even some noobish users like me became devs to raise the company above cheap Chinese brands. But now it’s status is deteriorating, it broke its partnership with Cyanogen and lost the support of so many great devs; and now it is left with some official noobish devs who are taking time like hell to provide a VoLTE patch for other users, this shows how irresponsible is the YU Company. And now it has already been provided by a YU Forum user. Even the Official YU OS is provided by our friend dev @AudioGod.

    I hope my above words reaches to the YU Company and they take this criticizing in the right way and improve itself. I want to see this Indian Company rise beyond heights.

    After lot of analysis and research I found that the cause of touch calibration issue was the kernel of YU5510A-LP ROM. It changed the TP-Firmware version and touch parameters of Yureka AO5510 (HD) according to Yureka YU5510A-LP (FHD) device and messed up the calibration.

    This TP firmware is different in Yureka and Yureka Plus and it never changes after flashing any firmware (fastboot or ROM).

    Yureka AO5510 : Each:GT970:0x1039:0x46
    Yureka Plus YU5510 : Ofilm:GT970:0x1039:0x48
    And mine was : Each:GT970:0x1039:0x47

    Yureka (Plus) Touch Panel is manufactured by Goodix, a Chinese Touch Panel and Fingerprint Sensor company.


    What didn’t fix the issue?
    These are the things which didn't fix the calibration issue:
    [/SIZE]
    • Flashing stock COS 12.1 ROM through recovery
    • Flashing COS 12.0/12.1 fastboot firmware
    • Flashing COS 12.0 CPB using YGDP tool (which threw an error of incompatible device before flashing)
    • Flashing all other partitons (=EMMC backup)
    • Using Annabathina’s Yureka Unbricking Tool

    How did I find a Fix?
    While surfing through internet I found a way to check the touch firmware version. Then I checked mine and also asked about it from other Yureka users. Then I searched about the firmware version and got an XDA Thread and also got to know about Goodix Touch Firmware and Goodix Firmware Upgrade Tool (GTP ADB Tool) from Elephone (another Chinese company) forum which I didn’t get from YU.

    I read the XDA thread learned about the whole thing and created a Goodix TP Firmware/Config myself.


    How to Fix Yureka AO5510 Touch Calibration Issue?

    STEP 1: Download GtpAdbToolV1.7_20140424.zip and GT970_1039_AO5510-TP-Firmware.zip on your Windows PC and extract it. Go to the extracted folder of Gtp Adb Tool and run the GtpAdbTool.exe application. Then connect you YUREKA AO5510 to your PC (be sure USB debugging is enabled in your device). You will see the GTP ADB Tool window similar to the screenshot below:



    STEP 2: Now click on the button as indicated in the screenshot below and navigate for the GT970_1039_AO5510-TP-Firmware.cfg file (that you extracted in Step 1) and select it.



    STEP 3: Then click on the button indicated in the screenshot below to execute firmware upgrade process. Once completed, you can unplug your device and reboot. Voila touchscreen issue fixed! :)



    NOTE (Important):

    If the GTP ADB Tool doesn't detect your device or TP firmware, then flash any of the following ROMs:

    NucleaROM by @Rakesh Batra
    Hexagon ROM by @Rakesh Batra
    Or any other ROM

    If the above ROMs doesn’t work then try flashing
    CoolUI 6.0 for YUREKA (Test build): https://www.androidfilehost.com/?fid=457095661767103935
    (After flashing this ROM you may see a 'root' indication on YU LOGO, but you can fix that using Annabathina's Tool)


    Important Files

    GTP ADB Tool: https://www.androidfilehost.com/?fid=385035244224387037

    YUREKA AO5510 TP Firmware: https://www.androidfilehost.com/?fid=385035244224387256


    Credits

    Special thanks to @iamreal2 (XDA member) and @Ethan (Elephone forum member)
    Special thanks to @darshan1205, @ricks and @Men_in_black007 who supported me in bad times
    Special thanks to @manis99 for providing me YU5510A-LP VoLTE Firmware :D
    Special thanks to @prasoon Mehra for providing me original Yureka AO5510 TP Config.
    And finally thanks to me for making this fix. :)
    2
    Original TP Firmware Files for Different Devices

    These are Original Stock Touch Panel Firmware/Configs for users who are suffering calibration issue not due to VoLTE firmware but due to other unknown causes.

    YUREKA (AO5510) : https://www.androidfilehost.com/?fid=457095661767104421 (Thanks to @Prasoon Mehra)
    YUREKA PLUS (YU5510) : https://www.androidfilehost.com/?fid=385035244224388338 (Thanks to @darshan1205)

    Users of other YU Devices may share their working TP Firmware to help others.... :)
    1
    Hello nitesh9,

    I am also having the same issue and tried above steps.
    My phone is not getting detected. in the GTP tool. My Phone is rooted and running STOCK ROM..
    it is getting connected in stock rom and GTP tool recognize it in ADB mode but not detecting TP chipset and IC version.

    as you instructed , I downloaded nuclearom and tried to install it via CWM_recovery but installation is getting aborted showing error "System7".

    ANY OTHER IDEA TO GET THIS DETECTED. PLZ HELP.. ALSO , I REALLY APPRECIATE YOUR EFFORT SHARING THIS KNOWLEDGEBASE.

    Many Thanks to all of you guys.... who have put their efforts a lot.
    finally I succeed to repair touch for Yureka. but in little bit different way.

    GTP tool was not working in both the custom ROM mentioned above. hence I started in recovery mode and mounted everything, immediately it detected the TP IC and its version and then I flashed the config. and... its done.
    1
    Hello Sir, does it works with Yureka plus device also? My devices half touch only works after updating to lollipop. Please help me. I can't use my device. Thanks in Advance, please reply as soon as possible.
    Added Yureka Plus TP firmware to the second post...Use that. ;)

    Sent from my YUREKA using Tapatalk