• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

(Guide) Hide Navigation Bar / Immersive Mode/ Transparent [root required]

Search This thread

OrphanBlack

Member
Jun 9, 2014
46
11
Hello.
I asked myself why you can not hide the Navigation Bar from the factory.
I Have long researched and have come to this solution until an official version works. It works very well and I am quite satisfied.

On Playstore I discovered this app (All in One Gesture) by YS Liang.

What it can do;

【Supported Gestures
• Swipe from edges.
• Double tap on the status bar.
• Long press on the physical keys (for Android 4.3+). Works great on Android 7
• Mouse or stylus (S Pen) is supported.

【Supported Actions
• Home, Back, Recent Apps, Screen Off, Immersive Mode, etc.
• Launch of an application or a shortcut.


Step 1:
- Open All in One Gesture> Enable Swipe
- scroll down to Corners> aktivate Lower Left Area

Step 2:
- swipe from left to right, you will see Side Panel [Settings]
- go to Personalisation and open Edge Preference; and make your settings.
- (mine configuration is: Opacity 0% , Corner Size 15px, Edge Sensitivity 60px, Edge With 50%, Horizontal
Offset 0%
, Vertical Offset 0%, Swipe Distance 40px).
- activate Behind Keyboard
- go back to Side Panel [Settings]

Step 3:
- swipe from left to right to see Side Panel
- click on Immersive Mode
- if you want to see the Status Bar, activate it
- Enable Blacklist and click on Manage Blacklist to exclude your desired apps from Immersive Mode
- Now activate the Immersive Mode in the upper right corner (for constantly usage )
or deactivate Blacklist/Immersive Mode (for using with a swipe down activation....)


you're Done, that's it. :) play with the settings and find your best solution!!)

short video guide
Look at attachment für more detailed information....

Greeting Blendit4
 

Attachments

  • 1.jpg
    1.jpg
    50.1 KB · Views: 4,034
  • 2.jpg
    2.jpg
    54.3 KB · Views: 3,914
  • 3.jpg
    3.jpg
    78.8 KB · Views: 3,867
  • 4.jpg
    4.jpg
    66.3 KB · Views: 3,486
  • 5.jpg
    5.jpg
    75.2 KB · Views: 3,509
Last edited:

OrphanBlack

Member
Jun 9, 2014
46
11
Thanks, but i cant seem to find preference button?
Do you have root? Check in Magisk Manager if root is granted for "All about Gesture". If not deinstall the app and install it from Play Store again, use link in post #1. Then check in Magisk Manager Settings, if "busybox" and "hide magisk" is marked on.... :highfive::good:
 

Attachments

  • SmartSelectImage_2017-04-25-15-58-23.png
    SmartSelectImage_2017-04-25-15-58-23.png
    206.6 KB · Views: 584
  • SmartSelectImage_2017-04-25-16-04-31.png
    SmartSelectImage_2017-04-25-16-04-31.png
    199.5 KB · Views: 574

snowblind2142

Senior Member
Jan 20, 2010
1,320
315
Manchester
Open the app and swipe from left to right side to see the Settings Panel...under Immersive Mode> Preference> Manage Blacklist

Do you have root? Check in Magisk Manager if root is granted for "All about Gesture". If not deinstall the app and install it from Play Store again, use link in post #1. Then check in Magisk Manager Settings, if "busybox" and "hide magisk" is marked on.... :highfive::good:

Ahhhhh that's why :) i haven't rooted.

For the first time i want to see how long i can go before it does my head in not having root ;)

Thank you for explaining. Might want to add to first post that root is required for per app basis.
 

Splen

Member
Jul 1, 2008
47
7
Beaumont
Using shell I typed in:

"adb shell pm grant com.phoenixstudios.aiogestures android.permission.WRITE_SECURE_SETTINGS" and the blacklist became visible. Also, my keyboard now works with this app.
 
  • Like
Reactions: Gr8man001

vboyz103

Senior Member
Apr 9, 2006
878
136
Alternative to this is go to your Edge settings (default by Samsung) and install the Edge Softkey and the order your Edge Softkey to be first.

Enable Immersive and swipe at the edge for navigation keys.
 
  • Like
Reactions: dzel

Top Liked Posts