• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[GUIDE] How to bypass authentication and flash in EDL with NO auth for FREE

Search This thread

VD171

Senior Member
Jun 21, 2012
1,979
2
1,617
127.0.0.1
LG K10
Samsung Galaxy J7
  • Like
Reactions: EnderTecks17

EnderTecks17

Member
Feb 25, 2019
5
1

shivam271104

Member
Aug 2, 2020
8
5
Redmi Note 9
Every time I try to flash I end up with this error .I have tried this for 12.0.1,12.07,12.0.8,12.5.1 for 1 full day trying my luck with any of these but every time I get this screen after the Download Da 100%.Everything has gone well before this step. I have even disabled protection If someone could help I would be grateful .Thanks in advance
Screenshot 2021-08-12 215612.png
 

cxdu

Member
Aug 12, 2021
15
0
I followed these steps and now my PC can't recognize USB after disable protection.
I've tried to restart, to shutdown, to power off the energy, I've tried in another PC and nothing.
Can you help?
 

Jazzda

Senior Member
Sep 18, 2019
107
14
Ask google
@VD171
In Bypass.bat I get Found port = COM3, and nothing more, then it just stay there, doing nothing.
In spflashtool -> options -> connection there's only COM1 to select.
In device Manager there is Ports (COM and LPT) -> MediaTek USB Port (COM3)

What's your advice, please?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    Thanks to:
    chaosmaster / k4y0z: GitHub / XDA
    xyzz / xyz`: GitHub / XDA
    Dinolek: GitHub / XDA


    • How to install:
    1. Download the attached file: VD171_MTK-bypass.zip.

    2. Extract the file and open the folder.

    3. Run and install python: python-3.9.1-amd64.exe.
    Keep atention: You need to select "Add Python to PATH" before starting the installation.

    image-000-jpg.5211735


    4. Open cmd or powershell and execute this command:
    pip install pyusb pyserial json5

    5. Go to the Driver folder and right-click on the cdc-acm.inf file, then click Install and then, close window.

    6. Run and install filter wizard: libusb-win32-devel-filter-1.2.6.0.exe.

    7. Launch filter wizard.

    8. Select Install a device filter and click Next.

    9. Connect powered off phone with volume- button to boot in EDL mode.

    10. Once you see new MediaTek USB Port in the list, select it and click Install.

    image-002-jpg.5211741


    Now, you are ready for bypassing EDL ! :cowboy:


    • How to bypass:
    1. Go to the Bypass folder. Run the script: bypass.bat.

    2. Connect powered off phone with volume- button to boot in EDL mode.

    3. Once you get "Protection disabled" at the end, without disconnecting phone and usb, run SP Flash Tool.

    image-003-jpg.5211729


    4. Once the SP Flash Tool opens, click Options > Options > Connection.

    5. Select UART mode and select Baud rate to 921600.

    image-004-jpg.5211727


    Now, you are ready for flashing ! 😍


    • How to update:
    1. Download latest release of the tool: https://github.com/MTK-bypass/bypass_utility/releases/latest

    2. Download latest release of payloads: https://github.com/MTK-bypass/exploits_collection/releases/latest

    3. Extract the content of both files to the Bypass folder.

    Now, you are updated ! :cool:


    • How does the bypass work?


    All Credits To:
    chaosmaster / k4y0z: GitHub / XDA
    xyzz / xyz`: GitHub / XDA
    Dinolek: GitHub / XDA




    :unsure: Do you need help with your MERLIN device ?
    Read this FAQ: https://forum.xda-developers.com/t/...for-merlin-redmi-note-9-redmi-10x-4g.4225163/


    #NoAuth #NoAuthentication #No-Auth #No-Authentication #MediaTek #Xiaomi
    #MiAuth #MiAuthentication #Mi-Auth #Mi-Authentication #XiaoMiAuth #free
    #XiaoMiAuthentication #XiaoMi-Auth #XiaoMi-Authentication #unbricking
    #unbricked #unbrick
    #MTK #MT6572 #MT6735 #MT6737 #MT6739 #MT6750 #MT6765 #MT6762
    #MT6761 #MT6768 #MT6771 #MT6785 #MT8127 #MT8163 #MT8173 #MT8695
    2
    Good job, The guide helped a guy in telegram group unbrick his device.


    Thanks for this :D
    2
    woah this can speed up custom rom development for the device, just like the factory images on redmi note 8 pro, i hope lots of people see this!
    2
    nice work !
    does this apply also to redmi note 8 ?
    2
    LOVE YOU >....you saved my life ....i succesfully bypassed the protection.. and unbricked my hard-bricked begonia phone
    i dont know how happy i am... huge thanks sir ....this was my first time doing such a work ..and you saved me from a huge loss
    ...thank you sir
    God bless you sir ....
    i have been trying to find a way for the past 16 hours continously .. i almost lost hope ...


    thanks sir ..
    Nice job, my friend !
    We love to know that. :cool:
    Please, too give some thanks to:
    chaosmaster / k4y0z: GitHub / XDA
    xyzz / xyz`: GitHub / XDA
    Dinolek: GitHub / XDA