• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Guide] How to enable USB audio on Nexus 5X

Did your USB audio work on the 5X out of the box?

  • Yes, it worked out of the box.

    Votes: 3 27.3%
  • No, it worked only after changing settings.

    Votes: 1 9.1%
  • USB audio does not appear to work at all.

    Votes: 7 63.6%

  • Total voters
    11
Search This thread

makogaleos

Member
Jul 16, 2012
14
11
The Nexus 5X's USB Type-C port can both input and output audio, however mine needed some setting up before it would work.

I plugged in a Blue Yeti microphone into the Nexus 5X using both the USB Mini-B to USB Type A cable (comes with the Yeti), and the USB-A female to USB-C male adapter from Google. The Yeti powered on instantly, it's red light turned on, and I could hear myself through its no latency monitoring via headphones (Blue Yeti has a 3.5mm headphone output), however the 5X would not recognize the Yeti as either an audio input nor as an audio output device.

I went into Developer Options, scrolled down to "Select USB Configuration" and changed the radio button selection to "Audio Source". I scrolled down even farther to the Media section, and there I disabled "Disable USB Audio Routing" (you might say that I enabled USB audio routing). There was no immediate effect, so I unplugged the Yeti, plugged it back in, et voila! The phone recognized the Yeti as both a microphone AND an audio playback device simultaneously.

I don't know for sure which of those two settings truly made a difference, as now that I've got USB audio to work, neither of those settings seems to make a difference anymore -- it seems as though my Yeti is permanently approved for USB audio in my 5X!

The USB audio works for listening to Google Music, and even for regular voice phone calls.

Do you have a USB microhone/headset/headphones/DAC? Get a good USB-A female to USB-C male adapter and you'll be quite pleased! And hopefully you'll be luckier than I was and it'll just work when you plug it in, but if not then toggle those USB audio Developer Options as described above.
 
Last edited:

makogaleos

Member
Jul 16, 2012
14
11
Just plugged the 5X into a Focusrite Scarlett 18i20. The phone recognizes the first two input channels and can record in mono or stereo (input 1 as left track and input 2 as right track).

Also it does seem as though you must keep the "Disable USB audio routing" off for it to work.
 

windplr

Member
Sep 4, 2015
9
2
This is really nice. Able to route usb audio to a Cambridge Audio DacMagic. Much better than the on-board dac, and no longer tied to a specific app.
 

Sleek69

Senior Member
Mar 26, 2011
254
76
My 6th gen iPod nano plays usb audio perfectly fine on my crappy pioneer deh-3300ub headunit, but no matter what settings or cables I try the stereo says "N/A USB" with my N5X plugged in.
 

drago10029

Senior Member
Nov 19, 2008
1,058
204
Phazon Mines
Anyone get the audio-in-via-usb to work with the built-in Google camera/camcorder app?

I am using Nexus 6P
The audio-in DOES work with this video app: https://goo.gl/Dtu14
But with the built-in camcorder, it only records audio from the phone's mic, not the usb mic.

I would think google designed it to only use built in microphone. It would take some mods or tinkering to get it to do otherwise.

---------- Post added at 11:25 PM ---------- Previous post was at 11:23 PM ----------

The Nexus 5X's USB Type-C port can both input and output audio, however mine needed some setting up before it would work.

I plugged in a Blue Yeti microphone into the Nexus 5X using both the USB Mini-B to USB Type A cable (comes with the Yeti), and the USB-A female to USB-C male adapter from Google. The Yeti powered on instantly, it's red light turned on, and I could hear myself through its no latency monitoring via headphones (Blue Yeti has a 3.5mm headphone output), however the 5X would not recognize the Yeti as either an audio input nor as an audio output device.

I went into Developer Options, scrolled down to "Select USB Configuration" and changed the radio button selection to "Audio Source". I scrolled down even farther to the Media section, and there I disabled "Disable USB Audio Routing" (you might say that I enabled USB audio routing). There was no immediate effect, so I unplugged the Yeti, plugged it back in, et voila! The phone recognized the Yeti as both a microphone AND an audio playback device simultaneously.

I don't know for sure which of those two settings truly made a difference, as now that I've got USB audio to work, neither of those settings seems to make a difference anymore -- it seems as though my Yeti is permanently approved for USB audio in my 5X!

The USB audio works for listening to Google Music, and even for regular voice phone calls.

Do you have a USB microhone/headset/headphones/DAC? Get a good USB-A female to USB-C male adapter and you'll be quite pleased! And hopefully you'll be luckier than I was and it'll just work when you plug it in, but if not then toggle those USB audio Developer Options as described above.

Can you test and report which apps can record audio with the blue yeti? free and/or paid, if you have the time to test of course.
 

chavook

New member
Sep 7, 2016
1
0
hi! I buy one of this adapter usb-c to 3.5 jack, beacuse my 3.5 jack has broken. I dont find how enable the output audio to work with my headphones. someone can help me? thanks!
 

GethPrime

Senior Member
Jan 13, 2011
3,374
2,522
hi! I buy one of this adapter usb-c to 3.5 jack, beacuse my 3.5 jack has broken. I dont find how enable the output audio to work with my headphones. someone can help me? thanks!
That's because you most likely did just get a basic 3.5mm to USB-C adapter with no active circuit. I'm fairly certain that Nexus 5X do not support analog passthrough over USB-C, which means you will need something with active circuitry.

Sent from my Le X829 using Tapatalk
 

anazhd

Senior Member
Jun 30, 2012
1,371
417
Los Santos
www.droidagency.com
hi! I buy one of this adapter usb-c to 3.5 jack, beacuse my 3.5 jack has broken. I dont find how enable the output audio to work with my headphones. someone can help me? thanks!

That's because you most likely did just get a basic 3.5mm to USB-C adapter with no active circuit. I'm fairly certain that Nexus 5X do not support analog passthrough over USB-C, which means you will need something with active circuitry.

Sent from my Le X829 using Tapatalk

You need a portable DAC (get a cheap one like Fiio A1 for 25usd). Nexus 5X USB-C is not USB3/3.1 interface, so it won't work.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 9
    The Nexus 5X's USB Type-C port can both input and output audio, however mine needed some setting up before it would work.

    I plugged in a Blue Yeti microphone into the Nexus 5X using both the USB Mini-B to USB Type A cable (comes with the Yeti), and the USB-A female to USB-C male adapter from Google. The Yeti powered on instantly, it's red light turned on, and I could hear myself through its no latency monitoring via headphones (Blue Yeti has a 3.5mm headphone output), however the 5X would not recognize the Yeti as either an audio input nor as an audio output device.

    I went into Developer Options, scrolled down to "Select USB Configuration" and changed the radio button selection to "Audio Source". I scrolled down even farther to the Media section, and there I disabled "Disable USB Audio Routing" (you might say that I enabled USB audio routing). There was no immediate effect, so I unplugged the Yeti, plugged it back in, et voila! The phone recognized the Yeti as both a microphone AND an audio playback device simultaneously.

    I don't know for sure which of those two settings truly made a difference, as now that I've got USB audio to work, neither of those settings seems to make a difference anymore -- it seems as though my Yeti is permanently approved for USB audio in my 5X!

    The USB audio works for listening to Google Music, and even for regular voice phone calls.

    Do you have a USB microhone/headset/headphones/DAC? Get a good USB-A female to USB-C male adapter and you'll be quite pleased! And hopefully you'll be luckier than I was and it'll just work when you plug it in, but if not then toggle those USB audio Developer Options as described above.