How To Guide [GUIDE] HOW TO INSTALL GSI CUSTOM ROMS ON REDMI NOTE 10 5G/POCO M3 PRO 5G

Search This thread

SPMR

New member
Jun 8, 2022
1
0
Hi All, I am really sorry for the noob question but I have been encoutering an error when trying to install the recovery image for Pixel Experience on my Redmi Note 10 5g. The error I keep getting is ''FAILED (remote: 'size too large')''. The version of Pixel Expererience I am trying to flash is ''PixelExperience_mojito-12.1-20220520-1549-OFFICIAL.zip''. Do you know what I am doing wrong here? Is it even possible to install this on the Redmi Note 10 5g? Thank you in advance!
 

julkidi

Member
Jun 20, 2011
27
4
Avignon
I install Corvus yesterday, and except no cam nor gallery come with it, the auto brithness seems to work perfectly !
Many thanks to both of you for your work and the time you took.
 
  • Like
Reactions: wetito

zjy29642

Member
Apr 10, 2022
8
0
GSI Brightness Fix patch
 

acerfreak

Member
May 12, 2022
18
0
TWRP asks for Password to encrypt Data on the unofficial Pixel Experience Rom for my Redmi Note 10 5G. Does anyone have a Solution?.
Edit: I found the Solution. It's Android 12 and TWRP is not compatible with it. There was an Header Error too. My Solution was to install a Android 11 Rom. I installed the Pixel Experience anyone else can choose Lineage OS or whatever. And that made the Heading Error dissapear and it did not ask for a Password. On Android 12 i had no password but still but it's fixed now with 11. Some Developers need to make a new TWRP for Android 12 to make it work.
 
Last edited:

Singkiit

New member
Jun 16, 2022
3
0
After I flashed it successfuly, after wiping and rebooting it just boot back in fastboot, What to do with this?
 

brian00009

Member
Mar 29, 2022
30
1
MIUI can't do this 😂
Opening multiple apps without killing another app. 39mb free ram and still holding apps lol

GSI ROM: DotOS android 11
Screenshot_20220618-214214_Termux~2.png
 

campanah

Member
Nov 3, 2020
28
0
Paris
I've installed this Corvus (vndklite) and, wonderfull ! there's no brightness bug. Now I'd like to root with magisk so I need the boot.img file, witch is with the recovery version, if I understood... The only I found is from here https://osdn.net/projects/corvusos/storage/ . As these files are pretty old, I don't think it will fit. Do you know where I can find the boot.img matching with the Corvus you quoted ?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Anyone have a solution regarding the delete logical partition_a. ? Even after flashing stock rom and gsi still boots only in fastboot.... Any help would be appreciated, thanks in advance :)
    Followed what u have said but no luck for me....tried different GSI's too,stil boots in fastboot mode only..... Maybe its because of me previously deleting the logical partition using the command
    " fastboot delete-logical-partition product_a "
    Have you tried flashing with Mi Flash?
    You could try have a work around with Mi Flash Pro, there are many tools in it that could help you out, especially SP Tool that can recover (almost) everything

    Not new to modding (actually my first time Im installing PE in my redmi), but could work in advance as it's basically one of the principal tools to recover a redmi or any xiaomi phone.
    1
    Just flashed it on my Redmi Note 10 5G. Working like a charm! Still getting it ready.
    Just wondering, is there any way to put the Android Status Bar a bit lower? I am aware that (if I am sure) this is a Pixel 6 Pro ROM port wich means it might have a bigger screen than it.
    Heres a photo of what I am talking about:

    IMG_20220712_121230.jpg

    Thanks!
    1
    Is that a Nippon gsi?
    Actually, no. Its the Pixel Experience you recommended in the post.
    Might actually flash a Nippon GSI some time later if I can't get a workaround to get 48MP camera, or come back to MIUI (would appreciate alot if you could help me out, but Ill try it myself first so dont bother (unless theres no way to do it, but somehow when I was on MIUI 13 EEA, GCam worked perfectly fine outdoors, might be different port tho), but still wondering about what wetito said.

    Also, thank you for making this guide

    Edit: Not sure if flashing the Nippon GSI I mentioned above would brick my device. Also couldn't get 48MP camera working. Taking photos outdoor somehow turned very bad quality since I went from MIUI to PE, and GCam in MIUI took outdoor photos better than MIUI camera.
    Still concerned about the warning. I'm not sure if I do flash the Nippon GSI I mentioned.
    1
    nippont gsi don't boot
    1

    Little update on more unoffical GSIs, and a official GSI for anybody who wants it


    Recently, I have some (maybe) good news for us.
    I tried a ArrowOS unofficial GSI ROM ---> https://t.me/naz_dis/40450. It booted fine:

    e3c6dca1-98ea-4d73-b6ed-0290c1905567.jpg


    However, on the setup, I encountered a error that wouldn't let me past thru the Google One backup screen request, see the image below.
    e2d448a8-3a61-4118-80e2-b17e6d2bfbf5.jpg

    And that's it. Tried rebooting, and I did wipe data after flashing. No root also.
    Or, could be my fault, but I really didn't know what I messed up on, or definitely I could get it to work by any step that I might had forgot.
    Anyways, if anybody wants to test, the link is above.

    Reflashed MIUI again and soon or not, going to test AncientOS official GSI ---> https://t.me/ancientrom/1785 or https://sourceforge.net/projects/ancientrom/files/gsi/V6.2/
    Select "AncientOS-S-Shield-v6.2-arm64_bgN-Steel-20220417.img.xz"
    If you do not want GApps pre-installed, select the "AncientOS-S-Shield-v6.2-arm64_bvN-Steel-20220417.img.xz"

    For those who don't know, here's a quick explanation about the letter "g" and "v":

    The letter "g" in a ROM name represents that there's Google Apps pre-installed, so you don't have to waste time to optionally root your device and flash Magisk GApps.
    The letter "v" in a ROM name represents "Vanilla" wich means theres no GApps included or pre-installed, wich means you need to root your device and install Magisk GApps.
    Quick tip also: The "N" means there's no SuperUser, or no root image pre-included.

    When I can arrange the time to flash AncientOS, I'll be sure to edit an update here (or if you're reading this you can try it whenever you can and want)

    Also, whoever wants to try the official Google Android 13 GSI, here's the link.
    Select "aosp_arm64-exp-TPB3.220610.004-8722590-510af211.zip" and extract to get the .img file.

    I am also aware people could get any GSI easily, just wanted to help those who don't prefer Pixel Experience, but I apologise if I'm doing anything wrong, as I am new to XDA and to Xiaomi modding. 😉
  • 3
    Code:
    I am NOT responsible for bricked devices, destroyed SD cards or any
    damage that may happen to your device.


    Requirements:
    Unlocked bootloader.

    WARNING

    Don't use Nippon gsi they aren't working,I recommend using phh gsi by @phhusson lineage os by @AndyYan and PE 12 by @ponces


    How to guide:

    power + volume down button

    fastboot reboot fastboot

    install fastbootd drivers,follow this tutorial


    fastboot set_active a

    fastboot erase system

    fastboot flash system (name gsi.img)

    fastboot --disable-verity --disable-verification flash vbmeta (vbmeta.img)

    fastboot flash vbmeta_b (vbmeta.img)

    fastboot set_active a

    fastboot reboot recovery

    in recovery select wipe data

    reboot to system


    The GSI will be installed in your phone ;)

    Bugs:
    Brightness slider but you can fix it

    Recommended rom:

    Pixel experience:

    Select arm64 ab variant


    How to fix brightness slider:

    Go to phh treble settings,misc settings enable "use alternative brightness scale", "use linear screen brightness slider" and "allow setting brightness to the lowest possible",reboot the device

    There is an better alternative to fix this annoying bug,follow this guide!



    How to fix bluetooth audio:

    Go to phh treble settings,misc settings, "Force enable a2dp off-load" and "Bluetooth workarounds" select mediatek option and reboot the device.


    How to install magisk on your device:



    How to flash gapps:
    You need magisk on your phone
    Download this file then flash from magisk


    3
    Latest corvus has auto brightness fixed
    2
    Nippon gsi is the largest community of ported gsi. but flash carefully. not al generic gsi are compatible with stock vendors driver. after rebbot you can have some bugs. but the stock system can be easily restored. i suggest ported gsi from redmi note 8
    2
    @Fire1511 do you picture proof on device with any GSI running on poco m3 pro 5g
    2
    that was fast. thank you
    side note, do you have twrp for poco m3 pro 5g?
    No twrp