How To Guide [GUIDE] HOW TO INSTALL GSI CUSTOM ROMS ON REDMI NOTE 10 5G/POCO M3 PRO 5G

Search This thread

1lopes

Senior Member
Just flashed it on my Redmi Note 10 5G. Working like a charm! Still getting it ready.
Just wondering, is there any way to put the Android Status Bar a bit lower? I am aware that (if I am sure) this is a Pixel 6 Pro ROM port wich means it might have a bigger screen than it.
Heres a photo of what I am talking about:

IMG_20220712_121230.jpg

Thanks!
 
Last edited:
  • Like
Reactions: Fire1511

1lopes

Senior Member
Is that a Nippon gsi?
Actually, no. Its the Pixel Experience you recommended in the post.
Might actually flash a Nippon GSI some time later if I can't get a workaround to get 48MP camera, or come back to MIUI (would appreciate alot if you could help me out, but Ill try it myself first so dont bother (unless theres no way to do it, but somehow when I was on MIUI 13 EEA, GCam worked perfectly fine outdoors, might be different port tho), but still wondering about what wetito said.

Also, thank you for making this guide

Edit: Not sure if flashing the Nippon GSI I mentioned above would brick my device. Also couldn't get 48MP camera working. Taking photos outdoor somehow turned very bad quality since I went from MIUI to PE, and GCam in MIUI took outdoor photos better than MIUI camera.
Still concerned about the warning. I'm not sure if I do flash the Nippon GSI I mentioned.
 
Last edited:
  • Like
Reactions: Fire1511

1lopes

Senior Member
Nippon gsi is the largest community of ported gsi. but flash carefully. not al generic gsi are compatible with stock vendors driver. after rebbot you can have some bugs. but the stock system can be easily restored. i suggest ported gsi from redmi note 8
Does that mean I can flash it with no problems a Nippon GSI on the Redmi Note 10 5G, no bricking risk and follow the same guide, but have some bugs in the ROM itself?
 
Last edited:

1lopes

Senior Member
nippont gsi don't boot
That's strange... or I made a misunderstanding.

You respectively mentioned "after rebbot you can have some bugs."
And yes, I am aware about the warning in the GSI. I can try it this Nippon GSI here -> https://t.me/nippongsi/5432 and I'll edit or post a reply about a update on it.

But why it doesn't boot? Its a GSI, its made to work for every device that has Treble, right?

Update: It didn't boot. Only went to fastboot, you were correct. Still don't understand why, or I made a misunderstanding about this.
Already flashing MIUI again.

Also, could someone help me to get the 48MP camera to work on Pixel Experience? Would be much appreciated. Photos outdoors seem really bad.
 
Last edited:

1lopes

Senior Member

Little update on more unoffical GSIs, and a official GSI for anybody who wants it


Recently, I have some (maybe) good news for us.
I tried a ArrowOS unofficial GSI ROM ---> https://t.me/naz_dis/40450. It booted fine:

e3c6dca1-98ea-4d73-b6ed-0290c1905567.jpg


However, on the setup, I encountered a error that wouldn't let me past thru the Google One backup screen request, see the image below.
e2d448a8-3a61-4118-80e2-b17e6d2bfbf5.jpg

And that's it. Tried rebooting, and I did wipe data after flashing. No root also.
Or, could be my fault, but I really didn't know what I messed up on, or definitely I could get it to work by any step that I might had forgot.
Anyways, if anybody wants to test, the link is above.

Reflashed MIUI again and soon or not, going to test AncientOS official GSI ---> https://t.me/ancientrom/1785 or https://sourceforge.net/projects/ancientrom/files/gsi/V6.2/
Select "AncientOS-S-Shield-v6.2-arm64_bgN-Steel-20220417.img.xz"
If you do not want GApps pre-installed, select the "AncientOS-S-Shield-v6.2-arm64_bvN-Steel-20220417.img.xz"

For those who don't know, here's a quick explanation about the letter "g" and "v":

The letter "g" in a ROM name represents that there's Google Apps pre-installed, so you don't have to waste time to optionally root your device and flash Magisk GApps.
The letter "v" in a ROM name represents "Vanilla" wich means theres no GApps included or pre-installed, wich means you need to root your device and install Magisk GApps.
Quick tip also: The "N" means there's no SuperUser, or no root image pre-included.

When I can arrange the time to flash AncientOS, I'll be sure to edit an update here (or if you're reading this you can try it whenever you can and want)

Also, whoever wants to try the official Google Android 13 GSI, here's the link.
Select "aosp_arm64-exp-TPB3.220610.004-8722590-510af211.zip" and extract to get the .img file.

I am also aware people could get any GSI easily, just wanted to help those who don't prefer Pixel Experience, but I apologise if I'm doing anything wrong, as I am new to XDA and to Xiaomi modding. 😉
 
Last edited:
  • Like
Reactions: nanchilanto

1lopes

Senior Member
Is there a way to get 48MP GCam working on Pixel Experience, or in general any GSI for Redmi Note 10 5G? Ive tried ANXCamera, even 48MP S Fix via Magisk, but I can't get it to work. Outdoor photos seem pretty bad quality, had to get back to MIUI because it's a really big let down for me.
Well, if its impossible, is there a way to stop MIUI's agressive app killing, atleast?
 

acerfreak

Member
May 12, 2022
18
0
I have TWRP Mount Error on Android 12. I have 0mb and it asks for Password even though that I don't have one set. My TWRP is 3.6.0
 

1lopes

Senior Member
GSI roms are very stable no bugs found only brightness slider on certain phone but I posted a fix
I used Pixel Experience for 1 week and perfomance was horrible to be honest... worse than MIUI.
Only the aggressive app killing was gone unlike MIUI.
Sometimes, but not rarely, it does freezes the entire phone, or when I open the GCam port I installed also freezes the phone for a whole minute, or can't take a photo till I close and reopen it again, or taking a photo freezes it again. (and no its not 90hz as I don't use it because it drains the battery fast)
 

1lopes

Senior Member
If anybody is using Pixel Experience, do not install the July v415 update as it does brick your phone, both Poco and Redmi.
Thanks skm_1 for the first warning.

I did it just to try it out, but no concern as I was gonna switch back to MIUI again and all my data is backed up.
The only way there is to update to the new July version is by reflashing Pixel Experience v415 all over again, which means your data will be wiped, or don't update.

I'm pretty sure there's no automatic OTA, only per request by the user to update, so no need to worry about, just ignore it. (this is only happening to both the devices in this forum, so could be caused by a vendor problem, or any other error, so other devices could update perfectly fine)
 
  • Sad
Reactions: tearex

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    is not a mac problem. fastboot works equal on all SO

    reflash stock firmare via xiaomiadbfastboot tool.

    ps: i dont know how, seems u have deleted system
    so i hope for you that miflash could solve your problem. otherwise u have to create a new partion table by yourself. an operation for medium/expert linux users
    I haven't deleted it, my phone boots fine and works fine. Maybe it's a new update or maybe I did delete it...or maybe it got deleted when Xiaomi unbricked my phone (it got bricked permeantly)

    Is there no other partition (but super, super does NOT work) to flash gsis to?

    Oh do I need to be in fastbootd for it to show? I was only in regular fastboot.

    Edit: i had to be in fastbootd thank you so much :)
  • 3
    Code:
    I am NOT responsible for bricked devices, destroyed SD cards or any
    damage that may happen to your device.


    Requirements:
    Unlocked bootloader.

    WARNING

    Don't use Nippon gsi they aren't working,I recommend using phh gsi by @phhusson lineage os by @AndyYan and PE 12 by @ponces


    How to guide:

    power + volume down button

    fastboot reboot fastboot

    install fastbootd drivers,follow this tutorial


    fastboot set_active a

    fastboot erase system

    fastboot flash system (name gsi.img)

    fastboot --disable-verity --disable-verification flash vbmeta (vbmeta.img)

    fastboot flash vbmeta_b (vbmeta.img)

    fastboot set_active a

    fastboot reboot recovery

    in recovery select wipe data

    reboot to system


    The GSI will be installed in your phone ;)

    Bugs:
    Brightness slider but you can fix it

    Recommended rom:

    Pixel experience:

    Select arm64 ab variant


    How to fix brightness slider:

    Go to phh treble settings,misc settings enable "use alternative brightness scale", "use linear screen brightness slider" and "allow setting brightness to the lowest possible",reboot the device

    There is an better alternative to fix this annoying bug,follow this guide!



    How to fix bluetooth audio:

    Go to phh treble settings,misc settings, "Force enable a2dp off-load" and "Bluetooth workarounds" select mediatek option and reboot the device.


    How to install magisk on your device:



    How to flash gapps:
    You need magisk on your phone
    Download this file then flash from magisk


    3
    Latest corvus has auto brightness fixed
    2
    Nippon gsi is the largest community of ported gsi. but flash carefully. not al generic gsi are compatible with stock vendors driver. after rebbot you can have some bugs. but the stock system can be easily restored. i suggest ported gsi from redmi note 8
    2
    @Fire1511 do you picture proof on device with any GSI running on poco m3 pro 5g
    2
    that was fast. thank you
    side note, do you have twrp for poco m3 pro 5g?
    No twrp