[GUIDE]How to install Old ATI Radeon Cards on Windows 8/8.1/10

Search This thread

Mitsos

Senior Member
Jun 26, 2007
67
6
Installs and works perfectly and smooth on Acer Trevelmate 5520, amd athlon 64x2 dualcore TK57 in combination with Ati Radeon X1250. On device manager it says X1200 series but who cares... :) Native resolution 1280x800! windows 10pro 1703 32bits built 15063.632. Thanks to the poster for his kind contribution!
PS. DO NOT FORGET after installation to disable fast startup on energy settings to avoid black screen on reboot!
 
Last edited:

Fluxvir

New member
Nov 6, 2017
1
0
Funcionó perfectamente en una Acer Aspire 3100-1405 con tarjeta de video ATI Radeon Xpress 1100 sobre Windows 8.1 de 64 bits. (Controlador: ATI Catalyst 12.11 B11 HotFix 11.09 V6 BETA)
 

Sanaameen

Member
Mar 4, 2017
18
0
Here is the best source to download free ATI drivers. I have personal experience with this website and therefore like to post here for all of us. So, it is all very helpful. This is valuable for the all kinds of windows versions. I felt this is sound good for all of us.
 

Shroamer

New member
Nov 29, 2017
1
0
GA-x1600pro blackscreen solved

Hello!
First of all I want to thank topic-starter and all other thread members for all of info you've been get here together. Really, it helps me not to return to win7 with all this time-wasting installations, etc.

I have x1600pro assembly by gigabyte. It has 2 video connectors onboard: digital DVI and analog VGA.
And I had the issues described above in thread that comes with x1600 series.

My story:
* My video worked well with screen connected to ANALOG output after successful driver installation .
Everything seems to work perfect, so I did not read all topic's pages.
"No so perfect" i notice past some time. There was an issue with wrong resolutions in analog connection: i could not see bottom part of image (no start button at desktop mode or action button within windows installation) it was cut. I changed resolution after windows installs.
Next issue i notice was about image falls out the screen a little bit (several pixels) when switching fullscreens, so i should press "auto config" button on my LCD screen to let it adjust image to screen frame. If was a little bit annoying.
So I decide to switch screen into DIGITAL output so it may detect resolutions actually supported by my screen.

* When I turned computer off and switch cables next thing I've got is black screen with mouse cursor.
And I started to read pages of this thread, thank you guys! :)

* When I shut down PC with power button (windows configured as power-off) this changes nothing. Screen shows "bye" screen for a moment and shuts off. After power-on it was black again. :(

* When I shut down PC with reset button I got my screen working. But without any start button and desktop icons on it. And I catch a sense of what is happening. :)

* Looking to "screen resolution" page I've noticed that there are two monitors windows think attached. And when i try to change it to ane real connceted to digital - it becomes black again.

I read about "fast boot" and try it. It worked. And i saw only 1 screen in "screen resolution" window. Hooray! :)

I understood that:
If i switch screen from one port to another with fast boot enabled in power-off state. system does not forget about port i left free. but ADDS new screen to connected port.
I think if can't handle two screens under win8 or some other compatibility issues of win7 driver running under win8.

So, what you can try in case you have black screen issue with x1600 and "win-F tab tab enter" does not works:
1. Switch off power
2. Switch display port to prefered
3. Press reset or somehow crash windows so it would not fast boot next time
Now it works well in my case thru DVI connector. And i can reboot it with fast-boot mode if I don't change screen port.
In case of changing output port I made "shutdown -s -t 0" shortcut. So I'm shutting down with this shotcut. It totally shuts windows so it can't fast-boot 1 time after it. Next I can change port and start windows. Everything works.

I am so appreciate you guys so I registered here to make this post and share my experience.
I love when old devices are working and doing their function, so i hope my post will help someone with x1600 or other double-port cards issuing black screen with cursor.

Good luck and have no static! :)
 

Ady1976

Senior Member
Apr 9, 2012
512
78
Manchester
UPDATE 23/10/2015
By @Simonkjam
NEW DRIVER !

PERFECT ON MOBILITY RADEON X1300 ON WINDOWS 10, AND FOR ALL OTHER MOBILE X SERIES IN MY OPINION!

DOWNLOAD HERE

Install with setup, custom install (remove all the ugly software, only driver and microsoft stuff)

Again,HUGE THANKS to @Simonkjam for this!

ORIGINAL POST

UPDATE 02/08/2015
Thanks to @comhon for testing,this guide will work even for Windows 10

Lets Begin :)

REQUIREMENTS
Windows 8/8.1/10
One of those video cards:

Drivers you can use :



If you meet all requirements Let's Begin



Hope this help,if you have any question or problem just reply :)

Great stuff however the FN + brightness does not adjust the brightness at all it doesn't work, also catalyst doesn't work so I don't knoe if it's using 32 bit colour? Any workaround for these 2 issues anyone? Just to add it's a Samsung R60 plus laptop.
 
Last edited:

hajj_3

Senior Member
Jul 17, 2010
129
24
since you created this driver a new hd audio driver has been released (16.4.0.0000), old driver is 15.20.0.1, hope you can update this.
 

star-affinity

New member
Jun 14, 2018
1
0
Using Windows Defender to scan the file in the "DOWNLOAD HERE" link in the first post for malicious software gave the result "Trojan: Win32/Bitrep.B" for the "Setup.exe" file in the "ATI Catalyst 12.11 B11 Hotfix 11.09 V6 BETA\Bin" folder. Doesn't sound very good… Any ideas?
 
Last edited:

tiga05

Senior Member
Jan 14, 2013
108
32
OnePlus 3T
Maybe I misunderstood the downloadable link from mediafire. I thought this is a modified driver or something.

Anyway, I played something around before you wrote me back. I also tried the 10.2 driver for Vista you recommend. But it does not work. He tells me everything is up-to-date. But its just the basic display adapter without hardware acceleration. I gave up for now. I just installed Windows 7 now, because I need this Notebook tomorrow. Maybe I will try it again, if I have some time.

But interesting, that you are still "alive" after so many years and answer me:D. Thanks for your answer.
 

Punit Parmar

New member
Dec 6, 2019
1
0
Sir my problem is that
I recently upgraded my PC to windows 10 but due to late night I felt asleep and when I wake maybe after an hour Igot a notification tha Automatic startup repair has stopped working......
And two tions were given
first SHUTDOWN
and second ADVANCED OPTIONS
But when I want to select the keyboard and mouse gets stop working what shoud I do ?
 

pedro2616

New member
Jan 9, 2014
1
1
Force Windows 10 to use a better driver than MS Basic ?

Toshiba Equium A300D-13X laptop with on board ATi Radeon X1250. With the withdrawal of support for windows 7, today upgraded to windows 10 using the media creation tool. Problem is the display is now a lower resolution than on windows 7 (64 bit). I tried the steps in this guide, but it will not use the ATi drivers and simply says it is already using the best drivers, i.e. the Basic Microsoft Display drivers.

So a forward step in getting a supported OS but a backwards step in terms of the screen display/graphics.

Is there a way I can improve the graphics.

I appreciate this is a very old machine, and it's not my main computer, but if it can be made to improve the display, I'd like to do it.

Is there a way to do this ?

Thanks in advance.

---------- Post added at 12:49 PM ---------- Previous post was at 12:23 PM ----------

Thought I'd post this as I solved my own problem with help from another webpage.

I went to Toshiba UK and downloaded the following driver having specified my my machine and asked for display drivers.
23/10/2009 Display Driver ATI Windows Vista 64 Bit 8.593.100.5 World Wide

I unzipped the file to a new location that I chose, and on the setup file, right clicked it, chose the compatibility tab and ran it in compatibility mode with windows 7 64 bit, (clicked apply and clicked ok and double checked to make sure the settings had 'stuck'). Then running the file I now have decent screen resolution.

NB With the catalyst centre during the the install I chose custom, and only the driver and the Microsoft Visual files, so deselected the catalyst control centre itself, (you can not deselect the control centre install manager, as I think that runs the installation process).

Anyway, display is now fixed. No idea if it will stay fixed with future Windows 10 updates or even on a reboot. Time will tell.

But thought I'd report back, as I've often been frustrated on forums when you don't get feedback on whether a fix worked or not. Maybe this will help some one else.
 
  • Like
Reactions: kensiko32

Tinger SAS

New member
Feb 21, 2020
1
0
I HAVE FOUND THE DRIVER!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!

PERFECT ON MOBILITY RADEON X1300 ON WINDOWS 10, AND FOR ALL OTHER MOBILE X SERIES IN MY OPINION!

Install with setup, custom install (remove all the ugly software, only driver and microsoft stuff)

Please post this on first page!

Link down, please can you upload it again
 

ronanronan

New member
Jun 9, 2020
1
0
X600 and Win10

Hey guys,

thanks for the post, but I can't seem to make it work.
I had no problems on Win7 64bit, ever since upgrading at work to Win10 64bit (pro) the potato X500/X600 Radeon doesn't want to install.

Does anyone have any insight? I've tried the hotfix, tried clean sweep of drivers and tried doing the hardware changes etc.
Any insight is appreciated - if it doesn't work, I'll roll back to Win7.

Did you ever find a solution?
 

jaskad

New member
Nov 10, 2008
3
0
I had x600 desktop card and win 10 x64 with last updates, install ATI Catalyst 12.11 B11 HotFix 11.09 V6 BETA, custom install, only microsoft and drivers (no hydravision, no avivo or such stuff) and installed without problem, replace basic driver and let me choose resolution.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 65
    UPDATE 23/10/2015
    By @Simonkjam
    NEW DRIVER !

    PERFECT ON MOBILITY RADEON X1300 ON WINDOWS 10, AND FOR ALL OTHER MOBILE X SERIES IN MY OPINION!

    DOWNLOAD HERE

    Install with setup, custom install (remove all the ugly software, only driver and microsoft stuff)

    Again,HUGE THANKS to @Simonkjam for this!

    ORIGINAL POST

    UPDATE 02/08/2015
    Thanks to @comhon for testing,this guide will work even for Windows 10

    Lets Begin :)

    REQUIREMENTS
    Windows 8/8.1/10
    One of those video cards:
    ATI Radeon 9500 Series
    ATI Radeon 9550 Series
    ATI Radeon 9600 Series
    ATI Radeon 9700 Series
    ATI Radeon 9800 Series
    ATI Radeon X300 Series
    ATI Radeon X550 Series
    ATI Radeon X600 Series
    ATI Radeon X700 Series
    ATI Radeon X800 Series
    ATI Radeon X850 Series
    ATI Radeon X1050 Series
    ATI Radeon X1300 Series
    ATI Radeon X1550 Series
    ATI Radeon X1600 Series
    ATI Radeon X1650 Series
    ATI Radeon X1800 Series
    ATI Radeon X1900 Series
    ATI Radeon Xpress Series
    ATI Radeon X1200 Series
    ATI Radeon X1250 Series
    ATI Radeon X2100 Series
    Drivers you can use :


    If you meet all requirements Let's Begin

    1.Download ATI Drivers from here:
    http://support.amd.com/us/gpudownload/windows/Legacy/Pages/radeonaiw_vista32.aspx

    2.Run Them,if Compatibility Check says "Cannot check compatibility" Just click on "more button" and Run Anyway

    3.Let Installer extract drivers,after that close the installer
    RfIWR.png


    4.Right Click on Computer-->Manage

    5.Search for VGA Controller/Card/generic VGA Adapter

    6.right click on the device-->Update Drivers

    7.Choose "Browse My computer for Drivers"
    oRYZS.png


    8.Select C:/ATI (Please Note:If you have other letter,it doesn't change nothing,just select ATI Folder on your HDD Root)

    9.Wait while it install Drivers

    10.Enjoy Windows 8/8.1/10,Lot Fast,Lot Smooth

    Hope this help,if you have any question or problem just reply :)
    4
    Hi guys

    Today i have installed ATI X1300 on Win8 64bit PRO

    I used those drivers http://www.touslesdrivers.com/index.php?v_page=23&v_code=28298&v_langue=en but i received info from windows:

    "Windows found driver software for your device but encountered an error while attempting to install it.

    The hash for the file is not present in the specified catalog file. The file is likely corrupt or the victim of tampering."

    To get it worked i need to Disable Driver Signature Enforcement in Windows 8

    I used this manual :)

    https://laslow.net/2012/03/14/disable-driver-signature-enforcement-in-windows-8/

    Good luck
    2
    Hi!Finally i discovered how to install ATI Old Cards in Windows 8!Even if it is not recognizing your Graphic Card

    Lets Begin :)

    REQUIREMENTS
    Windows 8 OS
    One of those video cards:

    Internet connection(not needed if you download drivers from another device/PC)

    If you meet all requirements Let's Begin



    Hope this help,if you have any question or problem just reply :)


    i Will upload screenshots later! :p

    does NOT work with my ATI Radeon x1300

    Regardless of how the drivers are installed it will always tell you that the driver is not designed for this version of windows and will default back to the generic windows display drivers.

    I am using windows 8 Pro build 9200
    Dell Inspiron E1505
    Ati Radeon X1300

    I can NOT stand this 1024X768

    Use http://www2.ati.com/drivers/12-8_vista_win7_win8_32_dd_ccc.exe

    the win 7 version worked for my Win 8
    2
    Works Here with ATI RADEON 4200 HD , But Can't get catalyst center to work .. any idea ?
    2
    Win8 pro on Alienware m5790 with Ati Radeon x1800

    [SOLVED] update:

    I downloaded several drivers, keep trying to find the good one for ati radeon x1800....and....here it is:
    http://www.touslesdrivers.com/index.php?v_page=23&v_code=28298&v_langue=en

    Please, for x1800 owners, use same method of first post but with these drivers!

    Now I've x1800 recognized by Win8 pro working on 2 monitors and 1920*1200 + 1920*1080 resolution,
    BUT,
    this solution didn't work for 64 bit! i had to install Win8 32 bit :(
    So cannot use sw made only for 64 bit pc like sony vegas 12, or CS5 premiere + aftereffects....