Guide how to unlock bricked MCU units

Search This thread

segu45

Senior Member
Jul 12, 2013
234
145
Vecindario
MTCD/E/P/H doesn't matter PX5 or PX6, OTG is same
I'm helping him, the problem is that he installed a different mcu than dasaita and the screen stayed that way. He has an internal card from which a ROM.img can be installed. The problem is that you cannot enter the recovery when you have installed a mcu.img from another distributor, you do not remember where it was downloaded from. We are looking to know where the holes are to be able to put the mcu with this system, the board is a HA 06100 with version of 08/20/2020. I have to see if they are your system by otg you can install the mcu.img, we will continue investigating.
 

Attachments

  • IMG_20211003_110011402.jpg
    IMG_20211003_110011402.jpg
    3.7 MB · Views: 26
  • IMG_20211003_105859923.jpg
    IMG_20211003_105859923.jpg
    3.1 MB · Views: 25
  • Like
Reactions: marchnz

rudyboler

Member
Jun 15, 2018
25
0
Well gentlemen, I just disassembled the px6 board, I removed the motherboard and I think I have seen the five holes that you see in the first post in the middle of the board you can see them, if you can confirm that they are those, and the The problem I have is that they are not identified, how can I know which one is, with the multimeter ????? Thank you. I leave you these photos
 

Attachments

  • IMG-20211003-WA0007.jpg
    IMG-20211003-WA0007.jpg
    362 KB · Views: 36
  • IMG-20211003-WA0006.jpg
    IMG-20211003-WA0006.jpg
    182.1 KB · Views: 35

mrjuniork

Forum Moderator
Staff member
Aug 29, 2015
1,484
2,727
OnePlus 9 Pro
@selimkelim
I have deleted your last two posts, since there almost impossible to translate.
I urge you to re-post that information and question of your, but most importantly, do so in the English language!
This is an international forum and English is the only accepted language for interacting within this great community.
Thanks for your understanding.

4. Use the English language.

We understand that with all the different nationalities, not everyone speaks English well, but please try. If you're really unable to post in English, use an online translator. You're free to include your original message in your own language, below the English translation. (This rule covers your posts, profile entries and signature). You could try :- https://translate.google.com/ or https://www.babelfish.com/ or use one of your choice.
 

selimkelim

Member
Nov 4, 2020
8
1
hello xda team I don't get any help from you half because I have turkish and written in German I wanted to change in English my erisin es8991v I also want to get fit for need your help. I accidentally installed falche mcu i now have stlink prepared soldered now need your help. so i ask for help from team xda forum. if I did something wrong, I owe myself to the team.
 

selimkelim

Member
Nov 4, 2020
8
1
hello a question with st link have mcu wrong bin file instaliert i can't get stlink to connect the chip anymore
I can't get a connection to the chip
 
  • Like
Reactions: marchnz

selimkelim

Member
Nov 4, 2020
8
1
hello, good evening, please convert a dcmu gs version 2.78 to recovery.bin. I have problems converting with win 7, 10, 11 with which windows are you doing with me is always an error that looks like this
mtcdmcutool.exe -r dmcu.img recovery.bin
Error in reading a file. Something gone wrong !!!
thank you
 

arnaud.xda

New member
Oct 31, 2014
2
0
Hello,
I think my PX6 is bricked (wrong MCU).
The screen is black with random white lines.
No LED, nothing work. Touch keys seem to work.
It reboot every 4/6 seconds.
screen.png


I have to buy ST-LINK V2 ( https://www.ebay.fr/itm/275052127795 )

Now, I want to know the connections on the motherboard (SYS_SWCLK,SYS_SWDIO,+3.3V,GND), how to identify them in the photo?

And after, between motherboard and USB programmer :
SYS_SWCLK <--> SYS_SWCLK
SYS_SWDIO <--> SYS_SWDIO
+3.3V <--> +3.3V
GND <--> GND
It's correct ?

Thanks all !
px6 motherboard.png
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 12
    I am not responsible for anything that may happen to your unit by flashing the recovery image.
    You do it at your own risk and take the responsibility upon yourself.


    Edit 20.05.2018
    Updated mtcdmcutool to preapre FULL recovery image (Now after flash recovery image is possible to future update to newer/other version using the standard dmcu.img upload procedure :victory:)

    Before you start you must know what is MCU and what is bricked MCU (this is not the same what bricked SOM: "my Android do not want boot", "my unit stucked at bootlogo" ...)

    What you need:

    Steps:
    • install ST-LINK utility on your PC
    • find pins on your board: SYS_SWCLK,SYS_SWDIO,+3.3V,GND. Some boards has special pinpads for that:
      board.jpg

      board2.jpg

      board3.jpg
    • connect appropriate wires to ST-LINK/V2 programmer and board
    • prepare recovery.bin using tool:
      Code:
      mtcdmcutool.exe -r dmcu.img recovery.bin
    • in ST-LINK utility connect to MCU. Should be identified as: STM32F091xB-xC
    • erase MCU (Target->erase chip)
    • program/flash file recovery.bin [Start address = 0x08000000]




    There is another method to flash MCU.
    Instead of ST-LINK/V2 programmer, it is possible to use TTL USBtoUART converter. But it requires a little bit more hardware modification. Maybe @Kayhan 17# will write some guide how to prepare and flash MCU. He did it already here

    RemmeberThis is not FULL MCU firmware image. So you will not be able to change the MCU firmware to newer/other version using the standard dmcu.img upload procedure. If you want a newer version you must repeat flash MCU according to steps above
    3
    @Wadzio, You are amazing, really great. Your help is successful.

    ST Link clue is, connect the main power suply when connecting with PC, can not use power supply from USB.

    and managed to write MCU.

    restart and upadate the firmware image.

    Thank you very much, without you I will be confused.

    greetings from Indonesia :good::good::good::good::good:
    2
    That explains everything, hahaha. The unit came with a PX3, I installed Malaysk and it was working for a week, after I rebooted it one day it never turn on again. The seller sent me another PX3 board as warranty and it worked for 3 months, then it stop working suddenly one day when I turned on the car.
    So then I bought a PX5 board, it worked for 6 months. One day I was driving using only Play Music app and the stereo froze, I turned off the car but the unit did not work again, so I removed it I re installed the original unit. Then after 4 months later I tried to fix it using a PSU but in the moment that I turned it on, the headunit boot and worked normally, I was happy and reinstalled it into my car, but it just worked for a few days. It stopped working when I turned on the car and it was on reverse gear, when I change to first gear the screen flashed and that's it (switch between camera and the main screen).
    Sorry for the long story.

    Where are you? To see how much is to send it. I can send it from the US.

    Thank you!

    New Zealand. It sounds like it has a bad connection, or dry solder joint.
    2
    I assume this is only for MTXX MCU?

    I have this unit

    Yes, thats why the thread is in the MTCD section.
    2
    @Wadzio. I was amazed to find this thread, hopefully can fix my PX5, the order of pins in my image is correct?

    Yes, those that pads but you wrong mark signlas. Look at the schematic:
    2018_02_20_21h43_33.png


    For me should be:
    2018_02_20_22h00_45.png

    But the surest solution is to check the connection between the pads and CPU pins (according to the scheme of course)