[Guide] Installing Blu_spark TWRP | Magisk 20.1 On Stable Oxygen OS 10

Search This thread

dynamode

Member
Oct 12, 2011
40
43
Hi there just incase someone else who had problems [like me]
who is hesitant or looking for a guide on how to install Blu_Spark TWRP and Root the device.
The guide below will work 99.9% of the time. just follow the instructions carefully

Necessary Files:
Install OnePlus 6 Driver
Install Fastboot Drivers
TWRP Image
Magisk 20.1
twrp-3.3.1-x_blu_spark_v9.107_op6
Stock boot image thanks [URL="https://forum.xda-developers.com/member.php?u=6994095" @Akhil701[/URL]



Step 1: [dont do this if you have installed ADB and Fastboot already]
Install Oneplus 6, ADB and Fastboot Drivers from the link above
* Reboot PC after installing

Step 2:
Put
Code:
Stock Boot Image [boot.img]
twrp-3.3.1-x_blu_spark_v9.107_op6.zip and
Magisk-v20.1.zip

on your internal storage

Also Put

Code:
twrp-3.3.1-11-enchilada-Q-mauronofrio.img

on your desktop

Step 3: Reboot device in fastboot/bootloader mode
Step 4: Connect Device to PC Via USB Cable
Step 5: On your desktop Press Shift Right Click then click the [Open Command Prompt Here]
Step 6: on the CMD Windows Type

Code:
fastboot devices

Press enter and see if your device shows up.

Step 7: type in the CMD Window

Code:
fastboot flash boot twrp-3.3.1-11-enchilada-Q-mauronofrio.img

press enter then after that on your phone screen use volume up or down button to reboot to recovery

Step 8:
Once you have the TWRP Screen

flash the stock boot image [boot.img] in boot partition [DO NOT Reboot!]

now go back and flash the Blu_Spark TWRP and then reboot to recovery

Step 9: Rooting

Flash Magisk 20.1.zip then reboot to system.

Thats it! no data will be wiped as long as your bootloader is already unlocked.

thanks to

@Funk Wizard for the initial instruction on how to install twrp and root
@eng.stk for the Blu_Spark TWRP
@mauronofrio for the initial TWRP Image
@Akhil701 for the stock boot.img
@remewer for inspiration to build this guide.
 

Nemesco

Senior Member
Nov 15, 2007
161
41
Thnx, this was a very easy walkthrough.
Only thing I want to say is that not everyone knows how to flash the 'boot.img' through TWRP. Maybe you can explain that in more detail.
 

jabs

Member
Feb 9, 2008
30
10
Hrebec
no patched boot.img you need
1. connect your OP6 to PC
2. flash TWRP (from mauronofrio) by fastboot from PC
3. reboot from fastboot to recovery
4. in TWRP flash stock img OOS, don´t reboot
5. in TWRP flash TWRP (blu_spark 9.107)
6- reboot to TWRP to another slot
7. in TWRP flash Magisk 20.1
8. reboot to system
 
  • Like
Reactions: hurray and dynaguy1

lukypuie

Senior Member
Mar 10, 2014
169
22
Ancona
I have noticed this too, probably they have changed somehow the system, even fastboot boot doesn't work anymore....

I had to install magisk via boot.img patching
 

Brisky86

Member
Sep 28, 2013
40
10
So I was unable to flash the new OTA through twrp running on my rooted OP6.
As such, I opted to install the new OTA through the "local install" option.
That worked great. Settings area all the same. Bootloader still unlocked (I double checked).

Drivers are all installed on my Windows 10 PC.

However, no matter what I attempt to flash from command prompt I always get:
FAILED (remote: unkown command)

Does anyone know of a solution yet?
I have been reinstalling drivers and rebooting my PC with no luck thus far.

Any ideas?
Thanks in advance.

Update:
Whelp now that it is upgraded to Android 10 (and was wiped of all data when I locked and then unlocked the bootloader again) it will not allow me to downgrade back to Andriod 9 through the local upgrade option and since I can not get fastboot to accept any commands I am stuck now in Andriod 10 without the ability to change anything at the moment. :(
 
Last edited:

magnamentis

Senior Member
Jul 30, 2013
8,682
8,621
Al-Ándalus
magnamentis.com
So I was unable to flash the new OTA through twrp running on my rooted OP6.
As such, I opted to install the new OTA through the "local install" option.
That worked great. Settings area all the same. Bootloader still unlocked (I double checked).

Drivers are all installed on my Windows 10 PC.

However, no matter what I attempt to flash from command prompt I always get:
FAILED (remote: unkown command)

Does anyone know of a solution yet?
I have been reinstalling drivers and rebooting my PC with no luck thus far.

Any ideas?
Thanks in advance.

Update:
Whelp now that it is upgraded to Android 10 (and was wiped of all data when I locked and then unlocked the bootloader again) it will not allow me to downgrade back to Andriod 9 through the local upgrade option and since I can not get fastboot to accept any commands I am stuck now in Andriod 10 without the ability to change anything at the moment. :(

i knew it while reading but thanks to the screenshot you provided you saved me from sounding "user error" once again and piss of so many who prefer to blame things and others LOL

in short, wrong command, it's fastboot flash boot <image name>

BTW and since i'm already at it, if anyone has a Mac runniing 10.15 "Catalina" and fastboot is working from terminal, i'd like to learn how he/she's done it ;) ;)

just came to my mind to ask here since i have to use windows 10 under parallels desktop to fastboot flash my android stuff at the moment and of course that's just an "Emergency" choice for me, everyone using both platforms will understand ;) ;) :D
 
Last edited:
  • Like
Reactions: Brisky86

Brisky86

Member
Sep 28, 2013
40
10
i knew it while reading but thanks to the screenshot you provided you saved me from sounding "user error" once again and piss of so many who prefer to blame things and others LOL

in short, wrong command, it's fastboot flash boot <image name>

BTW and since i'm already at it, if anyone has a Mac runniing 10.15 "Catalina" and fastboot is working from terminal, i'd like to learn how he/she's done it ;) ;)

just came to my mind to ask here since i have to use windows 10 under parallels desktop to fastboot flash my android stuff at the moment and of course that's just an "Emergency" choice for me, everyone using both platforms will understand ;) ;) :D

Wow. Okay.
This is becoming a comedy of errors on my part.

Oh boy now I am getting Qualcom flashdump messages...
Huh now it is just booting normal but not letting me get into the new recovery flash...
I got it all fixed.
Thank you everyone for your help and patience with my posts.
 
Last edited:

thejase

Senior Member
Jan 29, 2012
529
119
Does 10.0.1 still have the ability to do screen-off gestures for music? I like 10 but on my wife's 7t, either she didn't turn them on, our it didn't have them so I'm curious if there same thing is happening with this? I also noticed on her 7t, constant data problems when's switching from WiFi to data. Sometimes data won't come back and only a reboot solves. I know it's a bug on OOS 10 on 7t but wondering if it's a device specific bug or an Android 10 bug? Anyone having op6 issues with data not coming back when switching from WiFi?
 

Mefisto80

Member
Dec 19, 2011
22
12
Leipzig LE
WIFI problem solved!

Below OOS 10.0.1 back inTWRP
Wipe: cache, system and vendor
Flash OOS 10
Flash boot img
Flash TWRP
Flash Magisk
Reboot system
Reboot recovery
Flash OOS 10.0.1
Flash boot img
Flash TWRP
Flash Magisk
Reboot system

Wifi works
 
  • Like
Reactions: hurray

Coktail

Senior Member
Jan 12, 2008
130
2
Hello Mates,

i updated my rooted oneplus 6 from 10 to 10.01 and after that use this method to root again. But there is a Problem now: My WiFi doesnt work? I cant activate it.
Do anybody know how i can fix that Problem?

Thank you in Advance
Best Regards

Coktail
 

loggstar

New member
Dec 20, 2019
1
2
Hi guys, sorry to resurrect this thread. I did everything in the correct order using 10.0.3.0 and after step 8 (reboot after flashing blu_spark) my phone gets stuck on blu_spark splash screen without any option to boot into twrp. Normal boot results in bootloop... Any ideas? Do I need to use different versions of twrp.img and .zip?
 

swords90

Senior Member
Dec 14, 2012
81
28
Hi there just incase someone else who had problems [like me]
who is hesitant or looking for a guide on how to install Blu_Spark TWRP and Root the device.
The guide below will work 99.9% of the time. just follow the instructions carefully

@Funk Wizard for the initial instruction on how to install twrp and root
@eng.stk for the Blu_Spark TWRP
@mauronofrio for the initial TWRP Image
@Akhil701 for the stock boot.img
@remewer for inspiration to build this guide.

Hello.
I´m on 10.3.0 op6, I followed all the steps and when i finish the step 8 and reboot, i stuck on the recovery message. I repeat all the steps flashing clean rom and always have the same problem.....
Can someone help me? Because i don´t know another way for installing magisc....
Thanks!!!
 
Last edited:
  • Like
Reactions: pjotrski1000

pjotrski1000

Member
Jan 28, 2014
45
14
OnePlus X
OnePlus 6
Hi guys, sorry to resurrect this thread. I did everything in the correct order using 10.0.3.0 and after step 8 (reboot after flashing blu_spark) my phone gets stuck on blu_spark splash screen without any option to boot into twrp. Normal boot results in bootloop... Any ideas? Do I need to use different versions of twrp.img and .zip?

I am in exactly the same position here.
Followed all the steps and am now stuck on the blu_spark boot screen for the past 15 minutes
 
  • Like
Reactions: swords90

Top Liked Posts

  • There are no posts matching your filters.
  • 12
    Hi there just incase someone else who had problems [like me]
    who is hesitant or looking for a guide on how to install Blu_Spark TWRP and Root the device.
    The guide below will work 99.9% of the time. just follow the instructions carefully

    Necessary Files:
    Install OnePlus 6 Driver
    Install Fastboot Drivers
    TWRP Image
    Magisk 20.1
    twrp-3.3.1-x_blu_spark_v9.107_op6
    Stock boot image thanks [URL="https://forum.xda-developers.com/member.php?u=6994095" @Akhil701[/URL]



    Step 1: [dont do this if you have installed ADB and Fastboot already]
    Install Oneplus 6, ADB and Fastboot Drivers from the link above
    * Reboot PC after installing

    Step 2:
    Put
    Code:
    Stock Boot Image [boot.img]
    twrp-3.3.1-x_blu_spark_v9.107_op6.zip and
    Magisk-v20.1.zip

    on your internal storage

    Also Put

    Code:
    twrp-3.3.1-11-enchilada-Q-mauronofrio.img

    on your desktop

    Step 3: Reboot device in fastboot/bootloader mode
    Step 4: Connect Device to PC Via USB Cable
    Step 5: On your desktop Press Shift Right Click then click the [Open Command Prompt Here]
    Step 6: on the CMD Windows Type

    Code:
    fastboot devices

    Press enter and see if your device shows up.

    Step 7: type in the CMD Window

    Code:
    fastboot flash boot twrp-3.3.1-11-enchilada-Q-mauronofrio.img

    press enter then after that on your phone screen use volume up or down button to reboot to recovery

    Step 8:
    Once you have the TWRP Screen

    flash the stock boot image [boot.img] in boot partition [DO NOT Reboot!]

    now go back and flash the Blu_Spark TWRP and then reboot to recovery

    Step 9: Rooting

    Flash Magisk 20.1.zip then reboot to system.

    Thats it! no data will be wiped as long as your bootloader is already unlocked.

    thanks to

    @Funk Wizard for the initial instruction on how to install twrp and root
    @eng.stk for the Blu_Spark TWRP
    @mauronofrio for the initial TWRP Image
    @Akhil701 for the stock boot.img
    @remewer for inspiration to build this guide.
    3
    Has anyone been able to get twrp to stick without breaking their system with magisk on 10.3.0?
    The best I've been able to do is this:
    https://forum.xda-developers.com/showpost.php?p=81313297&postcount=12

    ---------- Post added at 01:19 AM ---------- Previous post was at 01:08 AM ----------

    Hi guys, sorry to resurrect this thread. I did everything in the correct order using 10.0.3.0 and after step 8 (reboot after flashing blu_spark) my phone gets stuck on blu_spark splash screen without any option to boot into twrp. Normal boot results in bootloop... Any ideas? Do I need to use different versions of twrp.img and .zip?

    Hello.
    I´m on 10.3.0 op6, I followed all the steps and when i finish the step 8 and reboot, i stuck on the recovery message. I repeat all the steps flashing clean rom and always have the same problem.....
    Can someone help me? Because i don´t know another way for installing magisc....
    Thanks!!!

    I am in exactly the same position here.
    Followed all the steps and am now stuck on the blu_spark boot screen for the past 15 minutes

    Hey man i was able to boot into twrp from fastboot and restored my pervious 10.0.2
    I can tell this update ducked something and i cant root anymore without bootloop :/

    Had the same issue. Managed to fix it after a whole night of bricking and restoring my phone lmao. Issue seems to be cause by having twrp on your phone, but fixed by flashing your rom's stock boot.img to both slots a and b. So you will lose twrp the next time you boot into recovery, you need to flash magisk and optionally any kernel if you want one before booting out of your recovery in slot b after you've flashed that boot image to slot a then slot b (make sure to do slot a before b so you can still install magisk and custom kernel if you want one before you lose twrp). This all might sound a little confusing so I wrote instructions below.

    Here's what worked for me after a ton of testing to get OOS 10.3.0 stable + magisk + blu_spark r112 kernel (kernel is optional) working. Give the following a try.

    Method A - If you already have twrp
    Boot recovery into slot a, flash your rom's stock boot.img, then boot into your recovery in slot b (dont boot into slot a recovery because slot a wont have twrp anymore), flash your rom's stock boot.img, magisk and (optional) your kernel of choice (or not) in that order, then you can boot boot into system. That's it.
    Method B - If you don't have twrp
    Boot into fastboot, and from your cmd/terminal run fastboot flash boot yourtwrp.img (I suggest Mauronofrio's twrp-3.3.1-16-enchilada-Q-mauronofrio.img or newer). Use your volume buttons to select boot into recovery. Make sure your active slot is B, (if it isnt, install twrp (bluspark and Mauronofrio's twrp both work great) by zip, then follow the steps above in method A). Once you've verified you're in slot B flash your rom's stock boot.img, magisk and (optional) your kernel of choice (or not) in that order, then you can boot into system. That's it.

    Useful links:
    Stock 10.3.0 boot.img https://drive.google.com/file/d/1w44cUg815g-H1h_6gObUVPLDTc_dtiMX/view
    blu_spark twrp https://github.com/engstk/android_device_oneplus_enchilada/releases
    Mauronofrio's twrp images and installers https://forum.xda-developers.com/on...overy-unofficial-twrp-touch-recovery-t3860815

    Hopefully @mauronofrio or @eng.stk can clue us in on why magisk or twrp bricks the system if you install them together in OOS 10.
    2
    no patched boot.img you need
    1. connect your OP6 to PC
    2. flash TWRP (from mauronofrio) by fastboot from PC
    3. reboot from fastboot to recovery
    4. in TWRP flash stock img OOS, don´t reboot
    5. in TWRP flash TWRP (blu_spark 9.107)
    6- reboot to TWRP to another slot
    7. in TWRP flash Magisk 20.1
    8. reboot to system
    2
    Hi guys, sorry to resurrect this thread. I did everything in the correct order using 10.0.3.0 and after step 8 (reboot after flashing blu_spark) my phone gets stuck on blu_spark splash screen without any option to boot into twrp. Normal boot results in bootloop... Any ideas? Do I need to use different versions of twrp.img and .zip?
    1
    So I was unable to flash the new OTA through twrp running on my rooted OP6.
    As such, I opted to install the new OTA through the "local install" option.
    That worked great. Settings area all the same. Bootloader still unlocked (I double checked).

    Drivers are all installed on my Windows 10 PC.

    However, no matter what I attempt to flash from command prompt I always get:
    FAILED (remote: unkown command)

    Does anyone know of a solution yet?
    I have been reinstalling drivers and rebooting my PC with no luck thus far.

    Any ideas?
    Thanks in advance.

    Update:
    Whelp now that it is upgraded to Android 10 (and was wiped of all data when I locked and then unlocked the bootloader again) it will not allow me to downgrade back to Andriod 9 through the local upgrade option and since I can not get fastboot to accept any commands I am stuck now in Andriod 10 without the ability to change anything at the moment. :(

    i knew it while reading but thanks to the screenshot you provided you saved me from sounding "user error" once again and piss of so many who prefer to blame things and others LOL

    in short, wrong command, it's fastboot flash boot <image name>

    BTW and since i'm already at it, if anyone has a Mac runniing 10.15 "Catalina" and fastboot is working from terminal, i'd like to learn how he/she's done it ;) ;)

    just came to my mind to ask here since i have to use windows 10 under parallels desktop to fastboot flash my android stuff at the moment and of course that's just an "Emergency" choice for me, everyone using both platforms will understand ;) ;) :D
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone