• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Guide] Installing Blu_spark TWRP | Magisk 20.1 On Stable Oxygen OS 10

Search This thread

lemon07r

Senior Member
Apr 8, 2013
134
68
Has anyone been able to get twrp to stick without breaking their system with magisk on 10.3.0?
The best I've been able to do is this:
https://forum.xda-developers.com/showpost.php?p=81313297&postcount=12

---------- Post added at 01:19 AM ---------- Previous post was at 01:08 AM ----------

Hi guys, sorry to resurrect this thread. I did everything in the correct order using 10.0.3.0 and after step 8 (reboot after flashing blu_spark) my phone gets stuck on blu_spark splash screen without any option to boot into twrp. Normal boot results in bootloop... Any ideas? Do I need to use different versions of twrp.img and .zip?

Hello.
I´m on 10.3.0 op6, I followed all the steps and when i finish the step 8 and reboot, i stuck on the recovery message. I repeat all the steps flashing clean rom and always have the same problem.....
Can someone help me? Because i don´t know another way for installing magisc....
Thanks!!!

I am in exactly the same position here.
Followed all the steps and am now stuck on the blu_spark boot screen for the past 15 minutes

Hey man i was able to boot into twrp from fastboot and restored my pervious 10.0.2
I can tell this update ducked something and i cant root anymore without bootloop :/

Had the same issue. Managed to fix it after a whole night of bricking and restoring my phone lmao. Issue seems to be cause by having twrp on your phone, but fixed by flashing your rom's stock boot.img to both slots a and b. So you will lose twrp the next time you boot into recovery, you need to flash magisk and optionally any kernel if you want one before booting out of your recovery in slot b after you've flashed that boot image to slot a then slot b (make sure to do slot a before b so you can still install magisk and custom kernel if you want one before you lose twrp). This all might sound a little confusing so I wrote instructions below.

Here's what worked for me after a ton of testing to get OOS 10.3.0 stable + magisk + blu_spark r112 kernel (kernel is optional) working. Give the following a try.

Method A - If you already have twrp
Boot recovery into slot a, flash your rom's stock boot.img, then boot into your recovery in slot b (dont boot into slot a recovery because slot a wont have twrp anymore), flash your rom's stock boot.img, magisk and (optional) your kernel of choice (or not) in that order, then you can boot boot into system. That's it.
Method B - If you don't have twrp
Boot into fastboot, and from your cmd/terminal run fastboot flash boot yourtwrp.img (I suggest Mauronofrio's twrp-3.3.1-16-enchilada-Q-mauronofrio.img or newer). Use your volume buttons to select boot into recovery. Make sure your active slot is B, (if it isnt, install twrp (bluspark and Mauronofrio's twrp both work great) by zip, then follow the steps above in method A). Once you've verified you're in slot B flash your rom's stock boot.img, magisk and (optional) your kernel of choice (or not) in that order, then you can boot into system. That's it.

Useful links:
Stock 10.3.0 boot.img https://drive.google.com/file/d/1w44cUg815g-H1h_6gObUVPLDTc_dtiMX/view
blu_spark twrp https://github.com/engstk/android_device_oneplus_enchilada/releases
Mauronofrio's twrp images and installers https://forum.xda-developers.com/on...overy-unofficial-twrp-touch-recovery-t3860815

Hopefully @mauronofrio or @eng.stk can clue us in on why magisk or twrp bricks the system if you install them together in OOS 10.
 
Last edited:

KuBi4K

Member
Jan 20, 2013
12
3
Lille
Hi,

I have some trouble here

I did the fastboot flash boot twrp-3.3.1-11-enchilada-Q-mauronofrio.img thing

Then I went into recovery, flash the boot.img

Then I installed the TWRP zip

Aaaaand.... nothing.


My phone is stuck on the start up screen (where it says "your phone is unlocked blablabla) and doesn't go further.
If I force it to Recovery, I can see the TWRP start screen but also, it won't load anything.

Could you check if I'm OK with the procedure ?

1 - In Fastboot mode, load fastboot flash boot twrp-3.3.1-11-enchilada-Q-mauronofrio.img
2 - Reboot in recovery mode
3 - flash the stock boot image [boot.img] in boot partition
4 - Go back and flash the Blu_Spark TWRP => Here, do you mean the blu_Spark TWRP IMG or ZIP ?
5 - reboot to recovery
6 - Flash Magisk 20.1.zip

Is there a way I can set everything back to stock so I can use my phone, and redo the whole thing later ?

Thanks
 

Colka

New member
May 30, 2017
2
0
thank you for bricking my phone, everything worked up until i flashed the recovery and was unable to flash the image due to my files being encrypted in twrp for whatever reason leaving me no other option but to restart and have twrp as my system, awesome
 

cbarai

Senior Member
Apr 10, 2011
138
45
Glasgow
OnePlus One
OnePlus 6
Step 4 - Flash the TWRP zip from within twrp, it is an installer zip it will install TWRP.
Just to confirm, on step 2 you say reboot to recovery, that is part of step 1 when you issue the fastboot command it will load twrp you shouldnt need to reboot to recovery again until after you flash TWRP.
Also you can skip step 3, you do that if you have installed TWRP or magisk previously only. The reason to do this is clean the existing setup and start a fresh. If you are just trying to install TWRP from stock you skip step 3 (flash stock boot img).

To restore to stock, you can follow either of the below

1. Flash the stock boot.img (appropriate to the OS you are using, sometimes best to extract it from within the OS full download file). You would normally do this from within TWRP or fastboot command.

2. Flash the stock OS full zip on top of the current setup, you can do this from within TWRP or using adb. If you are having success using the temporary TWRP image then you can use that to flash the full image from within there. You can mount storage from within TWRP and copy the file over if needed or use adb push command to move full OS zip file over to the phone from a PC.

3. If you are able to boot into the OS, you can run the OTA updater (which will force a full download due to root) or you can use the local update option from the options menu ( use this if you have manually downloaded the full OS zip).

Whatever you choose to do, if you are going to reflash the stock OS again then please ensure you use the full update and not the OTA update. The full os is about 1.6gig compared to 100-500meg OTA.


Hi,

I have some trouble here

I did the fastboot flash boot twrp-3.3.1-11-enchilada-Q-mauronofrio.img thing

Then I went into recovery, flash the boot.img

Then I installed the TWRP zip

Aaaaand.... nothing.


My phone is stuck on the start up screen (where it says "your phone is unlocked blablabla) and doesn't go further.
If I force it to Recovery, I can see the TWRP start screen but also, it won't load anything.

Could you check if I'm OK with the procedure ?

1 - In Fastboot mode, load fastboot flash boot twrp-3.3.1-11-enchilada-Q-mauronofrio.img
2 - Reboot in recovery mode
3 - flash the stock boot image [boot.img] in boot partition
4 - Go back and flash the Blu_Spark TWRP => Here, do you mean the blu_Spark TWRP IMG or ZIP ?
5 - reboot to recovery
6 - Flash Magisk 20.1.zip

Is there a way I can set everything back to stock so I can use my phone, and redo the whole thing later ?

Thanks
 
Last edited:

dynaguy1

Member
Sep 1, 2009
15
0
Last night I update my Oneplus 6 to 10.3.1 and I lost TWRP and root so I need some help.

Before the update the phone is running 10.3.0 and it is unlocked, blu_spark TWRP installed, and rooted. I booted up the phone to TWRP and flashed the full OTA image(OnePlus6Oxygen_22_OTA_043_all_2001151909_f33d538998.zip). Then tried to install the blu_spark TWRP. Here I was in trouble to install the TWRP. See attached screenshot. Tried multiple time and still failed to install it. So I had to let the phone reboot. Fortunately it boot into the updated 10.3.1 and the phone is working. Then I tried to reboot the phone to recovery and it seems that the TWRP is not exist any more. I can still boot into the fastboot.

Then I came here looking for some help and read this post. So I'd like to know how to reinstall the TWRP and then root my phone again. My plan is following OP's instruction to
1. sideload the TWRP image(twrp-3.3.1-17-enchilada-Q-mauronofrio.img), then boot to recovery mode
2. In recovery, flash the boot.img
3. without reboot install the TWRP zip (twrp-3.3.1-17-enchilada-installer-mauronofrio.zip)
4. Reboot to recovery, install Magisk (Magisk-v20.3.zip)

Is my above steps safe? Will the stock boot.img (downloaded from OP's link) works for the new 10.3.1?

Thank you for help.
 

Attachments

  • Screenshot_2020-02-07-22-09-39.png
    Screenshot_2020-02-07-22-09-39.png
    134.1 KB · Views: 205

dynaguy1

Member
Sep 1, 2009
15
0
Last night I update my Oneplus 6 to 10.3.1 and I lost TWRP and root so I need some help.

Before the update the phone is running 10.3.0 and it is unlocked, blu_spark TWRP installed, and rooted. I booted up the phone to TWRP and flashed the full OTA image(OnePlus6Oxygen_22_OTA_043_all_2001151909_f33d538998.zip). Then tried to install the blu_spark TWRP. Here I was in trouble to install the TWRP. See attached screenshot. Tried multiple time and still failed to install it. So I had to let the phone reboot. Fortunately it boot into the updated 10.3.1 and the phone is working. Then I tried to reboot the phone to recovery and it seems that the TWRP is not exist any more. I can still boot into the fastboot.

Then I came here looking for some help and read this post. So I'd like to know how to reinstall the TWRP and then root my phone again. My plan is following OP's instruction to
1. sideload the TWRP image(twrp-3.3.1-17-enchilada-Q-mauronofrio.img), then boot to recovery mode
2. In recovery, flash the boot.img
3. without reboot install the TWRP zip (twrp-3.3.1-17-enchilada-installer-mauronofrio.zip)
4. Reboot to recovery, install Magisk (Magisk-v20.3.zip)

Is my above steps safe? Will the stock boot.img (downloaded from OP's link) works for the new 10.3.1?

Thank you for help.

UPDATE:
@jabs post worked for me. Now everything is good.
 

Sepero

Senior Member
Dec 11, 2012
102
45
BEWARE
I wiped my phone 100%. I did all the steps, and everything *Seemed* to work out correctly. I finished setting up the phone, and internal storage is inaccessible. File manager reports "Can't load content at the moment". Doing a factory wipe again results in a *Recovery Loop*. Reinstalling OOS 10.3.2 fresh, and following the procedures again, gives the same results- Internal Storage Inaccessible.

An important point to note here is this- If you have TWRP+Magisk(v20.4) installed on OOS 10 (10.3.2), And Wipe your data, Then you will end up in a Recovery Loop.

I may be able to resolve this by booting into the OS once, and setting things up, before installing TWRP+Magisk. I will test it out and report back.
 
Last edited:

slicer2k

Member
Feb 10, 2015
39
2
Guys i have magisk 23 and installed new ota OOS 11.xx. using the new slot option inside magisk.

Got stuck in bootloop, i don't have twrp, but i'm trying to install all sorts of versions of twrp using fastboot but gives me an error like "qualcomm crashdump"

any advice on it, or i won't be able to use twrp in this version of OOS?


nevermind, fixed the bootloop just using this boot.img

 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 12
    Hi there just incase someone else who had problems [like me]
    who is hesitant or looking for a guide on how to install Blu_Spark TWRP and Root the device.
    The guide below will work 99.9% of the time. just follow the instructions carefully

    Necessary Files:
    Install OnePlus 6 Driver
    Install Fastboot Drivers
    TWRP Image
    Magisk 20.1
    twrp-3.3.1-x_blu_spark_v9.107_op6
    Stock boot image thanks [URL="https://forum.xda-developers.com/member.php?u=6994095" @Akhil701[/URL]



    Step 1: [dont do this if you have installed ADB and Fastboot already]
    Install Oneplus 6, ADB and Fastboot Drivers from the link above
    * Reboot PC after installing

    Step 2:
    Put
    Code:
    Stock Boot Image [boot.img]
    twrp-3.3.1-x_blu_spark_v9.107_op6.zip and
    Magisk-v20.1.zip

    on your internal storage

    Also Put

    Code:
    twrp-3.3.1-11-enchilada-Q-mauronofrio.img

    on your desktop

    Step 3: Reboot device in fastboot/bootloader mode
    Step 4: Connect Device to PC Via USB Cable
    Step 5: On your desktop Press Shift Right Click then click the [Open Command Prompt Here]
    Step 6: on the CMD Windows Type

    Code:
    fastboot devices

    Press enter and see if your device shows up.

    Step 7: type in the CMD Window

    Code:
    fastboot flash boot twrp-3.3.1-11-enchilada-Q-mauronofrio.img

    press enter then after that on your phone screen use volume up or down button to reboot to recovery

    Step 8:
    Once you have the TWRP Screen

    flash the stock boot image [boot.img] in boot partition [DO NOT Reboot!]

    now go back and flash the Blu_Spark TWRP and then reboot to recovery

    Step 9: Rooting

    Flash Magisk 20.1.zip then reboot to system.

    Thats it! no data will be wiped as long as your bootloader is already unlocked.

    thanks to

    @Funk Wizard for the initial instruction on how to install twrp and root
    @eng.stk for the Blu_Spark TWRP
    @mauronofrio for the initial TWRP Image
    @Akhil701 for the stock boot.img
    @remewer for inspiration to build this guide.
    3
    Has anyone been able to get twrp to stick without breaking their system with magisk on 10.3.0?
    The best I've been able to do is this:
    https://forum.xda-developers.com/showpost.php?p=81313297&postcount=12

    ---------- Post added at 01:19 AM ---------- Previous post was at 01:08 AM ----------

    Hi guys, sorry to resurrect this thread. I did everything in the correct order using 10.0.3.0 and after step 8 (reboot after flashing blu_spark) my phone gets stuck on blu_spark splash screen without any option to boot into twrp. Normal boot results in bootloop... Any ideas? Do I need to use different versions of twrp.img and .zip?

    Hello.
    I´m on 10.3.0 op6, I followed all the steps and when i finish the step 8 and reboot, i stuck on the recovery message. I repeat all the steps flashing clean rom and always have the same problem.....
    Can someone help me? Because i don´t know another way for installing magisc....
    Thanks!!!

    I am in exactly the same position here.
    Followed all the steps and am now stuck on the blu_spark boot screen for the past 15 minutes

    Hey man i was able to boot into twrp from fastboot and restored my pervious 10.0.2
    I can tell this update ducked something and i cant root anymore without bootloop :/

    Had the same issue. Managed to fix it after a whole night of bricking and restoring my phone lmao. Issue seems to be cause by having twrp on your phone, but fixed by flashing your rom's stock boot.img to both slots a and b. So you will lose twrp the next time you boot into recovery, you need to flash magisk and optionally any kernel if you want one before booting out of your recovery in slot b after you've flashed that boot image to slot a then slot b (make sure to do slot a before b so you can still install magisk and custom kernel if you want one before you lose twrp). This all might sound a little confusing so I wrote instructions below.

    Here's what worked for me after a ton of testing to get OOS 10.3.0 stable + magisk + blu_spark r112 kernel (kernel is optional) working. Give the following a try.

    Method A - If you already have twrp
    Boot recovery into slot a, flash your rom's stock boot.img, then boot into your recovery in slot b (dont boot into slot a recovery because slot a wont have twrp anymore), flash your rom's stock boot.img, magisk and (optional) your kernel of choice (or not) in that order, then you can boot boot into system. That's it.
    Method B - If you don't have twrp
    Boot into fastboot, and from your cmd/terminal run fastboot flash boot yourtwrp.img (I suggest Mauronofrio's twrp-3.3.1-16-enchilada-Q-mauronofrio.img or newer). Use your volume buttons to select boot into recovery. Make sure your active slot is B, (if it isnt, install twrp (bluspark and Mauronofrio's twrp both work great) by zip, then follow the steps above in method A). Once you've verified you're in slot B flash your rom's stock boot.img, magisk and (optional) your kernel of choice (or not) in that order, then you can boot into system. That's it.

    Useful links:
    Stock 10.3.0 boot.img https://drive.google.com/file/d/1w44cUg815g-H1h_6gObUVPLDTc_dtiMX/view
    blu_spark twrp https://github.com/engstk/android_device_oneplus_enchilada/releases
    Mauronofrio's twrp images and installers https://forum.xda-developers.com/on...overy-unofficial-twrp-touch-recovery-t3860815

    Hopefully @mauronofrio or @eng.stk can clue us in on why magisk or twrp bricks the system if you install them together in OOS 10.
    2
    no patched boot.img you need
    1. connect your OP6 to PC
    2. flash TWRP (from mauronofrio) by fastboot from PC
    3. reboot from fastboot to recovery
    4. in TWRP flash stock img OOS, don´t reboot
    5. in TWRP flash TWRP (blu_spark 9.107)
    6- reboot to TWRP to another slot
    7. in TWRP flash Magisk 20.1
    8. reboot to system
    2
    Hi guys, sorry to resurrect this thread. I did everything in the correct order using 10.0.3.0 and after step 8 (reboot after flashing blu_spark) my phone gets stuck on blu_spark splash screen without any option to boot into twrp. Normal boot results in bootloop... Any ideas? Do I need to use different versions of twrp.img and .zip?
    1
    So I was unable to flash the new OTA through twrp running on my rooted OP6.
    As such, I opted to install the new OTA through the "local install" option.
    That worked great. Settings area all the same. Bootloader still unlocked (I double checked).

    Drivers are all installed on my Windows 10 PC.

    However, no matter what I attempt to flash from command prompt I always get:
    FAILED (remote: unkown command)

    Does anyone know of a solution yet?
    I have been reinstalling drivers and rebooting my PC with no luck thus far.

    Any ideas?
    Thanks in advance.

    Update:
    Whelp now that it is upgraded to Android 10 (and was wiped of all data when I locked and then unlocked the bootloader again) it will not allow me to downgrade back to Andriod 9 through the local upgrade option and since I can not get fastboot to accept any commands I am stuck now in Andriod 10 without the ability to change anything at the moment. :(

    i knew it while reading but thanks to the screenshot you provided you saved me from sounding "user error" once again and piss of so many who prefer to blame things and others LOL

    in short, wrong command, it's fastboot flash boot <image name>

    BTW and since i'm already at it, if anyone has a Mac runniing 10.15 "Catalina" and fastboot is working from terminal, i'd like to learn how he/she's done it ;) ;)

    just came to my mind to ask here since i have to use windows 10 under parallels desktop to fastboot flash my android stuff at the moment and of course that's just an "Emergency" choice for me, everyone using both platforms will understand ;) ;) :D