[Guide]LG One Click Root - root LG firmwares (KitKat / Lollipop)

Search This thread


Feb 26, 2008
Neither GUI nor v1.2 batch script work...

For the batch script...

LG Root - One click script
Written by avicohh

Please make sure that USB debugging is enabled, and LG drivers are installed.

Starting adb server..

Waiting for device..

Device detected!

Pushing files..
3266 KB/s (1048328 bytes in 0.313s)
1488 KB/s (9393 bytes in 0.006s)
3675 KB/s (4017098 bytes in 1.067s)


Looking for LG serial port..

Serial port not found, please insert the phone manually into Download mode.

Disconnect the USB cable and turn off the phone.
Then press and hold the Volume Up button, and while you're doing that connect the USB cable again.

Waiting for device..

Phone found at COM5!

Rooting phone..

If you don't see the SuperSu installer script runs within about a minute,
then the root failed.

Author : blog.lvu.kr


So the first time the script ran to the point that instructs me to Ctrl-C, hit N and reboot the phone. No root.

The second time, the script also ran to the same point, rebooted the phone, still no root.

The third time, the superSU installer doesn't run at all.

The forth time, the superSU installer doesn't run either.

So I'm not sure what to do now...

Khush Kumawat

New member
Jun 12, 2017
One click root in any phone

that's actually a very easy process as you can simply use some applications to root any of your smartphone by just using them.
for this you may download free apps like kingroot, kingoroot, or wodershare dr. phone


New member
Jul 3, 2019
0% Problem

I have the same problem with the 0% issue. I have tried many different one click solutions and all run into that. I am also running marshmallow. Any way around this problem? Any help would be appreciated.


New member
Oct 5, 2019
Hi, this is vicehare.
OneClick Root Batch 1.2 or 1.3 both didn't work for me, I'm afraid:
Phone: LG G3 (D855)
Android 5.0
Kernel 3.4.0
Build number LRX21R.A1445306351
Software version V21a-EUR-XX

I used Windows 10 and LGUnitedMobileDriver_S51MAN313AP22_ML_WHQL_Ver_3.13.2.exe (which seemed to work) via VirtualBox in OpenSuse Linux. The connection seems to be ok, the USB connection and file transfer all was successful, but after the root script claimed to be done and ready, yet the phone was not rooted. Towelroot or Stumproot don't work either with this Android version.
Any ideas or info I can send? Or how I can use that on my native Linux?


Senior Member
Jul 4, 2013
Not working for me, sadly. Stuck on "Rooting". D-850, Lollipop, fully stock.

C/P of GUI text:

Starting adb server...
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
Waiting for device...
Device detected!
Pushing files...
2914 KB/s (1048328 bytes in 0.351s)
1126 KB/s (9226 bytes in 0.007s)
2694 KB/s (4017098 bytes in 1.455s)
Looking for LG serial port...
Serial port not found! please insert the phone manually into Download mode.
Disconnect the USB cable and turn off the phone.
Then press and hold the Volume Up button, and while you're doing that connect the USB cable again. ### I tried the GUI a few times and this message does not come up every time.
Waiting for device...
Phone found at COM4!
Rooting phone... ###stuck here indefinitely, uplugged phone at this point.
Author : blog.lvu.kr ##starting with this line, all up this text below appears AFTER the uplug.
- Mounting /system, /data and rootfs
- Extracting files
- Disabling OTA survival
- Removing old files
- Placing files
- Post-installation script
- Unmounting /system and /data


Dec 17, 2019
Not working in LG G$ H635 LL 5.0.2

Not one click method not manual
Process goes well, but when rebooting there is no root, neither SU program.


New member
Aug 30, 2012
D852 Not working

Starting adb server...
* daemon not running. starting it now on port 5037 *
* daemon started successfully *
Waiting for device...
Device detected!
Pushing files...
3118 KB/s (1048328 bytes in 0.328s)
899 KB/s (9226 bytes in 0.010s)
5099 KB/s (4017098 bytes in 0.769s)
Looking for LG serial port...
Phone found at COM6!
Rebooting into Download mode...
Author : blog.lvu.kr
Couldn't open the port //./COM6

Phone reboots, and connection seems to be lost. No root. From Android 6.0.


Senior Member
Feb 5, 2013
OnePlus 3T
OnePlus 7
So this method doesn't work when your phone is already on Marshmellow (Android 6.x). It seems the remaining options are: 1) downgrade first to KK or LP and try this option again or 2) use the dreaded Kingoroot or some other potential spyware. What success rate does the latter have? And when I need root only to install TWRP in order to flash LineageOS, I suppose everything that Kingoroot could have installed would also be removed. Or am I missing something? Because, for downgrading to some earlier stock firmware, one has to first find it. This doesn't seem to be easy.


Senior Member
Feb 5, 2013
OnePlus 3T
OnePlus 7
So Kingoroot didn't help because the bootloader remained locked. In the end, what I did was downgrading to KK, where rooting actually works, with LGUP. Then, I was able to run one click root. And finally I flashed Twrp through the official Twrp app. And I noticed, that on this phone you can't install lineageos via sideload. You must push it to the sd card first. Now everything is fine. A huge thanks goes to @HardStyl3r who gave me the right tips!
  • Like
Reactions: Trubadixt


New member
Jan 19, 2019
Doesnt work on my LG leon (h340 n) with android 6.0. It stopped after "rebooting into donwlod mode..." and then "waiting for device...", but i can see my lg device in the windows device manager at com3. What can i do, thet your program will continue the rooting process. I installed both lg drivers and the connection is working perfectly.

Top Liked Posts

  • There are no posts matching your filters.
  • 749
    Hi evryone.

    Recently I came across this guide, and it worked fine for me.
    So I wrote a tool that basically does the same thing, just make things easier.
    This method should work on any LG G3 official firmware (4.x.x / 5.x.x), and on other models too.

    Please leave your feedback if it worked for you, and indicate whether you used the graphical user interface or the old script.
    And if it's didn't worked, please attach here the log from the window.

    • I saw a lot of questions of G3 users about how to install Twrp after the root, so I will explain briefly:
      For now, if you are on stock lollipop you can't just flash Twrp via flashify etc like the old days in KitKat, but you can follow this guide over here.

    • After the root, if you want for some reason (warranty etc) to unroot the phone, all you need to do is a full unroot from the SuperSU settings.
      I don't know if this is enough to get OTA updates back, I'm still waiting for somebody else to answer this question. so please don't ask me about this any more because I really don't know the answer.

    Devices confirmed working with this method (If your device isn't listed it's most likely still supported)
    • LG G3 (all variants)
    • LG G3 Beat
    • LG G2
    • LG G2 Mini
    • LG G Pro 2
    • LG G Pad
    • LG F60
    • LG L90
    • LG Tribute
    • LG Spirit
    • LG Volt
    • LG G Vista

    A screenshot

    LG One Click Root 1.3 (Graphic UI)
    LG One Click Root 1.2 (The old script method - try this if the Graphic UI version didn't work)
    LG drivers
    LG Verizon drivers

    • Install LG drivers if they are not installed yet.
    • Download the LG One Click Root file above and extract to some folder. (double click on the 7z exe file)
    • Enable Usb debugging on your phone. (Go to Settings > General > About phone > Software information, tap Build number seven times and then go to Settings > Developer options and turn on Usb debugging)
    • Connect your phone to pc.
    • If you are using the GUI version just run the LG One Click Root installer, or if you are using the script then double click on the LG Root Script.bat file, to run the script.
    • Follow the instructions.
    • If the phone not recognize, try to switch between MTP and PTP options.
    • If you got "MSVCR100.dll is missing" error, install Visual C++ Redistributable.
      (64 bit users, also install this file and not the 64bit version)

    Video tutorial
    Big thanks to @qbking77

    If you like my work press Thanks, and feel free to Donate :eek:


    @Unjustified Dev for the original guide
    @Chainfire for SuperSU
    @qbking77 for the video


    LG One Click Root v1.3 - 13/04/15 (current)
    A new version with a graphical user interface instead of a script.
    Although the root process remains the same, it has been rewritten programmatically, so I hope it will solve problems on some devices.

    LG One Click Root v1.2 - 23/03/15
    Added instruction in the script to how enter download mode manually if needed.

    LG One Click Root v1.1 - 22/03/15
    Added support for Verizon users.

    LG One Click Root v1.0 - 17/03/15
    First version.
    I've got over 2.5GB free on internal storage, and about 14.9GB free on the SD card. Should be plenty of elbow room for the rooting process, as long as the card can be accessed in Download mode. If it can't, I could free up another 1GB by dumping apps, but the unzipped size of SuperSU is only 3.9 MEG. How much room does it need, to unzip??

    IF you are getting to 90% in download mode and its "freezing" wait........ maybe 3 mins........ and Just pull the usb from phone.
    YES while its stuck in download mode @ 90 % , wait three minutes and pull the usb from phone,
    count to 3
    power off
    count to 3
    power on
    android should upgrade ( install SU ! )
    joeykrim it :good:
    Finally one click root for lolipop. Thanks.
    Here's a tutorial video I made running this one click script! Hope it helps

    At the begin, in the popup window "Allow USB debugging?" did you checked the option "Always allow from this computer" before you click OK?
    If not, please try again, and this time you check this option.

    The thing is after the reboot (normal reboot), the script waiting again for ADB connection to be sure the phone is detected on the computer, before reboot into Download mode.
    The reason I had to do this normal reboot first, is because otherwise the files (previously pushed) my not saved properly.

    Just do "full unroot" in SuperSU settings, or flash full firmware again without wipe (normal flash, not cse) via LG Flash tool 2014.

    It worked now. I had already checked the "Always allow from this computer?", but the script was still waiting. What I did now was to unplug the phone from the USB, when the script "Looking for LG serial port...", and plugged it in another USB port. Then the script followed the installation normally.
    Anyway, thanks for help!