[Guide] [Magisk] Disable Dynamic refresh rate for Poco X3 NFC

Search This thread

CCARNIFEXX

New member
Jan 21, 2021
1
0
Спасибо за данный метод,
Сначала не получилось, а все как в инструкции было написано так и сделал.
Даже после перезагрузки, телефон не хотел убирать динамическую частоту.
Проблема была в следующем, я забыл стереть данные с приложения, питание и производительность. После этой динамической частоты исчезла, спасибо автору данного метода.
прошивка MIUI 12.0.5 global
 

Vincent Foxx

Senior Member
Jun 18, 2020
119
24
Brawley
I flash busy box zip file and magiskhide zip provided links. then reboot, and run the comands on terminal right?


Edit- Doesn't work on xiaomi.eu 12.0.7. did it manually, and followed all steps.
 
Last edited:

Zen9_o

Member
Nov 1, 2020
13
7
Found a module in telegram with working 120hz refresh rate, this works flawlessly for me on MIUI Global ROM. The module name is SpaceX - I did not create this module, but I feel as though it needs to be shared on here as some people don't use Telegram. If SlimK method does not work for you, just flash away with this module and you're good to go.
IMG_20210206_022052.jpg
 

Attachments

  • SpaceX-Falcon-MEMEUI.zip
    5.1 MB · Views: 515
  • Like
Reactions: Jonny993

aron11195

Senior Member
Jul 16, 2018
198
37
Found a module in telegram with working 120hz refresh rate, this works flawlessly for me on MIUI Global ROM. The module name is SpaceX - I did not create this module, but I feel as though it needs to be shared on here as some people don't use Telegram. If SlimK method does not work for you, just flash away with this module and you're good to go. View attachment 5211349
check hz when ur playing a video.
 

divisionobrabo

New member
Feb 22, 2021
2
0
A lot of people have complained about stuttering in between App switching and gaming. This guide helps you disable Dynamic refresh rate through MagiskHide Prop Config, which is easier than setting it manually and safer to disable if it doesn't work.



Requirements:
- Unlocked and rooted with Magisk v21.0.
- busybox-ndk.
- MagiskHide Prop Config installed (used often to pass safetynet CTS but can be used to set custom Props).

Instructions:
1- Run SU in your terminal of choosing.
2- Run props.
3- choose option 5 "Add/edit custom props".
4- choose n "New custom prop".
5- type in:
Code:
 ro.vendor.dfps.enable
6- Default value should be true, type in false to disable.
7- choose 2 "post-fs-data".
8- choose n, don't reboot yet.
9- choose n again to set another prop.
10- type in:
Code:
 ro.vendor.smart_dfps.enable
11- Default value should be true, type in false to disable.
12- choose 2 "post-fs-data".
13- Reboot.

Only tested on stock MIUI. Try at your own risk!
how do i know it worked?

when I opened the fps monitor it still keeps changing to 60Hz in apps that don't have support for 120Hz, is that correct?

something else, I used Termux, is everything okay?
 

divisionobrabo

New member
Feb 22, 2021
2
0
Found a module in telegram with working 120hz refresh rate, this works flawlessly for me on MIUI Global ROM. The module name is SpaceX - I did not create this module, but I feel as though it needs to be shared on here as some people don't use Telegram. If SlimK method does not work for you, just flash away with this module and you're good to go. View attachment 5211349
how to install this module?
 

rai2001

New member
Feb 24, 2021
2
0
Hello, I bought the Poco x3 for games but I have lag when playing light games that in reality with everything that should not or present that problem, I read that the Poco x3 has a fps drop due to the hz that this equipment has when performing this process Will I get rid of that lag in the games and not show jerks or fps drop? Or what other option can I take to no longer have that problem with games?
 

BinhNguyenVN

New member
Feb 27, 2021
1
0
Hello, I bought the Poco x3 for games but I have lag when playing light games that in reality with everything that should not or present that problem, I read that the Poco x3 has a fps drop due to the hz that this equipment has when performing this process Will I get rid of that lag in the games and not show jerks or fps drop? Or what other option can I take to no longer have that problem with games?
you are like me, even though locked at 90hz (as instructed) but when playing Mortal Kombat mobile game still drop FPS (60-90)!
 

rai2001

New member
Feb 24, 2021
2
0
[QUOTE = "BinhNguyenVN, publicación: 84569851, miembro: 11473405"]
eres como yo, a pesar de estar bloqueado a 90 hz (como se indica), pero cuando juegas al juego móvil Mortal Kombat, ¡aún pierdes FPS (60-90)!
[/CITA]
Si eh tenido problemas en buscado un monton de soluciones pero nada aun eh probado varias roms pero el problema persiste asi use modulos magisk
 

ErriK89

Senior Member
Oct 19, 2010
74
18
Milan
I'm running MIUI 12.0.8 nothing works for me. I set smart_dfps and dfps to false and confirmed the settings and also installed magisk module, but when I open a game refresh rate come back to 60Hz... Any idea?
 

gergo77

New member
Mar 17, 2021
1
0
Perhaps this is unusual, but I need to force a 50hz refresh rate for proper emulation of the C64 and Amiga computers, which were most popular in Europe. How can it be done? I've gone through disabling dynamic refresh rate.
 

Nazri786

Senior Member
Jul 18, 2011
588
88
Pulai
Xiaomi Poco X3 NFC
I stumbled upon this method while looking method to disable the dynamic refresh rate... And seems this one working as from the power monitor it doesn't fluctuate.... And it doesn't need root... Linked below...


Edit: Not working as expected... after a while the refresh rate drop to 30 when idle...
 
Last edited:

evolez

Senior Member
May 29, 2013
209
47
you are like me, even though locked at 90hz (as instructed) but when playing Mortal Kombat mobile game still drop FPS (60-90)!
Tried all miui based roms all are same, laggy as hell on many games. Just the AOSP ones run smoothly even at 120 hz. Tried arrowos and corvus-os both are great at mortal combat. No frame drops, stable at 120 hz. Suggest you to install one of those AOSP based roms
 
Last edited:

aymen peter

Member
Feb 12, 2021
15
5
Xiaomi Poco X3 NFC
To make things easier and more risk free, i have attached a config file to automate this process. New steps are even easier! Do the following:
1- Install the aforementioned modules.
2- unzip the attached .zip file to the root of internal storage.
3- Reboot.
New settings should've been applied successfully after reboot and the config file will delete itself.
i dont know how to install this can i install it through magisk or somthing can you explain more ?
 

Angyone1

Senior Member
Sep 6, 2018
113
17
Brescia
Android Wear
Sorry but in my sub forum I dont found nothing.... I can use this guide for my poco F3 with MIUI 12.5.3 eea alreagy rooted with magisk ? I want constant refresh rate because now when I touch the screen the refresh rate are to 120hz but when I dont touch the screen the refresh rate go down to 60.... This guide set the refresh rate constant always also when I dont touch the screen ? Thanks.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 6
    A lot of people have complained about stuttering in between App switching and gaming. This guide helps you disable Dynamic refresh rate through MagiskHide Prop Config, which is easier than setting it manually and safer to disable if it doesn't work.

    Disclaimer: Disabling Dfps (Dynamic refresh rate) will degrade battery life with prolonged use. According to my personal testing, battery life (SOT) decreased by 10-18% on average. Only use for short periods of time.

    Requirements:
    - Unlocked and rooted with Magisk v21.0.
    - busybox-ndk.
    - MagiskHide Prop Config installed (used often to pass safetynet CTS but can be used to set custom Props).

    Instructions:
    1- Run SU in your terminal of choosing.
    2- Run props.
    3- choose option 5 "Add/edit custom props".
    4- choose n "New custom prop".
    5- type in:
    Code:
     ro.vendor.dfps.enable
    6- Default value should be true, type in false to disable.
    7- choose 2 "post-fs-data".
    8- choose n, don't reboot yet.
    9- choose n again to set another prop.
    10- type in:
    Code:
     ro.vendor.smart_dfps.enable
    11- Default value should be true, type in false to disable.
    12- choose 2 "post-fs-data".
    13- Reboot.

    Only tested on stock MIUI. Try at your own risk!
    2
    dont know if this is possible but do make a standalone magisk module for this, without props and everything else. just a single module that disables dynamic refresh rate.
    I wanted to show everyone who is interested how to change this behavior under the hood. That is the main reason why I made a guide and not a mod (since everyone was using props module to pass safetynet anyway). However I made this attached module just for you. Do note that I have not tested it since I use a custom ROM at the moment, but it does what's in the guide without props config and should work flawlessly.
    1
    Hey. Thanks for the information. I'd like to try this out but I have two questions: 1 - Is it safe to flash magisk? Some guy from another thread said magisk corrupted his ramdisk and /sdcard when flashing. 2 - Where do I get power monitor to check the refresh rate? Thanks.
    To answer you questions:
    1- The guy in that thread has made the obvious mistake of flashing stock related files through twrp (a very baaad idea), since all current custom recoveries have limited access to system-vendor-product partition (read only). If he had read more carefully, his device wouldn't have been hard bricked. Besides, if you only want Root (Magisk), you don't even need a custom recovery, just an unlocked Bootloader, your current boot.img and a pc with some flashing knowledge.
    2- You can find it under Monitoring in Settings/Additional settings/Developer options/Power monitor. If you can't find the option there, then you probably debloated MIUI, in that case restore the app Power Checker with the package name:
    Code:
    com.xiaomi.powerchecker
    If you need further assistance, hit me up and I will help.
    1
    recent drops to 90hz. is that normal for recent to drop?
    Yes. In trying to make an "all day battery" phone, Poco has decided to cap recents to 90hz. So many cut corners. Anyways, Clearing storage of battery management app should fix that problem. I don't remember the name of the system app exactly, but it has a green battery icon :ROFLMAO:
    i only have youtube vanced
    If you installed vanced in non root mode, you can still install normal youtube from playstore alongside it. You don't have to do it tho.
    1
    Yes. In trying to make an "all day battery" phone, Poco has decided to cap recents to 90hz. So many cut corners. Anyways, Clearing storage of battery management app should fix that problem. I don't remember the name of the system app exactly, but it has a green battery icon :ROFLMAO:

    If you installed vanced in non root mode, you can still install normal youtube from playstore alongside it. You don't have to do it tho.

    recent drop is fixed by clearing data of battery and performance system app.

    tested official youtube. its not dropping hz. its constant 120hz