[GUIDE] Moto G4 Plus HardBrick SOLVED - ULTIMATE UNBRICKING GUIDE

Is your device is back to life using this method?

  • Yes

    Votes: 118 67.4%
  • No

    Votes: 57 32.6%

  • Total voters
    175
Search This thread

nittinarya25

New member
Feb 26, 2014
3
0
0
Thanks for the response, I'm not an admin but will try to help you as much as you can.
1)That suggests that the blankflash can't communicate with your device (which is supported by the fact your device is showing up as unknown in Device Manager). You wrote in your previous post that the 'waiting for device' was resolved though?
2)Again, supports 1) that your device can't talk to your computer.

Do you have driver signature enforcement enabled if you're using a Windows computer? If so, or are not sure, try to disable driver signature enforcement and attempt to use the blankflash again. I'm aware that driver signature enforcement may block fastboot drivers (or non Windows signed drivers) from loading, so by disabling signature enforcement you may be able to load the fastboot drivers and may be able to use the blankflash. Alternatively, you could right click on the unknown device and try to install the drivers manually (from the Motorola drivers you installed on your computer). The screenshot I've linked is what my device - booted into the bootloader - looks like in Device Manager when it's attached to my computer via USB. Note the red box and the listing of Motorola ADB Interface. You may wish to verify you see something similar, or if not, try to install the drivers shown. I have a Windows 10 PC with a XT1642, with Motorola USB 2.5.4 drivers installed

Also ensure you're using the latest blankflash as provided in the opening post.

However, what you describe in 5) does sound like hardware failure, which a blankflash may not solve. However, try with the suggestions above and see how you get on.[/QUOTE]

---------------------------------------------------------------------------------------------
Thanks for replying friend
Unknown device error solved now device manager showing motorola adb interface--
But after this still in bank flash waiting for device error even after disable signature...please help! is their any way to flash my moto g4 plus with any flashtool?????
Please help
Thanks
 

Fir3lordZuk0

Senior Member
Oct 10, 2015
818
203
63
Bangalore
Thanks a lot man.

I sold this in exchange offer at amazon. The agent was about to come to pick the device and it bricked(stupid Moto updates). I was ****ting my pants that he will not pick the device and wont give me new one. Then i found this post and it unbricked my device.
Thanks a lot again :)
 

duochoi0079

New member
Dec 28, 2017
3
0
0
no signal and not charging

i did the aforementioned commands but i ended up having no signal and device is not charging
i used BP TOOLS in bootloader options and it does solve the problems i mentioned, however it loses the usb transfer option...
im both thankful and scratching my head now
could you help me on this one?
 

echo92

Senior Member
Jan 1, 2017
3,732
1,989
223
Plymouth
Thanks for replying friend
Unknown device error solved now device manager showing motorola adb interface--
But after this still in bank flash waiting for device error even after disable signature...please help! is their any way to flash my moto g4 plus with any flashtool?????
Please help
Thanks

So you've tried the suggestions in this post here: https://forum.xda-developers.com/showpost.php?p=73434849&postcount=2 ? You may have to unplug and re-plug your device again for it to be recognised.

Are you using the original Motorola cable or another good quality USB data + power cable to connect your device to your computer?

Without being able to communicate to your device, I'm not sure if you could use any flash tools. However, as I suggested before, another cause of this behaviour may be a motherboard failure.

---------- Post added at 03:58 PM ---------- Previous post was at 03:54 PM ----------

i did the aforementioned commands but i ended up having no signal and device is not charging
i used BP TOOLS in bootloader options and it does solve the problems i mentioned, however it loses the usb transfer option...
im both thankful and scratching my head now
could you help me on this one?

Do you still have no USB transfer if you reboot normally (or power off and boot without using BP Tools)?
 

duochoi0079

New member
Dec 28, 2017
3
0
0
on a normal boot, it can perform USB transfers but you lose both the network signal and charging function
this might have been an earlier problem (not charging but it had network signal) from the previous owner, i thought flashing the rom again may help but it turned out that the network signal was totally gone and it cant charge in normal boot.
 

echo92

Senior Member
Jan 1, 2017
3,732
1,989
223
Plymouth
on a normal boot, it can perform USB transfers but you lose both the network signal and charging function
this might have been an earlier problem (not charging but it had network signal) from the previous owner, i thought flashing the rom again may help but it turned out that the network signal was totally gone and it cant charge in normal boot.

Yeah, appears that BP Tools switches your USB Interface to BP mode (presumably for developer testing/troubleshooting), possibly why you lost USB transfer when booting with BP Tools https://forums.androidcentral.com/motorola-droid-maxx/312723-weird-mtp-issue.html

Not much info on BP Tools though, apart from it's apparently used for baseband troubleshooting (from an old thread : https://forum.xda-developers.com/showthread.php?t=2121442 )

But either way, that device doesn't sound healthy - do you know the history of the device from its previous owner? Which firmware did you try to re-flash onto the device (and what device is it)?
 

duochoi0079

New member
Dec 28, 2017
3
0
0
i seriously have no clue. i just wanted to fix it back to normal but i guess that's rather impossible for now.
the only thing that bugs me is why the network signal disappeared on normal boot after flashing the rom because that wasnt part of the problem before
 

r1rony

Senior Member
Jan 13, 2017
82
11
0
Can anyone give qcn file of athene xt1643 plz:crying::crying: how to extract qcn tutorial is here
http://www.androidbrick.com/ultimat...agon-xiaomi-mi5-imei-and-baseband-repair-fix/ if anyone of u kind people help me to get baseband and Imei back and it would help others who lost their baseband and original Imei if someone give me qcn file I will make a thread to recover baseband and original Imei of athene it is only way that I could revive my athene xt1643 now I tried almost all of the method to recover it like pushing hw partition and flashing
 

Outfield303

Senior Member
Nov 6, 2016
286
220
43
Can anyone give qcn file of athene xt1643 plz:crying::crying: how to extract qcn tutorial is here
http://www.androidbrick.com/ultimat...agon-xiaomi-mi5-imei-and-baseband-repair-fix/ if anyone of u kind people help me to get baseband and Imei back and it would help others who lost their baseband and original Imei if someone give me qcn file I will make a thread to recover baseband and original Imei of athene it is only way that I could revive my athene xt1643 now I tried almost all of the method to recover it like pushing hw partition and flashing
FYI there is already a thread for recovering the lost IMEI and fingerprint https://forum.xda-developers.com/moto-g4-plus/help/moto-g4-pluss-model-changed-to-g4-lost-t3496912
 

Icesmash

Member
Nov 11, 2015
34
11
0
I was on a December 2016 security patch & OTA Updated to the newest version allowed for my Moto G4 PLUS XT1644 RETAIL US

Code:
Motorola qboot utility version 3.40
[ -0.000] Opening device: \\.\COM3
[ -0.000] Detecting device
[ -0.000] ...cpu.id  = 2418 (0x972)
[ -0.000] ...cpu.sn  = 23722320 (0x169f950)
[ -0.000] Opening singleimage
[  0.016] Loading package
[  0.016] ...filename = singleimage.pkg.xml
[  0.016] Loading programmer
[  0.016] ...filename = programmer.mbn
[  0.016] Sending programmer
[  0.234] Handling things over to programmer
[  0.234] Identifying CPU version
[  0.234] Waiting for firehose to get ready
[ 11.156] ReadFile() failed, GetLastError()=0
[ 11.156] ReadFile() failed, GetLastError()=0
[ 20.651] ReadFile() failed, GetLastError()=0
[ 20.651] ReadFile() failed, GetLastError()=0
[ 62.559] Waiting for firehose to get ready
[123.077] ...MSM8952 unknown
[123.077] Determining target secure state
[123.077] Waiting for firehose to get ready
[183.549] ...secure = no
[183.580] Flashing GPT...
[183.580] Flashing partition:0 with gpt_main0.bin
[183.580] Initializing storage
[183.596] Waiting for firehose to get ready
[244.036] Configuring device...
[244.036] Waiting for firehose to get ready
[304.446] Waiting for firehose to get ready
[364.886] Waiting for firehose to get ready
[425.373] Waiting for firehose to get ready
[485.814] ERROR: do_package()->do_recipe()->do_flash()->gpt_flash()->get_storage()->init_storage()->firehose_do_fmt()->do_recipe()->do_configure()->buffer_read()->device_read()->IO error
[485.814] Check qboot_log.txt for more details
[485.814] Total time: 485.814s
FAILED: qb_flash_singleimage()->do_package()->do_recipe()->do_flash()->gpt_flash()->get_storage()->init_storage()->firehose_do_fmt()->do_recipe()->do_configure()->buffer_read()->device_read()->IO error

It is registered under Ports as QualComm HS-USB QDLOADER 9008 (COM3)

When I don't press anything & just run the bat without holding down Power+Volume Down

Code:
Motorola qboot utility version 3.40
[  0.000] Opening device: \\.\COM3
[  0.000] Detecting device
[  4.032] ERROR: sahara_greet_device()->change_mode()->do_hello()->IO error
[  4.032] Check qboot_log.txt for more details
[  4.032] Total time: 4.032s
FAILED: qb_flash_singleimage()->sahara_greet_device()->change_mode()->do_hello()->IO error
Press any key to continue . . .

Before updating via the OTA this is what I was on

<Device Info>
Moto G4 Plus XT1644
athene_f
Bootloader 0xB106
Build NPJ25.93-14
Android Nougat (7.0) with December 1, 2016 Security Patch
Bootloader Unlocked
Carrier: T-Mobile

Apparently the fix to get into fastboot was to press & hold the power & volume down key & then let go after you get the Waiting for firehose to get ready command which then you must release.

Code:
Motorola qboot utility version 3.40
[  0.000] Opening device: \\.\COM3
[  0.001] Detecting device
[  0.003] ...cpu.id  = 2418 (0x972)
[  0.003] ...cpu.sn  = 23722320 (0x169f950)
[  0.003] Opening singleimage
[  0.003] Loading package
[  0.007] ...filename = singleimage.pkg.xml
[  0.009] Loading programmer
[  0.010] ...filename = programmer.mbn
[  0.010] Sending programmer
[  0.224] Handling things over to programmer
[  0.225] Identifying CPU version
[  0.228] Waiting for firehose to get ready
[  3.237] ...MSM8952 1.1
[  3.237] Determining target secure state
[  3.237] ...secure = yes
[  3.252] Flashing GPT...
[  3.252] Flashing partition:0 with gpt_main0.bin
[  3.252] Initializing storage
[  3.252] Configuring device...
[  3.268] ...blksz = 512
[  3.330] Re-initializing storage...
[  3.330] Initializing storage
[  3.377] Flashing bootloader...
[  3.377] Flashing aboot with emmc_appsboot.mbn
[  3.737] Flashing rpm with rpm.mbn
[  3.815] Flashing tz with tz.mbn
[  4.065] Flashing hyp with hyp.mbn
[  4.112] Flashing cmnlib with cmnlib.mbn
[  4.190] Flashing keymaster with keymaster.mbn
[  4.268] Flashing sbl1 with sbl1.mbn
[  4.424] Rebooting to fastboot
[  4.424] Total time: 4.425s

So now I'm in FastBoot with:

BL B1.06(*) SHA-0EDFB0D, 2017-06-01 12:10:43)
Product Varient athene_16mp 16GB P2A

Is it safe to flash the bootloader & rom back to the latest security update/rom from here?

https://sourceforge.net/projects/motog4plus/?source=typ_redirect
 
Last edited:
  • Like
Reactions: vaas kr

Outfield303

Senior Member
Nov 6, 2016
286
220
43
I was on a December 2016 security patch & OTA Updated to the newest version allowed for my Moto G4 PLUS XT1644 RETAIL US

Code:
Motorola qboot utility version 3.40
[ -0.000] Opening device: \\.\COM3
[ -0.000] Detecting device
[ -0.000] ...cpu.id  = 2418 (0x972)
[ -0.000] ...cpu.sn  = 23722320 (0x169f950)
[ -0.000] Opening singleimage
[  0.016] Loading package
[  0.016] ...filename = singleimage.pkg.xml
[  0.016] Loading programmer
[  0.016] ...filename = programmer.mbn
[  0.016] Sending programmer
[  0.234] Handling things over to programmer
[  0.234] Identifying CPU version
[  0.234] Waiting for firehose to get ready
[ 11.156] ReadFile() failed, GetLastError()=0
[ 11.156] ReadFile() failed, GetLastError()=0
[ 20.651] ReadFile() failed, GetLastError()=0
[ 20.651] ReadFile() failed, GetLastError()=0
[ 62.559] Waiting for firehose to get ready
[123.077] ...MSM8952 unknown
[123.077] Determining target secure state
[123.077] Waiting for firehose to get ready
[183.549] ...secure = no
[183.580] Flashing GPT...
[183.580] Flashing partition:0 with gpt_main0.bin
[183.580] Initializing storage
[183.596] Waiting for firehose to get ready
[244.036] Configuring device...
[244.036] Waiting for firehose to get ready
[304.446] Waiting for firehose to get ready
[364.886] Waiting for firehose to get ready
[425.373] Waiting for firehose to get ready
[485.814] ERROR: do_package()->do_recipe()->do_flash()->gpt_flash()->get_storage()->init_storage()->firehose_do_fmt()->do_recipe()->do_configure()->buffer_read()->device_read()->IO error
[485.814] Check qboot_log.txt for more details
[485.814] Total time: 485.814s
FAILED: qb_flash_singleimage()->do_package()->do_recipe()->do_flash()->gpt_flash()->get_storage()->init_storage()->firehose_do_fmt()->do_recipe()->do_configure()->buffer_read()->device_read()->IO error

It is registered under Ports as QualComm HS-USB QDLOADER 9008 (COM3)

When I don't press anything & just run the bat without holding down Power+Volume Down

Code:
Motorola qboot utility version 3.40
[  0.000] Opening device: \\.\COM3
[  0.000] Detecting device
[  4.032] ERROR: sahara_greet_device()->change_mode()->do_hello()->IO error
[  4.032] Check qboot_log.txt for more details
[  4.032] Total time: 4.032s
FAILED: qb_flash_singleimage()->sahara_greet_device()->change_mode()->do_hello()->IO error
Press any key to continue . . .

Before updating via the OTA this is what I was on

<Device Info>
Moto G4 Plus XT1644
athene_f
Bootloader 0xB106
Build NPJ25.93-14
Android Nougat (7.0) with December 1, 2016 Security Patch
Bootloader Unlocked
Carrier: T-Mobile

Apparently the fix to get into fastboot was to press & hold the power & volume down key & then let go after you get the Waiting for firehose to get ready command which then you must release.

Code:
Motorola qboot utility version 3.40
[  0.000] Opening device: \\.\COM3
[  0.001] Detecting device
[  0.003] ...cpu.id  = 2418 (0x972)
[  0.003] ...cpu.sn  = 23722320 (0x169f950)
[  0.003] Opening singleimage
[  0.003] Loading package
[  0.007] ...filename = singleimage.pkg.xml
[  0.009] Loading programmer
[  0.010] ...filename = programmer.mbn
[  0.010] Sending programmer
[  0.224] Handling things over to programmer
[  0.225] Identifying CPU version
[  0.228] Waiting for firehose to get ready
[  3.237] ...MSM8952 1.1
[  3.237] Determining target secure state
[  3.237] ...secure = yes
[  3.252] Flashing GPT...
[  3.252] Flashing partition:0 with gpt_main0.bin
[  3.252] Initializing storage
[  3.252] Configuring device...
[  3.268] ...blksz = 512
[  3.330] Re-initializing storage...
[  3.330] Initializing storage
[  3.377] Flashing bootloader...
[  3.377] Flashing aboot with emmc_appsboot.mbn
[  3.737] Flashing rpm with rpm.mbn
[  3.815] Flashing tz with tz.mbn
[  4.065] Flashing hyp with hyp.mbn
[  4.112] Flashing cmnlib with cmnlib.mbn
[  4.190] Flashing keymaster with keymaster.mbn
[  4.268] Flashing sbl1 with sbl1.mbn
[  4.424] Rebooting to fastboot
[  4.424] Total time: 4.425s

So now I'm in FastBoot with:

BL B1.06(*) SHA-0EDFB0D, 2017-06-01 12:10:43)
Product Varient athene_16mp 16GB P2A

Is it safe to flash the bootloader & rom back to the latest security update/rom from here?

update your device from following thread https://forum.xda-developers.com/moto-g4-plus/how-to/stock-rom-npjs25-93-14-4-march-1-t3608138
 
  • Like
Reactions: Icesmash

echo92

Senior Member
Jan 1, 2017
3,732
1,989
223
Plymouth
Thank you so much! To avoid a future brick how can I prevent OTA updates?

I plan on using ElementalX, twrp-3.0.2-r4-athene_shreps & Magisk-v15.2.zip so definitely don't want to brick it again perhaps there's a xposed/magisk module?

1) To avoid hardbricks, do not downgrade your device with older firmware and expect to take OTA updates. I noted you flashed the NPJ25.93-14 (December 2016 ) firmware onto your device, which may have likely been far older than the actual firmware on your device. You cannot downgrade bootloaders. Thus, taking an OTA with a mismatched bootloader and firmware in terms of patch levels runs a very high risk of hard bricking. Only flash firmware of the same or newer patch level as on your device, ideally as new or newer than your bootloader patch level. At least the blankflash worked this time.

2)If you're planning to root, you can use shrep's 3.1.1 TWRP as well. For disabling the OTA updater, you can see this thread: https://forum.xda-developers.com/moto-g4-plus/help/how-disable-notification-update-t3459587

However, depending on which firmware you've flashed, you may not receive OTA updates anyway. I recall NPJ25.93-14.7 is the latest US retail firmware; flashing NPJS25.93-14-10 or NPJS25.93-14-13 has been shown to work, but you may not get OTA updates because your builds don't match those expected of your device for your region.

Oh, and always have a backup in TWRP before you do any flashing of magisk/xposed. As always, flash ElementalX before flashing root/xposed, else you'll brick your stock ROM.
 
Last edited:

erica butson

Member
Jan 17, 2018
40
17
0
Hard bricked phone becomes soft bricked but the bootloader is corrupted,

Thank you for the flash file i was waiting for 4 months for this flash file.
My phone was hard bricked dead and successfully recovered using this flash file, But I think the boot loader is corrupted.
it only enters to fast boot nothing works recovery doesn't work. Tried to flash stock recovery using this command
fastboot.exe flash recovery recovery.img <--- Didn't work tried TWRP when my phone got bricked it was running TWRP so
fastboot.exe flash recovery twrp.img <--- Didn't work too.
The main problem is phone can enter only to fast boot but recovery mode doesn't work entering to recovery mode is also not possible.
Tried flashing stock rom of september ATHENE_NPJS25.93-14-10_cid50_subsidy-DEFAULT_regulatory-DEFAULT_CFC.xml the phone didn't boot or the recovery worked.
Tried flashing latest rom of December ATHENE_NPJS25.93-14-10_cid50_subsidy-DEFAULT_regulatory-DEFAULT_CFC.xml didn't work too.
Tried flashing stock rom which had come with phone Moto_G4_Plus_XT1643_ATHENE_MPJ24.139-63_Stock_Img didn't work too.
I used NPJS25_93_14_10_Sept2017_GPT_bootloader GPT and Bootloader to save my phone from hard brick.
Log of fastboot getvar all
(bootloader) slot-count: not found
(bootloader) slot-suffixes: not found
(bootloader) slot-suffixes: not found
(bootloader) version: 0.5
(bootloader) version-bootloader: moto-msm8952-B1.06
(bootloader) product: athene_16mp
(bootloader) board: athene_16mp
(bootloader) secure: yes
(bootloader) hwrev: P2A
(bootloader) radio: 4
(bootloader) storage-type: emmc
(bootloader) emmc: 32GB SAMSUNG RX1BMB RV=08 PV=07 FV=0000000000000007
(bootloader) ram: 3GB SAMSUNG LP3 DIE=6Gb M5=01 M6=05 M7=00 M8=7B
(bootloader) cpu: MSM8952
(bootloader) serialno: ZY2238L75Q
(bootloader) cid: 0x0032
(bootloader) channelid: 0xc0
(bootloader) uid: 9CEB7F0000000000000000000000
(bootloader) securestate: flashing_unlocked
(bootloader) iswarrantyvoid: yes
(bootloader) max-download-size: 536870912
(bootloader) reason: Volume down key pressed
(bootloader) imei: 358187070533255
(bootloader) meid:
(bootloader) date: 06-02-2016
(bootloader) sku: XT1643
(bootloader) battid: SNN5970A
(bootloader) iccid:
(bootloader) cust_md5:
(bootloader) max-sparse-size: 268435456
(bootloader) current-time: "Thu Apr 21 3:26:31 UTC 2016"
(bootloader) ro.build.fingerprint[0]: motorola/athene_f/athene_f:6.0.1/M
(bootloader) ro.build.fingerprint[1]: PJ24.139-63/64:user/release-keys
(bootloader) ro.build.version.full[0]: Blur_Version.24.31.64.athene.reta
(bootloader) ro.build.version.full[1]: il.en.US
(bootloader) ro.build.version.qcom: LA.BR.1.3.3-02720-8976.0
(bootloader) version-baseband[0]: M8952_70009.08.03.48R ATHENE_INDIA_DSD
(bootloader) version-baseband[1]: S_CUST
(bootloader) kernel.version[0]: Linux version 3.10.84-g061c37c (hudsoncm
(bootloader) kernel.version[1]: @ilclbld87) (gcc version 4.9.x-google 20
(bootloader) kernel.version[2]: 140827 (prerelease) (GCC) ) #1 SMP PREEM
(bootloader) kernel.version[3]: PT Thu Aug 4 19:33:05 CDT 2016
(bootloader) sbl1.git: git=MBM-NG-VB1.06-0-g57d1343
(bootloader) rpm.git: git=MBM-NG-VB1.06-0-ga970ead
(bootloader) tz.git: git=69dd24b-dirty
(bootloader) hyp.git: git=69dd24b-dirty
(bootloader) keymaster.git: git=69dd24b-dirty
(bootloader) cmnlib.git: git=69dd24b-dirty
(bootloader) aboot.git: git=MBM-NG-VB1.06-0-g0edfb0d
(bootloader) qe: qe 0/0
(bootloader) frp-state: no protection (142)
(bootloader) ro.carrier: retin
all: listed above
finished. total time: 0.476s
Log of erasing system
fastboot erase system -w
(bootloader) slot-count: not found
(bootloader) slot-suffixes: not found
(bootloader) slot-suffixes: not found
(bootloader) has-slot:system: not found
wiping userdata...
Erase successful, but not automatically formatting.
File system type raw not supported.
wiping cache...
Erase successful, but not automatically formatting.
File system type raw not supported.
erasing 'system'...
(bootloader) Permission denied
FAILED (remote failure)
finished. total time: 0.016s

I can flash the rom but only one error which i have read on other posts suggests it can be ignored.
fastboot flash recovery recovery.img
(bootloader) slot-count: not found
(bootloader) slot-suffixes: not found
(bootloader) slot-suffixes: not found
(bootloader) has-slot:recovery: not found
target reported max download size of 536870912 bytes
sending 'recovery' (16484 KB)...
OKAY [ 0.604s]
writing 'recovery'...
OKAY [ 0.399s]
finished. total time: 1.007s


Any help is appreciated. The phone was useless for months now somehow i managed to get it to soft brick. I just want to make this phone work somehow.
 

echo92

Senior Member
Jan 1, 2017
3,732
1,989
223
Plymouth
Thank you for the flash file i was waiting for 4 months for this flash file.
My phone was hard bricked dead and successfully recovered using this flash file, But I think the boot loader is corrupted.
it only enters to fast boot nothing works recovery doesn't work. Tried to flash stock recovery using this command
fastboot.exe flash recovery recovery.img <--- Didn't work tried TWRP when my phone got bricked it was running TWRP so
fastboot.exe flash recovery twrp.img <--- Didn't work too.
The main problem is phone can enter only to fast boot but recovery mode doesn't work entering to recovery mode is also not possible.
Tried flashing stock rom of september ATHENE_NPJS25.93-14-10_cid50_subsidy-DEFAULT_regulatory-DEFAULT_CFC.xml the phone didn't boot or the recovery worked.
Tried flashing latest rom of December ATHENE_NPJS25.93-14-10_cid50_subsidy-DEFAULT_regulatory-DEFAULT_CFC.xml didn't work too.
Tried flashing stock rom which had come with phone Moto_G4_Plus_XT1643_ATHENE_MPJ24.139-63_Stock_Img didn't work too.
I used NPJS25_93_14_10_Sept2017_GPT_bootloader GPT and Bootloader to save my phone from hard brick.
<snip>
wiping userdata...
Erase successful, but not automatically formatting.
File system type raw not supported.
wiping cache...
Erase successful, but not automatically formatting.
File system type raw not supported.
erasing 'system'...
(bootloader) Permission denied
FAILED (remote failure)
finished. total time: 0.016s

I can flash the rom but only one error which i have read on other posts suggests it can be ignored.
fastboot flash recovery recovery.img
(bootloader) slot-count: not found
(bootloader) slot-suffixes: not found
(bootloader) slot-suffixes: not found
(bootloader) has-slot:recovery: not found
target reported max download size of 536870912 bytes
sending 'recovery' (16484 KB)...
OKAY [ 0.604s]
writing 'recovery'...
OKAY [ 0.399s]
finished. total time: 1.007s


Any help is appreciated. The phone was useless for months now somehow i managed to get it to soft brick. I just want to make this phone work somehow.

1)Can you confirm that the flash files in your ADB terminal folder are that of the NPJS25.93-14-10 (September 2017), or the December 2017 NPJS25.93-14-13 stock ROM, and how are you flashing? Are you using a script or using the commands manually in fastboot? I think you need a complete flash before attempting to proceed.
2)How is your device appearing in Device Manager? Is it fastboot athene s or Moto G4 ?
3)Looks like you have a September 2017 bootloader but still a Marshmallow based system and baseband, hence suggesting the flashes you're performing did not work. When you flash again, can you please paste the flash log here?
4)I would caution against using 'fastboot erase system' with a device in this state.

---------- Post added at 05:20 PM ---------- Previous post was at 05:16 PM ----------

Security version downgrade
need gpt.bin more latest one please

Which GPT/bootloader do you need? September and June 2017 are in the main post. If you need the December 2017 GPT/bootloader, it's here: https://drive.google.com/drive/folders/0B-GUyOfb8OgzcUl1NUtHYWNIR2M

They've all been extracted from their respective stock ROMs.

I hope you didn't hard brick by taking an OTA update from Marshmallow...
 
  • Like
Reactions: vishal.mamidi

vishal.mamidi

Member
Dec 4, 2014
35
3
0
hyderabad
1)Can you confirm that the flash files in your ADB terminal folder are that of the NPJS25.93-14-10 (September 2017), or the December 2017 NPJS25.93-14-13 stock ROM, and how are you flashing? Are you using a script or using the commands manually in fastboot? I think you need a complete flash before attempting to proceed.
2)How is your device appearing in Device Manager? Is it fastboot athene s or Moto G4 ?
3)Looks like you have a September 2017 bootloader but still a Marshmallow based system and baseband, hence suggesting the flashes you're performing did not work. When you flash again, can you please paste the flash log here?
4)I would caution against using 'fastboot erase system' with a device in this state.

---------- Post added at 05:20 PM ---------- Previous post was at 05:16 PM ----------



Which GPT/bootloader do you need? September and June 2017 are in the main post. If you need the December 2017 GPT/bootloader, it's here: https://drive.google.com/drive/folders/0B-GUyOfb8OgzcUl1NUtHYWNIR2M

They've all been extracted from their respective stock ROMs.

I hope you didn't hard brick by taking an OTA update from Marshmallow...


thankkkkkkk youuuuu veryy much brooo
yes i need december 2017 :victory::victory::victory::victory:

---------- Post added at 03:35 PM ---------- Previous post was at 03:33 PM ----------

1)Can you confirm that the flash files in your ADB terminal folder are that of the NPJS25.93-14-10 (September 2017), or the December 2017 NPJS25.93-14-13 stock ROM, and how are you flashing? Are you using a script or using the commands manually in fastboot? I think you need a complete flash before attempting to proceed.
2)How is your device appearing in Device Manager? Is it fastboot athene s or Moto G4 ?
3)Looks like you have a September 2017 bootloader but still a Marshmallow based system and baseband, hence suggesting the flashes you're performing did not work. When you flash again, can you please paste the flash log here?
4)I would caution against using 'fastboot erase system' with a device in this state.

---------- Post added at 05:20 PM ---------- Previous post was at 05:16 PM ----------



Which GPT/bootloader do you need? September and June 2017 are in the main post. If you need the December 2017 GPT/bootloader, it's here: https://drive.google.com/drive/folders/0B-GUyOfb8OgzcUl1NUtHYWNIR2M

They've all been extracted from their respective stock ROMs.

I hope you didn't hard brick by taking an OTA update from Marshmallow...

bro is there any way to change Software status : modified to official
as i am unable to play pokemon go
for Safetynet test
thankk youu soo muchh broo
 

Top Liked Posts

  • There are no posts matching your filters.
  • 121
    Disclaimer :
    Code:
      #include<disclaimer.h>
     I am not responsible for bricked devices, dead SD cards,
     thermonuclear war, or you getting fired because the alarm app failed. 
     YOU are choosing to make these modifications,
     and if you point the finger at me for messing up your device, I will laugh at you.
     and also I shall not guarantee this method will work on your device.

    Hello guys,

    as you guys know lots of Athenes are bricked due to the last June security patch and latest blankflash's also were not working.
    and there was also some confusion between which blankflash to flash and which boot-loader and gpt files to flash.. So I will try to clarify this confusion at my best..... :)
    so lets get started......

    So, First of all download the latest BlankFlash by @marcelofilgueira [ MANY MANY HUGE THANKS TO HIM ]
    Here : https://drive.google.com/file/d/0B9rhtqQ4ZTDnTWdpX3ZaVk1pNk0/view

    There is a New BlankFlash file Provided by @rajatgupta1998
    https://forum.xda-developers.com/showpost.php?p=79013024&postcount=523
    It is available here: https://androidfilehost.com/?fid=1395089523397903736
    I can't test this blankflash because I don't have G4 Plus anymore...

    and Then connect your phone to PC( Your phone should Be detected as QualcommLoader or something like that in device manager under the ports section )
    Once connected, extract the Blankflash zip and run Blank-Flash.bat

    A command window will be open and it will flash some files to your phone....
    after 5-6 sec, your Phone will be rebooted to Fastboot Mode :D First sign of Life.... lol
    But process is not over yet....

    Now download the latest Bootloader and GPT files for the version NPJS25.93-14-8 Thanks to @tywinlannister7 and @echo92
    HERE : https://drive.google.com/open?id=0B-GUyOfb8Ogzamt6ME5fYncwdjg
    And if above files won't work then here are the Sept Patch Files of GPT and Bootloader : https://drive.google.com/file/d/0B-GUyOfb8Ogzc25FdW1WUDBMS1U/view
    and Also here are the GPT and boot-loader files for December patch if above won't worked : https://drive.google.com/open?id=1IfAX7v94ooB5wS7KTJGNYfQ2kXkHxP80
    and extract them into New folder. and don't forget to copy ADB and the fastboot files into that folder.
    ADB and Fastboot DOWNLOAD HERE : https://www.androidfilehost.com/?fid=673368273298979521
    Hold Shift key and press right key on the mouse and click on open command window in that folder and Paste the following command and then press Enter :
    Code:
    fastboot flash partition gpt.bin
    fastboot flash bootloader bootloader.img
    fastboot reboot-bootloader


    Once done then You can see the Fastboot mode on your screen ;)....

    The next step is easy, You just need to flash stock ROM, But you just can't flash older ROM i.e. downgrade this time, Otherwise your device can be bricked again...

    So I will recommend you to download latest ROM NPJS25.93-14-10 and Flash it. Thanks to @tywinlannister7 for providing the ROM
    DOWNLOAD LINK : https://drive.google.com/file/d/0B9tngVBGIajVQkQtLUUxR2NOTnc
    LATEST DECEMBER ROM: https://www.androidfilehost.com/?fid=745849072291698845
    Download it and then just extract it in and don't forget copy ADB and the fastboot files into that folder. Once done then Hold shift and press right key on mouse then select Open Command window here from that menu.
    then use this code to flash stock ROM :

    Code:
    fastboot oem fb_mode_set
    fastboot flash partition gpt.bin
    fastboot flash bootloader bootloader.img
    fastboot flash logo logo.bin
    fastboot flash boot boot.img
    fastboot flash recovery recovery.img
    fastboot flash dsp adspso.bin
    fastboot flash oem oem.img
    fastboot flash system system.img_sparsechunk.0
    fastboot flash system system.img_sparsechunk.1
    fastboot flash system system.img_sparsechunk.2
    fastboot flash system system.img_sparsechunk.3
    fastboot flash system system.img_sparsechunk.4
    fastboot flash system system.img_sparsechunk.5
    fastboot flash system system.img_sparsechunk.6
    fastboot flash system system.img_sparsechunk.7
    fastboot flash modem NON-HLOS.bin
    fastboot erase modemst1 
    fastboot erase modemst2 
    fastboot flash fsg fsg.mbn
    fastboot erase cache 
    fastboot erase userdata 
    fastboot erase customize
    fastboot erase clogo
    fastboot oem fb_mode_clear
    fastboot reboot
    pause
    And that's it!! You will get your Athene Back to Life :cool:
    I got my Athene back to life using this method............
    ------------------------------------------------------------------------------------------------------------------------------------

    IMPORTANT NOTE:
    If You've Updated your Device to the February Security Patch Then this method probably won't work because the GPT and boot-loader version is higher then the version included inside the BlankFlash
    So Be Careful...!

    ------------------------------------------------------------------------------------------------------------------------------------

    Now anyone who's getting errors, see post #2

    ------------------------------------------------------------------------------------------------------------------------------------

    Credits :

    blankflash.zip provided by @marcelofilgueira HUGE THANKS TO HIM
    Thanks to @strongst for being always there to help
    Thanks to tywinlannister7 for latest June Stock ROM
    and also thanks to you guys for reading this........

    if you like my work then please HIT that THANKS button
    5
    Reserved 1

    Now anyone who is getting 'Waiting for devices' error while flashing, here are some tips to fix it :

    1) Remove the USB cable and reinsert it
    2) Make Sure your device is detected in Bootloader interface aka Fastboot mode, you can simple see your device listed in device manager.
    3) Install Motorola Driver IF you haven't Installed it yet. Because it can be the main reason for this error. Download it from motorola website: http://motorola-mobility-en-in.custhelp.com/app/answers/detail/a_id/88481
    5
    Reserved 2

    Get latest Stock Firmware for any model of Moto G4 and G4+
    from here : https://forum.xda-developers.com/moto-g4-plus/how-to/stock-rom-npjs25-93-14-4-march-1-t3608138
    :fingers-crossed:
    5
    Here's a new blankflash file from OPJ28.72 build, this should work on OPJ28.111-22 as the bootloader version is same.
    Obviously I can't test it since I haven't bricked my phone. Any other news shall be given out whenever it appears.

    Download:
    blankflash_athene_8.1.0_OPJ28.72.zip
    MD5: ada83fc6809218084739ca0cc87c9f4a

    ;)
    4
    We need a updated blank flash i... Cos have install latest bootloader
    Can you please stop posting repeatedly in a demanding way? There's no newer blank flash at the moment so you have to wait if you don't want to spent money.

    Every android release users don't read/search before downgrading and taking ota and complain that there's no solution asap.
    You cannot expect that people fix YOUR faults if you have no patience.

    Thanks for understanding:)

    PS @echo92: as I expected https://forum.xda-developers.com/mo...-g4-starting-to-receive-t3839072/post77547833
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone