[GUIDE] Motorola One Power Unlock/Relock Bootloader,Flashing Custom Recovery,Rooting

Search This thread


New member
Jul 15, 2009
cannot relock the bootloader


I can't lock the bootloader on Motorola One - basic model 3GB / 32GB - (deen) XT1941-4 - RETEU.

I found a lot of instructions (fastboot), but none of them help. It looks like I have downloaded the wrong stock firmware from the internet. I still see boot img validation error. But why ? When do I use (I think at least) original stock firmware ?

I tried to follow about 3 procedures that I found, but none of them help and even if I use stock firmware, I get an error with boot.img validation.

Before that, I flash the entire firmware. I successfully unlocked the bootloader before flashing. I don't even know why anymore ... maybe it's not necessary :). There was a problem with non-functional SIM cards (this was not blocking the mobile operator). After flashing, everything works. I just want to get rid of the "unlocked bootloader" message. I'm using the stock firmware only.

I tried the procedures for locking the bootloader with the following firmware:

(Of course, I also flashed them on the phone.)
Source: mirrors.lolinet.com

Where can I find the 100% stock firmware ? I mean original firmware, already with google security patch for the date 2019-oct. In the instructions for flashing Motorola One on the xda-developer forum, it is written that the firmware must not be flashed with the older google security patch (there is a risk of device bricking).

The main reason is that I want to remove the annoying message when booting the phone. Maybe it would help to unroot the phone + TWRP and then flash some alternative firmware such as LineageOS ? Will this message disappear when the phone is restarted and booted?


OK. Problem is solved. I flashed the alternative "logo.bin", which also contains a replacement image instead of a warning image of the unlocked bootloader. https://forum.xda-developers.com/motorola-one/themes/logo-bin-unlocked-bootloaders-t3870159 Thanks to @tys0n.


  • warning_bootloader_has_been_unlocked.jpg
    139.8 KB · Views: 79
Last edited:


New member
Jul 4, 2020
Relocking failed bro I need help
error is
C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot oem lock
(bootloader) slot-suffixes: not found
(bootloader) slot-suffixes: not found
Aug 31, 2020
Hi guys, i'm having problems with ADB or the phone. When i tried to boot with TWRP the cmd is getting me this error.
I have enabled OEM unlocking and USB debugging and i tried with the both. :confused:

C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot boot twrp.img
downloading 'boot.img'...
OKAY [ 0.682s]
FAILED (remote failure)
finished. total time: 1.587s

I'm getting same error, After unlocked bootloader & allowed USB debugging


Apr 18, 2015
Hello. I can't unlock my bootloader, why do I get this message? My phone is xt1941-4. I mention that I can boot TWRP but I can't flash anything (probably because the bootloader isn't unlocked...
C:\Users\andre\OneDrive\Desktop\platform-tools>fastboot oem get_unlock_data
(bootloader) Unlock data:
(bootloader) 3A55450119516821#
(bootloader) 5A4C353232384E475351006D6F746F726F6C0000#
(bootloader) 9F166E4D1ECF117D14935E4D8FF30F9DD91B3F3B#
(bootloader) 48F9587C000000000000000000000000
OKAY [ 0.017s]
C:\Users\andre\OneDrive\Desktop\platform-tools>fastboot oem unlock QFFNYCGHQMPOMEF7NLEK
(bootloader) invalid boot state
OKAY [ 0.003s]
Finished. Total time: 0.004s


New member
May 13, 2020
Hey, I'm Facing isuue for unlocking bootloader. I Try same procedure but still not able to unlock bootloader.
Screenshot 2021-01-30 074109.png


New member
Jul 27, 2020
I am trying to unlock the Bootloader, when I try the ome get_unlock_data I am only getting one line of code back
does anyone know the reason for that and possible fix ?


Senior Member
May 26, 2019
Xt1941-3 relocking bootloader not working please help I tried all the combinations of commands still no luck it still says "still require signed boot.img"


New member
Jul 15, 2022
Unable to unlock

C:\adb>fastboot oem get_unlock_data
(bootloader) slot-counttas: not found
(bootloader) slot-suffixe: not found
(bootloader) slot-suffi: not found
FAILED (remote: unknown command)
finished. total time: 0.001s

Hello I am getting this error, I have enabled OEM unlocking and USB debugging. Also the phone is showing in fastboot boot while typed the command "fastboot devices". Any help ?
Even I am facing the same issue. I have downloaded the moto driver, minimal adb and fastboot. I have turned on oem unlocking and usb debugging. While i try to get_unlock_data, i am getting the following errors. I have tried it multiple times like said. Any help is much appreciated.


  • Screenshot (3).png
    Screenshot (3).png
    135.9 KB · Views: 15


New member
Sep 27, 2022
Im unable to unlock bootloader of moto one power.
(1st attempt)
C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot oem get_unlock_data
(bootloader) Failed to get unlock data.
OKAY [ 0.011s]
finished. total time: 0.011s

After running "fastboot getvar all" code
C:\Program Files (x86)\Minimal ADB and Fastboot>fastboot getvar all
(bootloader) kernel: uefi
(bootloader) version-bootloader: MBM-3.0-chef_retail-06369b83c90-210922
(bootloader) product: chef
(bootloader) board: chef
(bootloader) secure: yes
(bootloader) hwrev: PVT
(bootloader) radio: APAC
(bootloader) storage-type: eMMC
(bootloader) emmc: 64GB SAMSUNG DH6DMB RV=08 PV=05 FV=0000000000000005
(bootloader) ufs: N/A
(bootloader) ram: 4GB SAMSUNG LP4x DIE=16Gb M5=01 M6=06 M7=10 M8=12
(bootloader) cpu: SDM636 1.0 (1)
(bootloader) serialno: ZF6224355M
(bootloader) cid: 0x0000
(bootloader) channelid: 0x00
(bootloader) uid: 1D08F0C5
(bootloader) securestate: oem_locked
(bootloader) verity-state: enforcing (0)
(bootloader) iswarrantyvoid: no
(bootloader) max-download-size: 536870912
(bootloader) reason: Volume down key pressed
(bootloader) imei: 354143094077815
(bootloader) meid:
(bootloader) date: 10-16-2019
(bootloader) sku: XT1942-2
(bootloader) carrier_sku: XT1942-2
(bootloader) battid: SB18C28956
(bootloader) battery-voltage: 3648
(bootloader) iccid:
(bootloader) cust_md5:
(bootloader) max-sparse-size: 268435456
(bootloader) ro.build.fingerprint[0]: motorola/chef/chef_sprout:10/QPTS3
(bootloader) ro.build.fingerprint[1]: 0.61-18-16-19/da2f0:user/release-k
(bootloader) ro.build.fingerprint[2]: eys
(bootloader) poweroffalarm: 0
(bootloader) ro.build.version.full: <not found>
(bootloader) ro.build.version.qcom: LA.UM.8.2.r1-04300-sdm660.0
(bootloader) version-baseband: M636_31.85.01.104R CHEF_APDSDS_CUST
(bootloader) kernel.version[0]: Linux version 4.4.192-perf+ ([email protected]
(bootloader) kernel.version[1]: oid-build) (gcc version 4.9.x 20150123 (
(bootloader) kernel.version[2]: prerelease) (GCC) ) #1 SMP PREEMPT Wed S
(bootloader) kernel.version[3]: ep 22 12:35:38 CDT 2021
(bootloader) git:abl: MBM-3.0-chef_retail-06369b83c90-210922
(bootloader) git:xbl: MBM-3.0-chef_retail-efaf0cccb-210922
(bootloader) git:pmic: MBM-3.0-chef_retail-efaf0cccb-210922
(bootloader) git:rpm: MBM-3.0-chef_retail-0dc899d-210922
(bootloader) git:tz: MBM-3.0-chef_retail-1c4710449-dirty-210922
(bootloader) git:hyp: MBM-3.0-chef_retail-1c4710449-dirty-210922
(bootloader) git:devcfg: MBM-3.0-chef_retail-1c4710449-dirty-210922
(bootloader) git:cmnlib: MBM-3.0-chef_retail-1c4710449-dirty-210922
(bootloader) git:cmnlib64: MBM-3.0-chef_retail-1c4710449-dirty-210922
(bootloader) git:keymaster: MBM-3.0-chef_retail-1c4710449-dirty-210922
(bootloader) git:prov: MBM-3.0-chef_retail-1c4710449-dirty-210922
(bootloader) git:storsec: MBM-3.0-chef_retail-1c4710449-dirty-210922
(bootloader) frp-state: no protection (77)
(bootloader) ro.carrier: unknown
(bootloader) current-slot: b
(bootloader) running-bl-slot: _b/_b
(bootloader) running-boot-lun: 0
(bootloader) slot-count: 2
(bootloader) slot-successful:_a: yes
(bootloader) slot-successful:_b: yes
(bootloader) slot-unbootable:_a: yes
(bootloader) slot-unbootable:_b: no
(bootloader) slot-retry-count:_a: 5
(bootloader) slot-retry-count:_b: 6
all: listed above
finished. total time: 0.181s

What should I do next?

Top Liked Posts

  • There are no posts matching your filters.
  • 12



    NOTE: Unlocking the bootloader will Wipe/ factory reset your device, and will delete
    all personal data from your device such as apps, photos, messages, and settings.


    1. Make sure to take a backup of your entire device data.
    2. Go to Settings>About Phone>Tap build number continuously until you enable developers option,under developers option enable oem unlocking.
    3. Download the Minimal ADB and Fastboot.
    4. Install the latest Motorola USB Drivers.
    5. Put your device in fastboot mode (power off, then press the power and volume down buttons simultaneously).
    6. In Search Menu, search for Minimal ADB and Fastboot and open it.
    7. Connect your Phone to PC.
    8. Type this in the CMD prompt window:- fastboot oem get_unlock_data
    9. You will get a return string.The returned string will be used to retrieve your unlock key. Copy it. [Right Click-Mark- Mark the text by pressing the shift key-Now press Ctrl+C]
    10. Paste all the lines together in a notepad. Remove the empty spaces.

      On a Windows Desktop, the returned string format would be
      $ fastboot oem get_unlock_data
      (bootloader) 0A40040192024205#4C4D3556313230
      (bootloader) 30373731363031303332323239#BD00
      (bootloader) 8A672BA4746C2CE02328A2AC0C39F95
      (bootloader) 1A3E5#1F53280002000000000000000
      (bootloader) 0000000

      Paste together the 5 lines of output into one continuous string without (bootloader) or ‘INFO’ or white spaces. Your string needs to look like this:
    11. Now go to the Motorola Site. Sign in using your Google account or Motorola ID. Scroll down the page and paste the copied string in the field at step #6. Then click on ‘Can my device be unlocked?’, after which a "REQUEST UNLOCK KEY" button will appear at the bottom of page.
    12. To get your unlock key, select the ‘I Agree’ option. Note: You will receive an email with your Unlock Key at the email address you used to log in there.
    13. Important – Copy the 20-character key that Motorola sent you via email. Make sure your device is connected.
    14. Then in CMD type: fastboot devices (To check your device is connected)
    15. Then type: fastboot oem unlock UNIQUE_KEY

      NOTE:- In above command, replace the word ‘UNIQUE_KEY’ with the unlock code that you got via email. Then hit enter and the unlocking process should begin.Once done your device will reboot.



    1. Boot into fastboot mode.
    2. Open cmd and type:- fastboot oem lock
    3. Done.


    Method 1:

    Currently we don't have a separate recovery partition to flash recovery directly,so we have to temporarily boot twrp by the following process.


    1. Download the lastest TWRP Recovery from here.
    2. Rename the downloaded recovery to twrp.
    3. Boot device into fatboot mode.
    4. Connect device to PC.
    5. Open CMD in the downloaded folder and type:- fastboot boot twrp.img
    6. Done.

    Method 2:
    Thanks to @lalitjoshi06 for the permanent twrp installer.
    Follow the instructions from his thread TWRP INSTALLER



    1. Download the latest Magisk Stable/Beta Zip from here.
    2. Boot into custom recovery
    3. Flash the downloaded zip
    4. Reboot


    Version Information:-
    Status:- Stable

    Created 2018-10-26
    Last Updated 2019-01-15
    About flashing recovery shouldn't it be, fastboot flash recovery twrp.img

    Actually fastboot boot twrp.img is used to boot using twrp. It'll only happen once and will leave you stock recovery untouched after next reboot. It just boots the twrp for once. While fastboot flash recovery twrp.img is used to replace stock recovery with twrp.
    I think this is the case.

    There are some devices that won't let you boot directly like this and others will boot the image in a one go.

    Someone correct me if I am wrong.

    I'll suggest you to use command "fastboot flash recovery twrp.img" to avoid any problems.
    Unable to unlock

    C:\adb>fastboot oem get_unlock_data
    (bootloader) slot-counttas: not found
    (bootloader) slot-suffixe: not found
    (bootloader) slot-suffi: not found
    FAILED (remote: unknown command)
    finished. total time: 0.001s

    Hello I am getting this error, I have enabled OEM unlocking and USB debugging. Also the phone is showing in fastboot boot while typed the command "fastboot devices". Any help ?
    C:\adb>fastboot oem get_unlock_data
    (bootloader) slot-counttas: not found
    (bootloader) slot-suffixe: not found
    (bootloader) slot-suffi: not found
    FAILED (remote: unknown command)
    finished. total time: 0.001s

    Hello I am getting this error, I have enabled OEM unlocking and USB debugging. Also the phone is showing in fastboot boot while typed the command "fastboot devices". Any help ?
    Try again. It happens sometimes