• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
  • Fill out your device list and let everyone know which phones you have!    Edit Your Device Inventory

[GUIDE] New method to install Google Mobile Services on Huawei P40 and other phones

Search This thread

Deffault

Member
Jul 7, 2008
12
13
[GUIDE] New method to install Google Mobile Services on Huawei P40 / Mate 30 and other phones without GMS

Hi guys!!!

I'm thrilled to report that I just found this new way to get Google Mobile Services to work on Huawei and Honor devices that don't have them.

It's totally working [today is 20 june 2020] and it SOLVES the new problem that doesn't let the users sign-in to their Google accounts at the time of the installation.

Everything is very detailed and shown step-by-step on the following video...




Please be sure to download the .zip file that has all the stuff needed to get this to work. Using this method, that zip file must be copied to the root a pen-drive. It's here, for Android 10: https://bit.ly/2ATWPGE


[UPDATE - 29 / June / 2020]

Important stuff:
- You must have your phone in english in order to proceed with this method.
- After it is complete you can switch back to your preferred language, without problems.
- If you want to add more Google accounts, you should do this procure while you are installing GMS. Use this link: https://youtu.be/jgCN6SeP32c?t=1418 It guides directly to the right moment in that video.



By the way, it's working great for a lot of users. Push notifications, though, aren't working.
Still, I believe this is the best method around.


Cheers!
 
Last edited:

DTBrum

Senior Member
Apr 25, 2010
116
10
Birmingham
Just tried it - not working for me. Got passed the sign in issue where the old method failed, and successfully created a google account. However I get the message at the end of the process that my device isn't Google Play certified. I followed video to the end where I repeat the uninstalling and re-installing the last items again, but still the same error. I can get Play Store to run, and download aps, eg Gmail, but when I run it, there is the same error about play services not supported.

UPDATE.
Repested the last few stages AGAIN and now - Gmail runs and I can see my emails, however after a few seconds it closes every time.
Play store is no longer working.
Getting an "Error while retrieving information from serve: DF-DFERH-01"

I'll keep trying I guess
 
Last edited:

DTBrum

Senior Member
Apr 25, 2010
116
10
Birmingham
OK, giving up. I have repeated the uninstall, reinstall steps several times now and can't get it to work. Interestingly, in Device ID software my phone no longer shows any information for Google Services Framework, IMEI, SIM Subscriber ID, Sim Card, Hardware Serial. I'm guessing this is why Play Store won't run. Have tried rebooting.
Going to remove everything and reboot. Have to wait for another guide/work around.
 

matzedin

Member
Jan 27, 2006
29
3
Just tried it - not working for me. Got passed the sign in issue where the old method failed, and successfully created a google account. However I get the message at the end of the process that my device isn't Google Play certified. I followed video to the end where I repeat the uninstalling and re-installing the last items again, but still the same error. I can get Play Store to run, and download aps, eg Gmail, but when I run it, there is the same error about play services not supported.

UPDATE.
Repested the last few stages AGAIN and now - Gmail runs and I can see my emails, however after a few seconds it closes every time.
Play store is no longer working.
Getting an "Error while retrieving information from serve: DF-DFERH-01"

I'll keep trying I guess


same issue here..

the "new Method" works only temp...

- it works only on english system language
- after change to german system language, you get this error: Error while retrieving information from serve: DF-DFERH-01"
- or this can be fixed b ycleared cache and data of the services framework again (+force stop) but than you are can access google pay store but than the notifcation issue starts again.

Its not 100% and its not heaven and not better as any other methods on the past. It only fix the "google server can not be reached issue" and add two more problems..
 
Last edited:
  • Like
Reactions: dltdt82

antony1020

Member
Aug 29, 2015
14
1
[GUIDE] New method to install Google Mobile Services on Huawei P40 / Mate 30 and other phones without GMS

Hi guys!!!

I'm thrilled to report that I just found this new way to get Google Mobile Services to work on Huawei and Honor devices that don't have them.

It's totally working [today is 20 june 2020] and it SOLVES the new problem that doesn't let the users sign-in to their Google accounts at the time of the installation.

Everything is very detailed and shown step-by-step on the following video...




Please be sure to download the .zip file that has all the stuff needed to get this to work. Using this method, that zip file must be copied to the root a pen-drive. It's here, for Android 10: https://bit.ly/2ATWPGE

I'll detail the method here (in text), but right now I just wanted to let everyone know that this exists and it's heaven.


Cheers!

For me everything is working fine except google push service. Not receiving notification for most of the apps.
 
Last edited:

denzel09

Senior Member
Jun 28, 2009
4,234
876
Teheran
same issue here..

the "new Method" works only temp...

- it works only on english system language
- after change to german system language, you get this error: Error while retrieving information from serve: DF-DFERH-01"
- or this can be fixed b ycleared cache and data of the services framework again (+force stop) but than you are can access google pay store but than the notifcation issue starts again.

Its not 100% and its not heaven and not better as any other methods on the past. It only fix the "google server can not be reached issue" and add two more problems..

You are wrong. You are writing many wrong things. I used this method on my P40 in asian language and all works good. No notifications after reboot or similar. That DF-DFERH-01 error is a common problem that can come out also on previous guides. You need to reset your device and start following the guide from scratch.
 

matzedin

Member
Jan 27, 2006
29
3
You are wrong. You are writing many wrong things. I used this method on my P40 in asian language and all works good. No notifications after reboot or similar. That DF-DFERH-01 error is a common problem that can come out also on previous guides. You need to reset your device and start following the guide from scratch.

please: shut up..and dont provide fake infos: i had reset the device 20 ! times this night! It dont work!

Or can you explain me why thee notification is still coming after installing the file of step 5 but NOT before as i installed file STEP 4!
 
Last edited:

denzel09

Senior Member
Jun 28, 2009
4,234
876
Teheran
For me everything is working fine except google push service. Not receiving notification for most of the apps.

That's normal ;)

---------- Post added at 02:17 PM ---------- Previous post was at 02:15 PM ----------

OK, giving up. I have repeated the uninstall, reinstall steps several times now and can't get it to work. Interestingly, in Device ID software my phone no longer shows any information for Google Services Framework, IMEI, SIM Subscriber ID, Sim Card, Hardware Serial. I'm guessing this is why Play Store won't run. Have tried rebooting.
Going to remove everything and reboot. Have to wait for another guide/work around.

That's a common problem also with old guides. You need to reset completely your device and follow the guide from scratch until the Device ID appears again.
 

DTBrum

Senior Member
Apr 25, 2010
116
10
Birmingham
That's normal ;)

---------- Post added at 02:17 PM ---------- Previous post was at 02:15 PM ----------



That's a common problem also with old guides. You need to reset completely your device and follow the guide from scratch until the Device ID appears again.

I'll wait until others post about their experiences. I have wiped my device, done a full factory reset. Interestingly I tried my online banking app before wiping it - it reported me as signing in from another device. It listed this phone and the phone from yesterday (same handset) before I attempted this as 2 different devices. So I'm wondering if this works by sending some spoof ID (or even changes ID) to Google to get it as an authorised device, especially as a lot of the info was missing from Device ID? Play store was originally working up until you have to start uninstalling and re-installing files.

I may be tempted again at some point, especially if there is a way of doing this that works long term. But for now I think I will invest my time in finding alternatives to Google apps and look to moving my info across there. The only thing I used on a regular basis and will miss is the contactless payments., especially with Covid19. I can get emails working using another app that has access to Gmail. It's easy enough to export your data if you want to ditch Google. So far I've only encountered 2 non Google apps I use that refuse to run, FlightRadar24 (geek alert) and Ebay. It should be possible to access these from browser, I guess - not tried yet. And I have a good alternative for YouTube that works great as well. I can even use the online banking. Only had the phone 2 days, so still enjoying trying something different to my previous Samsung phones.
 
  • Like
Reactions: LevsOG

solmy

Member
Jan 19, 2008
9
0
Those who still have the problem
Do stop and delete
Google Play services
Google Services Framework

Install them again
Step 3
Google Services Framework
Then
Step 5
Google Play services

Restart the phone

Repeat the process if the problem is still
 

klebengan

Senior Member
Apr 23, 2011
472
97
Jogjakarta
i did that at least 50 times and still not working
this must me proceed all 24h..sometimes 2 times a day..that really bad!
this the simplest and shortest way. always work with me
https://www.youtube.com/watch?v=QDtx_wdR_Yc

I noticed that my Google Play Services has an update in the Play Store. Do you think I should just leave it alone or should I update it? I don't want to break the whole thing again
dont update it. it will overwrite the gms core mod 2. error notification will appear agaoin
 

DTBrum

Senior Member
Apr 25, 2010
116
10
Birmingham
this the simplest and shortest way. always work with me
https://www.youtube.com/watch?v=QDtx_wdR_Yc

That way hasn't worked for some time as it fails where you have to sign in to your Google account.
The updated way gets you to sign in from your browser.

The issue is something breaks once you start the uninstall and reinstall part. I had Play store running fine, and notifications coming through. Device ID doesn't show up any information about the phone any more and I get the error the device isn't authorised for use on Google Play services.

At the end of the video it states the steps to take if it doesn't work. Repeated them numerous times with no success. Factory reset phone and gave up.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    [GUIDE] New method to install Google Mobile Services on Huawei P40 / Mate 30 and other phones without GMS

    Hi guys!!!

    I'm thrilled to report that I just found this new way to get Google Mobile Services to work on Huawei and Honor devices that don't have them.

    It's totally working [today is 20 june 2020] and it SOLVES the new problem that doesn't let the users sign-in to their Google accounts at the time of the installation.

    Everything is very detailed and shown step-by-step on the following video...




    Please be sure to download the .zip file that has all the stuff needed to get this to work. Using this method, that zip file must be copied to the root a pen-drive. It's here, for Android 10: https://bit.ly/2ATWPGE


    [UPDATE - 29 / June / 2020]

    Important stuff:
    - You must have your phone in english in order to proceed with this method.
    - After it is complete you can switch back to your preferred language, without problems.
    - If you want to add more Google accounts, you should do this procure while you are installing GMS. Use this link: https://youtu.be/jgCN6SeP32c?t=1418 It guides directly to the right moment in that video.



    By the way, it's working great for a lot of users. Push notifications, though, aren't working.
    Still, I believe this is the best method around.


    Cheers!
    4
    Alrighty guys, I'm back with a working method for Google Assistant Voice Prompts!

    Firstly, install "Hotword Tasker Plugin".

    https://play.google.com/store/apps/details?id=nl.jolanrensen.hotwordPluginFree

    Also, download the tasker project file I have made for this. See below changelog and download links!

    Changelog:

    Version 1.0.1:

    Scrap all other links, I hadn't put the profile in to the project so no idea if it had it included in the previous exports but try this one guys ?

    This will listen for "Ok, Google" or "Hey, Google" IF the screen is on and proximity sensor is not covered - this is incase it is triggered in your pocket like it kept doing for me! ?

    There's also a task in this project which you can create a tasker task shortcut widget to toggle the Hotword plugin on and off.
    This task requires to have AutoInput installed, from the AutoApps made by Taskers developer. You can have it free on a 24hr basis by watching a video though.

    Following people's comments about push notification issues, such as Gmail, I've included a "fix" which is a timed event profile which runs a simple task to turn auto sync off and on - this then tricks syncing process and gives you push notifications for Gmail and other Google apps.

    It is currently set at 7 hours, to save battery but feel free to change to what ever you need by editing the profile event.

    Downloads:

    Version 1.0.1

    Google Drive
    https://drive.google.com/file/d/11AhA9B77kfPiUgd0dAhbVxj_aYsMclFX/view?usp=drivesdk

    Tasker Link
    https://taskernet.com/shares/?user=...mSL/BdDPXVcn+lGZNS4=&id=Project:GoogleHotword


    Open the Hotword Plugin app, click the red + circle at the bottom, choose both Google options - so you have "Ok, Google" and "Hey, Google" and press OK.

    edit both options and turn off the "Play ding sound" option. I found it annoying anyway as Google makes its own noise.

    Then, click app settings on top right, choose "start listening on boot".

    After this, you can click "microphone service" to ON Position, top right of the screen.

    This starts the plugin and at same time it interrupts Huawei "Celia" from listening I found.

    Then, import Tasker project "Google Hotword" that we downloaded at the start.

    Then, soon as that's added, try "Hey, Google" or "Ok, Google". At this point it should all be working!

    If you like what I've done, don't forget to click thanks as I know this is bugging a lot of people!
    3
    @nibera Could you please enlighten me how you made it work? I have very similar issues as you had:
    1) I can't install HiSuite 550 version on my windows 10 pc. Nothing happens after clicking on it.
    2) I could install HiSuite 510 instead. Via HiSuite Proxy application I could choose to downgrade to 131 (I have now 147). However, the download never started. It even doesn't show the percentage of the download progress.

    Could you let me know what have you done to resolve the issues you had? Thank you!

    Hi, I'll explain what I did:

    1) after having done a thousand tests without any results, I decided to format the PC by reinstalling WINDOWS 10 Full 64 bit from scratch, then I installed my usual PC programs, and then I did windows update of the operating system, restarted and everything I left as default settings of the system operated by windows 10, therefore or left active both windows firewall and windows defender.

    2) I installed hisuite 10.0.0.550 connected the P40 was recognized by my PC and installed hisuite on my phone (while before formatting my pc this did not happen)

    3) I have performed the procedure of hisuite proxy for the downgrade but nothing always the usual message of NETWORK ERROR ETC ...

    4) at this point doing a search on the net I found the version of hisuite for pc 10.0.0.510, I uninstalled the .550 version from my pc, I restarted the pc, and installed the .510 version it recognized the P40 phone regularly

    5) consider that my phone was with .147 firmware, all my programs I use and all my settings made, I only deleted my biometric data (fingerprint and face and code), I deleted the Hawei account.

    6) I connected the phone to the pc, I immediately recognized hisuite, I started hisuite proxy by inserting this string:

    http://update.dbankcdn.com/TDS/data/files/p3/s15/G5633/g1604/v414980/f1/full/changelog_base.xml

    and then

    ELS-LGRP4-OVS 10.1.0.136

    and then setup, when I closed and reopened hisuite on the pc, I clicked on update on the pc and recognized the presentation of the firmware update of version 10.1.0.136, and then everything was successfully downloaded and installed.

    7) as soon as the emui completed the installation on the phone, I unplugged the phone's usb cable from the pc, and I pressed volume up + power to restart the phone in recovery mode, I did factory reset + wipe cache, then or restart the phone and everything went well, without problems and errors of any kind.

    8) after reboot I installed google following this video:

    https://www.youtube.com/watch?v=tFNM9hsU3cI

    and everything went well, I installed all my google apps, fully functional.

    9) only then did I update the firmware via OTA of the phone to version .147, without deleting anything, the phone restarted and everything still works.

    this is what I did.
    2
    Not sure if any of you used THIS tutorial. It works perfectly. Only thing I don't have is Gmail notifications... No errors of any kind...

    2
    i did that at least 50 times and still not working
    this must me proceed all 24h..sometimes 2 times a day..that really bad!
    this the simplest and shortest way. always work with me
    https://www.youtube.com/watch?v=QDtx_wdR_Yc

    I noticed that my Google Play Services has an update in the Play Store. Do you think I should just leave it alone or should I update it? I don't want to break the whole thing again
    dont update it. it will overwrite the gms core mod 2. error notification will appear agaoin