[GUIDE] New method to install Google Mobile Services on Huawei P40 and other phones

Search This thread

bbdxxl

New member
Mar 15, 2012
1
0
How did you update after? My phone says no updates available

I downgraded my os on P40 pro from .154 to .131 with Huawei HiSuite. After installed all GMS from 2nd time it worked, nafter 2 weeks I updated to .154 OS and now I saw some issue with youtube and google map services. But still working :)
 

mrteyssere

Senior Member
Apr 21, 2011
81
18
Hi guys. My phone is dead! I managed to use a firmware from a p40 pro and now my phone is dead!
Anyone have an idea where to find new firmwares?

My phone needs an ANA-LGRP4-OVS.
European phone.

Best,
Andy

I`m looking for ANA-LGRP4-OVS aswell. Can`t seem to find any EMUI 10 versions on Firmware Finder, only EMUI 11.

Bought in Europe, Norway. Did you manage to find a software for yours?

Edit: When plugged into HiSuite, it shows up as "ANA-NX9"..?
 
Last edited:

ploplop25

Member
Jun 21, 2020
5
0
Dubai
hi does any one having a problem with google map. When you click the cross in the bottom of the app while you are done with direction the app is crashing.

Also if i click on a google map link on google it is showing open with google services instead of maps.

Any idea?
 

zekyog

New member
Nov 6, 2020
2
0
I`m looking for ANA-LGRP4-OVS aswell. Can`t seem to find any EMUI 10 versions on Firmware Finder, only EMUI 11.

Bought in Europe, Norway. Did you manage to find a software for yours?

Edit: When plugged into HiSuite, it shows up as "ANA-NX9"..?


Have you find it? i find the same problem... ANA-LGRP4-OVS with ANA-NX9 code C301 but anyone have tried to downgrade into different kind of ANA-NX9, e.g. from C432 or C185?
 

tboy2000

Senior Member
Oct 21, 2006
2,301
426
London
Huawei Mate 20
Huawei Mate 20 X
I have GMS installed and I updated to EMUI 11. All ok so far, touch wood.

My questions are can anyone log into Vanced? I can't log into my Google account in Vanced. Any working methods please?

I initially GMS months ago from a YouTube tutorial and I would get notifications with that. With the recent Googlefier I used the other day, I don't get any push notifications from appsb like HUKD or Crux. Just basic notifications like email, messaging, Facebook Instagram I get.

So anyone get working push notifications?
 

Sau01

Member
Jun 5, 2020
11
0
Hi, since about half year ago, when I installed G services everything was alright, but from last week my G maps start crashing every time when I turn on, also G play start work and when I turn on maps I got notice "Maps won't run without G play services, which are not supported by your device'. When I reinstalling maps to older version it works one day, but next day start crashing again, any ideas?
Thanks.
 

Shymmy

Senior Member
Feb 22, 2014
394
79
Bucharest
Huawei P9
Huawei P10 Lite
Hi, since about half year ago, when I installed G services everything was alright, but from last week my G maps start crashing every time when I turn on, also G play start work and when I turn on maps I got notice "Maps won't run without G play services, which are not supported by your device'. When I reinstalling maps to older version it works one day, but next day start crashing again, any ideas?
Thanks.
I used version 10.49.3.
Today I solved it as follows:
(LE: badmania98's guide)
a) the internet connection is closed (wifi + mobile data)

b) acting (differently) on Google Services Framework files (clearing the cache, deleting data, and forcing it off), Google Play Store, (clearing the cache, deleting data, and forcibly shutting down), and Google Services Play (clears cache)
settings / Applications / Applications / 3 points / activation / Show system processes / in the search window type goo and press search:

- Google Services Framework / Storage / Clear Cache \ Clear Data \ OK \ Back \ Shut Down \ Confirm Shut Down / Back
- Google Play Store / Storage / Clear cache \ Clear data \ OK \ back \ back \ Force off \ Confirm Power off / back
- Google Play Services / Storage / Clear cache \ (no data deletion and no forced shutdown)

c) Restart the phone

d) Acting on the Google Play Services file (clearing the cache, clearing the data and forcing it to stop))
- settings / Applications / Applications / 3 points / activation / Show system processes / in the search window type goo and press search
- Google Play services / Storage / Clear cache / Manage space / Clear all data / OK / Back / Force off \ Confirm Force off \ (continued)

e) Restart the phone

f) internet access via WIFi or mobile data is turned on

g) start Google Play Store \ check that no Uncertified Device messages appear (wait 1-2 minutes without installing apps in the store or other actions). If those messages do not appear:

h) Restart the phone.
 
Last edited:
  • Like
Reactions: Jake2kOne

Tekkamen77

Senior Member
Oct 22, 2017
748
51
Xiaomi Mi 11
I used version 10.49.3.
Today I solved it as follows:

a) the internet connection is closed (wifi + mobile data)

b) acting (differently) on Google Services Framework files (clearing the cache, deleting data, and forcing it off), Google Play Store, (clearing the cache, deleting data, and forcibly shutting down), and Google Services Play (clears cache)
settings / Applications / Applications / 3 points / activation / Show system processes / in the search window type goo and press search:

- Google Services Framework / Storage / Clear Cache \ Clear Data \ OK \ Back \ Shut Down \ Confirm Shut Down / Back
- Google Play Store / Storage / Clear cache \ Clear data \ OK \ back \ back \ Force off \ Confirm Power off / back
- Google Play Services / Storage / Clear cache \ (no data deletion and no forced shutdown)

c) Restart the phone

d) Acting on the Google Play Services file (clearing the cache, clearing the data and forcing it to stop))
- settings / Applications / Applications / 3 points / activation / Show system processes / in the search window type goo and press search
- Google Play services / Storage / Clear cache / Manage space / Clear all data / OK / Back / Force off \ Confirm Force off \ (continued)

e) Restart the phone

f) internet access via WIFi or mobile data is turned on

g) start Google Play Store \ check that no Uncertified Device messages appear (wait 1-2 minutes without installing apps in the store or other actions). If those messages do not appear:

h) Restart the phone.
I used version 10.49.3.
Today I solved it as follows:

a) the internet connection is closed (wifi + mobile data)

b) acting (differently) on Google Services Framework files (clearing the cache, deleting data, and forcing it off), Google Play Store, (clearing the cache, deleting data, and forcibly shutting down), and Google Services Play (clears cache)
settings / Applications / Applications / 3 points / activation / Show system processes / in the search window type goo and press search:

- Google Services Framework / Storage / Clear Cache \ Clear Data \ OK \ Back \ Shut Down \ Confirm Shut Down / Back
- Google Play Store / Storage / Clear cache \ Clear data \ OK \ back \ back \ Force off \ Confirm Power off / back
- Google Play Services / Storage / Clear cache \ (no data deletion and no forced shutdown)

c) Restart the phone

d) Acting on the Google Play Services file (clearing the cache, clearing the data and forcing it to stop))
- settings / Applications / Applications / 3 points / activation / Show system processes / in the search window type goo and press search
- Google Play services / Storage / Clear cache / Manage space / Clear all data / OK / Back / Force off \ Confirm Force off \ (continued)

e) Restart the phone

f) internet access via WIFi or mobile data is turned on

g) start Google Play Store \ check that no Uncertified Device messages appear (wait 1-2 minutes without installing apps in the store or other actions). If those messages do not appear:

h) Restart the phone.
guys i managed to put google services ... but google maps doesn't work is normal?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 5
    [GUIDE] New method to install Google Mobile Services on Huawei P40 / Mate 30 and other phones without GMS

    Hi guys!!!

    I'm thrilled to report that I just found this new way to get Google Mobile Services to work on Huawei and Honor devices that don't have them.

    It's totally working [today is 20 june 2020] and it SOLVES the new problem that doesn't let the users sign-in to their Google accounts at the time of the installation.

    Everything is very detailed and shown step-by-step on the following video...




    Please be sure to download the .zip file that has all the stuff needed to get this to work. Using this method, that zip file must be copied to the root a pen-drive. It's here, for Android 10: https://bit.ly/2ATWPGE


    [UPDATE - 29 / June / 2020]

    Important stuff:
    - You must have your phone in english in order to proceed with this method.
    - After it is complete you can switch back to your preferred language, without problems.
    - If you want to add more Google accounts, you should do this procure while you are installing GMS. Use this link: https://youtu.be/jgCN6SeP32c?t=1418 It guides directly to the right moment in that video.



    By the way, it's working great for a lot of users. Push notifications, though, aren't working.
    Still, I believe this is the best method around.


    Cheers!
    4
    Alrighty guys, I'm back with a working method for Google Assistant Voice Prompts!

    Firstly, install "Hotword Tasker Plugin".

    https://play.google.com/store/apps/details?id=nl.jolanrensen.hotwordPluginFree

    Also, download the tasker project file I have made for this. See below changelog and download links!

    Changelog:

    Version 1.0.1:

    Scrap all other links, I hadn't put the profile in to the project so no idea if it had it included in the previous exports but try this one guys ?

    This will listen for "Ok, Google" or "Hey, Google" IF the screen is on and proximity sensor is not covered - this is incase it is triggered in your pocket like it kept doing for me! ?

    There's also a task in this project which you can create a tasker task shortcut widget to toggle the Hotword plugin on and off.
    This task requires to have AutoInput installed, from the AutoApps made by Taskers developer. You can have it free on a 24hr basis by watching a video though.

    Following people's comments about push notification issues, such as Gmail, I've included a "fix" which is a timed event profile which runs a simple task to turn auto sync off and on - this then tricks syncing process and gives you push notifications for Gmail and other Google apps.

    It is currently set at 7 hours, to save battery but feel free to change to what ever you need by editing the profile event.

    Downloads:

    Version 1.0.1

    Google Drive
    https://drive.google.com/file/d/11AhA9B77kfPiUgd0dAhbVxj_aYsMclFX/view?usp=drivesdk

    Tasker Link
    https://taskernet.com/shares/?user=...mSL/BdDPXVcn+lGZNS4=&id=Project:GoogleHotword


    Open the Hotword Plugin app, click the red + circle at the bottom, choose both Google options - so you have "Ok, Google" and "Hey, Google" and press OK.

    edit both options and turn off the "Play ding sound" option. I found it annoying anyway as Google makes its own noise.

    Then, click app settings on top right, choose "start listening on boot".

    After this, you can click "microphone service" to ON Position, top right of the screen.

    This starts the plugin and at same time it interrupts Huawei "Celia" from listening I found.

    Then, import Tasker project "Google Hotword" that we downloaded at the start.

    Then, soon as that's added, try "Hey, Google" or "Ok, Google". At this point it should all be working!

    If you like what I've done, don't forget to click thanks as I know this is bugging a lot of people!
    3
    @nibera Could you please enlighten me how you made it work? I have very similar issues as you had:
    1) I can't install HiSuite 550 version on my windows 10 pc. Nothing happens after clicking on it.
    2) I could install HiSuite 510 instead. Via HiSuite Proxy application I could choose to downgrade to 131 (I have now 147). However, the download never started. It even doesn't show the percentage of the download progress.

    Could you let me know what have you done to resolve the issues you had? Thank you!

    Hi, I'll explain what I did:

    1) after having done a thousand tests without any results, I decided to format the PC by reinstalling WINDOWS 10 Full 64 bit from scratch, then I installed my usual PC programs, and then I did windows update of the operating system, restarted and everything I left as default settings of the system operated by windows 10, therefore or left active both windows firewall and windows defender.

    2) I installed hisuite 10.0.0.550 connected the P40 was recognized by my PC and installed hisuite on my phone (while before formatting my pc this did not happen)

    3) I have performed the procedure of hisuite proxy for the downgrade but nothing always the usual message of NETWORK ERROR ETC ...

    4) at this point doing a search on the net I found the version of hisuite for pc 10.0.0.510, I uninstalled the .550 version from my pc, I restarted the pc, and installed the .510 version it recognized the P40 phone regularly

    5) consider that my phone was with .147 firmware, all my programs I use and all my settings made, I only deleted my biometric data (fingerprint and face and code), I deleted the Hawei account.

    6) I connected the phone to the pc, I immediately recognized hisuite, I started hisuite proxy by inserting this string:

    http://update.dbankcdn.com/TDS/data/files/p3/s15/G5633/g1604/v414980/f1/full/changelog_base.xml

    and then

    ELS-LGRP4-OVS 10.1.0.136

    and then setup, when I closed and reopened hisuite on the pc, I clicked on update on the pc and recognized the presentation of the firmware update of version 10.1.0.136, and then everything was successfully downloaded and installed.

    7) as soon as the emui completed the installation on the phone, I unplugged the phone's usb cable from the pc, and I pressed volume up + power to restart the phone in recovery mode, I did factory reset + wipe cache, then or restart the phone and everything went well, without problems and errors of any kind.

    8) after reboot I installed google following this video:

    https://www.youtube.com/watch?v=tFNM9hsU3cI

    and everything went well, I installed all my google apps, fully functional.

    9) only then did I update the firmware via OTA of the phone to version .147, without deleting anything, the phone restarted and everything still works.

    this is what I did.
    2
    Not sure if any of you used THIS tutorial. It works perfectly. Only thing I don't have is Gmail notifications... No errors of any kind...

    2
    i did that at least 50 times and still not working
    this must me proceed all 24h..sometimes 2 times a day..that really bad!
    this the simplest and shortest way. always work with me
    https://www.youtube.com/watch?v=QDtx_wdR_Yc

    I noticed that my Google Play Services has an update in the Play Store. Do you think I should just leave it alone or should I update it? I don't want to break the whole thing again
    dont update it. it will overwrite the gms core mod 2. error notification will appear agaoin