• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Guide] Notification FIX - Works 100%

Search This thread

mazdamiata210

Senior Member
Apr 8, 2012
685
333
Brooklyn, N.Y.
So if you are having issues with notifications not coming in or coming in late this is finally how to fix it 100% on every app. It seems to have a very slight impact on battery but nothing major. From what I saw it was about 1% per hour drain... Which is worth it for a working phone

Anyways, the way to fix this requires it to be set from a computer on every restart of the phone which is probably the biggest problem with this method. I'm working on a way to maybe have a script run at every start up to fix the issue. Which will probably require root. We'll see...

1. Download and install the ADB drivers - Follow the guide here: https://www.xda-developers.com/install-adb-windows-macos-linux/

2. Once you have ADB installed and enabled on your phone like the guide says in step 1 above, you want to be on the ADB command prompt...

Type in the command:

Code:
adb shell dumpsys deviceidle disable

The command prompt should return with:

Code:
Deep idle mode disabled
Light idle mode disabled

That's it! Now your notifications will work fine. I've tested this for a day and every notification came through on time.

Just like to add that I have adaptive battery off, and every app is set to optimize. Not sure if this makes a difference or not.

Again this must be applied on every restart (which sucks) but at least it's something, for now.
 

AlkaliV2

Senior Member
Jun 12, 2012
1,479
1,672
¯\_(ツ)_/¯
Google Pixel 6 Pro
"if you are having issues with notifications not coming in or coming in late"

What he likely meant is more specifically what applications are you having issues with. Through extended idle I'll admit OOS kills every background task, but using the Oneplus messaging app and normal google applications I'm no longer getting late notifications like I was on my Oneplus 3. There is another setting that showed up under my notifications this morning that basically detected that I had gone to sleep and put all applications on hold until I woke up, though I cannot find this setting after clicking that notification this morning.
 

stardamore

New member
Mar 29, 2016
3
0
Yeah exactly the problem, doesn't matter what app... It's random... Follow my post it'll fix it

It's a general android issue with how doze mode works. This disables doze mode. Should work on any phone honestly.

Or, you could just turn off adaptive battery.

H8O4i1e
 

Poloasis

Senior Member
Oct 11, 2010
768
174
Philadelphia
So if you are having issues with notifications not coming in or coming in late this is finally how to fix it 100% on every app. It seems to have a very slight impact on battery but nothing major. From what I saw it was about 1% per hour drain... Which is worth it for a working phone

Anyways, the way to fix this requires it to be set from a computer on every restart of the phone which is probably the biggest problem with this method. I'm working on a way to maybe have a script run at every start up to fix the issue. Which will probably require root. We'll see...

1. Download and install the ADB drivers - Follow the guide here: https://www.xda-developers.com/install-adb-windows-macos-linux/

2. Once you have ADB installed and enabled on your phone like the guide says in step 1 above, you want to be on the ADB command prompt...

Type in the command:

Code:
adb shell dumpsys deviceidle disable

The command prompt should return with:

Code:
Deep idle mode disabled
Light idle mode disabled

That's it! Now your notifications will work fine. I've tested this for a day and every notification came through on time.

Just like to add that I have adaptive battery off, and every app is set to optimize. Not sure if this makes a difference or not.

Again this must be applied on every restart (which sucks) but at least it's something, for now.

You can create a script with the command on SManager "Root required", set script on boot. I will run the command above at every boot.
 

stardamore

New member
Mar 29, 2016
3
0
That was off since day 1 and I still had the problem, it's doze mode which has to be turned off with adb

Weird, since adaptive battery's description states that it's the reason why you might get late notifications and it's supposed to fix itself with time as the OS learns your app usage habits. Anyways, you might be right.
 

geovass

Senior Member
Oct 30, 2004
1,276
113
Tested on a Mate 20 Pro and Pie is not killing the apps in the background. Huawei have the option to select Doze - per application (Apps/Special Access/Battery Optimisation).
 

Top Liked Posts

  • There are no posts matching your filters.
  • 18
    So if you are having issues with notifications not coming in or coming in late this is finally how to fix it 100% on every app. It seems to have a very slight impact on battery but nothing major. From what I saw it was about 1% per hour drain... Which is worth it for a working phone

    Anyways, the way to fix this requires it to be set from a computer on every restart of the phone which is probably the biggest problem with this method. I'm working on a way to maybe have a script run at every start up to fix the issue. Which will probably require root. We'll see...

    1. Download and install the ADB drivers - Follow the guide here: https://www.xda-developers.com/install-adb-windows-macos-linux/

    2. Once you have ADB installed and enabled on your phone like the guide says in step 1 above, you want to be on the ADB command prompt...

    Type in the command:

    Code:
    adb shell dumpsys deviceidle disable

    The command prompt should return with:

    Code:
    Deep idle mode disabled
    Light idle mode disabled

    That's it! Now your notifications will work fine. I've tested this for a day and every notification came through on time.

    Just like to add that I have adaptive battery off, and every app is set to optimize. Not sure if this makes a difference or not.

    Again this must be applied on every restart (which sucks) but at least it's something, for now.
    6
    All right! Can anybody test the magisk module i make? All i do is patch the command into magisk module and this module does is that automatically disable deep idle doze on every boot so you don't has to manually do it on terminal or tasker... I been test it a little bit and seem everything work fine...let me know how it work for you! Also i suggested that you disable adaptive optimize for best!
    Credit to OP for founding the command!
    4
    I have issues with notifications not notifying me until I wake up my phone
    3
    So if you are having issues with notifications not coming in or coming in late this is finally how to fix it 100% on every app. It seems to have a very slight impact on battery but nothing major. From what I saw it was about 1% per hour drain... Which is worth it for a working phone

    Anyways, the way to fix this requires it to be set from a computer on every restart of the phone which is probably the biggest problem with this method. I'm working on a way to maybe have a script run at every start up to fix the issue. Which will probably require root. We'll see...

    1. Download and install the ADB drivers - Follow the guide here: https://www.xda-developers.com/install-adb-windows-macos-linux/

    2. Once you have ADB installed and enabled on your phone like the guide says in step 1 above, you want to be on the ADB command prompt...

    Type in the command:

    Code:
    adb shell dumpsys deviceidle disable

    The command prompt should return with:

    Code:
    Deep idle mode disabled
    Light idle mode disabled

    That's it! Now your notifications will work fine. I've tested this for a day and every notification came through on time.

    Just like to add that I have adaptive battery off, and every app is set to optimize. Not sure if this makes a difference or not.

    Again this must be applied on every restart (which sucks) but at least it's something, for now.

    You can create a script with the command on SManager "Root required", set script on boot. I will run the command above at every boot.
    2
    What notification problems are there?

    "if you are having issues with notifications not coming in or coming in late"