• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!
Search This thread

regalstreak

Senior Member
Jun 26, 2013
1,262
4,499
Mumbai
Ok, so loads of people have faced this problem. This guide will help you to make the home button/fps work again!

Do the fingerprint sensor test first
  • Dial *#808#
  • A menu will appear
  • Select Finger print test
  • Select Finger Print auto test
  • If it says pass, you already have a working sensor
  • Reboot the phone to make it work again
  • If it says fail, follow the given methods!

Method 1
  1. Put the phone on charging
  2. Note: Do not remove the charging cable during the whole procedure
  3. Go to Settings>Apps>All
  4. Find com.oneplus.fingerprints.service
  5. Select Clear Cache
  6. Select Force Stop
  7. Press the Power button for 10 seconds until the phone is completely off
  8. Switch it on normally
  9. Check if it works or not!

Method 2
  1. Press the power button to bring up the reboot menu
  2. Long press on Power Off option
  3. Reboot to Safe Mode will appear
  4. Click ok and let it reboot
  5. Check home button if it works or not
  6. Reboot normally
  7. Tip: Try doing method 1 in method 2 when in safe mode

Method 3 <<Tested working by me
  1. Drain the battery to 0%
  2. When the phone switches off, keep pressing the power button and starting it
  3. Keep doing Step 2 for 20 times
  4. This is for draining the left over battery completely
  5. Now, charge the phone to 100% keeping it switched off
  6. Remember: Charge to 100% Works only when it is fully charged
  7. After it says "OK" and it is fully charged, keeping the charging cable in, press the power button to boot the phone
  8. Remember: DO NOT TAKE OFF THE CHARGING CABLE HERE
  9. Enable the hardware buttons from settings if you have turned them off if you have been using software buttons (Settings>Buttons)
  10. Check if the home button and fingerprint sensor works

Method 4
  1. Clean flash OOS Stock version 2.0
  2. Check if the home button works now

Best of luck!
 
Last edited:

fburgos

Senior Member
Sep 1, 2012
1,511
384
For me none of the methods worked.

I presed the sensor arround until somehow changed to homescreen guess it was a bad contact or ground issue but its been working flawless since yesterday

Sent from my ONE A2005 using Tapatalk
 

regalstreak

Senior Member
Jun 26, 2013
1,262
4,499
Mumbai
I should mention that there is a shortcut rather than having to dial the number, you can make a shortcut with any activity launcher, in fact Nova launcher for instance can do that natively.

Sent from my ONE A2003 using Tapatalk
What number? Wrong group/thread lmao
Or am i missing something

Sent from my ONE A2003 using Tapatalk
 

teeluun

Member
Oct 1, 2014
31
6
Miri
Ok, so loads of people have faced this problem. This guide will help you to make the home button/fps work again!

Do the fingerprint sensor test first
  • Dial *#808#
  • A menu will appear
  • Select Finger print test
  • Select Finger Print auto test
  • If it says pass, you already have a working sensor
  • Reboot the phone to make it work again
  • If it says fail, follow the given methods!

Method 1
  1. Put the phone on charging
  2. Note: Do not remove the charging cable during the whole procedure
  3. Go to Settings>Apps>All
  4. Find com.oneplus.fingerprints.service
  5. Select Clear Cache
  6. Select Force Stop
  7. Press the Power button for 10 seconds until the phone is completely off
  8. Switch it on normally
  9. Check if it works or not!

Method 2
  1. Press the power button to bring up the reboot menu
  2. Long press on Power Off option
  3. Reboot to Safe Mode will appear
  4. Click ok and let it reboot
  5. Check home button if it works or not
  6. Reboot normally
  7. Tip: Try doing method 1 in method 2 when in safe mode

Method 3 <<Tested working by me
  1. Drain the battery to 0%
  2. When the phone switches off, keep pressing the power button and starting it
  3. Keep doing Step 2 for 20 times
  4. This is for draining the left over battery completely
  5. Now, charge the phone to 100% keeping it switched off
  6. Remember: Charge to 100% Works only when it is fully charged
  7. After it says "OK" and it is fully charged, keeping the charging cable in, press the power button to boot the phone
  8. Remember: DO NOT TAKE OFF THE CHARGING CABLE HERE
  9. Enable the hardware buttons from settings if you have turned them off if you have been using software buttons (Settings>Buttons)
  10. Check if the home button and fingerprint sensor works

Method 4
  1. Clean flash OOS Stock version 2.0
  2. Check if the home button works now

Best of luck!

Unfortunately, neither of the 4 methods works for me.

*edit: What I did, I reformatted all data wiped all cache. Installed the latest CM13/picogapps. BAM! it's working again!
 
Last edited:
  • Like
Reactions: kankees

Elxaan

Member
Aug 5, 2013
5
2
few days ago I wrote that method 2 with charging helped, but now it stopped working again
 

aleco90

New member
Mar 9, 2016
2
0
After following step 1 and step 2 my oneplus launcher isn't responding at all. now i don't have a working phone. GREAT!!!......
 

hunter_bruhh

Senior Member
May 1, 2015
111
136
Murfreesboro
What I did was two things. First I went to system/usr/keylayout and added 102 HOME VIRTUAL to the end of that file (follow the examples in the file) and then I installed xposed, downloaded gravity box MM, turned on the option in navigation keys to disable double tapping home button, and rebooted. This fixed my home button.
 
  • Like
Reactions: zia6182

Top Liked Posts

  • There are no posts matching your filters.
  • 43
    Ok, so loads of people have faced this problem. This guide will help you to make the home button/fps work again!

    Do the fingerprint sensor test first
    • Dial *#808#
    • A menu will appear
    • Select Finger print test
    • Select Finger Print auto test
    • If it says pass, you already have a working sensor
    • Reboot the phone to make it work again
    • If it says fail, follow the given methods!

    Method 1
    1. Put the phone on charging
    2. Note: Do not remove the charging cable during the whole procedure
    3. Go to Settings>Apps>All
    4. Find com.oneplus.fingerprints.service
    5. Select Clear Cache
    6. Select Force Stop
    7. Press the Power button for 10 seconds until the phone is completely off
    8. Switch it on normally
    9. Check if it works or not!

    Method 2
    1. Press the power button to bring up the reboot menu
    2. Long press on Power Off option
    3. Reboot to Safe Mode will appear
    4. Click ok and let it reboot
    5. Check home button if it works or not
    6. Reboot normally
    7. Tip: Try doing method 1 in method 2 when in safe mode

    Method 3 <<Tested working by me
    1. Drain the battery to 0%
    2. When the phone switches off, keep pressing the power button and starting it
    3. Keep doing Step 2 for 20 times
    4. This is for draining the left over battery completely
    5. Now, charge the phone to 100% keeping it switched off
    6. Remember: Charge to 100% Works only when it is fully charged
    7. After it says "OK" and it is fully charged, keeping the charging cable in, press the power button to boot the phone
    8. Remember: DO NOT TAKE OFF THE CHARGING CABLE HERE
    9. Enable the hardware buttons from settings if you have turned them off if you have been using software buttons (Settings>Buttons)
    10. Check if the home button and fingerprint sensor works

    Method 4
    1. Clean flash OOS Stock version 2.0
    2. Check if the home button works now

    Best of luck!
    5
    OK my home button died again today.

    5ca48527a958d9d5970625f5c38ac4cc.jpg


    Flashed oos no luck *#808# test fail
    Restored exodus, this problem must be hardware issue.

    Step one read some disassembly guide
    Step two remove back panel
    Step tree remove battery connection.
    Step four remove every other connector, but I notice some of the bottom one didn't make a click disassembly sound it was very easy to come off so I pushed back in until I fell and hear the snapping sound checked every other connector and found two were "loose" or not all the way in as it supposed to be.

    A picture indicating the loose connectors

    efd08bec2eb70c41770efb0a3d823437.jpg


    Step five put on the battery and boot exodus ROM and voilà FP working again.

    71e42ab6c4cd4a77662ca0d1480a9ae2.jpg





    Sent from my ONE A2005 using Tapatalk
    3
    Wow I should have came across this thread before!
    I had this issue before, but I fixed this issue with a clean install to OOS 2.2.0 myself.

    Overall, nice post OP!
    2
    Will keep this in bookmarks, because as a regular thing, this device should break my home button too. :D

    Thanks so much buddy.
    2
    Method 2

    Method 2 worked for me! I've tried a lot of things, including Safe Mode things. but this time Method 2 while charging worked! Thank you very much!