• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[guide]Package Installer will not install apk's - Cancel works but not Install button

Top Liked Posts

  • There are no posts matching your filters.
  • 64
    I practically ran into the same problem as outlined above. Since googling for this issue was not straightforward, I thought it wise to make the answer to this issue into a micro-guide.

    I can no longer install apps (apk's) from the Amazon App Store, or from downloaded apk files, but the market works fine.
    I am not rooted, and I am still running 3.2 (US). This started in the last few days, but I can't think of anything that I have done.
    I cold booted, but I still get the same results; The install dialog box comes up with the options at the bottom "Install" or "Cancel", however, install does nothing, the window is active because you can press "Show All", or "Cancel" and those do work, but not "Install". I can't think of anything that I have overlooked.
    Any Ideas?

    http://www.transformerforums.com/fo...-package-installer-will-not-install-apks.html

    The most a) likely solution comes in the form of b) security applications interfering with the installation, c) package incompatibility with the device or screen filter applications used to lower the device's brightness below the minimal limit of the Brightness settings.

    In my case it was the application "Lux" which was to blame. Thus make sure to untick "stay alive in the "generals" option menu. And kill the Lux app. Now installation proceeds unhindered. Avast was not at fault. So don't freak,- often the solutions are trivial - finding the answers isn't.


    Thanks to anyone who contributed in the original thread and to xda.
    8
    Re: Install apk problem - install button not working

    Oh man, thanks for this! For me, it was the app 'Screen Adjuster' that was blocking apps from being installed. I turned that off, and I finally have an ad blocker again!

    Droid Razr xt910 for the record.


    Re: Install apk problem - install button not working
    If not already done:

    Settings -> Apps -> All -> Package Installer Clear Cache & Data, Force Stop, reboot. If this doesn't work repeat, but reboot into recovery and wipe the cache partition.

    Still having issues try AppInstaller. Still having issues, there must be a bad system app (frameworks?) that needs clearing and force closed.

    100% work
    3
    I had this inssue too. It's problem with apps which work in background and creating some overlay elements. Disable all this apps and than you can install normally. I had this problem on P.A.C. Rom, after addition of HALO :)

    Sorry for my bad english ;)
    2
    softbuttons light did it

    I have the same problem, but I have no programs listed.
    I tried to disable the automatic brightness control Sony, the Sony Bravia mode, the interactive lockscreen (DashWidget) LightFlow, ....
    But it's the same
    I can not find what apply blocks installation


    Removing softbuttons light from domenico Messina resolved my problem.
    It's Obvious that you have to look for a installed app that does something with youre screen.

    succes
    2
    Another app causing the issue

    Velis Auto brightness.

    Too bad, because I liked this app. If anyone knows of an app like that that does not cause the issue, I would appreciate the name.

    Zarlof