[GUIDE][PROJECT CROISSANT] Installing official Chrome OS on any device (PC/PC-like)

Search This thread

teostar

Senior Member
May 30, 2013
317
55
Sony Xperia 5 III
Hi, is it possible to install on an AMD laptop. I have an old Lenovo laptop and its struggling on win 10 and Linux mint. I'd hate to to just throw it out. Wanted to try chrome os if its possible.
 

dankolikio

New member
Apr 18, 2020
3
0
Ryzen 3

Any news about a working image for Ryzen processors?
Lenovo launcher a ryzen chromebook but i cant find its image
 

raamoon

Member
Aug 9, 2015
47
11
I get everything working perfectly on my Lenovo Z500 but after reboot my apps from android including play store don't open anymore, if I click the icon keeps spinning and nothing else happens, anyone has a suggestion? If I do the "system reset" it works again but after a reboot stops again, sometimes afeter I turn off the laptop and leave for a while and turns on the apps back to work.
 

LeoNg628

Senior Member
Dec 2, 2009
306
35
hi, I've installed cloudready onto my ASUS VivoTab Note 8 (M80TA), everything seems fine but no auto rotation and no auto brightness, can I apply the chromefy to turn it into real ChromeOS? Thanks.
 

osaruben

New member
Feb 4, 2011
1
1
hello, can be install on a galaxy book 2? just see this "tablet" is just 4gb ram coming with windows (a really low ram for windows). Im interested to know before buy if i will be allow to install ChromeOs on it. the cpu is Qualcomm SDM850 so im not sure.
thanks
 
  • Like
Reactions: NeoFL

Batero2000

Senior Member
May 20, 2014
92
12
Hi! I have an old laptop and I wish to install this vanilla Chrome OS. Is this viable with legacy BIOS?
 

devhamid

New member
Jan 27, 2017
2
0
is allowed by Google?

is this project have been allowed by Google? because I read on Chromium OS FAQ, Chrome OS just for manufacture. I really want to using that as my daily OS but I don't want feel guilty if Google don't allow using this Chrome OS recovery for free.
 

phoenixgck

Member
Jan 14, 2009
26
1
Recovery website is down. Do you guys have an alternative?

---------- Post added at 03:03 AM ---------- Previous post was at 03:01 AM ----------

It is good now. Just after my last post.
 

vanputten80

Member
Aug 17, 2016
11
3
Does anyone have any recommendations for which recovery to try please?
Tried Eve (different numbers). With swtpm and with Caroline.
Tried also older versions of Chromium OS.

I can't get past the login' screen. Can connect to Wifi, put in my GMAIL + password -> Please wait... nothing happens.

Can somebody advise me?

I have a Dell Latitude E7250 with Intel core I5 5300U CPU
 

sillycat98

Senior Member
Nov 24, 2014
340
62
Nexus 7 (2013)
HTC One (M8)
I tried this install and it was borked with errors showing the image didn't have enough storage and wouldn't write in Rufus.

This ended up working for me:


Decided to watch this thanks to your post. Worked perfectly, have full chrome os and Android apps on my old acer c720. Thanks again awesome person.

Sillycat98
 
Last edited:
  • Like
Reactions: NeoFL

runningslow

Senior Member
Mar 25, 2010
193
30
Dallas
OnePlus 9 Pro
I'm trying to breath some new life into an old laptop that has an AMD Turion Neo X2 L625. I was able to install and boot CloudReady on it, but I'd really like to get the Play Store. I'm very skeptical that I'll find a suitable official ChromeOS image to run on it, since I don't believe there are any Chromebooks with this old of an AMD CPU. Can anyone point me in the right direct or am I just SOL with this laptop running an Official image?

Edit: So, I've now tried using the grunt and rammus images with no luck. I guess I either need to stick with CloudReady or just install a lightweight Linux to run instead.
 
Last edited:

meciu99

Senior Member
Oct 9, 2010
145
39
Google Pixel 6 Pro
Hey guys!
I've succefully installed ChromeOS on my HP Elite x2 G1 (1012) using HP Chromebook 13 G1 (Chell) image and now I'm investigating two things:
-Non functioning power button while running CrOS, pressing it does nothing.
Is there any option to remap hardware button so I'll be able to put device to sleep with single power button press? (Like in Win10)

-Auto screen rotarion doesn't work.
Currently I'm using external app as workaround.


Update 1.
Installed EVE build, and auto screen rotation works flawlessly.
Now I need to find build that fixes power button.

Update 2.
Sometimes pressing simultaneously power + vol up/down puts device to sleep (probably?).. better than nothing.
 
Last edited:
  • Like
Reactions: ipd98 and NeoFL

sillycat98

Senior Member
Nov 24, 2014
340
62
Nexus 7 (2013)
HTC One (M8)
Anyone have an Acer c720? I'm currently using rammus but moonlight doesn't work. Gives me a can't create opengl context error. I tried using Eve but it doesn't boot so I'm curious to see if anyone else has this particular model and has another image working.
 

lulli1

Senior Member
Dec 12, 2011
1,459
834
Google Nexus 5
OnePlus 5T
I have an old subnotebook 32 bit intel pentium m processor. Couldn't get any cros to work.
Neither rammus or any other build nor arnoldthebat's chromium builds. Neverware stopped support for 32 bit machines.
Does anybody now a website or server with working older chrome os builds for x86 processors? Playstore should work that's important for me. Would be very kind... :)
 

Sayamae

New member
Jul 31, 2020
1
0
I have an old subnotebook 32 bit intel pentium m processor. Couldn't get any cros to work.
Neither rammus or any other build nor arnoldthebat's chromium builds. Neverware stopped support for 32 bit machines.
Does anybody now a website or server with working older chrome os builds for x86 processors? Playstore should work that's important for me. Would be very kind... :)

Hello, in fact they just removed the download link from the site but they still stored in their server, here is the download link for the 32 bit image.
enter it in the browser:
davrt8itj6cgg.cloudfront.net/cloudready-free-76.4.42-32-bit/cloudready-free-76.4.42-32-bit.zip
Keep in mind that the partitioning is different, that the installation may very well not be done and it is no longer support, but normally it should work.
Unfortunately, like any Chromium system, there is no playstore, and cloudready cannot be chromified
 

Top Liked Posts

  • There are no posts matching your filters.
  • 117
    r2ZCej0.png
    CHROME OS ON ANY DEVICE

    About Project Croissant (formerly known as Ć̸h̷̢̡r̢͝o̡҉ḿ̴̢̧e̷͜҉f̡͝y͝͞͡͡)

    This project is aimed at making Chrome OS (the official releases by google) available for any non-chromebook devices (ATM The device must be able to boot from live USB, this excludes most Android-only devices);
    The steps can also be followed on a chromebook, to install an image with android and linux support.
    The script uses an official Chrome OS image, while it uses the Kernel and GRUB bootloader from another Chromium OS distribution (EX: ArnoldTheBat builds).
    This project has an official GitHub/Wiki page, a Telegram group, a Twitter page and is the result of many ideas and contributions.
    Please fill this survey to let us know whether Chromefy works (or doesn't) on your device


    Required files

    • An official Chrome OS recovery image (downloads on the right; RECOMMENDED: eve (best) or pyro are the most complete images [must be from the same chipset vendor (Ex: Intel, ARM or RockChip); If eve/pyro doesn't work, try an image from a device with a similiar chipset as your own]
    • Another Chrome OS recovery image from a TPM 1.2 device (EX: caroline or kip) or the swtpm.tar file (swtpm TPM2 emulator needs VTPM proxy support in kernel) (this step is only needed if using an image from TPM2 device to fix a login issue, which is most likely the case for newer ones)
    • An image from a Chromium OS distribution (EX: ArnoldTheBat builds).
    • The Chromefy installation script.


    Installation guide (Partition method)

    For method 1 (bootable USB image generation) check this video guide:


    Method 2-B (chromium OS root partition conversion) described below:
    Other methods described in the official GitHub/Wiki page.
    This procedure will install Chrome OS on top of a Chromium OS kernel, you will thus need to install a Chromium OS distribution on your device first;
    RECOMMENDED: ArnoldTheBat builds
    NOTE: CloudReady builds are not yet supported due to a different partitioning scheme and incompatible kernel

    If you consider this guide too generic, try reading a more comprehensive guide

    1. Flash the selected Chromium OS build on a live USB, boot into the live USB and install it on your HDD/SSD by typing the following command on the shell
      Code:
      sudo /usr/sbin/chromeos-install --dst [COLOR=Blue]YOURDRIVE[/COLOR] [COLOR=DeepSkyBlue](Ex: /dev/sda)[/COLOR]
      now make sure the your chromium HDD/SSD installation is working before proceeding.
    2. Resize the third partition of your sdX drive (EX: sda3 inside sda) from its current size to atleast 4GB; I suggest using Gparted live USB to resize it; you can either downsize sdX1 (data partition) or delete the sdX5 partition (we won't need it) to get more unallocated space.
    3. Boot from your live USB again, make sure you have your Chrome OS images available and run the installation script with the following command
      Code:
      sudo bash /path/to/chromefy.sh [COLOR="blue"]YOURSYSTEMPARTITION[/COLOR][COLOR="DeepSkyBlue"](EX: /dev/sda3)[/COLOR] /path/to/chosenchromeosbuild.bin /path/to/carolinebuild.bin_OR_swtpm.tar
    4. Don't leave live USB yet, make a powerwash (manually) by typing
      Code:
      sudo mkfs.ext4 [COLOR="Blue"]YOURDATAPARTITION[/COLOR][COLOR="DeepSkyBlue"](Ex: /dev/sda1)[/COLOR]

    You can now reboot and enjoy your new "chromebook" :D


    Images supporting swtpm TPM2 emulator

    FAQ
    • Can I dualboot with Windows/Linux?
      Yes, but it's a little more complicated
    • Will this ever work on CloudReady?
      We don't know, nor we have any ETAs. There's currently a repartitioned image (still not working with chromefy)
    • My motion sensors do not work, how do I rotate the screen?
      Laptop mode/keyboard connected: press ctrl+shift+f3
      Tablet mode: use this app by Andrew Whaley (source) (check out his blog)
    • Linux apps (crostini) are not working at all, how do i fix it?
      Go check if you have enabled all virtualization related option in your BIOS (Ex: "Intel Virtualization", "VT-x", "VT-e" etc...) (you should)
    • Do automatic updates work? How to update?
      Not at the moment, and it's unlikely we find a workaround; you can update by ONLY repeating step 3 (without step 4).
    • ChromiumOS works on live USB but not HDD, what to do?
      Did you remove the USB before rebooting the fist time? If you did NOT, you might need to reinstall it. If you did, try using fix_grub.sh
    • Some apps (ex: Netflix) do not show up in the Play Store, how do I fix it?
      Read next answer
    • SafetyNet check fails, why?
      For SafetyNet not to break you need two things, leave selinux on enforcing when chromefying (only working on Pie, otherwise will break android container) and disable "cros_debug" in the grub launcher to boot without developer mode (Custom images [ex: CloudRadish] have custom boot entries for this)
    • ChromeOS flags are not showing up, why?
      Try opening the chrome://flags page in incognito mode.


    Alternatives
    FydeOS

    Fyde OS is a Chromium OS based operating system that comes with Android apps; if you don't want to bother with the hassle of running the chromefy script and just want an OS that works out of the box, this might be for you.
    ...Also the developers are awesome :D

    ArnoldTheBat

    Does not come with Android apps (yet), but he's awesome too, so there's that


    Credits
    • allanin for all of his ideas on Arnoldthebat discussion, most part of the code is from him
    • TCU14 for upgrading, and the MultiBoot guide
    • Dnim Ecaep from the Telegram Group for the shell command to change the SELINUX to permissive
    • Diogo from the Telegram Group for the corrections on the firmware migration
    • Danii from the Telegram Group for the work on the TPM bypass method and TPM2 emulation method
    • sublinhado for writing down the steps needed for the TPM bypass method
    • alesimula for the installation script
    • Giedrius Tamošiūnas (liolka) for the custom chromium kernels
    • ++ some poor unlisted guys
    4
    Tried that some time ago and never worked for me as well as this method, also this one let's you have Crostini with the new recovery images that have tpm protection.

    That is simply a hardware based issue and not selecting the right build. I admit my project needs more work but even the github page tells you to use a build close to your own hardware. Also the TPM is bypassed and not a functioning part of the OS in this regard the same as mine, from a quick look anyway.

    All this does is the exact same as my script but you have to download a lot of other crap too, my script does it all for you. This seems a rather long method to get the exact same thing.

    Mine also doesn't require any messing with partitions, even between upgrading to newer versions.
    4
    Amazing. Just confirming whether Google play store work in this?

    Awesome work!
    Does it work with FydeOS builds?

    Play Store (and crostini) works.

    And yes, you can install it over FydeOS;
    Some users report Arnold kernel working better for them, for others it's Fyde, so just test both to find the best one for your device
    4
    I'm using ArnoldTheBat's Chromium OS from a USB drive on Lenovo Yoga 2 Pro, I wonder if I can install Chrome OS on top of it to the same USB drive? I want to keep my Windows 10 on the SSD intact and don't want to install Chromium on the different partition of the same SSD, because Windows update will inevitably mess up Chromium sooner or later. The laptop has 2 USB ports, so I would be able to use another USB drive if needed. I think many people would be grateful if someone wrote instructions on how to do it on a USB drive instead of a multiboot on one SSD/HDD. Thanks!