[GUIDE][RECOVERY][ROM] Xiaomi/Fengmi/Wemax Mi Led/Laser Projector/TV

Search This thread


New member
Dec 23, 2017
Hi guys. I just bought 1080p international version of Xiaomi Mi Laser 150 and wait for delivery next week. In some review on the net It shows that chinese version have 3D. What about International version? Any possible way to enable 3D on it?


Jan 22, 2011
Hello everyone,
Hello @spocky12

I am the owner of a WemaxA300 projector that I recently had to reroot, and I have installed the highly sought-after Projectivy Tools Launcher. However, despite setting the projector to boot to HDMI1, I am consistently directed to the Launcher Home Menu instead, even when HDMI1 is actively transmitting. Do you happen to have any suggestions for resolving this issue?

Thank you for your time.
Last edited:


Mar 19, 2023
Hello everyone,
I've a Mijia 1S 4K (MJJGTYDS04FM) and I'm having an issue at boot time. The projector lens stays off but the system boots up correctly (I can hear sounds pressing keys on the remote).

I've tried to keep usb UART connected and it says this:

[   [email protected]] dlp64xx_i2c_busy_check now i2c is busy! 1
[   [email protected]] projector init is not ok!
[   [email protected]] dlp6421 don't care irq

I'm able to boot up only starting recovery with a USB connected that contains a stock image (Full rom 1.3.105 ( from post #4)
And it manages to boot up correctly using that one, it starts up, I'm able to even update to latest OTA and do all reboot I want.

Once I shut it off, it won't light up the projector lens anymore. Only way is to boot up recovery with USB and flash stock again!

I'm wondering if I'm just flashing the wrong image and there's something wrong in that driver.

I met the same issue... Did you find a solution to fixit?


New member
Nov 27, 2022

I think there is a trick to change the thermal strategy.

The image above (update-jerry) allowed me to retrieve the thermal strategy for my model (see attachment).

Then, to apply it, just take a usb key and put the new strategy with the name test.json at the root of the usb key.
Then, you need to go fengmi tools to load test.json from thermal menu.
This configuration will be set (even after a reboot) if you let the usb with the file.


  • thermal-l166fcn_0-default.json
    5 KB · Views: 14
Last edited:


New member
May 10, 2014
Hi everyone

I've been configuring my Xiaomi Mijia Youth 2 for two weeks. (Chineese version: MJTYYQCB02FM)

I tried to find a global version rom with Google Apps and spanish language, with no results.

I've been reading almost all the posts. Everything works fine with Projectivy launcher except Netflix.

I tried this apk:
For Xiaomi Youth Edition 2

Download on your computer
- [email protected]
Install in usb

In APTOID TV, install :
- Youtube
- MolotovTV
- MyCanal
- Kodi
- Amazon Prime Vidéo (black) [not Prime Vidéo Android TV (blue)]

Remote G10BTS 6,85€ (- 0,86€ possinle)
Appair Bluetooth on the Xiaomi Youth Edition 2 : [OK] + [Back]
Name : "BLE Remote"
air mouse is ok
[OK] + [vol-/+] pour speed of mousse
But it does not work. I am getting Netflix error: no connection.

Could anyone help me?


New member
Dec 23, 2017
Is there any way to check video and audio quality statistic, similar to Youtube stats for nerds or Fire TV MUL menu in XIaomi Mi Laser 150 international android tv version? This projector supports HDR playback only from HDMI sources and not from Android tv apps on the projector itself. I have Fire TV Stick 4k connected and HDR support is great, but I want to check my PC HDMI source playback. I played HDR videos with Pot player and MadVR with HDR metadata passthrough and I'm pretty sure HDR work ok on projector, because colors and picture brightness are good, but I want to find a way to be absolutely sure about that, because there is no HDR icons indication on this projector. btw with Fire TV stick 4k and Just video player even dolby vision files are played correctly on the projector, which is nice.


Senior Member
Mar 2, 2010


Mar 19, 2023
I think that has to do with issues on the lamp/projection side only.

My issue specifically is something related to the software not being able to turn it on at all, only fresh install each time is able to bootstrap it
You're able to boostrap it with fresh install ? Can you give me the installation instruction plz to allow me to identify if i meet a software or hardware issue...


Senior Member
Mar 2, 2010
You're able to boostrap it with fresh install ? Can you give me the installation instruction plz to allow me to identify if i meet a software or hardware issue...
I've explained it here

You can find available roms here


Mar 19, 2023
I've explained it here

You can find available roms here
Thank you!!
  • Like
Reactions: dedo.93


New member
May 10, 2014
Hi everyone

I've been configuring my Xiaomi Mijia Youth 2 for two weeks. (Chineese version: MJTYYQCB02FM)

I tried to find a global version rom with Google Apps and spanish language, with no results.

I've been reading almost all the posts. Everything works fine with Projectivy launcher except Netflix.

I tried this apk:

But it does not work. I am getting Netflix error: no connection.

Could anyone help me?
At the end, I installed com.netflix.mediaclient_4.16.1_build_15145-15145_minAPI19(armeabi-v7a)(nodpi).apk

It it not an Android TV app, but it works!


May 29, 2014
Hi Guys, I have a wemax one pro and when watching HD content I get blurry images when there is movement in dark scenes.

The video projector is 1080p but supports 4K playback and in 4K this issue disappear completely .

what do you think could be causing this ?



Apr 18, 2012
Hope the project will support more tv series, I'm using redmi x65t mitv 2. 😄 if someone can make a recovery it would be great


New member
Apr 23, 2023
Hi everybody,
I own a Fengmi Cinema 4k (L176FCN) and after having some issues with the HDMI ports, I tried to flash the different full roms.
First I made a full backup with the twrp. Then, wiped all data and flashed the 1.3.105 (, after that again wiped all data and tried the 1.3.105 ( As the problem still remained I wiped again all data and flashed the oldest firmware, the 1.3.105 ( After the automatic reboot, there is no more picture and the fans don't start anymore.

However the system seems to start, because I get a connection the router (can see the device and the IP Adress on the router), but I can't establish an ADB connection (no developer, I think).

I don't know wether I can start in recovery menu. It seems to work something, when I put the USB with the newer roms in and boot into recovery (at least try the procedere), it reboots after a while automaticly.

Maybe someone can help?
I am sorry if there is the solution somewhere in the 134 pages, I didn't find anything..


New member
May 5, 2023

First of all, big thanks to spocky12 and its projectivity Launcher along all the explantions and RAM/Updates shared herewith. (really helpfull and usefull :)

Ok, seems I encounter a similar problem as other on a MJJGTYDS04FM. (i.e. batman ROM)

History: I have it since 2 years, had it rooted and using projectivity tool alongside various small app for video streaming. After some months I encountered the double line heating issue. I had my projector fixed (from projectorjunkie , another great source of help ! :) and all was fine again until a few weeks back when I start encountering heating issue (could see the limit of temperature in projectivity launcher information going up rapidly before my projector switch off ). Fan are working, the room temperature was normal (20 C) . For me it was, and it seems to be, a software issue.

I then decided to start from a blank sheet. Using recovery image.

I believe I have tried all the most obvious combination, using the FULL and OTA images with no real succes sat the end.

- Using the image recovery from the projector (I do have the litle boy image flying and the menu to delete data/recover system) - End up with a working machine - fan, button sound in menu ,.. - But NO Dispaly
- using the various Full recovery package - most ending up in a working machine - fan working, sound when using remote, .. - but NO display image
- using the various recovery and applying the OTA - in sequence or only the last ones.

Only one of those, let me reach a start of a display at the end of the flashing process the Full rom 1.3.105 ( - When the flash is done, the machine boot up then I either end up on another flying boy update finishing or even I can reach the welcome background of Mui ... but for a few second only, the machine switching off - Like it was before, looking like the heating issue.

So here are question as I try to see what path to go:
- Is there any other update available (after 1.3.105) that could potentially fix this heating issue (I suspect the heat limit - would have loved to have a function to bypass these limit and automatic switch off)
- When i enter into recovery mode (original one), the menu stay on without problem. So lamp ok. When I apply it of the Full one - 312 or 494 - I end up with a machine working but no display : it there a solution to root from a remote terminal - As I cannot access the menu I cannot turn android into developper mode - Root could potentially give me access to the heat strategy or something like that ?

- Any other hint ?

(kind of frustrating when you have a software issue... and a machine working :-/

Eric B

Top Liked Posts

  • There are no posts matching your filters.
  • 59
    Projectivy Launcher (formerly ProjecTivy Tools) now has its own dedicated thread located here.


    There's so much information here that a new user could probably feel lost without the courage to read everything. So let's keep things simple : as the thread's title says, the primary aimed devices are projectors produced by Xiaomi related brands (xiaomi/fengmi/wemax), though it could probably be useful to other Android Tv models and other brands, so you might want to keep reading until the end of the introduction.

    What you can find here :
    • Full tutorial to Googlize your chinese device with my custom made Google Apps package dedicated to Android Tv 6 (only tested on MiUi Tv, root required)
    • General FAQ related to these devices [post #2]
    • Information on how to root xiaomi/wemax/fengmi/vava projectors (and custom made TWRP for many chinese models) [post #2]
    • Full firmware and OTA for many models [post #2]

    Google Apps / Services instructions

    Here's a full tutorial to root and install Google services on your Android 6 MiUi device (ie: chinese xiaomi/fengmi/wemax).
    This has been tested successfully on all devices where a custom TWRP is available below. If anything goes wrong for you, try to factory reset / clean flash
    Except for "AndroidMediaShell" (Google Cast server), most (all?) features are working fine including :
    • Tv settings
    • Google Play (to let it install/update apps, please enable the Accessibility Service)
    • ATV remote service : if you install Google ATV remote on your smartphone, everything (including speech recognition) will work
    • Google Assistant : with the Accessibility Service enabled, a short press on the mic button on your stock remote control will launch Google Assistant. Then, when it's listening, press and hold the mic button while speaking and release it when done. According you've used More Locale to change to your mother tongue, this will even work in your language.

    Installation steps:
    • root your device (see post #2) (you don't need to flash any firmware)
    • if not already done, install the latest version of ProjecTivy Launcher and launch it
    • execute Applications / install 3rd party apps, then install :
      • Aptoide Tv Store
      • ATV launcher [optional] (alternative launcher)
      • Youtube [optional]
      • MoreLocale [optional] (in case your mother tongue is not english, it will let you choose more than what's listed in Android settings)
      • Google Apps/services (don't forget it :D)
    • execute Applications / Freeze Stock launcher (to disable your stock home screen)
    • execute Applications / Freeze Stock apps (to disable most Xiaomi apps and services)
    • execute System / Custom Props override (to pass safetynet checks, enable more stock behavior and fix black screen with non-stock launcher)
    • execute System / Accessibility Service, enable the service in accessibility settings (to fix "Google Play" ability to install/update apps and to link the stock remote control "Voice recognition" button to Google Assistant as well as many other features)
    • [Optional] Install magisk module "Nexus Media" to change the stock bootanimation (go to Shortcuts / Magisk Manager to execute it, and then in the left menu, "Downloads" section, just install "Nexus Media")
    • Reboot and complete the Welcome app to setup your Google account (first and second boot will be longer than usual)
    • Note that an Android accessibility setting might get enabled after the first reboot when Google Apps have been installed. It'll cause green borders around buttons. Just go to settings / accessibility and disable "talkback".
    • Launch Google Play to update Google apps and let the update finish before exiting Google Play (if the app's accessibility service is running as it should, it will display a message when launching/exiting Google Play)
    • [Optional] start MoreLocale to change your language
    • Disable the "smart update" in the projector settings so that it doesn't try to download and install OTAs (which would just display an "error" message after each boot, when it fails to install it)
    • Enjoy your Google Tv device !

    Important :
    Once installed, don't change the device resolution in the Android Tv settings. This is not supported by the video drivers that will then only display a checkerboard. The only known solution as of now is to factory reset and start again.

    Engineering Menu App Translation

    Here you'll find information about xiaomi's engineering menu app.
    After a bit of google translate and reverse engineering, here's a translation of the different menus, along with my own values (1st one is for "rainman", second one for "batman")
    1. Projector information
      • - Brightness [1541][1610]
      • - DLP vendor name [APPO][APPO]
      • - Production Week [1812][1921]
      • - Contrast ratio [3828][3370]
      • - Brightness Uniformity [940][856]
      • - Serial Number
      • - Color coordinates [r:860 g:860 b:860 x:283 y:302][r:860 g:860 b:860 x:2720 y:2790]
    2. Solid color (android) -> displays a solid color (using android system)
    3. Solid color (projector) -> displays a solid color (native)
    4. Other image test (android) -> displays a gradient (using android system)
    5. Other image test (projector) -> displays a gradient (native)
    6. Color wheel delay -> when incorrectly set, this can lead to posterization issues (gradients become unnatural and tend to display large uniform areas) [490][420]
    7. Save color wheel delay to Android
    8. Image mode: change the screen light intensity
      • - Standard
      • - Highlight
      • - Energy saving
    9. Temperature monitoring
      • - ambient temperature [31][43]
      • - color wheel [52][63]
      • - Laser temperature channel 1 [60][74]
      • - Laser temperature channel 2 [61][74]
      • - DMD temperature [-][0]
    10. Model name [MiProjA1][MiProjLAS2]
    11. Human body induction -> enables/disables IR sensor that disable image when coming close to the laser
    12. Save information to projector
    13. DLP version [major:1, minor:2, patch:5][major:7, minor:3, patch:7]
    14. 3D (when modified, need to restart to take effect) -> enable/disable 3d support

    Devices list

    For reference, here's a list of devices where ProjecTivy (and several of its special features) has been tested working fine.
    Only models using Android 6 can be rooted yet.
    • 1080p Laser Projectors:
      • Xiaomi Mi Laser UST Projector 150" (chinese) / MiProjA1 / model: MJJGYY01FM / codename: rainman
      • Wemax One 7000 / MiProjA1 / model: FMWS01C / codename: rainman (thanks rockpaperscissors)
      • Wemax One Pro / MiProjA1 / model: FMWS02C / codename: rainman
      • Xiaomi Mi laser UST Projector 150" (international) / MiProjA1 / model: MJJGYY02FM / codename: anglee (thanks Nathan0121) (no root supported yet)
      • Xiaomi Mijia ALPD 3.0 (rear throw laser) / model: L185JCN / codename: franky (no feedback concerning twrp yet, try rainman and report if it works)
    • 4k Laser Projectors:
      • Xiaomi Mi Laser UST Projector 150" 4k (chinese) / MiProjLas2 / model: MJJGTYDS01FM / codename: batman
      • Xiaomi Mijia 1S 4k (chinese) / MiProjLas2 / model: MJJGTYDS04FM/ codename: batman
      • Wemax A300 / MiProjLas2 / model: L1668FCF / codename: batman
      • Fengmi 4K cinema laser / MiProjLas2 / model: L176FCN / codename: batman
      • probably not released yet / MiProjLas2 / model: L246 / codename: batman
      • Fengmi 4K cinema pro laser / FMProjA2 / model: L176FCNPro / codename: jerry (no root supported yet)
      • Fengmi 4K C2 (cinema 2) / ? / model: L166FCN / codename: jerry (no root supported yet)
      • Fengmi 4k Max / model: L406FCN / codename: jerry (no root supported yet)
      • Xiaomi Mi 4K laser UST Projector 150" (international) / model: XMJGTYDS01FM / codename: angleeUHD (no root supported yet)
    • Led projectors:
      • Xiaomi Mi Home Projector Lite / Mijia DLP Projector Youth edition / MiProjLED1 / model: MJJGTYDS02FM / codename: conan (root using rainman twrp below)
      • Mi Smart Compact Projector (international) / Mijia DLP Projector Youth Global edition / model: M055MGN / MiProjM05 / SJL4014GL / codename: ?
      • Fengmi M055FCN / model: M055FCN / MiProjLED1 / codename: doraemon (root using rainman twrp below)
      • Xiaomi Mijia Mi / ZMiProj / model: TYY01ZM / codename: zodiac
    • Tvs:
      • Xiaomi Mi TV 3s / codename: mission impossible
      • Xiaomi Mi TV 4 / codename: pulpfiction
      • Xiaomi Mi TV 4a/4c/4s/4x / codename: matrix/xmen
      • to be completed

    More in post #2 below 👇
    FAQ and more resources related to these devices

    Differences between projector devices

    Wemax One / Chinese Xiaomi Mi Laser:

    They are (almost ?) the same.
    • Software-wise :
      • They are exactly the same (exaclty same codename, firmware, etc...)
    • Hardware-wise :
      • Wemax is black, Xiaomi Mi is white
      • Wemax is described to be 7000 lumens (1688 ansi lumens), Xiaomi mi 5000 lumens (1600 ansi lumens) (not sure if hardware is different or it's only a software parameter that changes its laser power)

    Chinese Xiaomi Mi Laser/ International Xiaomi Mi Laser:
    • Software-wise :
      • Chinese one comes with android 6.0.1 and MiUI Tv (a Xiaomi UI dedicated to chinese users), International one comes with android 8.1 (more details below)
    • Hardware-wise :
      • Chinese one is equipped with DDR3 ram, International version DDR4
      • Chinese one has Amlogic T968 with onboard Mali T830 gpu, International one has Amlogic T962 with onboard Mali 450 gpu (somewhat less powerful, not sure it has any real world impact)
    • Also note than more often than not, International version will probably come with a warranty. It might be important, as few people complaining about dead white pixels seem to have a hard time getting their chinese projector repaired.

    Pros/Cons of 8.1 international device / firmware (as of 10/10/2018)
    This might help people choose between 02 international version and 01/wemax devices. Most of the information below come from this test. This is however subject to change as I believe Xiaomi will probably enhance their drivers in the coming monthes.

    • Complete software translations (no more chinese ressources)
    • Better user interface
    • Google Play Store availability
    • Better support of media apps that hardly work on 6.01 (Netflix, Prime Video...)
    • Better default colorimetry (but less configurable)
    • Less input lag (75,6 ms vs 126,6 ms) fixed on 1218+ firmwares
    • No 3d support
    • Less options related to display settings (missing RGB levels)
    • Worse image quality as noise reduction and sharpness seem to be less effective than on the 01 version
    • Judder and image tearing during media playback

    Can devices international firmware be flashed on chinese models
    No :
    - devices hardware is not exactly the same
    - partition layout is different (android 8.x requires a vendor partition)
    - we don't have access to any international firmware

    Supported video modes
    EDID data here for "rainman" (1080p version) : View attachment edid-rainman-report.txt
    EDID data here for "batman" (2160p version) : View attachment edid-batman-report.txt
    EDID data here for "jerry" (2160p version) : View attachment edid-jerry-report.txt
    EDID data extracted with HDMI 2.0 enabled from /sys/devices/hdmirx.28/hdmirx/hdmirx0/edid and analyzed with Advantiv EDID Editor 1.01.0268

    Is my 4K device really displaying in 2160p ? Why does YouTube refuse to stream 4k ?
    - Yes.
    - Blame it on Google. Or AmLogic.
    More details here.
    Note : more recent devices such as Fengmi Cinema 4k pro (codename Jerry) based on Amlogic T972 soc don't have this limitation (they support VP9 hardware accelerated decoding)(but seem to lack 3D support)

    ALR Screens
    Interesting post from @servo386 regarding Ambient Light Rejection screens dedicated to UST devices.

    Rainbow effect
    I see many questions regarding rainbow effect (due to the DLP technology used). What I can say is that I never saw anybody complaining about it on the Mi laser projectors. A previous projector I owned (an Optoma) was also using DLP technology and I could see this rainbow effect from time to time. In the case of rainman/batman, I've never been able to see it.

    Input lag
    The Mi laser projectors have relatively high input lag (150/175 ms). Firmware updates sometimes help. As of september 2019, the lowest input lag can be obtained on "Monitor" or "Game" mode (approximately 100ms on batman, 75ms on rainman). If your device is rooted and you're using the ProjecTivy Tools, you can also use the "User" mode, and long press the "back" button to get down to the same input lag as "Monitor" mode, with the benefits of keeping your calibration settings.

    Dead/black/white pixels
    One owner of the chinese version here (french) who had a dead pixel managed to fix it by increasing RGB custom settings above 1500 for some time (don't know how long). When reverting to previous values, the white pixel had disappeared. Didn't work out for another user, but it might be worth a try.
    This might change in the future (in this case, please keep me informed), but trying to manually repair by changing the chip is a dead end. It's not the usual Texas Instrument DLP4710FQL, but the DLP4711FQL (source), which is not compatible(source) and can't be bought online.

    Display issues with MJJGTYDS01FM (Xiaomi branded 4k model)
    Many display issues can affect this device : taking time (minutes) to start displaying something, displaying only half image or white lines/bands... Most issues appear when the device is cold and get fixed when it has heat up.
    Seems like a hardware design issue that can be fixed by removing a few screws. More information here. After this, like your projector, you won't be screwed anymore :D
    More details can be found here as well.

    HDMI input ports don't work anymore in International devices after upgrade
    Install the tools, launch engineering menu and select "HDCP key reset" (thanks @xthing)

    Cross platform Remote Control
    I also developped a simple web based remote control for MiUI TV (Xiaomi with chinese interface) based android devices (such as projectors, boxes, TVs).
    No need to install anything special on your controlled device, this website/webapp communicates with the MiUI TV internal web server to send events to your device.
    It should be compatible with anything running a web browser (provided it's quite up to date): Android, iPhone/iPad, PC/Mac computers...
    Just head to http://mireco.hopto.org, configure your device local IP address and you're good to go.
    More details on GitHub.

    Other Tools
    MiiInfo from 4PDA user Loly, shows various details concerning your projector.

    Firmware updates after rooting and/or installing Google Apps
    Firmware updates won't install if files on your system or kernel partition are modified. Using the ProjecTivy Tools and installing the Google apps won't modify existing system files, but rooting with magisk will modify the kernel. So before any update, you have to restore your kernel (aka "boot") partition using TWRP, and then reapply Magisk once update is done.

    Google Apps Issues / not yet working
    • Amazon Prime video : it's been reported that Amazon purposefully blocks the app on projectors. The app loads, but refuses to stream videos. Some previous versions (requiring mouse for some features) work fine though. You can install the most recent compatible one using the ProjecTivy Tools.
    • Netflix : No recent Tv version seems to work. Some previous versions (requiring mouse for some features) work fine though. You can install the most recent compatible one using the ProjecTivy Tools. Anyway, due to missing full widevine support, full hd / 4k will probably never work.
    • Chromecast framework (Google Cast Server, aka AndroidMediaShell) isn't supported (devices need to be approved by Google to be supported)

    To go into recovery, turn off your projector, unplug it, hold down OK and BACK buttons simultaneously (OK and HOME for anglee) on your remote and plug back your projector while still holding them down.
    Warning : don't "hot-unplug" it, turn it off before, or it won't work.
    If you're looking for TWRP, have a look a few points below :D

    Start the Magisk Manager app and select uninstall
    Boot Twrp and reflash the Boot (kernel) backup you made just before installing Magisk

    Factory Reset
    Reflash the full stock firmware available below in this post. This doesn't require any intervention on your part so it should work even if you can't see the display
    Boot the stock recovery and select the "reset device" (not sure of the exact terms) option

    Note : both methods below work for rainman as well as batman (4k) devices.
    Easy Method:
    This method doesn't require any special hardware, only the TWRP I made (, based on stock recovery files), along with another config file.
    Thanks to @cr4zyw3ld3r who made a video tutorial based on the following instructions.
    For french people, here you can find a tutorial made by Pierre. Thanks to him.

    • Extract this file View attachment batman_twrp_3.2.2.0b.zip (for "batman" 4k), this file View attachment zodiac_twrp_3.2.2.0.zip (for "zodiac"), or this file View attachment rainman_twrp_3.2.2.0.zip (for "rainman" 1080p and most other devices such as conan) at the root of your (FAT32 formatted) USB drive, where you also place the latest magisk version (magisk 20+ version support has been added on tools v3.5+), and plug it into your projector (I used the right USB port)
      I also built (but not tested) a twrp for Vava projectors here : View attachment vava_twrp_3.2.2.0b.zip (please report if it works).
    • Download ADB for your computer (check here)
    • Start command line (terminal)
    • Enable USB debugging in Android settings / developer options (you can access them from the projectivy tools)
    • Type "adb connect IP_OF_YOUR_DEVICE:5555" to connect through the network
    • Type "adb reboot update" (This will restart your device and make it boot the TWRP on the USB drive.)
    • Once in TWRP a mouse will be required. Make backups if you wish (at least "boot" partition that you'll need to restore before applying any OTA update), and then mount SYSTEM, and install magisk in order to root the device (it will be in "/udisk" and will be called Magisk-......zip)
    Note : to thank the donors, I also developed an application that installs on your Android smartphone, which automates steps 1 to 6. There is no need for computer or custom command lines in this case. Once the app is connected to your projector, you're only one button click away from TWRP.
    Note : if it still boots to stock recovery and not twrp, make sure you extracted the zip and not only copied it to your usb drive. If it's extracted correctly but still doesn't work, try another usb drive, a few people reported that this fixed their issue (some users had to try 3 or 4 usb devices before finding one the works).

    Old Method:
    With the correct hardware, you can root your device, following this tutorial from @servo386
    To simplifiy the rooting process described in the link above :
    • Extract this file View attachment twrp-files.zip at the root of your USB drive, where you also place the latest magisk version (as of now 19.3), and plug it into your projector
    • Follow the steps described in the tutorial, up to the point where you have a root console access in recovery
    • Then, according you've plugged your USB drive before starting your device, just type ". /udisk/twrp.sh" in the root console. This will copy the necessary files and automatically run twrp, reducing the number of steps (and potential mistakes) to root your device.
    • Once in TWRP, make backups if you wish, and then mount SYSTEM, and install magisk in order to root the device (it will be in "/udisk" and will be called Magisk-.....zip)

    Roms / Dumps

    Due to issues on the new XDA 2021 website (preventing edition of long posts containing many links), full firmwares and OTA have been (temporarily ?) moved to post #4.
    You'll have to scroll down by yourself, I can't even add a link to it 🤔
    Xiaomi Mi Laser Root Procedure

    This is a long one. Also it was originally written for an audience who may have not been as familiar with Android/Linux commands so it has lots of explanation that might feel out of place on XDA.



    I definitely am just a copy cat who guessed that his process would also work on this device since their both Xiaomi TV devices with Amlogic T96* boards.

    So if you read his post (which you definitely should in addition to this post in order to get the full picture of how this is done), you'll see that this is quite complicated and a kind of high level hack. I hope I'll be able to explain it enough and walk through it enough for it be fairly accessible for less technically inclined people who want to root their Xiaomi projectors.

    What is required:

    1. HDMI cable you can chop up or an HDMI breakout cable like this one: https://www.amazon.com/Adapter-signals-Terminal-Breakout-Connector/dp/B01CU9SHOO/

    2. UART to USB adapter cable/board like this one: https://www.amazon.com/Adapter-Serial-Converter-Development-Projects/dp/B075N82CDL though there are cheaper options available

    3. Cables/wires to connect both things. The USB UART package above comes with some, though you'll have to strip the ends to screw them into the terminals of the HDMI breakout board.

    4. A spare USB drive

    5. A computer to use the USB to UART adapter and a terminal program, i am using Putty.

    So the basic idea behind this is that one of the HDMI ports (HDMI 1 in this case, the one closest to the edge) also serves as a diagnostic/UART port via 3 of the 19 pins of the HDMI. When this HDMI port is properly wired to the UART adapter, and you have a terminal open observing said port, upon boot the machine reads out all its startup stuff and when booting into recovery, gives you a completely liberated UNIX terminal that accepts input from the UART terminal, with full root privileges and busybox! As @loly says in his post, here we thank the people at Xiaomi for not bothering to secure this section and giving us full diagnostic root access with busybox. This is almost surely the way the developers of this machine would interact with this machine and developed for it. So let me try to explain how this works and how we get to TWRP and root.


    1. We need to properly connect the correct pins on the HDMI cable to the correct pins on the UART.

    Here I am going to re-post some of @loly's images from the original thread, so all credit goes to him.

    Here we see the pins we need. Pin 14 is our VCC, which in this 5v (the UART adapter im using has a switch for 3.3v or 5v, this switch needs to be set to 5v!) Pin 15 is the receive pin and Pin 16 is the transmit pin

    The fourth lead we need is the GND (ground), which in the case of an HDMI cable is usually an un-shielded wire that connects to the the case of the connector itself.

    I'm going to stop here for a sec and say this is why it's alot easier to use the HDMI breakout board over trying strip an HDMI cable and finding which wire corresponds to which pin (you need a multi-meter to do that)

    its a small investment but it makes everything ALOT easier. On the HDMI breakout board, the ground terminal is pin 20.

    the corresponding pins on the UART are pretty straightforward. VCC goes to VCC on the UART, pretty straightforward, on the other hand the RX pin of the HDMI (pin 15) goes on the TX OF THE UART makes sense right? the receiever of the HDMI should be listening to the transmitter of the UART and vice versa, so the TX pin of the HDMI goes on the RX pin of the UART. The GND pin (pin 20 on breakout board) goes to the GND on the UART.


    Here's my setup. Sorry for the not very great picture. The terminal blocks on the HDMI breakout board work basically like you were connecting speakers to an amp, you unscrew the terminal till you see a little metal hole and you stick the stripped tip of the cable into the hole and screw the terminal back up till its snuggly holding onto the cable. You can use a multi-meter if you have one to make sure the wire is making contact with the terminal and even test the exact pin with the cable to make sure the connection goes all the way. If you're cable is making contact with the metal of the terminal, it is almost certainly correctly making contact with the actual HDMI pin, barring maybe a badly manufactured breakout board. I used spare MALE end pin connector cables to strip the ends and stick in the terminals, and connected them to the FEMALE connectors that came with the UART adapter. You don't necessarily have to do it this way, you can directly strip one of the female ends of the cable and connect the other female end to the pins on the UART, but you'll have a pretty short cable from HDMI to USB and you'll probably need a USB extension to comfortably use it with a computer.

    So now you have you're HDMI diagnostic cable!

    2. Setup your computer for UART and Putty.

    Connect your UART to USB adapter to your computer. In Windows 10, it should automatically install drivers, but if it doesn't, your device should come with a link or something to download the drivers. I'm not going to get into the specific of how to install drivers on Windows computers but needless to say, you need to get the computer to recognize the device and properly utilize it via the drivers. Once you have it properly installed on the machine, it should show up in your device manager under Ports (COM & LPT) or something similar.


    this is important because we need to 1. determine what COM port you're device is on and 2. change the baud setting.

    So in the photo you see that it tells you what COM port is, which we need for later.

    Now you need to go into the settings of the device and go into Port Settings tab



    Very important!

    Setting up putty:


    Basically open up putty and put the button on Serial, set the speed to 115200 and in the SERIAL LINE put the correct COM port number (COM1, COM2, COM3, ect)

    Pressing enter on this should open a big blank black terminal with no activity. Thats good because its working. If it wasn't, you'd get an error about not reaching COM port or something.

    3. Testing out our diagnostic cable with UART and Putty

    Unplug your projector. Plug your HDMI into HDMI port 1 and connect your USB to computer. Open up a Putty terminal session as outlined above. If you get a big black screen with no errors upon launching the terminal, youre in a good spot.

    Plug in the Projector. If you've done everything right you should get a big long readout of text scrolling by as it boots. If you get this, congratulations, you've accessed the diagnostic correctly!


    The final step for actually accessing the usable terminal is doing the same but while booting into recovery.

    4. Booting into recovery

    Turn off your projector. Unplug it. Take your remote and hold down THE OK BUTTON and the BACK BUTTON at the same time. While still holding this, plug in the projector. It should start booting up. You're terminal Putty should be going crazy with text readout like last time. After a few seconds, let go of the buttons. Your projector should eventually end up on the Recovery menu, which is just some big buttons in english and chinese with a black background.

    image courtesy of jaberwocky on AVS

    After the readout in the terminal has stopped, press enter. It should skip to a new line with


    Tada, root! You're officially in a fully privileged root terminal in the underlying unix system of the projector.

    This is the hard part of all this. If you've successfully reached this part, you've won the battle. Everything from here on out is just a couple of commands and some files being downloaded and transferred.

    Launching TWRP, making a Nand dump, flashing Magisk, getting Root

    So if you indeed have reached the point where, from recovery, you can enter commands into the terminal session, now the question what to with it. The answer is basically anything you want, but let's launch TWRP and go from there.

    So here is where you need to download this zip file, also courtesy of @loly from the original russian thread. He went to the trouble of (I'm assuming) compiling his own TWRP for Xiaomi Mi TV 4A which, which as I've mentioned before it's chip (Amlogic T962) is the in the same family as the chip in our projector (Amlogic T968) so it works. That said I would say right now this is not a full TWRP specially made for our projectors, so we aren't going to flash it. We are going to launch it from the terminal (as per @loly's instructions) and use it, but not flash it to our recovery partition. This is for the best right now because a. it's not for our device and b. stock recovery allows us to install OTA updates if they come in the future

    View attachment TWRP.zip
    my attached version has only the twrp folders, no recovery image, no magisk included.
    https://yadi.sk/d/uTUrwdAl3ZyUcN <---- original zip

    Download that zip file and unzip its contents right into your USB drive, so that the folder `twrp` (lowercase) is in the root of your drive . This will make it easier to type the commands exactly as they appear later. Ignore the recovery.img, we're not flashing this onto this device.

    The magisk included in the TWRP.zip is old by this point. I flashed Magisk 17.1 flashable zip, the latest stable as of this writing. Get it here https://github.com/topjohnwu/Magisk/releases/download/v17.1/Magisk-v17.1.zip and put it on the flash drive.

    A quick primer, this terminal instance has Busybox installed. Busybox is a "swiss army knife" of unix command like binaries because it packages all the standard linux commands into one single binary, so instead of calling
    to see the contents of the directory you instead would type
    busybox ls
    and it would work.

    One last thing before I continue: while doing terminal stuff, I quickly learned that occasionally the terminal would throw up all kinds of gibberish which, as far as I can tell, had no rhyme or reason to it and more important had no discernible effect on what i was doing. Its a weird bug that maybe only ill experience because of my setup, I don't know. It would take two forms, one where it would throw up a bunch of lines of technical sounding text which included references to errors and such, but would ever actually affect anything. the other is when it would randomly spit out something like "hotplug_9" and again, id just press enter to get to the new line and nothing would have been affected. Don't be alarmed.

    1. Insert USB drive into projector
    Take your USB and plug it in. On your terminal, you should a small flurry of activity and references to a new device located at
    take note of this, because this is the physical address of your USB drive thats going to have to be mounted. sda1 is the typical one, in my experience.

    2. Mount USB and copy over files
    This is just a series of commands, type them in precisely as I have them here, assuming you've maintained the same file structure on your USB stick as I did, unzipped the TWRP.zip straight onto the root of the USB.

    busybox mount /dev/block/sda1 /sdcard
    This mounts your USB device to the folder `/sdcard' if you're usb is at a different device location, change it appropriately.

    busybox ls /sdcard
    Just do a quick readout of the contents of `/sdcard` to make sure it properly mounted. you should see the contents of your USB drive listed here

    busybox cp -r /sdcard/twrp/twres /
    Copy the folder `twres` from the USB to the root of your projector

    busybox cp -r /sdcard/twrp/license /
    Copy the folder `license` to the root of your projector

    busybox cp -rf /sdcard/twrp/etc/* /etc
    Copy the contents of the folder `etc` to the etc directory on your projector

    busybox cp -rf /sdcard/twrp/sbin/* /sbin
    Copy the contents of the folder `sbin` to the sbin directory on your projector

    busybox chmod -R 0750 /sbin
    Change the permissions of the sbin folder to its all executable

    So thats all the copying, now the moment of truth

    3. Launch TWRP


    after hitting enter on this command, TWRP should boot up on your screen (and a bit of readout in your terminal


    I hope if you're doing this you're somewhat familiar with TWRP, but I will try to walk through the 2 most important things to do

    4. Rom backup
    One of the big buttons is BACKUP, go there and you'll see a series of check boxes for each of your partitions (boot, bootloader, recovery, system, ect). Select the ones you want (I selected all but I know for a fact this is unnecessary but I did't want to overlook anything and I didn't want to guess which I could ignore). It should ask you where to save the backup, select either the USB drive or internal memory and pick a folder. Slide over the thing to begin backup. It'll take a bit but eventually it should finish. Tada, you have a backup of your entire device.

    5. Flash Magisk (ie get root)
    This is the big kahuna, the one that unlocks everything OS-wide. Before trying to flash Magisk, we need to mount the system partition. This was big headache for me cause I didn't know why all the commands in the install scripts for failing and it was because /system/bin contains all the commands/binaries that Magisk installer script uses to do its stuff, so thats why we need to mount it first before trying anything. Go to the big MOUNT button and you should see checks next to USB and INTERNAL MEMORY or something to that effect, i can't remember off the top of my head. Almost certainly SYSTEM does not have a check next to it, meaning its not mounted. Click the check mark next to SYSTEM and that should be it, it is now mounted.

    There is a quick way to check this, which is to go to ADVANCED>TERMINAL and in the terminal type

    if you get any sort of read out of device partitions, you're good, that means the mount command is working meaning the /system/bin is being made available to TWRP to execute commands.

    With that done, go over to the INSTALL button on the home screen and navigate over to your USB stick and find the Magisk 17.1.zip. Select it. Check the check mark to reboot after install. Slide over the slider to begin the install. Moment of truth, you'll likely get to errors in big red text something like MOUNT -O BIND /SDCARD FAILED or something, thats fine, ignore it. It should go onto to say

    |----Magisk Installer Script 17.1----|
    or something like that, that means its doing its thing. Everything should go well and it should ask to reboot.

    6. Verify root
    Once you boot into the Xiaomi home screen after flashing Magisk, you should get some kind of thing asking to confirm that you want to install the application. That application is the Magisk Manager, which means you did it, Magisk installed successfully!

    Go ahead and install some app that you know asks for superuser and it should prompt you for superuser access, grant it. You did it, you're root!
    View attachment 4617430
    Apologies mmmalas for taking ages to respond - I've had some other issues going on lol
    I could find specific examples - but as you go though here you will find more people with issues

    as for the hours - I've only had the projector for a few months, and yes it just got progressivly worse.
    its not an overheating issue (in terms of how hot Australia is at the moment) as I've had the projector during our winter - so it was only getting up to 20 or so degrees C.

    Good Point you noted mmalas on your comments on sending the projector back to get fixed.

    you would have to trust they would actually repair it, and if they sent it back to you would have to pay import tax again.

    I purchased mine off Gearbest - and using their support helpdesk they were pushing for ME to contact the manufacture to get it repaired - and weren't very helpful.
    but once I used paypal to contact them, they changed their tune pretty quick - and were either going to give a piss weak refund ($650 AUD) or let me send it to Hong Kong to repair.

    I sat on that thinking about the best decision, but for the reasons you indicated I'm not going to waste my time.

    I'm quite happy to crack my projector open and have a look at reflowing the solder - might have a look on the weekend.

    Same here, the time to start up is getting longer and longer every day. I can confirm it's no overheating issue. I opened up an issue today, but after reading your experiences I'm not really optimistic right now. I should open a PayPal issue as soon as they aren't helpful. I'm from Germany so i also do not want to send it back to Hong Kong because if I do that I might never see my projector again.

    I would really appreciate it if you could provide me information as soon as you found out how to fix it.
    I can't understand why it only has problems when it starts up, but then it works fine for 10 + hours without a problem. It seems to have something to to with the laser unit gettin power or something like that.

    If in can help in any way, just let me know how, and I try my best.

    I had myself offered from reseller (I bought from mainland china) to send to Xiaomi, and really do not want to go that route.

    thanks, I had gone through tihsamikah, and this confirms my theory on the reflow issue.

    there was a video on youtube, sadly its removed now as the owner account was closed. where he opened the projector. it was fairly simple process:

    1- remove the screws, I think those are hidden under the feets all accessed from the buttom
    for screw locations, check the first image in this and notice the long white screw holes


    2- the projector lifts up, and speaker grill can be removed, and you will end up with the whole projector

    3- under the L shaped black thing, there are 3 Lyers of PCBs connected to each others with cables.
    those are
    a) power Delivery (PSU)
    b) android logic board, which also host the connections at the back (I think this is the only difference between the international and Chinese model but this is just a theory)
    c) Video controller \ driver to the DMD chip

    3- the board where the video controller chip, is the most likely candidate, since DMD failure would be very different from what you saw.

    4- on the right side (this is for your info, please do not touch it ) is the laser assembly, do not open, as its sealed system.
    its laser source then shines toward the DMD chip, (DMD imagine tiny mirrors instead of pixels, those switch direction to reproduce black \ white)
    this light is reflected off the DMD (when its white) and pass through the color wheel, which constructs a full image, but with a single color,
    DMD switch again, syncronized with the color wheel, and thus construct the second color, etc until full image is formed.
    there is massive heatsink to cool the laser and the back of the DMD chip itself. but as I mentioned, this

    5- rest of the stuff, is fans\ speakers, modules could be wifi \ bluetooth etc. but there is not need to remove those.

    when you open it up, take res photos of the boards, and remember which side the DMD chip plug to, trace the PCB to check where most of the lines are going, this would be the faulty chip that needs reflowing.
    Google the part number and it should match my description.

    best way to reflow is to remove the chip, clean it, and resoldier it again. it's not a hard process in the right hands.

    I will send you my phone number privately so you can talk on what's app if you need more details during the disassembly.
    Solved now

    Sorry one thing I also looked at, is the heatsink here, is affixed by nothing but tape, and I pulled it off and no thermal paste to hold it down.
    I removed this too, and replaced it.
    I wonder - if this became dislodged, and was shorting something on the PCB??

    Thank you so much tihsamikah, you pointed me to the right direction.

    Check my video here : https://youtu.be/geVQZxHYTXM
    The ribbon cable seems to be the source of our problem.
    **edit: in fact, it's what you meant by 'pushing the DLP black cable in a bit further'**

    As you told : The box is too tight when the projector is closed.
    When the box is closed, the ribbon cable get compressed

    The video I took is from a cold start (after not using it during 2 days).
    Previously I had to wait at least 2 minutes before seeing any display.

    Now, I have to find a way to avoid the case touching this cable.
    As you told : keeping the case not fully closed should do the trick.

    For those who need it, opening the case is identical than on the video posted by wire_less :
    Here is the original teardown video from China:

    The differences are :
    -There is no screw behing the sticker on the back (SKU sticker).
    -There is no screw at the center of the card on the back (the card with the hdmi slots)
    -There are yellow warranty stickers on the sides of the card with the hdmi slots, theses stickers are hiding screws.
    Please note that the side of the case where the power cable go is difficult to open, use a credit card or a mediator to unclip all the small plastic hooks.

    *EDIT: There are some grooves lines inside the top case cover,
    theses lines was pressing on the ribbon cable and the metal plate (farraday cage on the top right).
    On the 2 last photos, I can see the horizontal lines marks made from the upper case design compressing the metal cage and the dlp ribbon cable.
    Using sand paper to remove those lines inside the plastic cover can maybe avoid the case compressing too much the hardware.*

    *EDIT2: Did a cold boot without the metal plate while projector was closed: it's not solving the problem (long boot time).
    Back part of the projector was loosened, but front part was fully closed. will try to loosen the front part too in some hours.*

    Now, it's fixed for me too. \O/
    I removed the side of the rubber sticked on the top of the DLP (the part under the red square of my 1st pic).
    Then, I sticked it back but less tighten (so the black ribbon cable is more free).

    In order to be sure that the projector top case will not touch the ribbon cable when it's closed :
    I sticked 2~3mm of 3M Coated Tissue Tape on the top of this rubber (still on the DLP side).

    I closed the projector case (just clipsed, no screw), started the projector and got no problem (fast display on a cold boot).
    The only screws I put back are the ones at the back side of the projector (to maintain the card with the hdmi ports).

    So my problem was not only the cover touching the black DLP ribbon cable, but also the grey rubber tape tightening it too strongly.
    And the front part can't be tightly closed or late display on a cold boot appears again.