[GUIDE][ROOT] How to Root the CAT s60 ... ... and more !!!

Search This thread

lu0z

New member
Apr 16, 2011
1
1
Hi All.
I noticed that the links are dead. So here are the update*.zip files and other things (TWRP, QPST, drivers) I used in a rar file. Also, rather than use the SuperSU stuff, just use Magisk with the TWRP included, works like a charm. Personally I'm pleased with the phone, though I see it gets a lot of hate.
Hi! can i use the guide to downgrade my firmware in order to remove the latest update that seems the reason of the unusual battery drain issue?
 
  • Like
Reactions: XenonF-Dev

XenonF-Dev

Member
Apr 28, 2021
13
14
Last edited:

XenonF-Dev

Member
Apr 28, 2021
13
14
Hi! can i use the guide to downgrade my firmware in order to remove the latest update that seems the reason of the unusual battery drain issue?

If it helps, what I did to fight most battery drain issue I had is to disable background network scan, and updating Flir app though Play store (as battery started draining really fast after using Flir app, even after it was closed and stopped).

Hope it helps.
 

solnyshok

Senior Member
Jul 10, 2006
158
13
I bought S60 with LTE_D.... 0.38 firmware. So, no need for OEM unlock /ADB access in Developer settings, no need to install 0.32 and update all the way up. Only thing I had to do to obtain root, was to flash recovery with QFIL, and immediately reboot into recovery and flash magisk (v23.0). Works quite well. Too bad there is no Lineage OS for this device. Mine is in mint condition, screen and battery were changed by official repair shop half a year ago.
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 25
    EDIT 2019: rooting with TWRP from 038 read at the bottom of this post

    HOW TO.... Stock, Update, custom recovery and root your s60 !!!!
    Disclaimer: if you brick your phone, it's your fault, i have tested this way of rooting my s60 now for a several times and it works 100%
    SO READ TWICE, CHECK TWICE, BEFORE YOU CLICK ONCE !!!!! i will not take any responsibility !!!
    !!! ONCE AGAIN, READ THE WHOLE GUIDE BEFORE YOU START !!!


    OK, now we start:
    Thanks to everybody who contributed and made the root possible, here in this thread (Cesarq, OpenMinded, Tuschi, BetonJohn, etc.......) the software in the link further down, is the collected data, freely available in the net and linked in the original Thread several times, i have only bundled one package and wrote this, hopefully usefull guide.

    in principle do as follows: (I will only explain once how to sideload or load via recovery, afterwards i will only state what kind and what file)

    Prerequisites
    - switch phone OFF
    - download my collection of the essential s60 files : Here is my collection
    EDIT 2019: - grap the 035 update here from the Thread: Thanks to tusch00101
    i did not find the 038 update as a single zip file to download. if somebody could provide it ?
    (there are ALL files included to flash stock, update to .035, flash twrp recovery and root.)
    (this is for Win7 x86, you have to check if it works for other versions yourself, sy..)
    - install USB drivers
    (for recovery and adb !!! There are two different USB drivers needed)
    - install "minimal ADB and fastboot"
    - copy the two updates (update032.zip & update033.zip) into the folder, where you have installed "minimal ADB and fastboot" (makes live easier later)
    - install QPST (the version of QPST is the one from Androidmtk and should be virusfree.)

    (The version of QFIL in my collection is the one without reboot, so you have to reset/reboot your phone manually (resetbutton below hatchdoor on your phone) whenever stated in this guide.)
    - format micro SD card in fat32 ! and copy SuperSU.zip onto it. Then insert microSD card into your phone.
    - switch phone ON
    - enable Developer Options, by going into the settings menu and go to "About Device". tip/touch/tap 7x the -build number- field. A message will appear: "You're now developer" (something like this)
    - enable USB-debugging. Go again to settings, then "Developer Options" and enable USB-debugging.(flick the switch)
    - connect a WORKING USB cable to your phone (Not to your PC atm !!!)
    - dial *#06# to see the iMEI('s) of either one or both simslots. dial #02# to check what firmware version you are on
    (just for your info: It looks like the "S" in the firmware version (LTE_X.....) indicates, that SingleSim only is activated, while the "D" stands for DualSim activated. my s60 had an "S"...;) )
    (In my phone the second Sim slot (under the microSD card slot), was blocked with a small piece of, simcard shaped, black plastic. With the help of some tweezers the scrap
    plastic was gone easily. Anyway --- BE CAREFULL --- when removing it.)

    If you are allready on an LTE_D... Firmware version 033 or above (atm only confirmed up to 035) and you want to root with custom recovery, you only need to follow the last step in this guide ("getting twrp and Root") everybody else, continue reading...

    getting twrp (for saving your old firmware only)
    - power off phone.
    - start minimal adb on your PC
    - start QFIL (part of QPST) on your PC
    - press VOL+ & VOL- simultanousely and connect phone with PC (it will vibrate once, top right LED starts blinking red, screen stays black) (- DOWNLOAD MODE -)
    (just in case: to leave Download mode, disconnect phone from PC, press and hold power button for apprx. 15 seconds)
    - as soon as you connect your phone to the PC, QFIL should show the Phone/port in the topline allready
    (if not, either try to manually select the port, or you probably still have a problem with the USB drivers or the USB cable !)
    - QFIL - tick "Flat Build" (top left)
    - QFIL - select Programmer, "browse" to the saved location of "update-twrp-recovery-nobootpatch" and select the "prog_emmc.blablabla...mbn" file and doubleclick
    - QFIL - "load XML" ,select rawprogramm, doubleclick, select patch0, doubleclick

    - QFIL - click on "download"
    - if everything was OK up till now, it should start download - BE PATIENT- and read the status window on QFIL, when it shows "finish download"....
    - disconnect phone from PC
    - press and hold simultanousely POWER and VOL+ (- RECOVERY MODE -) AND...
    - ... use a small tool to push the reset button on the phone under the hatch, while still pressing Power and Vol+ !
    - the phone should now be in twrp recovery. If so, do a full backup now to your (allready inserted and fat32 formatted) microSD card!!!


    when done

    - Power off your phone !

    flashing stock 31.02
    - enter download mode again (Vol+ & Vol-, connect phone to PC.......)
    - this time in QFIL, browse in programmer path to "s60_stockFW_31.02" and select the programmer from there
    - load XML's (the ones that belong to Stock31.02)
    - start download... this will take a while !!!! BE PATIENT !!!!
    - when QFIL status window shows finish download, push the reset button on the phone and let it reboot.

    (it is normal, that the phone should restart itself 2, maximum 3 times during the first startup, but sometimes it ends up in a bootloop (Cat Logo, reboot, CAT logo, reboot, etc, etc, .......))
    (The bootloop mainly happens, if you clear, in twrp recovery, the whole OS, or if you came from another firmware version (LTE_S... -> LTE_D... i.e., but that's no issue either...).

    - if it ends up in a bootloop, no worries, just continue ! Believe me, i did this process now several times !

    you are back on stock 31.02 !

    - Power off your phone again

    Updating to 032
    - bring up minimal ADB sideload on your PC (start it, if not allready done in previous step (getting twrp)).
    - press and hold POWER and VOL+ button on your phone
    - when in stock recovery select (with Volume keys) "adb sideload" and click the Powerbutton
    - connect your phone to the PC
    - on PC, type into the black ADB Terminal window "adb sideload update032.zip" and hit enter
    - if correct USB drivers are installed, phone will start downloading the update now.
    - when complete, select clear cache, and clear data then reboot your phone.

    (again, same as in the step (flashing stock), if bootloop, no worries, just continue, if it boots up, let it boot up and then..)

    you're on 032 now

    - Power off the phone again

    Updating to 033
    - do the same steps as described under "Updating to 032" only difference, type in adb window " adb sideload update033.zip"

    EDIT2019: - do the same steps for 035 and 038

    (After updating to 038, your phone should boot up normally by now. NO MORE BOOTLOOP !)

    getting twrp and Root

    - this is the same step as above "getting twrp" only difference, this time, no backup needed and...
    - when in twrp-recovery, select "install" browse to your micro SD-card, and...
    - install SuperSU.zip from SDcard.

    - once more, clear cache and data and reboot.


    The phone should boot up now, you should be on FW 033, with custom recovery and root !!!

    That's all !!!

    Oh, one last thing, whoever is having an s60, where only one simslot is working, this guide unlocks the second Simslot as well !!!
    Also the problem, some people had, following the other guides (incorrectly) ! (me included) ! , by not using the right QFIL (the one without reboot), in the old Thread, resulting in a
    not working WIFI is no issue anymore :)

    EDIT 2019 !!!

    Getting TWRP with stock 038 thanks to: CDMCCDMC for the addition !
    https://forum.xda-developers.com/showpost.php?p=77978181&postcount=135
    4
    OK, so heres how i got v38 rooted with TWRP

    1. Flashed Stock 31.02 with QFIL
    2. With ADB Sideloaded v32, then clear data/wipe cache, click restart, let the phone bootup untill it says choose language.
    3. Repeat step 2 untill you sideload all v33, v35, v38 updates with clear data/wipe cache and restart after each one is finished and let phone boot till that language screen each time.
    3. After installing v38 let the phone boot fully, login to your google account and so on.
    4. Turn the phone off.
    5. Get in to the DOWNLOAD mode (hold "volume +" and "volume -" at the same time and plug in the USB cable) red light should start blinking.
    6. Install update-twrp-recovery-nobootpatch with QFIL.
    7. After TWRP finished installing, unplug the USB and go in to recovery (power button + "volume +")
    8. Swipe right to allow system modification.
    9. Click "Install" and install SuperSU-v2.82-201705271822.zip from your SD card.
    10. Wipe cache thing and reboot.

    After phone booted up i installed root check to check if the root is there, it was. Then restarted the phone few times to see if TWRP is still there, and it was still there.
    3
    Hi All.
    I noticed that the links are dead. So here are the update*.zip files and other things (TWRP, QPST, drivers) I used in a rar file. Also, rather than use the SuperSU stuff, just use Magisk with the TWRP included, works like a charm. Personally I'm pleased with the phone, though I see it gets a lot of hate.
    2
    am i supposed to be loading the nobootpatch recovery in qfil as the last step and then install su? thats how i attempted it. any help would be greatly appreciated. thanks in advance!

    I asume, you have SuperSU copied onto your microSC card ?!
    When you have finished flashing the nobootpatch recovery (QFIL shows finish download), you have to disconnect the phone from the PC, push Vol+ and Power and Reset (under the hatch) at the same time.
    Otherwise Bootloader gets overwritten, your Wifi is gone, no custom recovery and no root.
    If you are not using the version of QFIL from my package, you probably have a version that automatically reboots when download is finished and you're screwed !!!
    If you did it correctly your phone should boot into twrp custom recovery and you should be able to install SuperSU from SD.
    2
    So I spent the greater part of the weekend working to get update to 038.
    Two important things I discovered:
    1. OTA update from 032 to 038 seems to work!
      • Flash stock 031 with QFIL
      • ADB sideload to 032
      • Boot
      • Connect to WiFi
      • Wait
      • Receive update notification about 038 update (140 MB)
      • Proceed with update
    2. Rooting 038 with Magisk 17.1 did not work for me. I made multiple attempts and each time after installing Magisk, the next boot asked me for a boot password and nothing I tried worked - default_password, all of my own passwords I could think of - with unlock password set first, without unlock password set first...
    3. Rooting 038 with Magisk 15.3 did work - no unexpected boot password - and upgrading to Magisk 17.1 afterward worked fine. Not sure why, but as I need my phone to work, I'm not planning to do any more fiddling.