[GUIDE] ROOT OnePlus 7T Pro McLaren 5G (T-Mobile version HD1925)

Search This thread


Aug 29, 2021
Haven't rooted the phone for over a year so I can't really remember what i did. I just wanted to updated to and keep root
Since there's no fully working TWRP for HD1925, I always use the MSMDownload Tools to downgrade my firmware then upgrade manually directly on the phone.
Follow this link on how to downgrade or unbrick HD1925
  • Like
Reactions: myxdad


Aug 29, 2021
PS can anyone refresh my memory as to what I need to do to go from HD rooted & bootloaded unlocked, to HD

Do I just install the patched My OTAs don't work.
Once you're rooted, your OTA won't work.
The best way is to revert it back to factory using msmdownload, upgrade the firmware on the phone directly, unlock bootloader then rooted it again.


As far as I know, Tmobile also don't provide their rom to be downloaded.
  • Like
Reactions: myxdad


Dec 24, 2020
Thanks guys. Thats a lot of work. Is there any real reason to go form to


Aug 29, 2021
Attached please find the fully functional working TWRP installer and image file for our beloved TMobile Oneplus 7T Pro 5g McLaren (HD1925). I just tested and worked on the latest firmware
I also included the stock and magisk patched boot image for


  • twrp-installer-3.6.2_11-0-hotdog.zip
    37.4 MB · Views: 40
  • twrp-3.6.2_11-0-hotdog image.zip
    37.9 MB · Views: 36
  • Magisk-Pacthed Boot Image
    17.3 MB · Views: 44
  • Stock Boot Image
    17 MB · Views: 39
Last edited:


Dec 19, 2014
So, for those of you having the same issue I was having, I figured out what the problem was, and I want to detail the issue and how I went about fixing it in case it helps others. The problem was with the Google USB driver that I installed for when the phone is booted into the bootloader. The below link describes in detail the process you need to go through, with one exception. After, you select the android_winusb.inf file in step 12, the document just says to click next, which will select the first option in the list, Android adb interface. That is NOT the option you want to select. You want to select the second option, Android Bootloader interface. Once I installed this driver to load when my android boots to the bootloader, I was able to boot TWRP images perfectly. If you already have a driver installed when your device boots into the bootloader, you will need to attach your device to your computer and boot it into the bootloader so that the driver will load. Then, launch Device Manager, locate the device in device manager, right click it, uninstall the driver (also check the box to uninstall the driver software or whatever if it appears), and then scan for hardware changes. You will likely see your device with a yellow triangle next to it. This is the state you want it to be in when following the steps as outined in the below article. Hope this helps:
This fixed my issue! For anyone who sees this, download the Youtuber's (Qasim) files (you'll need to subscribe to the Youtube channel to unlock the download link) and follow all instructions. Immediately after this, I went back to the terminal on my computer, which still had a bunch of other commands and outputs on it (same session), typed "fastboot devices" and bingo. It displayed my phone's ID # as:

(******** fastboot)

similar to doing the ADB devices command. Excellent!

Note: didn't see my device with a yellow triangle next to it in the Device Manager window. Mine says: Android Device -> Android Bootloader Interface. Idk if that makes a difference or not.

Unfortunately, my phone hangs on the Fastboot Mode splash screen and I cannot proceed. Works with the patched bootloader though! Maybe I got impatient with the twrp files? I'm starting to get impatient though.

I used the files provided by chueppo and now my phone's background looks different lol. So that means it probably, if not definitely, worked.

Holy cow. I had this phone for a year and I finally got the darn thing rooted lol. Victory! Thanks for everyone's help again.

I'm also keep an archive of the files I used to make everything work (adb, fastboot, patched ROM, etc) LMK if you're having trouble finding smth because it's quite a PITA hunting around for files to install on your PC etc.
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 51
    Hi. So I wanted to put together a little write-up on how to root the T-Mobile McLaren 5G variant, at least how I rooted mine, as there doesn't seem to be anything about this yet. I was actually able to root my device last night successfully, so I hope this guide helps others go through the process.

    **WARNING** Unlocking your bootloader will render your phone unable to take OTA updates! This is a newly discovered problem that hopefully will be fixed soon. But currently, unlocking the bootloader will wipe your data and also a reserve.img needed for the OTA updates. Proceed with caution!

    *I do not take ANY credit for this work. I am simply gathering data from various sources into one single reference guide*

    *Credit is due to HolyChickenGuy and dstryrwiz mostly, as I gathered most of the data from these members. Also, topjohnwu of course for Magisk.*

    So, anyhow, with this version of the OnePlus Pro 7T being carrier-locked, you must of course follow different procedures than a typical unlocked phone. And because OnePlus thinks they are special somehow, you also have to obtain an unlock code for the bootloader. :laugh:

    Steps that I followed:

    1. Obtain SIM unlock status via T-Mobile. In order to do this, I simply just asked a T-Mobile employee via Twitter if they could provide me a permanent unlock. And without any issues, they were very kind to do so....even after day 2 of owning the phone. And on the EIP, it's not paid off.

    2. After getting them to add your IMEI to the unlock list, go to the system settings --> WiFi & internet --> SIM & network section. There will be an option called "Network Unlock" at the very bottom under the 'Advanced' section. Click that and then go through the prompts. You want to choose "Permanent Unlock". Then, if T-Mobile made on their promise, it should ask to reboot...after which the 'OEM unlocking' option under the Developer Options will no longer be grayed out. Woohoo!

    3. After obtaining successful SIM unlock, now you have to submit a form to OnePlus to obtain the actual unlock.bin file to get the bootloader unlocked, generated from a unique 64 character code you will obtain in the next step.
    Ensure that USB Debugging is turned ON. In fact, make sure it's always on during this entire procedure, because it's required. Enter fastboot mode via holding the power and volume DOWN buttons during boot up. Or easiest way is to simply soft reboot with the "Advanced reboot" option enabled from the Developer Options. Once in fastboot mode, enter the following command to obtain this 64 character code...​
    fastboot oem get_unlock_code
    This will spit out that 64 character code. Now go to this page, sign in, and fill out the form to submit for the .bin file.​
    NOTE: This takes at LEAST 7 days to get the .bin file. For whatever reason...it must be an automated system. I tried contacting them twice, but they wouldn't budge and told me I had to wait. LOL. And it seriously took EXACTLY 7 days and like 12 minutes for the email to arrive.​

    4. So after you have the "key" to finally unlock this darn phone, enter fastboot mode again and enter the following commands...
    fastboot flash cust-unlock "%path\to\unlock_code.bin%"
    fastboot oem unlock
    <<-- This step will ERASE everything on your phone. Most people know this, but I have to say it. Internal storage will be wiped too. :good:

    Finally, the phone is unlocked. Now we can root it.

    *I used various information from different forum postings...and some previous knowledge of course. Again, I don't take credit for any of this. I'm just following instructions. :cowboy:

    5. Download the unofficial TWRP .img file for the OnePlus 7T Pro from here. To be honest, I am not even sure if using TWRP for this part is really necessary, but somehow I came to that conclusion. LOL. This process worked for me, so yeah. Anyhow, enter fastboot mode again and boot to TWRP (do NOT flash it!) by entering the following...
    fastboot boot "%path\to\twrp-3.3.1-5-hotdog-unified-mauronofrio.img%"
    Now in TWRP, enter the following commands to extract your stock boot.img file...
    adb shell dd if=/dev/block/bootdevice/by-name/boot of=boot.img
    adb pull /boot.img
    This will copy your boot.img file to wherever adb is running on your computer.

    6. Take that boot.img file and copy it over to your internal SD on your phone. Boot your phone up as normal, and go grab Magisk Manager from Git here. Open up Magisk Manager, expand the "Advanced Settings" option, and check the "Preserve force encryption" and "Preserve AVB 2.0/dm-verity". Select the "Install" button from the regular Magisk option and choose "Select and Patch a File ". Find your boot.img file and Magisk Manager will created a patched .img file. Copy this new .img file from your phone over to your PC.

    7. Enter fastboot mode again. Now just boot from this newly patched .img file by entering the following...
    fastboot boot "%path\to\magisk_patched.img%"

    8. Final step. And hopefully your phone boots up.
    *If not, and you're stuck in a boot loop...you might need to make the A or B partition active. To do this, while back in fastboot mode, enter either command (most likely B)...
    fastboot --set-active=a
    fastboot --set-active=b
    Again, hopefully the phone just booted up normally without having to do that. Now in your phone, open up Magisk Manager again and simply choose the same Install option, but instead select "Direct Install". Magisk will now flash that .img file, ultimately granting permanent root privileges.
    Reboot and enjoy!! :D

    ***Here is a good write up on adb and how to get it running on your PC....https://www.xda-developers.com/install-adb-windows-macos-linux/***
    stock and magisk patched 5G McLaren boot images

    OnePlus 7T Pro 5G McLaren
    2 boot images (zipped with ZArchiver app), one is stock and the other patched with latest available Magisk.

    #1 Wed Dec 4 20:44:37 CST 2019

    Android security patch level
    November 1, 2019

    As mentioned, booting the unzipped Magisk patched boot image requires an unlocked bootloader.
    Very curious, how did you pull the stock boot image from without twrp working on OOS 11? Is there another way? If so, please share. Thank you so much!!
    I did:
    fastboot getvar all [to see what boot slot I needed to pull; this specific phone was was on b]
    fastboot boot twrp-3-5-1_10-hotdog.img
    adb pull /dev/block/by-name/boot_b boot.img
    [someone else might need boot_a if on slot a]
    So, I fastboot booted this TWRP and pulled boot image via ADB: https://github.com/Systemad/android_device_oneplus_hotdog/releases/tag/a11
    stock boot image for is attached (zipped).
    magisk patched (stable 22.1) boot image for is attached (zipped).