[GUIDE] Switch software region to Upgrade to ColorOS 11 and enable Dual Sim.

Search This thread

Titano97

New member
Apr 17, 2021
2
0
Updates are just veeeeeeeerrrrrrrryy slow at OPPO. I received the CPH2025_11_C.63 update this morning, with time stamp from 1st of march 2021, with march security patch.
So the update is already 1 month old when I receive it. If was the same for the C.59 update, I received it almost 1 month after the release date mentioned in the changelog.

And my Find X2 Pro is modified to EUEX Dual SIM.
File for a 73 5G??
I want to upgrade
 

Rampage.73

Senior Member
  • Dec 4, 2020
    76
    1
    C.64 update for Find X2 Pro VPN France-Netherlands
     

    Attachments

    • Screenshot_2021-04-18-08-11-14-82.jpg
      Screenshot_2021-04-18-08-11-14-82.jpg
      418.8 KB · Views: 75

    sastredick

    Senior Member
    Feb 9, 2014
    59
    4
    Pavia
    i have the token, i wanted to try euex region but not swicht regions page ... what's the difference between multilangual ex and euex?
     
    Last edited:

    hoho9043

    Member
    Apr 17, 2011
    31
    2
    Hong Kong
    Damn... I never saw the OK in the right pane.(installed loop-test)
    But when I turn wired network off. (the SEC5 still runing)
    The wifi contact automatically, and bang! Ok in the right pane...
     

    FrAsErTaG

    Senior Member
    May 22, 2009
    1,375
    1,096
    Canberra
    Hi All (Hi XDA, Long time no talk)

    I recently purchased one of these phones and I am having difficulties with Android Auto, If Iask google a question it will respond. If I ask google a question which then google asks me a question back, it is no longer listening. I usually play some quiz games in the daily commute to work and not being able to answer a question breaks these kind of games.

    it will also sporadically restart android auto sometimes which is annoying but not a deal breaker.

    I am wondering if anyone had this issue on this phone? And I am wondering if COS 11 will potentially fix it?
     

    simonecapo

    Member
    Nov 17, 2020
    29
    2
    Hi All (Hi XDA, Long time no talk)

    I recently purchased one of these phones and I am having difficulties with Android Auto, If Iask google a question it will respond. If I ask google a question which then google asks me a question back, it is no longer listening. I usually play some quiz games in the daily commute to work and not being able to answer a question breaks these kind of games.

    it will also sporadically restart android auto sometimes which is annoying but not a deal breaker.

    I am wondering if anyone had this issue on this phone? And I am wondering if COS 11 will potentially fix it?
    Since version c57 there are various problems with android auto and waze ... In android auto the spelling in Italian / English has been solved but on waze no. Both of them loop to screen lock, but it's a color os problem. I hope they focus on solving these problems instead of blocking the region change sec5 software ...
     
    • Like
    Reactions: FrAsErTaG

    Rampage.73

    Senior Member
  • Dec 4, 2020
    76
    1
    Can anyone on the new C64 firmware please test if the sec5 region change tool is still not working? Thanks.
    I repeat it again the sec. 5 has been blocked by oppo so you will no longer be able to activate the dual sim and even debrading open that now this tread will be blocked because it is a bit stuffing always the same questions and no longer working
     

    Top Liked Posts

    • There are no posts matching your filters.
    • 1
      Can anyone on the new C64 firmware please test if the sec5 region change tool is still not working? Thanks.
      C63, not work.. Actually after C62, the code 391 has been blocked.
      1
      For sure, ColorOS 11 won't fix it. ColorOS updates does not fix bugs. They only add new ones.
      1
      Hi All (Hi XDA, Long time no talk)

      I recently purchased one of these phones and I am having difficulties with Android Auto, If Iask google a question it will respond. If I ask google a question which then google asks me a question back, it is no longer listening. I usually play some quiz games in the daily commute to work and not being able to answer a question breaks these kind of games.

      it will also sporadically restart android auto sometimes which is annoying but not a deal breaker.

      I am wondering if anyone had this issue on this phone? And I am wondering if COS 11 will potentially fix it?
      Since version c57 there are various problems with android auto and waze ... In android auto the spelling in Italian / English has been solved but on waze no. Both of them loop to screen lock, but it's a color os problem. I hope they focus on solving these problems instead of blocking the region change sec5 software ...
    • 5
      I want to write this here so it's all in one place and not scattered around different threads. Apologies for the bad formatting in some parts as this is on of my first contribution. Most of this is copied from this thread: I am adding onto this based on my experience and a twitter thread that I can't seem to find anymore. All you need is a Windows computer, ADB, and a super shady program (I've tested it and there don't seem to be any viruses in it). Let's get started.

      DISCLAIMER: Use this at your own discretion. So far, when it works, it doesn't wipe any personal data and nearly no issues are caused. Still, I am not responsible for bricked devices, broken warranties or lost data.

      If you haven't already, enable Developer Options and USB Debugging.
      Next, download the Oppo_Free_Unlock_v1.0.zip file from the attachments and extract it somewhere.
      Before you run anything, though, there's a little preparation that needs to be done.
      Open Device Manager and expand the Network Adapters category.
      Find your Ethernet adapter and double click it to open its properties.
      Go to the Advanced tab and find the Network Address option in the Property pane.
      Under the Value pane, select the radio button next to the text box and paste in the following: 704D7B61ABCD.
      If you don't have an Ethernet adapter, try to find another network adapter here that has the Network Address property. It may help to install VirtualBox, since it will add fake Ethernet adapters.
      Close the properties window and close Device Manager.
      Go to where you extracted the unlock tools. Open Sec5.exe.
      Make sure your device is in MTP mode, and then press the Unlock button.
      After about a second, a string of numbers and letters should show up in the left pane. A few seconds later, "OK" should start flashing in the right pane. If it says "device not found" or something similar, make sure MTP Mode is activated. Press "Stop unlocking" and close the window.
      Open the phone app on your device and dial *#3954391#. Then dial *#391#. A screen should come up with a whole bunch of regions listed. Choose this one: "Singapore Ex". Note: This Version has Theme Store, but no Ringtone Maker. Feel free to try other versions. EDIT: DO NOT CHANGE TO A REGION WITH CARRIER, ESPECIALLY THAILAND AS YOU WON'T BE ABLE TO CHANGE BACK! AT LEAST WHILE ON ANDROID 10. STICK WITH THOSE THAT END IN EX. Once you have done this, it appears that you can always bring up the region menu when dialing the numbers..
      Your phone should now reboot. Once it's rebooted, your region will have changed.

      Every time you changed region and want to change it again you need to use the software. You can get a code that you can use every time to change the region instead of using this software every time. (Update- one person report that this code(token) wont work for every time as his STAMP code changed.)
      For this you need to: Open the dialer app , dial *#9434# ,press authtokendecrypt. You will see a IMEI and STAMP. Open the Sec5.exe and write the IMEI and STAMP shown on your phone in the blank space of the IMEI and STAMP in the software and press Generate a token, you will see a string of numbers and letters, write it on the token blank text box and click authtokendecrypt. Now you will see every text written in green. Now you can follow the steps in the guide but skip the steps that have to do with sec5. The Token that the software gave you is the same code that you need to enter in the *#9434# every time you want to change region so you do not need to use the software ever again.

      UPDATE: Currently, it doesn't seem to work anymore for some people. Try installing Loopback network driver ( How to install Loopback) and uninstalling or disabling all other network drivers. If you are afraid of doing this with your own device you can use a Virtual Machine, too. I tried it this way.. Rest of the process is the same, just change the network address in Device Manager the same way as before.

      Now that you are on the Pakistan Version, you can also run the device in dual sim mode, which was disabled in EU Mode. Some users have ordered Dual-Sim-trays on AliExpress and are now able to use it in this way. Also this might open up the path to unlock the bootloader, since that is limited to chinese devices only. I have not tried this out yet, though.

      In theory, changing your region like this should work on any OPPO device running at least Android Pie (9). It may even work on earlier versions.
      NOTE: This will not work for Chinese variants. These codes are filtered and will only work for international variants.
      3
      Why has this thread been hijacked by non Find X2 Pro users???
      3
      @koloure2211 the region DOES change but like I said that is something else than changing the software! Look, originally we used the Sec5 tool to get early access to Android 11, which Singapore had already rolled out. BUT changing the region to Singapore alone wasn't enough to actually receive the Singaporean software, we first had to flash a software via ozip file from which we could actually FIND the OTA update, in this case this was the Pakistani one. You always need the right combination of region code AND currently installed software to be able to find OTA updates from a certain region. Wasn't a big deal back then because you could just go and download the needed software from the Oppo website. Now we are pretty much in the opposite position: we want to get AWAY from the Singaporean software, and again we would have to change region code AND install software from the region we eventually want to get to in order to be able to find future OTA updates of that region! But the problem is that as of now we don't have said software file yet, as there still are no Android 11 ozips available.
      3
      No it's not after 62 update and February security update
      Sec5 is still working. It's the codes inputed onto phone that no longer work.
      2
      Writing this to help anyone else who is still struggling getting the unlock to work through sec5.
      My setup: Surface Pro (wireless only, no ethernet)

      Short version: Follow the guide, just don't use the number it says to put in the Network address under your network adapter properties.
      • I opened Device Manager, and under Network adapters disabled EVERYTHING other than my wifi adapter and loopback device.
      • Rebooted.
      • As per instructions elsewhere, I did NOT use the code for the network address on any adapter, left blank.
      • Followed the rest of the guide and it works.
      On my desktop, I had both wireless and ethernet, and originally had put the number in as stated on the guide and had the same issue as others. To get it to work, I set that back to being blank (as in not overridden), installed the loopback adapter and rebooted after disabling everything other than my ethernet and loopback device. I was then successful on the desktop and had no further issues since. Tested a few times on both machines, with success every time. I was also able to generate a token as in the latter part of the guide.
    Our Apps
    Get our official app!
    The best way to access XDA on your phone
    Nav Gestures
    Add swipe gestures to any Android
    One Handed Mode
    Eases uses one hand with your phone