[GUIDE] Switch software region to Upgrade to ColorOS 11 and enable Dual Sim.

Search This thread

Gusev888

Member
Aug 13, 2020
9
0
OPPO returned my smartphone to Android 10 A.52.
then i found update c.62 installed for download. meanwhile changed the region to Singapore EX. then install the update.
I received a broken firmware without the possibility of updates. downloaded here from the forum C.75
installed via recovery.
after which I downloaded the manual update F.14 from the last page. after that, F.17 immediately arrived, but already by air.

the question when entering * # 54794824 # writes 5G is activated but did not appear in the SIM card menu.
There is a second SIM card. but there is no call recording.
Im not try this, but if you upgrade from android 10 I think it will show "Installation failed"
 

awais_666

Senior Member
Jun 29, 2013
93
7
HI Guys, Has anyone tried this method to upgrade to coloros 12 for Find X3 Pro I got telstra version in australia and it is stuck on color os 11 with update of October 2021 no vpn and other solution worked thinking to try this method
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 8
    I want to write this here so it's all in one place and not scattered around different threads. Apologies for the bad formatting in some parts as this is on of my first contribution. Most of this is copied from this thread: I am adding onto this based on my experience and a twitter thread that I can't seem to find anymore. All you need is a Windows computer, ADB, and a super shady program (I've tested it and there don't seem to be any viruses in it). Let's get started.

    DISCLAIMER: Use this at your own discretion. So far, when it works, it doesn't wipe any personal data and nearly no issues are caused. Still, I am not responsible for bricked devices, broken warranties or lost data.

    If you haven't already, enable Developer Options and USB Debugging.
    Next, download the Oppo_Free_Unlock_v1.0.zip file from the attachments and extract it somewhere.
    Before you run anything, though, there's a little preparation that needs to be done.
    Open Device Manager and expand the Network Adapters category.
    Find your Ethernet adapter and double click it to open its properties.
    Go to the Advanced tab and find the Network Address option in the Property pane.
    Under the Value pane, select the radio button next to the text box and paste in the following: 704D7B61ABCD.
    If you don't have an Ethernet adapter, try to find another network adapter here that has the Network Address property. It may help to install VirtualBox, since it will add fake Ethernet adapters.
    Close the properties window and close Device Manager.
    Go to where you extracted the unlock tools. Open Sec5.exe.
    Make sure your device is in MTP mode, and then press the Unlock button.
    After about a second, a string of numbers and letters should show up in the left pane. A few seconds later, "OK" should start flashing in the right pane. If it says "device not found" or something similar, make sure MTP Mode is activated. Press "Stop unlocking" and close the window.
    Open the phone app on your device and dial *#3954391#. Then dial *#391#. A screen should come up with a whole bunch of regions listed. Choose this one: "Singapore Ex". Note: This Version has Theme Store, but no Ringtone Maker. Feel free to try other versions. EDIT: DO NOT CHANGE TO A REGION WITH CARRIER, ESPECIALLY THAILAND AS YOU WON'T BE ABLE TO CHANGE BACK! AT LEAST WHILE ON ANDROID 10. STICK WITH THOSE THAT END IN EX. Once you have done this, it appears that you can always bring up the region menu when dialing the numbers..
    Your phone should now reboot. Once it's rebooted, your region will have changed.

    Every time you changed region and want to change it again you need to use the software. You can get a code that you can use every time to change the region instead of using this software every time. (Update- one person report that this code(token) wont work for every time as his STAMP code changed.)
    For this you need to: Open the dialer app , dial *#9434# ,press authtokendecrypt. You will see a IMEI and STAMP. Open the Sec5.exe and write the IMEI and STAMP shown on your phone in the blank space of the IMEI and STAMP in the software and press Generate a token, you will see a string of numbers and letters, write it on the token blank text box and click authtokendecrypt. Now you will see every text written in green. Now you can follow the steps in the guide but skip the steps that have to do with sec5. The Token that the software gave you is the same code that you need to enter in the *#9434# every time you want to change region so you do not need to use the software ever again.

    UPDATE: Currently, it doesn't seem to work anymore for some people. Try installing Loopback network driver ( How to install Loopback) and uninstalling or disabling all other network drivers. If you are afraid of doing this with your own device you can use a Virtual Machine, too. I tried it this way.. Rest of the process is the same, just change the network address in Device Manager the same way as before.

    Now that you are on the Pakistan Version, you can also run the device in dual sim mode, which was disabled in EU Mode. Some users have ordered Dual-Sim-trays on AliExpress and are now able to use it in this way. Also this might open up the path to unlock the bootloader, since that is limited to chinese devices only. I have not tried this out yet, though.

    In theory, changing your region like this should work on any OPPO device running at least Android Pie (9). It may even work on earlier versions.
    NOTE: This will not work for Chinese variants. These codes are filtered and will only work for international variants.
    3
    Why has this thread been hijacked by non Find X2 Pro users???
    3
    @koloure2211 the region DOES change but like I said that is something else than changing the software! Look, originally we used the Sec5 tool to get early access to Android 11, which Singapore had already rolled out. BUT changing the region to Singapore alone wasn't enough to actually receive the Singaporean software, we first had to flash a software via ozip file from which we could actually FIND the OTA update, in this case this was the Pakistani one. You always need the right combination of region code AND currently installed software to be able to find OTA updates from a certain region. Wasn't a big deal back then because you could just go and download the needed software from the Oppo website. Now we are pretty much in the opposite position: we want to get AWAY from the Singaporean software, and again we would have to change region code AND install software from the region we eventually want to get to in order to be able to find future OTA updates of that region! But the problem is that as of now we don't have said software file yet, as there still are no Android 11 ozips available.
    3
    No it's not after 62 update and February security update
    Sec5 is still working. It's the codes inputed onto phone that no longer work.
    2
    Writing this to help anyone else who is still struggling getting the unlock to work through sec5.
    My setup: Surface Pro (wireless only, no ethernet)

    Short version: Follow the guide, just don't use the number it says to put in the Network address under your network adapter properties.
    • I opened Device Manager, and under Network adapters disabled EVERYTHING other than my wifi adapter and loopback device.
    • Rebooted.
    • As per instructions elsewhere, I did NOT use the code for the network address on any adapter, left blank.
    • Followed the rest of the guide and it works.
    On my desktop, I had both wireless and ethernet, and originally had put the number in as stated on the guide and had the same issue as others. To get it to work, I set that back to being blank (as in not overridden), installed the loopback adapter and rebooted after disabling everything other than my ethernet and loopback device. I was then successful on the desktop and had no further issues since. Tested a few times on both machines, with success every time. I was also able to generate a token as in the latter part of the guide.