How To Guide [GUIDE] [T220/T225] Flash a GSI on the A7 Lite (without TWRP)

Search This thread

medjai

Senior Member
Nov 18, 2008
59
1
Can someone please help unblock me I'm not sure why I'm getting an error when running

Bash:
lpmake --metadata-size 65536 \
--super-name super \
--metadata-slots 2 \
--device super:6023020544 \
--group main:2814210184 \
--partition odm:readonly:4349952:main \
--image odm=./odm.img \
--partition product:readonly:1184133120:main \
--image product=./product.img \
--partition system:readonly:916398216:main \
--image system=./system.img \
--partition vendor:readonly:709328896:main \
--image vendor=./vendor.img \
--sparse \
--output ./super_new.img


Error:
Code:
lpmake I 10-01 09:33:46 52395 52395 builder.cpp:1012] [liblp]Partition odm will resize from 0 bytes to 4349952 bytes
lpmake I 10-01 09:33:46 52395 52395 builder.cpp:1012] [liblp]Partition product will resize from 0 bytes to 1184133120 bytes
lpmake I 10-01 09:33:46 52395 52395 builder.cpp:1012] [liblp]Partition system will resize from 0 bytes to 916402176 bytes
lpmake E 10-01 09:33:46 52395 52395 builder.cpp:599] [liblp]Partition vendor is part of group main which does not have enough space free (709328896 requested, 2104885248 used out of 2814210184)
Not enough space on device for partition vendor with size 709328896


Here are my partition sizes respectively. (I am under the impression I don't need to include the super.ext4.img)

odm.img 4349952
product.img 1184133120
system.img 916398216
vendor.img 709328896


super.ext4.img 6023020544


Would appreciate any pointers as to what I'm doing wrong
 
Last edited:

nirogu325

Senior Member
Oct 15, 2010
3,688
1,914
Can someone please help unblock me I'm not sure why I'm getting an error when running
Would appreciate any pointers as to what I'm doing wrong
--group main:SUM_OF_ALL_PARTITIONS_SIZES \

^ There it is. 8837230728 should be the value given your information. Don't give up, you're almost there. The rest of the steps are super easy.
 
  • Like
Reactions: tuelho_post

camljh

Member
Oct 24, 2022
19
1
can someone help compile lineageOS for me on T220? i was trying to get this to work on my own but every command i try gives me an error saying the command isnt recognized.

lineage-19.1-20221011-UNOFFICIAL-a64_bvS-vndklite.img is the one i want to use
 

tom.android

Senior Member
Jul 12, 2016
912
297
can someone help compile lineageOS for me on T220? i was trying to get this to work on my own but every command i try gives me an error saying the command isnt recognized.

lineage-19.1-20221011-UNOFFICIAL-a64_bvS-vndklite.img is the one i want to use
this variant was not booted. and SM-T220 is ARM64 not A64.
 
Last edited:

t111

Member
Dec 6, 2013
22
0
hello i manage to boot cheris os 13 on t220, everyting works fine , but i cant install any app from playstore (i get an error) and a yellow triangle in any app i try to install.
this is because i install a slim version of gsi?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    enjoy android 12 partitions extracted from super:https://mega.nz/folder/GJ430ATA#IripVV_yItbgzvcIgIKNTQ

    super.ext4.img 6023020544
    product.img 1184133120
    vendor.img 709328896
    odm.img 4349952
    1
    i just tried lineage 20 gsi on a12 fw and it bootloop
    not supported vndklike.
    1
    i flashed this rom but after the factory reset on the recovery, the tablet freezes on the animated logo cherish os.
    maybe the problem is the base firmware ? i used the T220XXS1BVJ2 base firmware Android 12
    No, your base is not the problem. That particular version of A12 CherishOS uses PHH v415 which has issues booting for our devices. Only PHH v414 or v416 GSIs like this one boot for us (it works for VJ2 firmware, tested it myself). Sadly I don't see any other developer releasing an A12 v416 based GSI like the one I linked to so yes, that's what we have for now until the newer A13 GSIs pick up the v416 patches hopefully.
  • 7
    Hi everyone, this is a short guide on how to flash a GSI on the A7 Lite (without TWRP).

    Its a nice little tablet for the price but it doesn't have a very powerful SOC and for me the One UI is barely usable on this device. The launcher and the whole system UI feel extremely laggy, but apps generally run fine.

    I tried phhusson's custom Android 12 GSI and the device was almost resurrected. Much much less UI lag and the battery life is the same as stock ROM. The only thing i found not working is MTP but i don't need it.

    Since i saw a couple users here asking about GSIs i decided to make a very simple guide.

    As always do this at your own risk. You may brick your device. You will void your warranty.

    Follow the guide only if you know what your are doing. Read each step carefully and avoid copy pasting stuff randomly.

    I won't go deep into details as i believe you should have some basic knowledge if you decide to do this.

    The procedure sould work for both T220 and T225 (i tested it on a T220).

    I did this on Windows using WSL for some of the steps.

    Sources


    Thanks to @kkoo and @Brepro1 for the useful info

    - https://forum.xda-developers.com/t/...sing-odin-without-twrp-phh-lineageos.4114435/
    - https://forum.xda-developers.com/t/...r-img-and-flashing-our-modifications.4196625/

    Requirements​


    - Unlocked bootloader

    If you haven't done this already follow the steps in parts 1-2 from:


    - Latest official ROM

    I used T220XXU1AVE1 for EUX region


    - Download your preferred GSI

    I used AOSP 12.1 v414 with gapps from phhusson


    - Clean vbmeta.img from Google


    Tools​


    - lz4


    - simg2img


    - lpunpack and lpmake


    - tar-md5-script-tool

    Use the attached tar-md5-script-tool.zip

    Steps​


    1. Extract official ROM files (BL, AP, CP, CSC)

    2. Extract AP .tar.md5

    3. Decompress the extracted super.img.lz4

    Code:
    lz4 -d super.img.lz4 super.img

    4. Convert the sparse super.img

    Code:
    simg2img super.img super.ext4.img

    5. Unpack super.ext4.img

    Code:
    lpunpack super.ext4.img

    I got 4 partitions in my image (should be the same for all T220/T225 ROMs):

    - odm.img
    - product.img
    - system.img
    - vendor.img

    6. Replace system.img with your GSI (rename it to system.img)

    7. Get the size of all partitions and the size of the original super.ext4.img (not the sparse super.img)

    Code:
    stat -c '%n %s' IMG_FILE.img

    8. Repack super.img

    Code:
    lpmake --metadata-size 65536 \
    --super-name super \
    --metadata-slots 2 \
    --device super:ORIGINAL_SUPER_IMG_SIZE \
    --group main:SUM_OF_ALL_PARTITIONS_SIZES \
    --partition odm:readonly:ODM_PARTITION_SIZE:main \
    --image odm=./odm.img \
    --partition product:readonly:PRODUCT_PARTITION_SIZE:main \
    --image product=./product.img \
    --partition system:readonly:SYSTEM_PARTITION_SIZE:main \
    --image system=./system.img \
    --partition vendor:readonly:VENDOR_PARTITION_SIZE:main \
    --image vendor=./vendor.img \
    --sparse \
    --output ./super_new.img

    Replace ORIGINAL_SUPER_IMG_SIZE, SUM_OF_ALL_PARTITIONS_SIZES, ODM_PARTITION_SIZE, PRODUCT_PARTITION_SIZE, SYSTEM_PARTITION_SIZE, VENDOR_PARTITION_SIZE with the values you obtained in step 7.

    Read lpmake docs for a more detailed expalation of the args used above:


    9. Compress the repacked super_new.img

    Code:
    lz4 -B6 --content-size super_new.img super_new.img.lz4

    10. Compress the clean vmbeta.img

    Code:
    lz4 -B6 --content-size vbmeta.img vbmeta.img.lz4

    11. Extract tar-md5-script-tool.zip

    12. Put all the *.img.lz4 files extracted from AP .tar.gz in tar-md5-script-tool dir

    13. Replace super.img.lz4 and vbmeta.img.lz4 in tar-md5-script-tool dir with your repacked and compressed super_new.img.lz4 (rename it to super.img.lz4) and the clean compressed vbmeta.img.lz4

    14. Run batch.bat in tar-md5-script-tool dir

    You will find the new AP .tar.md5 in the temp-folder subdir

    15. Flash your custom AP .tar.md5 with Odin along with BL, CP, CSC from original ROM

    16. Reboot into recovery and do a factory reset

    17. Done
    2
    Can we boot lineage-19.1 GSI (nogapps, no magisk ) on tab 7 lite ?
    if yes, please compile for test Thank you.
    Device: SM-T225 Regeion: THL
    Happy testing :)

    GSI: lineage-19.1-20220613-UNOFFICIAL-arm64_bvS-vndklite.img

    https://www.filehosting.org/file/details/8249475/GSI-Lineage-19.1_SM-T225_THL_T225XXU1AVB2.zip
    2
    Thank you so much for compiling the AP for me bro but when i try to flash it with odin i get this error
    <ID:0/004> Firmware update start..
    <ID:0/004> SingleDownload.
    <ID:0/004> preloader.img.lz4
    <ID:0/004> FAIL!


    For your information the current OS build on my tablet is INS with the baseband version of T225XXU1AVB2 and security patch of 1 Feb 2022 hope this helps you.
    Here is GSI build for SM-T225_INS_T225XXU1AVB2
    https://www.filehosting.org/file/details/7129248/GSI-12_SM-T225_INS_T225XXU1AVB2.zip
    2
    Successfully flashed GSI with magisk on my T220 following the OP's procedure. MTP is not working as the OP said. However, I can use my flash drive so I don't really miss MTP.

    I chose "system-squeak-arm64-ab-vndklite-gapps-secure.img.xz" for GSI. "Treble Info" app can tell you what image would be compatible with your device.

    If you want to use a different launcher like Nova instead of the default one, change the "Smallest width" setting from 600 to 598 in Developer options to hide the annoying taskbar.

    AOSP-Mods and "Project Themer - Android 12+" work fine for me.

    Here is my build for my device SM-T220 (SM-T220_EUX_T220XXU1AVE1):

    GSI: system-squeak-arm64-ab-vndklite-gapps-secure.img.xz
    Custom AP: https://www.filehosting.org/file/details/7045394/AP_TAR_MD5_CUSTOM_FILE_ODIN.tar.md5
    Custom AP with Magisk patch: https://www.filehosting.org/file/details/7045714/magisk_patched-25101_cauJQ.tar

    You can extract BL and Home_CSC from SM-T220_EUX_T220XXU1AVE1.

    Screenshot_20220624-113012.pngScreenshot_20220624-113035.pngScreenshot_20220624-113131.pngScreenshot_20220624-113205.png

    Notes: My device is actually SM-T220 XAR, but I have been updating it with SM-T220 EUX firmware versions without any issue.
    1
    Can you share screenshot as I think treble projects are only stable on SD chipset.

    System lang is italian but should be easy to understand.

    I found only a couple bugs so far in phhusson's GSI:
    - in the launcher dragging apps from drawer to homescreen doesn't always work (just use another launcher)
    - crashed once while searching in settings app

    I use the tablet only for media consumption and some retrogaming, so there are probably other bugs i haven't noticed.

    This is a generic guide, it won't include a "known issues" section since it largely depends on what GSI you choose.

    I haven't tested this on the LTE version so i can't say for sure if mobile network works or not.

    Unfortunately i don't have the time to make a custom ROM, test it and keep it updated here on the forum but maybe if there is enough interest someone will do it.

    I hope other users will try to flash a GSI and share their experience here so we can gather some info on working/broken stuff, especially on the LTE model since i can't test that.