• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

Guide To DAB For MTCB/MTCC Head Units

Search This thread

typos1

Senior Member
Apr 3, 2007
9,447
1,718
UK
Hi all,
can anyone please tell me about my head-unit, what i can and cant do with it and if its upgradable.
Audio sources d90-810
CPU CORTEX-A9 DUEL CORE
ANDROID VERSION 4.2.2
MCU VERSION 4.3.11-22-13-E50201
SYSTEM VERSION 2.9.3-20150115


I have fitted a USB DAB dongle and down loaded the YHX_DAB+20170328-zoulou-2017-04-09.apk its all installed but when i put the car into reverse it says no video signal

Any help will be very appreciated

regards
Patrick

I can tell by your MCU that you do not have an MTCB head unit, so youre in the wrong forum, try the Android Headunits General forum.

I can also tell you that the "no signal" message is likely to be referring to the lack of a signal from a reverse camera, not a DAB box.
 

ishan81

Senior Member
Nov 6, 2014
50
2
Also a tip for people experiencing bad DAB reception issues . I have experimented with lots of types of aerials in UK .

1) ok to bad reception - non powered glass mount aerial . Come with most dab modules

2) ok - reception - powered glass mount reception . Common design dab-a1

3) best reception - bee sting external aerial . ( goes on roof ) shark fins are not that great .

Compromise solution - external aerial mounted behind rear bumper with signal amplifier which is what I have . ( my car is a convertible)

Also If you have HID or led headlight conversions which are non OEM . These can give interference in car wiring and disrupt signal . I had this issue. Best to test this during the day by unplugging the mod first and then with to see if reception decreases . to solve I used magnetic shielding on headlight mod cables also on aerial and cables going to dab unit . See pic attached . This solved my issues . IMG_9096.JPGIMG_9097.JPG


Sent from my iPhone using Tapatalk
 
Last edited:

ishan81

Senior Member
Nov 6, 2014
50
2
Also a tip for people experiencing bad DAB reception issues . I have experimented with lots of types of aerials in UK .

1) ok to bad reception - non powered glass mount aerial . Come with most dab modules

2) ok - reception - powered glass mount reception . Common design dab-a1

3) best reception - bee sting external aerial . ( goes on roof ) shark fins are not that great .

Compromise solution - external aerial mounted behind rear bumper with signal amplifier which is what I have . ( my car is a convertible)

Also If you have HID or led headlight conversions which are non OEM . These can give interference in car wiring and disrupt signal . I had this issue. Best to test this during the day by unplugging the mod first and then with to see if reception decreases . to solve I used magnetic shielding on headlight mod View attachment 4486143cables also on aerial and cables going to dab unit . See pic attached . This solved my issues .

Here’s pic of aerial mounted in bumper . Reception is better than glass but not good as bee sting .

Sent from my iPhone using Tapatalk



IMG_9097.JPG



Sent from my iPhone using Tapatalk
 

Munz84

Member
Jan 28, 2021
6
0
Hello. Reaching out as I'm fairly new to this but I installed an Eonon head unit in my VW Touran from which I had an Dension USB-U dab adapter installed on the factory unit. The new head unit, running Android 10 failes to recognise the Dension adapter and says it is corrupt and needs to format it. Any ideas?
 

typos1

Senior Member
Apr 3, 2007
9,447
1,718
UK
I m sure I ve read about people using the Densions on these units, maybe it downs to the app being out of date, or needing a newer version to work on 9/10?

Post where to download it from and I ll try it on Oreo and Pie for you.
 

Munz84

Member
Jan 28, 2021
6
0
I m sure I ve read about people using the Densions on these units, maybe it downs to the app being out of date, or needing a newer version to work on 9/10?

Post where to download it from and I ll try it on Oreo and Pie for you.
I think it's down to the configuration of the Dension adapter. It can be configurated to fit different head units by installing different config files available on the Dension website, but despite my efforts it seems impossible to figure out which one will work on android 10 based units.
 

typos1

Senior Member
Apr 3, 2007
9,447
1,718
UK
Have you contacted Dension suport ?

BTW, you realise this thread is for MTCB/C units which were never available with Android 10 ? What unit do you have ?
 

Munz84

Member
Jan 28, 2021
6
0
Have you contacted Dension suport ?

BTW, you realise this thread is for MTCB/C units which were never available with Android 10 ? What unit do you have ?
I did not realise that, sorry 😂

I have the Eonon GA9453B.

Dension told me to just try different config files, which in best case is a very vague answer.

Where would be the appropriate place to discuss this on here?
 

typos1

Senior Member
Apr 3, 2007
9,447
1,718
UK
Thats your processor not your MCU, your MCU will be clearly prefixed by "MCU".

MTK is short for Mediatek which means youre deffo in the wrong forum as no MTCB/C or MTCD/E units have Mediatek processors.

Try the Android Auto General Android Headunit forum.
 

junk68

Member
Oct 12, 2015
8
1
Napoli
Hallo to evryone. I have a problem in running a dasaita DAB dongle on my Dasaita PX5 head unit. I first mounted it a few months ago, after leaving it for several months lying around. It is a dedicated Dasaita dongle without USB (it plugs in on the rear of the unit) At first my head unit didn't "read" any unit pluged in and I couldn't find the DAB settings in the menu. I wrote to dasaita, their reply was that I didn't plug it in correctly, so I unmounted evrything and put it back together (twice). Meanwhile I received an MCU update from them, bringing my firmware to latest version. I installed and unistalled several times the software provided, but I have always the same result: software runs, I am able to run a radio station search, software shows me signal strength of radio station, but anyway, I don't hear any sound. Funny thing I noticed is that when I start the DAB sw, I hear music playing from FM radio chip: I hear the last radio station, but at much lower volume. Trying to do something, I pressed randomly on evrery part of the screen. By keeping pressed the signal strentgh suddenly a pop up message showed up saying that firmware had to updated and a percentage ticker came up. After 10 or more minutes it was still at 1%, so I broke it up in order not to uncharge my car battery. I tried again the day after, this time with running engine, but nothing changed. Is there any software that I can try to see if the dongle is connectec properly? Shall I try to disconect and re plug it in again? Is there something I can do in order to have it running? I updated from android 8 to android 9 and now to Hal9k mod v4
Thank you ton anybody that can give me some answers (Dasaita doesn't seem to know how to help me. I've sent them also video footage of the device not running, they answered that I have to plug it in properly)
 

junk68

Member
Oct 12, 2015
8
1
Napoli
Hallo to evryone. I have a problem in running a dasaita DAB dongle on my Dasaita PX5 head unit. I first mounted it a few months ago, after leaving it for several months lying around. It is a dedicated Dasaita dongle without USB (it plugs in on the rear of the unit) At first my head unit didn't "read" any unit pluged in and I couldn't find the DAB settings in the menu. I wrote to dasaita, their reply was that I didn't plug it in correctly, so I unmounted evrything and put it back together (twice). Meanwhile I received an MCU update from them, bringing my firmware to latest version. I installed and unistalled several times the software provided, but I have always the same result: software runs, I am able to run a radio station search, software shows me signal strength of radio station, but anyway, I don't hear any sound. Funny thing I noticed is that when I start the DAB sw, I hear music playing from FM radio chip: I hear the last radio station, but at much lower volume. Trying to do something, I pressed randomly on evrery part of the screen. By keeping pressed the signal strentgh suddenly a pop up message showed up saying that firmware had to updated and a percentage ticker came up. After 10 or more minutes it was still at 1%, so I broke it up in order not to uncharge my car battery. I tried again the day after, this time with running engine, but nothing changed. Is there any software that I can try to see if the dongle is connectec properly? Shall I try to disconect and re plug it in again? Is there something I can do in order to have it running? I updated from android 8 to android 9 and now to Hal9k mod v4
Thank you ton anybody that can give me some answers (Dasaita doesn't seem to know how to help me. I've sent them also video footage of the device not running, they answered that I have to plug it in properly)
I'd like to thank publicly Hal9k for his help provided! I wrote him in private, and even if it has nothing to do with his mod or with the hardware he normally uses, he tried to help me out.
 
  • Like
Reactions: SKiZO123

Top Liked Posts

  • There are no posts matching your filters.
  • 1
    Hallo to evryone. I have a problem in running a dasaita DAB dongle on my Dasaita PX5 head unit. I first mounted it a few months ago, after leaving it for several months lying around. It is a dedicated Dasaita dongle without USB (it plugs in on the rear of the unit) At first my head unit didn't "read" any unit pluged in and I couldn't find the DAB settings in the menu. I wrote to dasaita, their reply was that I didn't plug it in correctly, so I unmounted evrything and put it back together (twice). Meanwhile I received an MCU update from them, bringing my firmware to latest version. I installed and unistalled several times the software provided, but I have always the same result: software runs, I am able to run a radio station search, software shows me signal strength of radio station, but anyway, I don't hear any sound. Funny thing I noticed is that when I start the DAB sw, I hear music playing from FM radio chip: I hear the last radio station, but at much lower volume. Trying to do something, I pressed randomly on evrery part of the screen. By keeping pressed the signal strentgh suddenly a pop up message showed up saying that firmware had to updated and a percentage ticker came up. After 10 or more minutes it was still at 1%, so I broke it up in order not to uncharge my car battery. I tried again the day after, this time with running engine, but nothing changed. Is there any software that I can try to see if the dongle is connectec properly? Shall I try to disconect and re plug it in again? Is there something I can do in order to have it running? I updated from android 8 to android 9 and now to Hal9k mod v4
    Thank you ton anybody that can give me some answers (Dasaita doesn't seem to know how to help me. I've sent them also video footage of the device not running, they answered that I have to plug it in properly)
    I'd like to thank publicly Hal9k for his help provided! I wrote him in private, and even if it has nothing to do with his mod or with the hardware he normally uses, he tried to help me out.
  • 2
    There are several DAB options for MTCB head units :

    1)The RTL type DVB-T/FM dongle and the Wavesink app, see this thread in the hardware mod section: http://forum.xda-developers.com/and...development/adding-dab-functionality-t3208344

    2) Use DVB-T card or module specifically for MTCB head units and use the "radio" function. These can be bought with the head unit or purchased separately. Some manufacturers like KGL/HuiFei use and add on box, others like Klyde, use cards mounted inside the unit. In factory settings, at the last count, there were about 12 different types of TV tuner that can be selected.

    3) Or use general Android USB DVB-T dongle and use the "radio" setting on its accompanying app. If this method is chosen, obviously you dont need to go into factory settings and pick a tuner, as these settings are only for DVB-T tuners bought with/for MTCB head units.

    (Radio through a DVB-T card IS digital (using either MPG2 or MPG4 depending on the type of DVB-T tuner you have) but it is not DAB. Its also dependant on what radio channels your country chooses to transmit over DVB-T, for instance in the UK in my local area, none of the local stations are transmitted and not all of the national ones are either.)

    4), 5) & 6) Dension sell 3 Android DAB products, one that uses BT to connect (which may prove a problem with the BT implementation on MTCB head units, edit: May 2016, the BT type seems to no longer be available), one that connects via USB and 1 that uses FM modulation (which means station names/info displayed via RDS in the FM/AM radio app, but a separate controller for the DAB for changing channels is needed) see here : http://www.dension.com/products#dab-radio-solutions

    7) Navall sell a DAB module for their units, they sell both KGL (Hui Fei) units and also the Ownice head unit (the Ownice is NOT an MTCB type unit) see here : http://navallstore.com/Options/DAB -DAB-plus(Digital-Audio-Broadcasting)

    8) Joying sell an add on DAB box (its not L band compatible though) : https://www.carjoying.com/joying-di...iversal-android-car-auto-radio-head-unit.html

    9) FIAMM make a DAB antenna with built in tuner and BT, so youd simply install the antenna and use BT on your head unit to connect to BT (there is an app available), how it would work with the BT on MTCB head units, however, is unknown :

    http://www.smartantenna.it/en/page-product.php

    https://play.google.com/store/apps/details?id=com.fiamm.sm2&hl=en

    10) And finally Klyde sell a DAB module specifically for their units (I ve just bought a new Klyde head unit with it). They use a DAB module made by Shinwa who also supply DAB modules to Blaupunkt, Pure and Philips. I m told it is not retro fittable as modifications are needed to the board, I ve tried to make it work on my non DAB Klyde unit. but I ve had no luck, so far at least. Its a separate module, but its quite small (approx 10cmx4cmx5cm). Its small enough to be mounted inside the unit, something I intend to do with mine. It uses the DAB app that started appearing in ROMs from June (2015), although they have recently updated it. I ve added pictures of the module and the new app. It works quite well, although I m not over keen on the interface of the app personally, but it can be modded like any other MTC app. As the DAB app appears in ROMs since June, its been developed by MTCB (who develop ALL the software for ALL the MTCB type headunit, which is why they are so similar and have interchangeable software, WHICHEVER manufacturer version you have) this may mean that the other manufacturers will have OEM DAB options soon - I m sure MTCB have not developed the DAB app just for Klyde. So far at least, Klyde is the only company selling DAB units that use this app, AFAIK Navall use a different app and set up.
    2
    I changed the Dab-App a little bit. You can download it here: https://mega.nz/#F!69JH3SwZ!G30W-fliypsgxOMw6NigBg
    1
    Sweet! I may replace my current hu in the near future then; quad core and dab+ would be worth it


    Does the app not give you channel list? Only next/prev?

    Soz for delay, I m not getting emails when my posts get replies, for some reason.

    Yeah, there is a channel list, you press the menu button on the top left I think, its hard to tell cos I using it with horizontally mounted DVB-T antennas so I only get that channel currently, I need to get a proper DAB antenna !

    I ll change this thread to a general "DAB for MTCB Headunits" thread soon and list all the DAB/digital radio options - basically the Navall DAB module, RTL DVB-T tuners with Wavesink, this DAB module from Klyde and using a DVB-T card/module/usb TV dongle to receive digital radio through digital tv).
    1
    Did you check that you are subscribed to the thread?

    Lol, I AM subscribed because I started it ! Still I got an email for your reply, I think t may be to do with the changes at XDA recently.

    I've also been thinking about merging this into the other one. What do you, @typos1, think about that? As this is a new thread it would work...


    I saw the other thread, but that was specifically for using the Wavesink app with RTL dongles, which is technically a hardware "mod" as you are adding hardware, whereas this was meant to be a general DAB/digital radio guide, hence putting it in the "general" section, also, if you buy a unit with DAB already, its not a "mod". I ve added a link to the Wavesink DAB thread. Maybe you could re-name that thread "Using Wavesink for DAB" or something ? I think you d have to re-name this one as well, as I dont think threads can be re-named by non mods (take it youre a mod now Alex ?!), can you re-name it "Guide to DAB on MTCB headunits" ? And if there are threads about DVB-T dongles, the Dension DAB options and DVB-T tuner supplied with MTCB head units (I know all have been discussed in the original thread) I can add links to them in this thread also.

    (Need to reply to your pms BTW Alex, I will do soon)
    1
    Hallo to evryone. I have a problem in running a dasaita DAB dongle on my Dasaita PX5 head unit. I first mounted it a few months ago, after leaving it for several months lying around. It is a dedicated Dasaita dongle without USB (it plugs in on the rear of the unit) At first my head unit didn't "read" any unit pluged in and I couldn't find the DAB settings in the menu. I wrote to dasaita, their reply was that I didn't plug it in correctly, so I unmounted evrything and put it back together (twice). Meanwhile I received an MCU update from them, bringing my firmware to latest version. I installed and unistalled several times the software provided, but I have always the same result: software runs, I am able to run a radio station search, software shows me signal strength of radio station, but anyway, I don't hear any sound. Funny thing I noticed is that when I start the DAB sw, I hear music playing from FM radio chip: I hear the last radio station, but at much lower volume. Trying to do something, I pressed randomly on evrery part of the screen. By keeping pressed the signal strentgh suddenly a pop up message showed up saying that firmware had to updated and a percentage ticker came up. After 10 or more minutes it was still at 1%, so I broke it up in order not to uncharge my car battery. I tried again the day after, this time with running engine, but nothing changed. Is there any software that I can try to see if the dongle is connectec properly? Shall I try to disconect and re plug it in again? Is there something I can do in order to have it running? I updated from android 8 to android 9 and now to Hal9k mod v4
    Thank you ton anybody that can give me some answers (Dasaita doesn't seem to know how to help me. I've sent them also video footage of the device not running, they answered that I have to plug it in properly)
    I'd like to thank publicly Hal9k for his help provided! I wrote him in private, and even if it has nothing to do with his mod or with the hardware he normally uses, he tried to help me out.