Guide to Flash TWRP (Unofficial) and Root Redmi Y2/S2 (YSL)

Search This thread

Skyfire1

Senior Member
Jan 2, 2015
120
20
After installing twrp first time the data ( everything from your use ) is gone. Did you do a backup before flashing anything? Maybe something is saved in Google cloud?

---------- Post added at 07:03 PM ---------- Previous post was at 06:59 PM ----------

Did you try installing os by twrp before using miflash? Flashing with miflash makes a virgin phone!
I cannot recommend any custom recovery. Maye when I have my new internet connection on next weekend I can search for it.
 

areevave

New member
May 9, 2020
1
0
Hi guys i face a problem that after wipe all data.. i install custom rom then i reboot its say NO OS INSTALLED keep continue.
Over and aver stuck at TWRP

olease help me
 
Mar 30, 2020
10
0
Hi guys i face a problem that after wipe all data.. i install custom rom then i reboot its say NO OS INSTALLED keep continue.
Over and aver stuck at TWRP

olease help me

I too stucked before in TWRP. So try solutions from youtube. If not worked. Then flash stock rom using miui flash tools (all data will be erased) and again use orangefox recovery for your RedmiY2 (miui version 11 working). For details
https://youtu.be/WIyKrrZKlz8
For twrp
https://youtu.be/EIuSzBGV10g

I preferred orangefox this time, because TWRP lead me to stuck last time. But this TWRP also may work good without any issue. (I did not tried)
I hope this will help you.
 

vinay45

New member
Nov 18, 2019
4
1
Stuck on installing twrp

[email protected]

Author : mahajant99/Hacker's Club
Version : 7.0

:: ------------------------------------------------------------ ::
:: - TWRP TOOLKIT - ::
:: - Redmi Y2/S2/YSL - ::
:: - by mahajant99/Hacker's Club - ::
:: ------------------------------------------------------------


target reported max download size of 534773760 bytes
erasing 'recovery'...
OKAY [ 0.018s]
sending 'recovery' (31528 KB)...
OKAY [ 0.926s]
writing 'recovery'...
OKAY [ 0.376s]
finished. total time: 1.327s
downloading 'boot.img'...
OKAY [ 0.888s]
booting...

It keeps on booting but twrp not installed.
 

Snpy1337

Member
Nov 6, 2019
6
0
Can't boot

I'm trying to run fastboot boot recovery.img (I renamed the file) and it's stuck at 'booting...' Any ideas? I just got back to stock rom today but I'm trying to launch twrp so I can enable camera 2 api
 

Top Liked Posts

  • There are no posts matching your filters.
  • 4
    Here I present you my toolkit for flashing TWRP and rooing Redmi Y2/S2/YSL.

    Requirements
    1. PC
    2. Fastboot Drivers
    3. Unlocked Bootloader (Guide)
    4. Flashing TWRP Toolkit
    5. Magisk flashable file

    Steps for Flashing TWRP
    1. Download the file. Link given in the end of the threads.
    2. Boot your device into Fastboot mode (in power off state press power button + volume down button).
    3. Connect your device from pc.
    4. Now open the downloaded folder and run the file "Flash.bat".
    5. Then press any key to continue.
    6. Now your phone will automatically boot into TWRP.
    7. Now you have sucessfully flashed Twrp.8. Before rebooting your device do flash lazyflasher-no-verity-opt-encrypt.zip.

    Note :-
    * If you don't flash Lazy Flasher then the Custom recovery will be replaced with stock recovery in next Boot.

    Steps for Rooting
    1. Download and place the Magisk zip fiile into your device.
    2. Boot your device into TWRP Recovery (in power off state press power button + volume up button).
    3. Select the option of 'Install' and then locate the directory where you have placed the Magisk file and select it.
    4. After selecting the file, swipe the arrow loacted at the bottom.
    5. When the flashing is completed click on 'Reboot System'.
    6. After the phone has booted successfully install magisk apk.


    Congrats you have rooted your device !!

    Note :-
    * This is Exclusively for Redmi Y2/S2/YSL and if you try this on any other device probably you may be bricking your device!!
    * I am not responsible for bricked devices, dead SD cards, thermonuclear war, or you getting fired because the alarm app failed.
    * First boot may take upto 15-20 mins. So don't panic.

    Links :-
    * TWRP Toolkit - Click here
    * Lazy Flasher - Click here
    * Magisk - Click here
    2
    So I got stuck on Bootscreen. :(
    I flashed MIUI with TWRP and was back on stockrom with stockrecovery. :)
    Then I booted TWRP temporarely with ADB. (adb command: fastboot boot twrp.img )
    Now I installed Magisk and I am happy now ;)
    Just DON´T install TWRP. Boot it temporarely !

    I used MIUI from here: https://www.theandroidsoul.com/download-miui-10/
    2
    use xiaomi eu roms they dont ask twrp password
    1
    will try this as soon i am able to unlock my bootloader, thanks!
    (i hate xiaomi for locking the device for 1 month....!! :mad:)
    1
    Flashing LF ends in endless boot. No loop but endles bootscreen 1,2,3 dots endlessly! Any ideas ?
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone