[Guide-Tool][Linux] Projekt ScriBt v2.2.1 [Build-A-ROM][Newbie-Friendly]

TimSchumi

Senior Member
Mar 9, 2016
869
395
73
19
why did this happen?
There is no error in here. The Android Source is full of warnings (e.g. "Some input files use unchecked or unsafe operations"), you can ignore those though. But make sure to ask in a ROM buildimg thread next time, not here. The chat in here should be related to ScriBt, not ROM building in general.
 

dj_chele

Member
Feb 21, 2009
18
0
0
Help with Rom Project Fujitsu Arrows F-02E

Hello everybody

I have a Fujitsu Arrows F-02E since 2013 with a software issues
I think that the unique solution to return device to life is building a rom to install them
At this time I am not programmer I only have knowledge about windows and basic programming
I have source code of rom for this phone in a tar.gz file but I don't know how I can get kernel and other files

It is possible that I share with you open source code file for this phone and you help me compilating a rom to install on phone through recovery?


I really appreciate your comments

Regards
 

TimSchumi

Senior Member
Mar 9, 2016
869
395
73
19
Hello everybody

I have a Fujitsu Arrows F-02E since 2013 with a software issues
I think that the unique solution to return device to life is building a rom to install them
At this time I am not programmer I only have knowledge about windows and basic programming
I have source code of rom for this phone in a tar.gz file but I don't know how I can get kernel and other files

It is possible that I share with you open source code file for this phone and you help me compilating a rom to install on phone through recovery?


I really appreciate your comments

Regards
We cannot help you with developing directly and build errors and questions should be posted in a ROM building thread, not here.

---------- Post added at 01:00 PM ---------- Previous post was at 12:58 PM ----------

How can I compile faster?
Get a better PC or upgrade it.
Most important:
- Faster CPU
- Better I/O (e.g. get a SSD)
- (maybe) more RAM
 
  • Like
Reactions: dj_chele

bertino

Senior Member
Oct 17, 2014
263
92
48
Is it compatible with ubuntu 18.04, or does it need an update? I tried and it tells me
[!] No supported package manager has been found.
[!] Arch Linux or a Debian/Ubuntu based Distribution is required to run ScriBt.
 

TimSchumi

Senior Member
Mar 9, 2016
869
395
73
19
Is it compatible with ubuntu 18.04, or does it need an update? I tried and it tells me
[!] No supported package manager has been found.
[!] Arch Linux or a Debian/Ubuntu based Distribution is required to run ScriBt.
It probably needs just a copy-over of the package list. I'll push it in a few hours.

EDIT: Eh, misread the error. Could you check if apt-get is still installed on your system? (And please check the command "apt-get moo", too)
 
Last edited:

Pac_MM

Member
Jan 11, 2016
16
4
0
It probably needs just a copy-over of the package list. I'll push it in a few hours.

EDIT: Eh, misread the error. Could you check if apt-get is still installed on your system? (And please check the command "apt-get moo", too)
Same error here.

apt-get installed ok:

[email protected] ~/PacKitchen $ apt-get moo
(__)
(oo)
/------\/
/ | ||
* /\---/\
~~ ~~
..."Have you mooed today?"...

Thanks Team!
 

dargonswim

Member
Oct 26, 2010
36
20
0
Hello I have never done any ROM and have little idea of programming. Is there a step-by-step tutotial for dummies to compile a ROM? I've tried several times but I can't even get to step 1

Thank you
 

bassbounce

Senior Member
Feb 14, 2011
546
369
93
Betuwe
When i start to build the kernel i get some strange errors.


Code:
../scripts/gcc-version.sh: line 31: printf: Is: invalid number
../scripts/gcc-version.sh: line 31: printf: your: invalid number
../scripts/gcc-version.sh: line 31: printf: PATH: invalid number
../scripts/gcc-version.sh: line 31: printf: set: invalid number
../scripts/gcc-version.sh: line 31: printf: correctly?: invalid number
../scripts/gcc-version.sh: line 31: printf: Is: invalid number
../scripts/gcc-version.sh: line 31: printf: your: invalid number
../scripts/gcc-version.sh: line 31: printf: PATH: invalid number
../scripts/gcc-version.sh: line 31: printf: set: invalid number
../scripts/gcc-version.sh: line 31: printf: correctly?: invalid number
/bin/sh: 1: [: 0000: unexpected operator
  CHK     include/config/kernel.release
  UPD     include/config/kernel.release
Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler
/home/bassbounce/ScriBt/kernel/Makefile:1073: recipe for target 'prepare-compiler-check' failed
make[1]: *** [prepare-compiler-check] Error 1
make[1]: Leaving directory '/home/bassbounce/ScriBt/kernel/popo'
Makefile:150: recipe for target 'sub-make' failed
make: *** [sub-make] Error 2
 

pezeus

Member
Dec 2, 2018
8
2
0
Baddi
[Linux Mint] No supported Package Manager found.

Code:
[!] No supported package manager has been found.
[!] Arch Linux or a Debian/Ubuntu based Distribution is required to run ScriBt.
[!] Unsetting all variables
[!] Thanks for using ScriBt.
[</3] Failed somewhere :(
I'm using Linux Mint and I can't really figure a workaround, did it work on Mint Previously?

PS: I'm fairly new to Android ROM Development.
 

Deepansh Pandey

New member
Nov 10, 2018
3
0
11
Durg
deepanshpandey.ml
When i start to build the kernel i get some strange errors.


Code:
../scripts/gcc-version.sh: line 31: printf: Is: invalid number
../scripts/gcc-version.sh: line 31: printf: your: invalid number
../scripts/gcc-version.sh: line 31: printf: PATH: invalid number
../scripts/gcc-version.sh: line 31: printf: set: invalid number
../scripts/gcc-version.sh: line 31: printf: correctly?: invalid number
../scripts/gcc-version.sh: line 31: printf: Is: invalid number
../scripts/gcc-version.sh: line 31: printf: your: invalid number
../scripts/gcc-version.sh: line 31: printf: PATH: invalid number
../scripts/gcc-version.sh: line 31: printf: set: invalid number
../scripts/gcc-version.sh: line 31: printf: correctly?: invalid number
/bin/sh: 1: [: 0000: unexpected operator
  CHK     include/config/kernel.release
  UPD     include/config/kernel.release
Cannot use CONFIG_CC_STACKPROTECTOR_STRONG: -fstack-protector-strong not supported by compiler
/home/bassbounce/ScriBt/kernel/Makefile:1073: recipe for target 'prepare-compiler-check' failed
make[1]: *** [prepare-compiler-check] Error 1
make[1]: Leaving directory '/home/bassbounce/ScriBt/kernel/popo'
Makefile:150: recipe for target 'sub-make' failed
make: *** [sub-make] Error 2




i am getting the same error in 2021
how did you fixed it