• Introducing XDA Computing: Discussion zones for Hardware, Software, and more!    Check it out!

[Guide][Tutorial] Root TWRP LG V20 using Dirtysanta[Most Variants][Noobfriendly]

Search This thread

Jesus is God Almighty

Senior Member
Aug 19, 2016
322
22
Seems I got the F800K variant rooted. But then, what now?
I can't seem to upgrade it to version 8, Google have placed things in it so Rooted phones can't upgrade and then I seem to be stuck at version A7... Which is not the way to go as my LG backup needs Android 8 to work.

But it seems I am at least rooted, 3 try made it for me - although I am thinking of doing another and see if I can install Magick in replacement of SuperSU which I did the third time.

Or I cold just do it now I guess, but I have an update that can't update and seem to be stuck and telling me it needs to be updated... Overall, not sure which direction to go from here.

Anyone know if I can install A8 with root? I just wanted the standard latest rom A8 with Root really. Is that possible?
 

Jesus is God Almighty

Senior Member
Aug 19, 2016
322
22
Okay not many writing... Okay... So, I am at the point updating version 7 to hopefully still before the dating of the locking happening from the Criminals at Google.
Although I wanna update to A8 with Root, I tried yesterday with no success and I have like 2 manuals to try out. Although I think one might be forgetting somerthing and not sure how to work out the other. I have not used Boot adb or whatever it is called much. But it should be installed, and it did seem to do something yesterday although when I tried to get into the Recovery I ended up deleting things in replacement as it did not seem to be there. I guess one can use a command from the computer to do it, yet not that experienced with it.

Well, I guess there is no other way then try again a couple of times I guess - I most likely will not work out the first couple of tries testing things out. Hopefully I can get it done but... Who knows.

Would be nice with some help on the commands for flashing TWRP with that thing... In command prompt, mostly that was what did me in, and apparently lost it at that point.

Anyway... Will try again, just a lot of steps to do every single time to recover TWRP and going from there. I can do a recover if I have access to TWRP but... if it ruins TWRP then I have a problem. One guide did not try to do anything but just say go into TWRP, and it does not seem you flash Recovery when upgrading A8.

I have 2 kernels I have found that I can test with, I guess with A8. mk2000 and another which name eludes me... Schwifty_Kernel_Axon7_vR5 it was.
Dunno if there is any other kernels or how it will run.

I tried to install the newest version of TWRP, but that seemed to do serious damage to the speed of the overall phone... Apparently that can also be somewhat of an issue. Apparently.

Sigh so many factors and such.

Although not giving up!!! But for something that should just have taken a second, I am very angry at Google and LG for bullshitting people like this. This is absolutely nonsense how many hoops one has to hit correctly to get things to work as one wants. And it should have just taken 1 second, to push ROOTED! Clearly these Tyrants are evil working for the Devil - as they jail us in, more and more.
 

Jesus is God Almighty

Senior Member
Aug 19, 2016
322
22
I will try this guide, he does not seem to try to install TWRP in it, which hopefully will work, that would be nice! Taking hours and hours to get to specific points, I'm just updating the version 7 to have a more updated version as a backup, although I guess it should not matter, but there seems to be a good amount of bugs in the oldest version 7 that I have:


Congrats, now you have a rooted, twrp phone. Now onto flashing oreo with root

2. file needed: TWRP 3.2.3-2 for US996 (can be found here), oreo mk2000 beta(the most up to date) kernel for F800L/s/k, lastest magisk or su zip file, oreo kdz - the latest one 2018-12-13 *I have the F800K version, so search for that if you have another phone L S K* and SD card. 3. copy all these file to sd card. 4. connect your phone to pc, open patched lg up it should detect your variant, select kdz directory, select PARTITION DL and flash kdz with partition dl mode, uncheck recovery, recoverybak, aboot, abootbak

5. wait for it to finish!

*He seems to not think I need to do anything, but just go into recovery... Like no reflash of it or anything, I hope that is true. But we will see... Partition DL as far as I can understand don't override those recovery stuff, so why should it not work? Dunno... I will try and hope for the best, this seem to be my hiccup for now*
6. boot to recovery by hold volume down + press twice the home button the screen gonna show factory reset, select yes twice then it gonna boot to recovery. 7. you might need to repeat all those step twice but > format data > flash Magisk/SU, reboot recovery then format and flash mk2000 kernel then flash root Magisk/SU again to make it work. 8. clean dalvik cache for safety, and reboot system. 9. your phone gonna booting up, if it pass through all LG logo (may take some time, be patient), you are done, if the LG logo keep showing for too long, then you may try boot recovery and repeat all those step.
 

Jesus is God Almighty

Senior Member
Aug 19, 2016
322
22
It seems the F800K Oldest version which does not go beyond 2017 is December 1 2016. They also seem to have fixed the Camera in this version, so that is good. And the Memory issue is not there either. So at least 2 bugs fixed and most likely a lot of others. Just nice to not have those at hand.
Sadly I flip away to quick but I think the next update it is now downloading is 2017 Feb, which most likely will have the security so one cannot root.
So I should stop at this point.

The Newest version A8 F800K that one can download, has one update back to being fully updated. Not a biggie overall, don't care much for the security anyway as long as it works. It's outdated anyway, whatever I do :p

As long as I can get it working smoothly, then I am happy, with root and all! That would be my goal. If not I will just install it unrooted and use it as is. But I really would like to have it rooted. Will most likely also help me transfer programs from one phone to another future one that I am still awaiting to get.
 

Jesus is God Almighty

Senior Member
Aug 19, 2016
322
22
No this update is from 2016 12 20... This should be all good, I will install it. And move forward, just amazing how long it takes to update things :/
Anyway, hopefully everything will be fixed without issues and then I can make a backup with less bugs from the beginning at least! :)

Hmmm... Yup takes a long time to download and update, as it takes one after another. hours and hours to do it really. Kinda wasteful if I can get the A8 working but hey... step by step getting closer to the goal.

Still have lots of videos and reading of stuff to do... Digging around and all that.

Just weird that TWRP would effect the system speed, I think... I wonder what that is about, might need to retest it to see if it continues with that. Of cause A8 might work differently overall with the speed, and who knows if there is more kernels and all that.
 

Jesus is God Almighty

Senior Member
Aug 19, 2016
322
22
Okay... This update is 2017 Jan 10 so... I think I will reset the mobile now with the version I have from before Jan and go from there so I don't have the update annoying me. Although need to set things up again... But whatever. Erasing now. At least the updates absolutely made the phone better from the first. Will be interesting to see if I can root TWRP it and Root it now. And surely make a backup out of it.
So far so good :) Some more days, and some more work and it should be Rooted with A8 I hope.... I hope.... At least others have done it, I should be able to figure it out as well.
So now it starts from the beginning with the updates
So far so good :p
Security patch level December 1 2016.
Against I don't dare try to install the next update as it is from 2017, but if one wanted just to stay on Android 7 with root I guess one could try it out and see how far one can go before it breaks. At least this updated version of 7 seems to be pretty good overall.
 

Jesus is God Almighty

Senior Member
Aug 19, 2016
322
22
After 4 days of work, study, testing and seeking I have a Rooted Android 8...
And it seems to be running smoothly and stable, as far as I can see.

What a maniac experience.

Still of cause I have things that I would like to test out, but overall... I have something that seems to work now as I wanted it, as my goal.

I should be able to restore all my apps from my old unrooted LG V20 Hongkong to this rooted phone and from there, when my main phone sometime, hopefully arrives from Germany, I can move them over without needing any google as they have a version without it which would be nice. To just get away from the Tyranny of google to the best of my ability.

Anyway... Still waiting for the phone, and I have no idea when it comes around. But at least I have a new V20 that can serve as a replacement of my broken V20. So many things have broken on it, yet... it still runs but it is ticking for sure.
 

Jesus is God Almighty

Senior Member
Aug 19, 2016
322
22
Lets see if I can do this with my old H990N - just to see if it might be possible as most people say it is not.
First step at the moment is being done, if anything it would not be a big loss if it bricks it...
It seems to be some time on the last part, not sure if it has broken already or not. This step could take some time to finish I recall.
The mobile is still scanning the SD card, and I just wanna install the Terminal program... Sigh, I recall it could take some time as well for the system being ready. I have downgraded the mobile to the lowest Android 7 - which was easy enough although hard to recall all the steps. If anything I will just go back to the Android 8 version, so no biggie, if it does not work.

Hmm still not done with the first step... I'll just try again and see what happens. It is at the last part, that some times can take some time to do... I will give it some time this second time... And if it does not work just turn back to Stock A8. Oh, there we go! :p It came through.

Next step is on the mobile... Really if it fails, I can just restore everything as far as I know, as I've done with the other F800K so many times.

First step seems to have done its work! :) Getting report on my computer. Lets go to the next step then ;)
Step 2 finished, so far so good...
Step 3... Ahh we need the drivers... There we go, process ongoing.
Rebooting... Will be interesting to see what it has done or are going to do... Standing on the LG Screen for now, it could take a while. Although who knows how long. I'll give it 15 minutes I think... 00:20.

Hmm, at least the script did seem to do something, hmm it is loading now.... some sound.... animation is on... Uhhhhhh...... He he he. Hmm, I think we are in the system now. YUP! So... now what.... Ohhh, Blue screen :p
Ehh, I guess it did not work so well then. It depends, if TWRP is installed then... Everything is good and there might be some options, who knows. Lets first try to reset it, and see if we get another blue screen after it loads up. Yup... another blue screen... Could be the version of TWRP that is installed maybe, overall, lets try to get into TWRP. Hmm, English warning, interesting to see something else then Korean. Seems to move forward, lets see if we get into TWRP. If so then I could try to make a reset first hand, and try another TWRP version or... just install Android 8 and a kernel... Hmmm, We are now in TWRP!!! :D Asking for password, oh there was something about that. Not sure if I did that correct... I should have made a backup before doing that, lets see what happens. So easy to forget these things.

I think I might have deleted more then I should. Ohh yea, delete and then root I think was the game. Although I don't have those tutorials up so just running from memory at the moment. I might have broken the mobile by what I did in TWRP, not good. we have sound and animation now, it might not have been so bad. :) Ahh here we go with the Encryption unsuccessful... No matter, I think that was mostly a TWRP problem. Blue screen again.... okay... Well lets update to A8!

Not giving up so easily! Okay, Aboot and Recovery unclicked... there was a boot as well, but... I only recall needing to unclick 4 and not 5. So, lets do that for now. So progressing now, thinking thinking... If I recall I can still enter TWRP after this, hopefully. If something did not go bad. Screen making the standard issues in Download mode, no biggie. I wonder which kernel is best to install for this, but I guess I will just try the one I use for the other LGV20. Well... :D Yup so here we see the expected issue of the kernel issue. So everything is as it should be. Lets let it wait for the rebooting and all, and then see if I can enter TWRP. Okay, seems to be done in LGUP!!! Hmmmmmm Well, lets see if we can get into TWRP! ;)

Hmmm, no.... It seems to try to reset it... Okay, I need to think here. Oh yea, I need to install TWRP again. How was it.... Fastboot maybe. Yup, seemed to do it! So far so good. Thinking... Hmmm, okay... nope.... Lets try with the adb...
 

Jesus is God Almighty

Senior Member
Aug 19, 2016
322
22
Sigh... Okay, lets see if that did it. nope.... hmmm, I wonder why.... It did flash the recovery file, maybe I need to do it a couple of times, dunno...

Okay... did I finally get it? I hope... We will see, it would not work the other way around so ran the step 3 from the script from the computer, it does it automatically a lot of times. I am in TWRP! :D

The other thing should have worked, but as always, you have to do a lot of weird things to get things to work. Try this and try that and now the truth of hour seems to finally dawn upon us, I guess. Lets reboot and see if we have jackpot or not! Sigh... I hope it works, just used the files for the F800K for the H990N and now, now for the first boot. If anything...

Waiting... Heh, my my my.... But it does seem to be hackable, somewhat at least. It will most likely be some minutes before going into the system, I wiped the partitions... Still uncertain if, but it did not seem to break anything last time.

Tick tock, tick tock... No animation yet or sound - maybe I should make some food.

Well... Still nothing, it stands in the LG image thing. But it could take some time, to recreate all the files and all, data and what not, I guess. At least have not seen it move yet.

If anything I could try to install Lineage if this does not work, I have TWRP working now... There is as far as I know no kernel for the LG H990N as it is said to not be rootable. Well, I seem to have gotten pretty far although, I might have hit the wall here. At least yet to do anything and time is going. It does seem pretty dead, but who knows really...

Okay... I'm thinking I might have done a mistake, as it also flashed the boot as well, which I think it should not have done. Let me try to flash the Boot from the original A8. Lets see if that does anything... rebooted.... now the question is, will anything happen. It did, but the screen is full of gliching.... But it works. TWRP was not installed anymore.... Okay....

TWRP installed and named the boot something else so the script step 3 could not fix it. So far so good.

Format and then reboot, and then we do another format and then we install the kernel and Magisk. Lets see if we get it this time. Well... Kernel installed, Magisk installing and then a reboot. Who knows, if anything will work.... I don't wanna waste to much time on this. But, it does go quicker then last time for sure. Okay, restarted.... At least it did something, lets give it some time and see what happens, the big moment! :D

Does it work, or not.... In any case, I have some Lineage ROMs I can try as well... Hmm I think we might have a bootloop going. Interesting.

I can't really remember how I did that step.... wow sound and animation incoming. Something seems to happen... Password unlock.... Oh come on. That might be a TWRP issue... I recall having one version work on A7 and another version working on A8... Very annoying and tedious. TWRP is at least still working. I will try again. Typically one needs to waste so much time trying stuff to get it to work. But I do have an unlocked bootloader or recovery or whatever. TWRP is absolutely working. And A8 was working it seemed as well, although no screen working.

Okay lets try again, install kernel and install Magisk. And then... Well, I might as well try some of the ROMS of lineage if this does not work. It does seem close, very close indeed, sadly one forgets quickly these things. Well here we have the sound and animation again. But yet again it wants me to enter a Password to unlock... okay I have one other option to try out. Or many more if I wanted to use more time on this. But really not.
I will try to install the old TWRP and try it all over again, that seemed to work on the other with A7. Okay, that should fix the old version, lets get into it again. *Sigh*

Well... so far so good.... Reboot and lets install the Kernel and Magisk one more time and see what happens. If that security nonsense is still going to bug me or not. Take it from there, lets reboot the thing and hope for the best. Nothing more to do really, I will check to my food.

Well.... Android is starting.... 44%.... done... uhhhh, what is going to happen I wonder...... Restart..... well okay... hmmm or did it turn it totally off...... Well, at least the screen was working it seems. Lets try to turn it on again and hope for the best, it seemed to have turned it off... but I might have gone beyond the issue of encryption... So... the H990N is not rootable... Well, WELCOME it says! :D

Well, so far so good... Inside the operating system now..... There is a link to Magisk Manager, might need to further install it. No it seems it is installed.... Well.... It seems I am inside Stock A8, Rooted and all with screen working! :D Took some time... Well I guess the blue screen could come at any moment, but it seems to do just fine really....

Well.... I guess I am getting better at things, although I do wonder where I got the information about it needed to have TRWP installed again, or maybe I figured it out last time. Used so many days on the F800K, this took some hours but it work it seems...

Was not really needed overall as the phone is surely falling apart more and more, but wanted to see if it was possible. And lo and behold, as far as it seems for now... It works! :) I can install the newer version of TWRP again 3.5.0 - these things are like puzzle pieces to break, need the right pieces and the right connections and there you go, a picture.
 

Jesus is God Almighty

Senior Member
Aug 19, 2016
322
22
So after toying around and fixing this and that, I can now say I have a rooted Android Stock H990N Hongkong model - which seems to be stable, although I have no idea if everything works or not... or if it will continue to be stable. But it looks pretty good to say the least. Thought it might work with A8 even if it broke on A7 ;)
Hack the planet... or something...
 

Jesus is God Almighty

Senior Member
Aug 19, 2016
322
22
Well, lets just check if the mobile connection works with a sim card.... Overall, I am not going to use this phone much anymore, beside maybe as a tool or mp3 player. Really it seems to run pretty smooth after being rooted, without much issues really. Looks good, although.... Waiting for connection here.... :p
Who knows that might not work. Seems like the network does not work, I guess it could be the foreign kernel installed for the LG F800K or something, dunno - but overall, the mobile seems stable and smooth.

I could look further into this, and try some other kernels... but... well, enough for now.
I don't know how far you guys got on it, but this is my written testimony on the LG-H990N rooting and jailbreaking into freedom! So free so you don't have any calls bugging you :p Ha ha ha
 

ElMudshark

Member
Apr 29, 2018
24
3
Upstate NY
Before I start I need to know how to find out if I have Google's security patch of January 2017 or later.
It's an LG v20 vs99520c
Security software = MDF v2.0 v4
Android 8.0.0
Androiod security patch 10 October 2018
Kernel v 3.18.71 -perf+
 
  • Like
Reactions: cx5

C D

Senior Member
Before I start I need to know how to find out if I have Google's security patch of January 2017 or later.
It's an LG v20 vs99520c
Security software = MDF v2.0 v4
Android 8.0.0
Androiod security patch 10 October 2018
Kernel v 3.18.71 -perf+
Google's security patch referred to by the OP is the same as the Android security patch date. Nowadays, the chances of having a V20 that doesn't need to be downgraded for this procedure are very low. And any phone on Android 8.0 has a patch date from 2018, so they all have to be downgraded for this.
 
  • Wow
  • Like
Reactions: virginwidow and cx5

virginwidow

Senior Member
Mar 6, 2013
162
15
Knoxvegas TN
Moto X Pure
LG V20
Google's security patch referred to by the OP is the same as the Android security patch date. Nowadays, the chances of having a V20 that doesn't need to be downgraded for this procedure are very low. And any phone on Android 8.0 has a patch date from 2018, so they all have to be downgraded for this.
MAY_09-21_07-40-27001.jpg


Fastboot UTTERLY fails on this device:

LG-us996
SW ver: US99610f
"patch level" 12-01-2016

Is not the cable... adb commands work... LGUP reverted it to correct SW...

Once adb puts it into fastboot, only thing ya can do is pull the batt - tried pulling USB in and out, no workee...

Fastboot kills the USB connection HOW?
 

andruyd

Senior Member
Dec 14, 2011
116
9
So after toying around and fixing this and that, I can now say I have a rooted Android Stock H990N Hongkong model - which seems to be stable, although I have no idea if everything works or not... or if it will continue to be stable. But it looks pretty good to say the least. Thought it might work with A8 even if it broke on A7 ;)
Hack the planet... or something...
Bro, were you able to get Lineage running on your H990N? I've been able to convert an H915 to H910 by flashing the H910 stock firmware (kdz) without any issues for months now. I'm considering converting the H990N to H990DS through the same process.

Can someone chime in if this is the right way to get Lineage OS 18.1?
 

sev7en

Senior Member
Jul 10, 2006
1,156
266
www.maccopoli.net
Hello,
thanks! I am stuck here: applypatch /system/bin/atd /storage/emulated/0/dirtysanta

the terminal reports an error about the way to type the command. I confirm I have the untrusted app in the tasks.
 

systemdlessvirgin

New member
Jun 16, 2021
2
0

help with dirtysanta on v20?​


elsa:/ $ id
uid=10258(u0_a258) gid=10258(u0_a258) groups=10258(u0_a258),3003(inet),9997(everybody),50258(all_a258) context=u:r:untrusted_app:s0:c512,c768

2|elsa:/ $ applypatch /system/bin/atd /storage/emulated/0/dirtysanta
usage: applypatch [-b <bonus-file>] <src-file> <tgt-file> <tgt-sha1> <tgt-size> [<src-sha1>:<patch> ...]
or applypatch -c <file> [<sha1> ...]
or applypatch -s <bytes>
or applypatch -l
Filenames may be of the form
MTD:<partition>:<len_1>:<sha1_1>:<len_2>:<sha1_2>:...
to specify reading from or writing to an MTD partition.
2|elsa:/ $
i cant seem to get the command 'applypatch /system/bin/atd /storage/emulated/0/dirtysanta' command to work, any help?
 

Top Liked Posts

  • There are no posts matching your filters.
  • 31
    Good day,
    Here's the modified dirtysanta method to root LG V20 and install TWRP. This guide will help you in rooting your device with much easier situation.


    Before you begin:
    (Your phone's internal storage will be wiped or simply formatted or more simply erased)

    (You will observe a static boot screen on each boot on some variants)
    (These instructions are specifically done using root package 4.0. Some steps will be different if you use other version)
    Read this carefully and completely. In this tutorial, I will show you how to root your LG V20 using DirtySanta method.This method is currently working for devices mentioned below in working device headings. So, you are warned not to try this on any other device (or not mentioned device) because this might brick your device. If you're on stock rom with Google's security patch of January 2017 or later then you need to flash a firmware with December 2016 or earlier security patch. This method flashes a debug bootloader, So, if you try to re-lock your bootloader it will brick your device.*
    And most important before beginning, read 4th post carefully.

    Currently, LS997 (Sprint Variant) cannot return to stock because there is no KDZ available for these devices (they mostly don't release TOT, KDZ).
    For H910:
    If your phone is on non-rootable firmware you can cross flash a H915 or US995 kdz with December 2016 patch by using Patched LGUP and then proceed to root.
    If you are faced any problem you can ask help, I will try my best to help but can't promise and blamed if your device is bricked. Always process is root only if you have enough patience and experience to deal with brick and bring phones back to life.

    Working Devices:
    - Verizon (VS995)
    - Sprint (LS997)
    - ATT (H910)
    - Korean(F800L)
    - USS996 (BPT, UCL)
    - Canadian (H915) --> Follow this Method (Specially for H915)
    again don't try on others you may face a brick. But if you're so much courageos to try it on others devices then tell me your experience (if works).. DO NOT TRY THIS ON ANY OTHER VARIANT, YOUR PHONE WILL BRICK (INCLUDING BUT NO LIMITED TO H918)

    Required Things:​
    All things that you require for this process can be found in 2nd post.

    Preparation:
    1: Download files from download section. (Always download latest root package so any bug is removed & automation is improved)
    2: Install Terminal Emulator on your phone.
    3: Extract root package.
    4: Install “ADB” through “ADBSteup.exe” from Software Folder
    Optional Either copy root zip (SuperSU or MAGISK) to external Sdcard of phone or wait till process to end so you can copy it after formatting internal storage from TWRP
    6: LG Driver can be found in Software folder (Install it, if not installed already)



    Steps:
    Bootloader Unlocking:
    1: Navigate to extracted Root Toolkit

    hDBoMR_WTH1iLMQp3DdZGu8erETvtU9_g-mARYA_3QaIJU5adCty7jEDKFl6GMzURukHurhgcB5JBXdfnf7RmcEu31ZQ7wkzRFNf5w=w1280-h1024-rw-no


    2: Run "JustRunMe.cmd".

    oWArKVwlqo0l6fEFkSe5Cf0UtF5hbc9NLSp0E6WWlXeq9xwrGbt_BPTX04KtAi9KD6VvobiB789u7wiiileoPO9WnPmW_IXvs6Gcpw=w1280-h1024-rw-no


    3: Enter "1" to begin process and follow on-screen information. All steps will start automatically one-by-one.

    5NYoKiMe029p6U7H9VMp7JhOEMwm3Xic0xQC2bP0PdZNY47qKr2n_QIOdxTWwFklgaqN0yWR-RJS161sGIZgcf0OkRIxmTB3V7KB0A=w1280-h1024-rw-no


    1VwE0lsSCi-JJhZiFy_j8PPwyuYfE0mlmQ4OoANJXoFcN0W1aadJMjH-3TWE5ZKZgdGvVrIg3sFookbmuH1NvftFpvzr1IyehyLeIA=w1280-h1024-rw-no


    EBDnUZoHsEZGfCMSa9MYLZLxYKSUXCdiCztD25UvRx7WgWtilen9ZIxFKglWXp7aeChNSSzyXBmRqXZfb8Jc1hT5iMyx-Xa9tlLIlA=w1280-h1024-rw-no


    4: When prompted open terminal emulator and perform following commands. (Commands are also described in respective scripts).
    Code:
     id

    check it output if it says ”Context = untrusted_app”. If it say so then you're fine to go to next step or you will have to began from step 1.

    P1%2BTerminal%2BID.png


    Code:
    applypatch /system/bin/atd /storage/emulated/0/dirtysanta

    5: Now bring Logcat window to front and wait till it says you to start step 2.
    Press any key on main "JustRunme.cmd" and it will start 2nd step automatically.

    9rGdj6p_q1NuqK67u_iINapcnj5zBAUd59dZZvwyzVJ5POGUAibzyGQmNv-mrC5oTojA46sOe-7ekAhmU0_EcFjdoY0LUFxk8Ap42g=w1280-h1024-rw-no


    it will boot your device into bootloader after success.

    When done, step2 window will close automatically. Press any key on main window to begin 3rd step.

    IBbwQVfa5h9RZIqU-8qF_exnHFXg2CwetUk376DklRxuerCx-n-Brreq3AX1bjgKi4w15Y2Rw-5mjHc7xK7eVFVUT8_k6gB3a1LiEg=w1280-h1024-rw-no


    WY-5H9NzDrpIkFF646vcKvwg4fT5vrz6wIzEGIDMDbUdwmz5ULtoWChToyElgweRaSpwQfgs3nTRQcpJge4CkyXGq7fUzOzXxqQV-g=w1280-h1024-rw-no


    It will flash TWRP on your device. Your phone will reboot and boot into system after some time. If it takes more than 15 minutes or your kept seeing static window then reboot back into fastboot mode.
    To boot into fastboot (or bootloader) mode simply turn off phone by taking battery out then press volume down and plug-in USB cable while holding the button.
    Flash Boot2 image by entering “2” then “1” from JustRunMe window. (Different for root package 6.0)
    It will reboot and phone should boot now.
    (If you're faced with any secure boot password then you will have to format data within TWRP. Just poweroff your device and boot into TWRP)

    Rooting, Removal of Encryption, Installation of SuperSU or Magisk:
    8: Now boot into recovery mode either by entering “5” then “1” or by key method,
    Cancel password prompt.
    To Remove Encryption Error (It'll wipe all your internal data)
    9: On TWRP. Swipe to allow modification.
    Click → Wipe → Format Data → type “yes” → enter.
    Now you will have access to internal storage from TWRP. Connect your phone to PC with USB cable while in TWRP.

    10: Now copy your Supersu or Magisk to phone (Whatever you prefer).

    11: Flash this zip by
    Press → Install → (Select copied zip) → swipe to flash and wait till it is finished.

    12: If you're faced with any secure boot password then you will have to format data again by
    Boot into TWRP –> Wipe → Format Data → yes → enter
    after that
    Press → Wipe → check Cache, Dalvik Cache, Data → Swipe.
    Press → Home → Reboot → System.
    11
    Download Links:
    1: LG V20 Root Package
    Old iterations
    LG V20 Root Package Here
    LG V20 Root Package 3.0 Here

    Current iterations:
    a: LG V20 Root Package 4.0 Drive | DropBox
    b: LG V20 Root Package 6.0 Drive | Mega
    2: Terminal Emulator PlayStore or Mirror

    3: LG Drivers Here (No need to download from here. From Root Package 4.0, driver can be found in Software folder of extracted files)
    OPTIONAL FILES
    Patched LGUP (If you want to cross flash firmwares. Use with extreme cautions and don't blame anyone if you hard brick the device)
    extract it to "C:\Program Files (x86)\LG Electronics\LGUP" (different for 32-bit windows)
    Rootable Firmware
    US996 10f KDZ (rootable) (Flash it through Patched LGUP on H910 if your current firmware is not rootable, as no kdz is available for H910 by carrier)
    US 996 KDZ
    LG US996 KDZ all Available versions
    7
    FAQ

    • Will this work on the lg v20 H918 10q and up?
    Well, Short answer = No.
    Long Answer = This guide is just beginner friendly. Which means that I is just a more easy version of dirtysanta with FAQ, Video Tutorial (probably) and less anxiety. The reason behind creating this is simply to help new V20 user root and install TWRP more easily. This is no upgrade to method. It is just a modification. It will do only what @me2151's method can do.


    • Is there any way to revert my phone to a the version before att security patch. I am not super tech savvy so I wouldn't know where to start. I am very frustrated
    I did it by flashing a H915 kdz on H910 which had December 16 security patch. After that phone had TWRP by this method. You can try flashing either an H915 or US996 firmware with December 2016 or earlier security patch. US996 10f kdz link is given in 2nd post which is rootable. You can try with that if you have H910 phone.
    Here's the link for that tutorial to cross-flash a kdz rom on H910 using patched LGUP. (You can give a try to other variants but H918 which is highly brickable)
    Here or Here


    • How do I find out if my firmware is rootable?
    If security patch of your phone says it's December 2016 or earlier then it is rootable using dirtysanta method.

    • Does that mean I can flash h915 or US996 firmware on h910 even without rooting the device?
    I have H910. I can confirm directly flashing H915 and US996 kdz directly using patched LGUP (in 2nd post attachments).

    • If yes, are there any software requirements/restrictions (be it the AT&T firmware version required, or the h915/US996 kdz I can install - eg. only install version XYZ of h915/US996 firmware if at&t firmware is before/after a certain version)?
    Currently there are no software restriction. By flashing firmware from US996 or h915 firmware you can get rid of ATT bloatware and WiFi Hotspot will work without any further enhancements. If you want to root your non-rootable firmware (H910 with firmware along January 2017 or later security patch) then try flashing an US996 firmware with December 2016 (or earlier) security patch to root.


    • I had the latest US996 firmware (10p) installed, and it worked but I had signals problems (once 4G enabled, connection dropped randomly).
      I then tried to flash h915 10e firmware, and I'm now stuck in a bootloop. I tried re-flashing the US996 firmware that worked before, but it no longer works. The phone is still detected as US996 in LGUP (even if I flash h915 firmware).
    Try doing a factory reset using button method (The same used to enter TWRP).


    • This procedure just completely bricked my H918. Everything went perfect until step 2 finished - and then instead of rebooting to bootloader, it simply died/crashed. Now it won't respond in any way whatsoever. I have no download mode, no fastboot - the thing won't even charge. Was on 10d. So that's cool
    That's really sad situation.
    (No where in the OP does it say that this works on the H918 therefore you bricked your phone.)
    6
    Video Tutorial
    6
    I disagree, if members would read the threads then they would have found the answer without having to make a post please give me this or point to that. As you stated there's numerous threads with the info needed if the members weren't lazy and took some time to read, and searching on the xda app on a mobile device is not difficult I do it all the time, and it's simple to do a Google search through your web browser

    Sent from my LG-H910 using XDA Labs
    Your attitude throughout this issue (which wasn't an issue until you made it one) is very poor. While we want members to do a little self help by searching, there is no reason to react in a hostile manner. If you had any intentions to help, you would've stated that they need to search first, and then offer some assistance by at least pointing him in the right direction. That is the spirit and ethos of XDA. However, it is clearly evident that you had no intentions of helping this member, In which case, you shouldn't have bothered responding.

    From here on out, I want to see some decency between member interactions in this thread, from everyone.

    Neo