[GUIDE] Unlock Bootloader, Install Custom Recovery, and Root the Pixel C (2/4/2016)

Search This thread


New member
Nov 18, 2022
Hi guys.
I have a big problem with my Pixel C Tablet.
After turnig off i wanted to start the tablet nomally but I get the little green Android with message "no command" - "Kein Befehl".

OK. I tried to install the backup but it wont start. It always ends up to the little green Android.

Now I installed ADB on PC etc. downloaded the original ROM and wantet to make a new clean installation.
But my biggest problem is that I can not unlock the boot loader because I did not activated the OEM unlock on my tablet while it was working.

So is there any possibility to get a new installation on my Pixel?

I also tried sideload. But here I get a message: "fastboot flash ....... command failed"
I tried different USB cables and USB 2.0 and 3.0 ports. But nothing helped.
The command "fastboot devices" brings "6130000644 fastboot". So communication works.

fastboot flash recovery twrp.img
Sending 'recovery' (16520 KB) OKAY [ 0.437s]
Writing 'recovery' FAILED (remote: 'unsupported command')
fastboot: error: Command failed

ADB sideload with stock zip brings:
Total xfer: 0.00x

On tablet:
Finding update package....
Opening update package......
Veryifying update package.......
E: footer is wrong
Update package veryfication took 0.0s (result 1).
E: Signature veryfication failed
E: error 21
E: failed to open driver control: No such file or directory
Installation aborted.

Can anyone help me???
Thanks a lot



May 7, 2021

My bad ! I am on the Lineage ROM ! thanks !

now i try to make the keyboard work and I will be very happy
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 33
    The instructions in this guide are outdated and way more complicated than necessary. Once the official release of Android 7.0 Nougat becomes available/rooted, I will update the procedures in this thread. In the meantime, I recommend referencing this post along with the original instructions.

    A massive shout out to @cheep5k8 for all the hard work he did in getting root and recovery working on the Pixel C. Please donate to him if you can. He deserves it.

    Disclaimer: This will wipe your device. Backup anything important before you start. I mostly made this guide for selfish reasons. cheep5k8 has done a great job but some of the instructions are a little vague. I like being spoon fed and I wanted a resource to refer to in the future. You know the drill. If it breaks, not my problem. Post in the forums or hop onto the XDA IRC channel.

    There may be more efficient ways to do this, but this will get you where you need to be. If you find any problems or have any suggestions, feel free to reply (BE VERY SPECIFIC WITH STEPS) and I will do my best to update the instructions.

    • ADB/Fastboot - Minimal ADB and Fastboot
    • ADB/Fastboot Drivers - I recommend using Wugfresh's Nexus Root Toolkit and using the full driver installation guide. Alternatively, you can install them yourself using the official Google Drivers (no installer)
    • An easy way to access the ADB prompt is to navigate to the directory that ADB is installed in, hold shift and right click inside the directory. This will give you an expanded right click menu that includes an option to "Open command window here." Select this option and a command prompt will open that is already in the ADB directory, saving you from having to do a bunch of cd nonsense. You can check to see if your device is recognized in ADB by typing "adb devices." If ADB and the driver are all working correctly, it should come back with something like "5A20001071 device." You can also check to make sure your device is recognized in fastboot by booting to the bootloader and typing "fastboot devices." It will show something similar.
    Necessary Files:

    Device Prep:

    Enable developer mode
    1. Go to Settings > About tablet
    2. Tap on Build Number 7 times until it says "You are now a developer"
    Enable OEM Unlocking
    1. Go to Settings > Developer options
    2. Enable OEM Unlocking
    3. Tap on Enable when a disclaimer pops up
    Enable USB Debugging (ADB)
    1. Go to Settings > Developer options
    2. Enable USB debugging
    3. Tap on OK when prompted with a disclaimer
    4. If the ADB USB driver has been installed, you will see a popup that says "The computer's RSA key fingerprint is: xx:xx:xx:xx(blah blah)"
    5. Check the box next to "Always allow from this computer"
    6. Tap on OK

    Unlock Bootloader:
    1. Open ADB prompt (see prerequisites)
    2. Input the following:
      adb reboot-bootloader
    3. The device will now boot into the bootloader and say
      Waiting for fastboot command...
    4. Input the following to unlock the bootloader:
      fastboot flashing unlock
    5. You will be prompted on the tablet screen with a warning about unlocking the bootloader.
    6. Press the power button to unlock the bootloader.
    7. The device will reboot and say "Bootloader is unlocked and OS verification is OFF. Device will continue booting in 30 seconds." You will also hear an audible beep. You will then see the green android with some spinny stuff. This is the userdata being formatted.
    8. When complete, the device will boot back into the bootloader and say
      Waiting for fastboot command...
    9. Boot back into Android by inputting:
      fastboot reboot
    10. Your Pixel C will be reset, so you will need to re-enable USB debugging. Connect to your wireless network and then skip past everything else in the initial setup, as all of this setup info will be wiped again later on. Refer to the "Enable USB Debugging (ADB)" steps above to re-enable USB debugging.

    Install Custom Recovery:
    1. Open ADB prompt (see prerequisites)
    2. Input the following:
      adb reboot-bootloader
    3. The device will now boot into the bootloader and say
      Waiting for fastboot command...
    4. With the Pixel C in the Fastboot bootloader and the recovery file in your ADB directory, input the following:
      fastboot flash recovery (replace with custom recovery filename).img
      C:\>fastboot flash recovery twrp-
      target reported max download size of 268435456 bytes
      erasing 'recovery'...
      (bootloader) erasing flash
      OKAY [  0.054s]
      sending 'recovery' (13760 KB)...
      OKAY [  0.349s]
      writing 'recovery'...
      (bootloader) writing flash
      OKAY [  0.375s]
      finished. total time: 0.783s
    5. Reboot into Recovery using the physical buttons. If you reboot the device back into Android, it will write over the custom recovery with the stock one. This will be fixed in the future.
      Power + Volume down until screen turns off, keep pressing volume down to boot into Coreboot Bootloader. Navigate to Reboot into Android Recovery with volume down and then press power to select.

    Install Root:
    1. In TWRP, navigate to Wipe > Format Data
    2. Type "yes" in the warning prompt and wait for the userdata partition to format. Again, this will wipe your tablet.
    3. Press the Home button at the bottom when the format is complete
    4. Navigate to Reboot > Bootloader to boot back into Fastboot
    5. In the ADB prompt, flash the new kernel:
      fastboot flash boot (replace with xCeeD kernel filename).img
      C:\>fastboot flash boot xceed-kernel-google-dragon-02-01-2016-RC1.img
      target reported max download size of 268435456 bytes
      erasing 'boot'...
      (bootloader) erasing flash
      OKAY [  0.064s]
      sending 'boot' (6220 KB)...
      OKAY [  0.161s]
      writing 'boot'...
      (bootloader) writing flash
      OKAY [  0.197s]
      finished. total time: 0.426s
    6. Reboot into Android. The device may boot twice.
      fastboot reboot
    7. Reboot back into Recovery. Power + Volume down until screen turns off, keep pressing volume down to boot into Coreboot Bootloader. Navigate to Reboot into Android Recovery with volume down and then press power to select.
    8. In TWRP, navigate to Mount and check only Data
    9. In the ADB prompt move su.img to /data:
      adb push su.img /data
      C:\>adb push su.img /data
      5677 KB/s (33554432 bytes in 5.772s)
    10. In TWRP, navigate to Mount and uncheck Data
    11. In TWRP, navigate to Reboot > System
    12. Perform initial device setup
    13. Once you are at the home launcher, re-enable USB debugging (Refer to Device Prep)
    14. In the ADB prompt, install superuser.apk:
      adb install Superuser.apk
      C:\>adb install Superuser.apk
      8612 KB/s (6227998 bytes in 0.706s)
              pkg: /data/local/tmp/Superuser.apk
    15. Install Busybox from the Play Store: link

    Congrats. You are now rooted (not in the Australian sense).
    How To: Root the PixelC / Android N(7.0)

    I threw together a quick writeup, because why not :)

    Standard disclaimer: Perform these actions at your own risk. I take no responsibility for your actions, nor the outcome of any information/actions outlined below. If you don't know what you're doing, take the time to look around XDA and read, learn and ask questions. I'm not responsible for any damage, nor am I tech support.

    This post assumes the reader has some general competency around flashing, including but not limited to:
    • Your bootloader is already unlocked.
    • You have up to date adb and fastboot drivers available/installed.
    • You know how to install SuperSU from TWRP
    • You know how to flash the official android images from Google
    Make sure you're good with the above before proceeding further.

    1. Following these steps will erase all data on your device - backup anything you want first.
    2. Fresh install Android N factory image from the official site - clean flash (flash-all) --Keep your life simple, don't mess around with a dirty flash on a major OS update
    3. Android N starts up as normal.
    4. Get SuperSU 2.76 on the device storage -- either from USB transfer from your computer or by downloading it with the tablet
    5. Turn USB debugging on in Android N
    6. Reboot to bootloader
    7. Flash followmsi's TWRP (3.0.2-21.img)
    8. Reboot directly to recovery (TWRP)
    9. Wait for a minute or three for TWRP to provide an interactive environment (not frozen, but looks like it for a bit)
    10. When TWRP Loads, swipe to allow modifications in TWRP (this can be tricky due to the very slow performance of TWRP-- just keep trying, I find a slow swipe works better; it can take multiple attempts)
    11. Now you're in TWRP proper - Install SuperSU as normal - again, be patient with the UI
    12. Reboot the device as prompted by TWRP - notice the warning that it can take a few minutes and/or loop a few times. Let it sit.
    13. Device reboots, probably more than once, this is fine.
    14. You're back in N - rooted -:good:
    Yeah, ext4 is a filesystem -- you can't flash an image to that in TWRP.

    As for MTP access - it's not the fstab. It's the sysfs path which is different. The init.rc has to be modified to include this path creation for instances other than on boot.

    Thanks for your hints .. there were a few smaller issues.
    Finally I have manged it :)

    Uploaded new version .. as TWRP flashable zip !

    Just made a fresh backup to my usb-stick via USB-OTG .. :)

    Finally we can make OTG on Pixel C !

    Thanks for all your help ..

    P.S. One thing to add, for those who bought SuperSU Pro, you can install that too from the Play Store instead of installing the APK, but at the moment, it will say that the su binary is outdated (because the xCeeD kernel comes with 2.66, but SuperSU is already at 2.67). There needs to be a somewhat better solution but it's a bit hard to come up with it.

    xCeeD v1-RC4 will have SuperSU updated to 2.67, and I'm thinking of how to make it possible to flash the normal SuperSU ZIP in TWRP. I will probably modify TWRP in some way to make that possible.