[GUIDE] Unlock/Root/Safetynet for Pixel 4a

mikkoc

Senior Member
Mar 19, 2011
53
10
28
Looks
It seems to be widespread and not only linked to Pixels 4a : https://forum.xda-developers.com/t/...t-prop-edits-and-more-v5-3-6.3789228/page-244

No workaround yet.
Looks like a workaround has already been found, only for Android 11 though. It works for me.
 

Azor129

New member
Nov 9, 2017
3
0
1
Looks


Looks like a workaround has already been found, only for Android 11 though. It works for me.
Yep, works for me too.

Had to wipe data for both google play / google pay for Google Pay to work again.
 

cmstlist

Senior Member
Jan 11, 2010
3,357
517
243
Toronto
Since I cannot wipe Google Play Services data without destroying COVID exposure data, can anyone suggest a more targeted approach? E.g. delete specific files/folders from within Play Services data instead of a full wipe?
 

DiamondJohn

Recognized Contributor
Aug 31, 2013
4,588
3,663
243
Sydney
Since I cannot wipe Google Play Services data without destroying COVID exposure data, can anyone suggest a more targeted approach? E.g. delete specific files/folders from within Play Services data instead of a full wipe?
I did not see your original post. What is it that you are trying to achieve?
 

cmstlist

Senior Member
Jan 11, 2010
3,357
517
243
Toronto
I did not see your original post. What is it that you are trying to achieve?
I am passing SafetyNet again but Google Pay still says "Your phone doesn't meet security requirements".
Last time this happened the steps to get it back included clearing data of Google Play Services. However when I did this, it also cleared the COVID exposure data used by Canada's COVID Alert app. So I lost 14 days of anonymous Bluetooth codes that could be used to notify me if someone who'd been near me later tested positive for COVID.
I am trying to figure out what I can selectively clear from GP Services storage, that will get Google Pay working again without losing COVID exposure data.
 

SpecialKCF22

Member
Jan 13, 2021
7
0
1
I haven't gone through all the replies here yet but, for some reason, in terminal, when I enter the su -c props command, on the next screen where I would choose "Force Basic Key Attestation" that option is not available. Any idea why?