How To Guide [Guide] Xiaomi Mi Pad 5 MIUI12/13 ROOT Step-by-step - Pass SafetyNet, Widevine L1

Search This thread

cysmaster

New member
Jun 21, 2022
2
0
I also have this module installed without problems, as there is no recovey for Pad5, it is a good idea to install in magisk the module Magisk Bootloop Protector, which serves exactly to prevent what you are afraid that happen with your tablet
Thank you for the information. I didnt know such module and I happily installed it. Though I am afraid it did ton fix anything. I just rebooted after installing and the same - several minutes into recovery and finally snapped in and worked : (
Anyhow I installed the module in "Auto" mode. Was it a mistake? Should I have selected other mode?
 

alooby

New member
Jun 26, 2020
1
0
Pro i need to contact with you about proplem on my pad 5 in google play store .

I have downlod games wild rift and it has an additional file need to be downloaded but the proplem is google play say ( waiting for wifi to be continue larg downlod ) but the wifi is already connected .
i try so many method like clear data and restart ...etc

Need help please man !!!!
 

xnegx

New member
Jul 22, 2022
2
0
Xiaomi Mi Pad 5
I think I screwed up
I went to do the procedure to lock boot again,
and now my tablet is in loop starting at "MI" screen
any way to revert?


I already fixed
thanks
 
Last edited:

xchamelionz

Member
Jul 14, 2022
27
7
Xiaomi Mi 9 SE
Xiaomi Mi Pad 5
After unlocking bootloader and rooting is widevine L1 still available?

Edit:
I managed to root the device successfully and also flashed Universal SafetyNet Fix through Magisk Manager and I still have Widevine L1 (Checked both on DevCheck and Netflix app).

I only had one issue with "Hide the Magisk App" in Magisk Manager settings. It returned a 'Failed!' message after pressing the button.
To fix this just uninstall the Magisk app and reinstall it again.

Many thanks @kisielec
 
Last edited:

Top Liked Posts

  • There are no posts matching your filters.
  • 15
    Everything you do, you do at your own risk. I'm not responsible for all damages, this can also lead to loss of warranty.

    Hi,
    Probably many of you know how to do a Magisk install without TWRP, but this guide is for people who don't know and don't want to mess things up.
    I will try to show you step by step how to do it.

    Many thanks to:
    kdrag0n
    topjohnwu
    Leave them a nice feedback ;)

    !!! Before we start make sure your device is unlocked, if you don't know how to do it below is link to official Xiaomi guide !!!
    https://c.mi.com/thread-2262302-1-0.html

    Requirement
    • Xiaomi Mi Flash ver. =>3-14-0 - Needed to install all adb drivers Download
    • ADB & Fastboot tools - Could be the one built into Mi Flash tool I'll use this to make it simple
    • Magisk =>24.2 - This software is base of our rooting process Download
    • SafetyNet Fix => 2.2.1 (Zygisk) - Needed to backdoor SafetyNet fail check, at the moment it is only working method for Mi Pad 5 Download Make sure you download the Zygisk version!
    • Boot.img - You can download from official MIUI website full flashable rom and separate boot.img file from there, or use my if your Miui version is China 13.0.5, EEA 13.0.3, Global 13.0.1
    Installation
    To make it easier, Green color mean what you need to do on Tablet, Orange on PC

    1. Unzip Mi Flash tool
    2. Open folder and run XiaoMiFlash.exe, if window "Driver" won't pop-up click on the Driver tab and then "Install" button and close all windows.
    3. Connect your tablet to computer, when your tablet ask how you want use USB, choose File Transfer/Android Auto
    4. Copy to internal storage Magisk-v****.apk, safetynet-fix-v****.zip and boot.img
    5. Open File Manager on your tablet find a folder where you copied all files, and install Magisk
    6. Open Magisk app, and click on Install in section Magisk, then select "Select and Path a File", after that find your boot.img file and click on it
    7. Click "LET'S GO" button on the right side and wait until process will be finished
    8. On your computer in the tablet's storage window, go to the file specified in the application probably /Download/magisk_patched-*****
    9. Copy this file to a subfolder of Mi Flash on your computer, exactly to MiFlash2020-3-14-0\Source\ThirdParty\Google\Android and change the name of this file to boot.img
    10. Open PowerShell/Windows Terminal in this folder (Hold Shift + Right click -> Open PowerShell window here)
    11. Make sure your tablet have enabled USB debugging in Developer options Setting -> Additional settings -> Developer options -> USB debugging
    12. Turn off your tablet, then hold down Power and VOL- until the screen lights up, then release power button, if Fastboot appears, everything went fine
    13. Go back to your Terminal window and type to check if your computer see your tablet
      Code:
      ./fastboot.exe devices
      If you see answer "******** fastboot" it mean there is communication between PC and Tablet
    14. Next type this command to flash patched boot image
      Code:
      ./fastboot.exe flash boot boot.img
    15. Next type this command to reboot your device
      Code:
      ./fastboot.exe reboot
    16. Restart can take a longer time than normal
    17. Open Magisk app and check status of Magisk, if you see for exaple "Installed 24.2 (24200)" everything went fine
    18. Open Settings in right corner of app and in section App click on Hide the Magisk app then type name for hidden app, it will ask to install new app so do it
    19. Open again Magisk app and open Settings in section Magisk enable Zygisk (Beta) and Enforce DenyList
    20. Click on Configure DenyList than click on three dots in right corner and uncheck Show system apps
    21. Search for all the apps in the list below and check them. It is important to click on their name to see all modules, once you have done this click on the box to activate all of them
      Code:
      Google
       Google Assistant (I have two)
       Google Pay
       Google Play services
       Google Play Store
    22. After that reboot your tablet, and open again Magisk app
    23. On the bottom click on Modules
    24. Click on Install from storage button and find file safetynet-fix-v*******.zip, than click on it
    25. After that reboot your device one more time
    26. After reboot open Android Settings go to Apps and Unhide system services than find and clear all data of Google Play services and Google Play Store
    27. Reboot tablet last time
    If you have reached this point it means that everything has gone correctly, probably for about 3 hours you will still not be able to install Netflix and some banking applications but after this time everything will be back to normal, this is because Google's servers have detected that Magisk has been installed but that the application has been changed and Zygisk has been enabled so at the next check it notices that everything is Ok and gives access back.

    Quick explaination what happend here:
    1. Magisk has been installed and device is Rooted
    2. The application has been changed and hidden
    3. Zygisk has been activated and hidden from Google services
    4. SafetyNet-fix was installed, which restores the functionality of SafetyNet and Widevine L1, which is blocked after the installation of Magisk and unlocked Bootloader