[GUIDE][XPOSED][ALL VARIANTS] Installing Xposed without recovery

Search This thread

tkdsl

XDA TV Producer / Portal Team / Forum Leader
Jul 12, 2007
398
71
Los Angeles
www.tktechbay.com
I just tried it again, and this time it worked and I saw the apps updating after the reboot.

could not figure out why it failed but we are good. now. :)


You're welcome. I'm glad to hear it's working. I'll update the OP stating, you may have to try it multiple times to get it to work. Did you do anything different this time?
 
  • Like
Reactions: tabp0le

Saigonian

Senior Member
Jul 26, 2010
61
10
Thank you so much for your help.
I also confirmed it's working on H818P10e.
The following modules are working fine: Xblast tools, Android Vibrator, Boot Manager, Xuimod, Youtube ads remover, MinminGuard, Lunar calendar (by Vietnamese), OBB on SD.
 

tourbound129

Senior Member
Jun 15, 2010
1,081
314
Another confirmed Sprint install. Pretty quick too.

Only had blank screen for about 30 seconds, then it was scrolling commands and said 'waiting' on the screen for about a minute. Then it took about another 90 seconds to get to 'Optimizing Apps'. So 3 minutes total there then about 11 minutes to optimize 286 apps.
 

nipun1110

Senior Member
Aug 6, 2011
696
159
Dhaka
So...I am stuck in another problem now. Previously I installed xposed just fine in my rooted H815T. Everything was okay until I maybe tried some modifications in gravitybox and my phone was stuck into bootloop. I had no other options but unroot my phone with stock firmware and again then rooted. But no data was wiped, so all the apps were there. Now I had xposed app & all the mods installed in my phone (except gravitybox for precautions), but that xposed zip file wasn't. So I tried to install it via FlashFire. It went to black screen and didn't bootup. I waited for more than a hour. So I pulled out the battery and manually booted it up. Xposed didn't install. Now I uninstalled the xposed app & all the mods and tried to install the zip file again. Same result.
Now, can anyone tell me what to do????? Please.

Sent from my LG-H815 using Tapatalk
 

Zebov

Senior Member
Feb 7, 2011
61
10

xxlikquidxx

Senior Member
Jan 29, 2009
365
19
working on H815 unlocked, SEA version. took 15 minutes total.

Black screen will flash a couple time showing FlashFire working, then it will reboot and you will see "Android is starting..." intro screen while it's loading your apps.
 

Follow_and_Feel

Senior Member
Apr 7, 2014
528
216
Montabaur
Very nice!

I can confirm working on H815 10c, no unlocked bootloader and no custom recovery. Was done within 6 minuits. I can also confirm that it pays of to get home from a crazy night and flashing it, because you then have xposed working on your g4 :D

Thanks OP for this great way to bring xposed to lollipop LG.
 

Attachments

  • Screenshot_2015-08-22-07-05-31.png
    Screenshot_2015-08-22-07-05-31.png
    222.9 KB · Views: 462

andypiznti

Senior Member
May 8, 2011
81
8
@tabp0le , can u please tell me how to disable xposed in case i get stuck in bootloop in an locked bootloader phone?

haha i literally just got on here to ask the same question. seems like a factory reset would be the only way. makes me not even wanna touch gravitybox.

I did a complete backup with titanium last night onto my external sd card (had to use sdfix app) after thinking about this.
 
Last edited:

nipun1110

Senior Member
Aug 6, 2011
696
159
Dhaka
haha i literally just got on here to ask the same question. seems like a factory reset would be the only way. makes me not even wanna touch gravitybox.

I did a complete backup with titanium last night onto my external sd card (had to use sdfix app) after thinking about this.
Yah I had to do this twice coz didn't actually know which caused the bootloop. But hey u can do minimal tweaks with gravitybox e.g. long press kill app, data traffic monitor etc.

Sent from my LG-H815 using Tapatalk
 

Top Liked Posts

  • There are no posts matching your filters.
  • 132
    UPDATE: You can install the official Xposed framework (v74) by @rovo89. I have updated the instructions accordingly. It is recommended you upgrade to this version, as it has some bug fixes and is an official version.

    You do not need a custom recovery or unlocked bootloader. All you need is root. Here is how I did it:

    NOTE: I AM NOT RESPONSIBLE IF YOU BRICK YOUR DEVICE. FOLLOW THIS GUIDE AT YOUR OWN RISK.


    1. Download Xposed framework (xposed-v74-sdk22-arm64.zip) from here
    2. Download official Xposed installer (XposedInstaller_3.0_alpha4.apk) (APK ONLY!) from here
    3. Install FlashFire (you will have to sign up for the beta program) here
    4. Make sure your phone is fully charged. Make sure it's unplugged from computer or any power source.
    5. Flash Xposed framework using FlashFire. (Just use the flash .zip option. Do not check Automount) (This will take A VERY LONG TIME-Your phone will not boot for at least 10-30 minutes.)
    6. Install official Xposed installer
    7. You have Xposed! Enjoy!

    *Please note: Some users have reported the flash appearing successful, but after booting, the Xposed framework is not installed. Some of these users report second and third attempts failing. You may have to try it over and over before it actually installs the framework. Currently it is unknown why this is an issue. This is a rare issue, but there have been a few reports of it.


    Confirmed working on:
    LS991 (Sprint) confirmed by me
    H810 (AT&T) confirmed by @djkinetic & @uly609
    H815L confirmed by @AvivEliyahu
    H815 SEA confirmed by @BySezerSimsek
    H815 v10c confirmed by @blaqlemon
    H815 v10D confirmed by @DoubleJOption
    H815T confirmed by @Winrahr
    H818P (Dual-SIM) confirmed by @vintag552
    H818n(India) confirmed by @AbhimanyuAryan
    H812 confirmed by @juju2011
    VS986 (Verizon) confirmed by @yoonee
    US991 (US Cellular) confirmed by @Z3ldaFan88
    H811 (T-mobile) confirmed by @tkdsl
    H810PR (Claro) confirmed by @user787
    6
    Confirmed working on AT&T H810! Entire process from start to finish took 30 minutes.
    3
    Did you install the deodexed system apps? If not, you need to do that. Follow this guide: http://techjeep.com/2015/12/21/how-to-get-xposed-on-lg-g4-running-android-6-0-marshmallow/ and switch the installation of the different apps to the latest (SuperSu 2.66, latest deodexed apps). Check the thread for deodexed apps: http://forum.xda-developers.com/g4/themes-apps/h815-mm-v20b-deodexed-apps-xposed-t3258980

    I have only tried this with 20b, but it should work with 20c. Don't think there's deodexed system apps for 20d yet. Use TWRP or ADB instead of Flashfire. Don't let TWRP install SuperSu when it claims you don't have root.

    Did it work?

    Yes! You saved my life ;)

    I have stock 6.0 v20a german OS and i used the V5 version for v20b OS but it worked fine!
    my way with LG G4 6.0 v20a-ger:
    download this one
    restart into twrp
    install the zip
    whipe cache and dalvic
    download v79sdk23 xposed framework from here
    restart into trwp
    install zip
    restart and whipe cache and dalvic
    -> the restart took me 3-4 min but others say about 5-30 min
    -> after restarting all apps reconfigured and that took another 10min
    install the XposedInstaller_3.0_alpha4.apk
    tadda finish ;)

    i will post crashes and bootloops but nothing so far.

    THX Snah
    3
    Thanks for a fast answer -

    Flashfire version downloaded from the link from XDA that took me to Google Play installation - version FlashFire Free v0.27 as stated at the top of the settings in the app on my phone after download, I wasn't even aware there was a newer version.

    The first flashing attempt was with it for the v80sdk22-64 recommended for LG G4 818p. Xposed insaller 3alpha 4 doesn't see the framework as installed (text in red). Any suggestions? Or is there supposed to be another workable version of Flashfire?

    Ah sorry i meant v0.24 -- v0.27 (which is also the newest version) was the one that didnt work. Just google for flashfire 0.24 apk or something along these lines

    OR use my gdrive link: https://drive.google.com/file/d/0ByEaE-9E0HwkUlhYMWJJZ1hHamc/view?usp=docslist_api
    2
    Anyone test on verizon. If not. I will when wife gets home.hopefully one step closer to bliss. Now just need b/l unlock it work around.

    Sent from my VS980 4G using XDA Free mobile app
Our Apps
Get our official app!
The best way to access XDA on your phone
Nav Gestures
Add swipe gestures to any Android
One Handed Mode
Eases uses one hand with your phone