[H910][Oreo][Stock][Rooted] AT&T LG V20 Stock Oreo rooted flashable zip

Search This thread
D

Deleted member 11468629

Guest
I did a clean flash from stock no good to 17.1 unofficial and didn't have to flash any kernels that was right after I rooted the phone too. They must have a boot image in there already. If I remember correctly from the threads that I went through you will have to flash gamma kernel to have IR blaster support though

ah ok thx :) i just flash the oreo.zip in TWRP and wipe everything except vendor before install lineageos?or i not wipe anything?
 

parag0n1986

Senior Member
May 3, 2015
367
95
36
LG V20
OnePlus 7 Pro
ah ok thx :) i just flash the oreo.zip in TWRP and wipe everything except vendor before install lineageos?or i not wipe anything?
I went from Nougat stock rooted right to 17.1. you need to do a data format so all of your internal stuff will be gone so make sure to do a backup before you do it and then I just flashed 17.1 and then the g apps magic I just downloaded the manager and then reinstalled it through there and it worked fine for me but that was on 17.1 I haven't tried 18 yet
 

per4manz

Member
Jan 31, 2017
21
3
Has anyone had issues with image rendering in apps after installing this?

More specifically, I have found that, e.g., the Slickdeals app (and others) won't display images or displays them garbled if using the default Open GL renderer. If i set the Open GL render to Skia the images render fine. However, then other apps (Nextdoor, for example) start suffering missing or scrambled images.
 

Top Liked Posts

  • There are no posts matching your filters.
  • 21
    Good Morning

    New: Well AT&T updated us to Sept Security patch
    here's the new Stock rooted rom > H910_20h_Oreo_full_rooted.zip > https://www.androidfilehost.com/?fid=1322778262904015326

    Tested by @darkknight200
    i dirty flashed over the 20g rooted setup. It booted up fine and works like normal.
    Now have to debloat att apps and restore twrp. This time i used twrp app to restore twrp right in system and it worked properly. Saves the hassle to go into fastboot to push twrp.

    All in all those are minor inconveniences, The zip is fine.
    Thanks allot man.

    After @NotYetADev posted his VS995 rooted Oreo We decided to give it a try on the H910.

    It's not perfect but it does work. You'll need to Format Data and flash the H910_20g_Oreo_full_rooted.zip + the Newest - H910_mk2000 kernel from recovery-twrp-h910-2018-10-18.img

    Your phone will be wiped and updated to Stock rooted Oreo so backup your phone first!

    If you have never rooted your H910 you'll need to use the guide here first > https://forum.xda-developers.com/v20/how-to/root-h910-v10m-t3664500

    Note: when you get where you would flash 10r just use my rom instead. Don't forget to flash the kernel after the rom
    Note2: Flash TWRP again before you reboot (Install / Install Image / recovery-twrp-h910-2018-10-18.img to Recovery

    It's also recommended to use the new TWRP for Oreo found here > https://forum.xda-developers.com/v20/development/recovery-twrp-3-2-1-0-t3720239
    Note: you'll have to flash TWRP back to the phone after flashing the rom and kernel because it installs stock recovery.

    If you have any problems getting DATA on any sim other than AT&T check this post to fix your APN > https://forum.xda-developers.com/showpost.php?p=79619740&postcount=244
    Thanks @StrikerTheHedgefox

    After your phone is setup be sure and install the Magisk apk

    Hide unlocked Bootloader warning boot screen by 4shared < This removes the ugly pink and black screen on reboot. I tested it and it works great

    Huge thanks go to @darkknight200 and @askermk2000 for the Idea and the kernel.
    3
    Can you just flash the Oreo rom from recovery and then flash TWRP recovery back from the same recovery session in TWRP without rebooting or do you neeed to boot up once into the Oreo version of the Rom with the stock recovery before putting TWRP back?

    ---------- Post added at 12:30 PM ---------- Previous post was at 12:27 PM ----------



    Did you check the MD5 hash on the download before installing it? You apparently also need to use the Oreo-compliant newer version of TWRP to flash it. There is a link for that in the main post.

    Hey, saw that this wasn't answered yet. Here is how I flashed both v20g and v20h. I did exactly what you're asking about. I flashed Oreo, then re-flashed the correct Oreo version of TWRP from the same recovery session. It worked both times. Obviously when I went from v20g to h, I did not fully wipe, I just dirty flashed right over it. There's no reason you can't just flash v20h directly, at least I don't think so; it should be a full image and not a differential update. These instructions will assume you're going from anything Nougat based to Oreo. You have to install the Oreo version of TWRP as your first step, and then reboot (from within TWRP) into recovery again. Don't try flashing Oreo using the older versions of TWRP. These instructions assume you're already on the proper version of TWRP!

    1. I made a full nandroid backup. I chose system, not system image and data, not the beta option that includes media. I usually just copy /sdcard over to /external-sd and rename it to /external-sd/.sdcard
    2. I went into the Wipe menu, and completely wiped "system" and then also chose the option to wipe "data" without wiping /data/media. Don't remember if it matter or not. Pretty sure it didn't, and my "internal SD card" was wiped. That's why I copied the entire thing in Step 1
    3. Flashed v20h ZIP
    4. Flashed mk2000 ZIP
    5. Flashed Magisk 17.1 ZIP - I've been informed this step is superfluous since mk2k is already patched for Magisk, but it didinstall Magisk Manager for me, so, do what you want.
    6. Flashed TWRP Image
    7. Went one step further and did all of my debloating before first boot! I've added two screenshots at the bottom to show what I copied off to the SD card and then completely deleted from /system/ - Wi-Fi Calling still works (AT&T customer)
    8. Wipe cache and dalvik
    9. "Fix Contents" (because you've been using TWRP to manually delete things in /system/)
    10. "Reboot to System"

    It powered up, went straight to the AT&T logo (when I went from v20g to v20h - when I initially installed v20g, it rebooted three times before I saw the AT&T logo) re-did all the odex / oat / Dalvik stuff ("Upgrading Android" screen) then the LG theme app undid all of my substratum overlays and restarted System UI. Which was nice, because normally when you forget them running before you update, you get stuck in a force close loop.

    What I deleted from /system/priv-apps/
    b4obs1W.png


    What I deleted from /system/vendor/app/
    pCdbqou.png


    SafetyNet a-OK :good:
    GTrlFqP.png


    You can probably get away with de-bloating more. I saw no need to; these were the most annoying, persistent, and/or resource intensive pieces of bloat aboard. Too lazy to check the screenshots, not sure if I trashed YouTube too initially, but I ended up deleting it from wherever it was and then also unlinking it from the Play Store because I use the Vanced Magisk module and I like to hit "Update All" without worrying about it disappearing.

    Good luck!
    3
    I would tell you to poke around thermal-engine-8996.conf and edit a few lines, but it isn't the same anymore and it looks like gibberish when I try to edit it. Previously it was plain-text and had a few very overzealous configuration options that damn near limited you to 500 ma charging almost all the time. Any temps above 40, the screen being on, you name it, limited charging speed.

    On the bright side, it looks like I didn't hhave to edit it on Oreo because I've been on v20h for a few days now and it works great!

    Debloating was a bit of a PITA - I use Facebook, but I don't wwant Facebook as a bloody system app! Seriously AT&T/LG?! Some of the apps kept bringing themselves back from the dead too!!! I finally used SD Maid Pro and completely nuked Lookout, Facebook, Facebook Installer, Facebook App Manager, all of the DirecTV ****, and every other AT&T app other than myAT&T which I just froze (disabled) and Device Help, which I froze in either Ti Backup or SD Maid because Android wouldn't allow me to disable it. Caller Name ID nuked too, the only ones I think I kept too was Hot Spots, and it's also frozen. Any remaining AT&T apps I went after and made sure they had absolutely 0 permissions left. I know one of them was actively redownloading **** like DIRECTV as I was uninstalling it. Assholes. None of said de-bloating broke Wi-Fi Calling or VoLTE. Thx again OP.

    Also, I don't remember where I saw it asked, but I can confirm that Oreo hasn't broken HDMI - it still works with my Microsoft Display Dock - SlimPort is DisplayPort over USB-C, and anything capable of handling that should still work.

    Only real nuisance is being unable to get Bromite WebView working, but it should work once I change the package name.

    And in case anyone is curious, none of my de bloating tripped Safety Net. If you somehow managed to, there's a Magisk module for editing device fingerprint that may help, here's mine from before I started cleaning up. I don't think any of it is personally identifying, but if it is, please tell me so I can edit it out
    Code:
    lge/elsa_att_us/elsa:8.0.0/OPR1.170623.032/181871124f959:user/release-keys
    3
    LOL -- so they check for stock recovery, and if it isn't there, then: "NO DATA FOR YOU!". I wonder if that was intentional.... I doubt it since they could have just as easily checked for the eng aboot and refused to allow data, or even boot.

    Glad you got it figured out ;)

    -- Brian
    2
    Seems the quality is getting worse on these cards recently.

    As I understand there's a lot of "pirating" going on with sd-cards. I was reading up on the matter a while
    back, and it seems it is to such an extent that you cannot be sure you got the real stuff almost no matter
    where you buy it from.

    Even if it's not outright fake wares, it could be the manufacturer itself who sells mislabeled or subpar cards
    in some cases.
    At least that is what I read, but it is not such a stretch to imagine it's true.

    One thing is definitely true; if you buy from Ebay... beware